18:14:26 <SumitNaiksatam> #startmeeting networking_policy
18:14:27 <openstack> Meeting started Thu Jun 19 18:14:26 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:14:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:14:30 <openstack> The meeting name has been set to 'networking_policy'
18:14:37 <SumitNaiksatam> now it seems to be proper
18:14:47 <SumitNaiksatam> #topic Mapping driver/data path patches
18:15:13 <banix> wow
18:15:16 <ivar-lazzaro> ban hammer again!
18:15:35 <s3wong> SumitNaiksatam is turning bunch of people away everytime mapping driver is mentioned :-)
18:15:43 <banix> this is actually more fun; some get kicked out randomly
18:15:44 <SumitNaiksatam> s3wong: hahaha
18:16:02 <SumitNaiksatam> GPM API-1: #link https://review.openstack.org/#/c/100716/
18:16:35 <SumitNaiksatam> we just have to work through adversarial circumstances, i think we are used to it :-P
18:16:46 <s3wong> rkukura: did you get dropped and rejoin?
18:16:56 <SumitNaiksatam> i think rkukura is back
18:17:08 <rkukura> got dropped
18:17:10 <s3wong> for some reason rkukura is always selected :-)
18:17:18 <rkukura> all the freenode rooms split
18:17:27 <SumitNaiksatam> rkukura: you are on the spot as well
18:17:45 <s3wong> rkukura: that's right, can't blame OpenStack, happening to ODL also
18:17:46 <SumitNaiksatam> rkukura: GPM-API-1 ^^^
18:17:55 <rkukura> I think mandeep_ has been on the same side of the split as me, but doesn’t seem to be in this meeting
18:18:16 <rkukura> The patch SumitNaiksatam is in review
18:18:26 <SumitNaiksatam> rkukura: is, great
18:18:40 <rkukura> The GPM-DB-1 patch is updated based on that and all Sumit’s recent updates in the GP-*-1 series
18:18:50 <SumitNaiksatam> rkukura: okay
18:18:54 <rkukura> So I’m just finishing up the UTs and should post that for review today
18:19:02 <SumitNaiksatam> rkukura: great thanks
18:19:11 <rkukura> I think the GPM-plugin-1 patch is trivial, so might get that out today too
18:19:30 <rkukura> Then the work on the drivers continues, so those should be in review by mid next week
18:19:54 <SumitNaiksatam> rkukura: so (for the benefit of the folks here who havent looked at the GPM patch), the GPM API patch basically maps EP, EPG, L2/3 policy to the traditional neutron resources, right?
18:20:01 <rkukura> I’m traveling from 6/25 - 7/2, so my goal is to get the drivers into review beforehand
18:20:10 <rkukura> SumitNaiksatam: correct
18:20:28 <SumitNaiksatam> rkukura: and we use attribute extension, right?
18:21:04 <rkukura> Thanks to support SumitNaiksatam added in his UTs, I was able to remove almost all UT code from GPM-API-1
18:21:41 <rkukura> The GPM-DB-1 patch will also reuse the GP-DB-1 UTs, but needs to add several additional UTs
18:22:13 <rkukura> Anyway, its been slow going, but I think the initial series should be very stable now, so less churn going forward
18:22:28 <LouisF> mapping RD->router, BD->subnet, etc?
18:23:06 <SumitNaiksatam> LouisF: yes, though i made add RD is L3 policy now, and BD is L2 policy
18:23:10 <rkukura> LouisF: Yes, but RD is now L3P and BD is now L2P, and both use lists
18:23:14 <SumitNaiksatam> made -> may
18:23:25 <LouisF> ok thx
18:23:45 <rkukura> EPG->subnets, EP->port
18:23:53 <rkukura> L2P->network
18:24:06 <SumitNaiksatam> rkukura: thanks for the update (and also the reviews)
18:24:07 <LouisF> right
18:24:39 * SumitNaiksatam thinks rkukura is the master of three letter acronyms..ML2 was the first…now L2P, L3P :-P
18:24:49 <rkukura> So once this series is complete, the GP API will be usable to boot VMs, but all traffic will be allowed between EPGs in the same L3P
18:25:09 <rkukura> ;)
18:25:25 <SumitNaiksatam> rkukura: okay good to know about the path forward
18:25:49 <SumitNaiksatam> any other questions for rkukura on the mapping API patch?
18:25:54 <s3wong> Guys: getting out of the room for a moment, BRB
18:26:21 * SumitNaiksatam thinks s3wong is jumping out a strategic time ;-P
18:26:32 <rkukura> SumitNaiksatam: I don’t see it on the agenda, but are you getting started on the GP-*-2 series of patches?
18:26:52 <SumitNaiksatam> rkukura: yes
18:27:08 <SumitNaiksatam> rkukura: so that is the breadth series
18:27:43 <SumitNaiksatam> the plan was to base that off the plugin-1 patch (until the mapping driver stuff comes along)
18:27:53 <rkukura> SumitNaiksatam: Makes sense
18:28:07 <banix> Aiming J-3 for those?
18:28:26 <SumitNaiksatam> so breadth is something like API-1 -> DB-1 -> plugin-1 -> API-2 -> DB-2 -> plugin-3
18:28:39 <SumitNaiksatam> banix: noooo…everything is aimed for J-2 :-)
18:28:56 <SumitNaiksatam> we might not merge but at least lets try to get it out for review
18:29:06 <rkukura> We should aim to get at least GP-*-1 and GPM-*-1 merged before J-2
18:29:08 <banix> SumitNaiksatam: ok; i think that should be the goal for getting in Juno
18:29:09 <SumitNaiksatam> banix: we should work towards the goal
18:29:25 <SumitNaiksatam> banix rkukura: agree
18:29:35 <prasadv> CLI and Heat stuff is that for J2 too?
18:29:43 <SumitNaiksatam> the thing is that the client and horizon patches have dependecies on the model patches
18:29:51 <rkukura> And getting as much of GP-*-2 and GPM-*-2 into review as possible by J-2?
18:29:52 <SumitNaiksatam> and heat too, as prasadv points out
18:30:11 <SumitNaiksatam> prasadv: lets discuss that in your part of the agenda
18:30:49 <SumitNaiksatam> btw, correction from earlier, i meant to say: API-1 -> DB-1 -> plugin-1 -> API-2 -> DB-2 -> plugin-2
18:30:59 <banix> i think the GP-*-1s are ready; so we have to push for reviews to see if there are anything that need changing and move forward
18:31:07 <rkukura> SumitNaiksatam: What do you mean by “model patches”?
18:31:18 <SumitNaiksatam> banix: totally
18:32:03 <rkukura> SumitNaiksatam, banix: Isn’t our strategy to get GPM-*-1 into review before pushing for cores to +2/+A GP-*-1?
18:32:15 <SumitNaiksatam> rkukura: model patches being API/DB/Plugin-1/2/3 where 1 is for EP, EPG, L2P, L3P, 2 is for classifier, action and rules, and 3 is for Contracts and EPG/Contract association
18:32:30 <SumitNaiksatam> rkukura: i think thats what banix meant
18:32:40 <SumitNaiksatam> rkukura: in anticipation of your mapping patches landing
18:32:53 <banix> They are coming!
18:33:29 <banix> GP*-*-1
18:33:37 <banix> *-1
18:33:45 <SumitNaiksatam> banix: :-)
18:34:10 <SumitNaiksatam> we already covered UTs in the earlier update
18:34:45 <SumitNaiksatam> i think we have agreement from the current set of reviewers regarding the current approach on the UTs
18:35:15 <SumitNaiksatam> changes such as directly calling the DB layer are currently planned as an enhancement iteration
18:35:18 <SumitNaiksatam> is s3wong back?
18:36:24 <SumitNaiksatam> lets circle back to adv services in a bit
18:37:21 <SumitNaiksatam> #topic CLI, Horizon update
18:37:48 <SumitNaiksatam> prasadv: so any updates from hemanth on the CLI
18:37:58 <SumitNaiksatam> prasadv: i know you are bit blocked my the API patches
18:38:11 <prasadv> no updates. We will get started on them soon
18:38:12 <SumitNaiksatam> my -> by
18:38:18 <SumitNaiksatam> prasadv: okay, np
18:38:31 <SumitNaiksatam> prasadv: my understanding is that we are targeting J-2 even for this
18:38:41 <prasadv> is heat also planned for J2?
18:38:53 <SumitNaiksatam> prasadv: we want to be able to give the reviewers all the tools to be able to review this in entirety
18:39:01 <prasadv> hemanth is in India. I will let him know
18:39:03 <SumitNaiksatam> prasadv: may be we can go to J-3 for heat
18:39:14 <SumitNaiksatam> is ronak here?
18:39:16 <LouisF> is there a patch for the heat work?
18:39:25 <SumitNaiksatam> LouisF: yes
18:39:34 <banix> LouisF: old one
18:40:02 <SumitNaiksatam> LouisF: #link https://review.openstack.org/93657
18:40:05 <SumitNaiksatam> banix: true
18:40:13 <LouisF> thx
18:40:18 <SumitNaiksatam> LouisF: this was written for the PoC
18:40:26 <SumitNaiksatam> prasadv: so the plan is to build on this?
18:40:45 <prasadv> SumitNaiksatam: yes
18:41:08 <prasadv> susaant is not on the IRC. Will ask him start attending this
18:41:20 <prasadv> for heat
18:41:23 <SumitNaiksatam> prasadv: ok
18:42:03 <prasadv> we might have heat for J2 but will confirm
18:42:27 <SumitNaiksatam> prasadv: sweet
18:44:43 <SumitNaiksatam> i dont think we have ronak here
18:45:09 <SumitNaiksatam> ok moving on
18:45:22 <SumitNaiksatam> is s3wong back?
18:45:46 <banix> Trouble in Texas!
18:45:57 <SumitNaiksatam> may be banix can chime in
18:46:13 <SumitNaiksatam> #topic Adv services integration
18:46:44 <SumitNaiksatam> banix: have you heard for any progress?
18:46:58 <SumitNaiksatam> banix: or rather any blockers?
18:47:05 <banix> Well, from yesterday meeting it looks like we will have flavors and hopefully steering moving forward
18:47:12 <SumitNaiksatam> banix: okay
18:47:21 <SumitNaiksatam> banix: but specifically for our GP integration
18:47:34 <banix> SumitNaiksatam: no
18:47:42 <SumitNaiksatam> banix: we have the GP requirements on the agenda, but we are not able to bring it up
18:47:48 <SumitNaiksatam> banix: ok
18:48:08 <banix> the only thing is that not sure about the status of service chaining
18:48:16 <SumitNaiksatam> banix: ok
18:48:41 <SumitNaiksatam> #action banix SumitNaiksatam to check on the status of service chaining support for GP
18:49:03 <SumitNaiksatam> perhaps once we have the mapping driver framework in place, it will be easier to make progress with the services’ integration
18:49:37 * SumitNaiksatam thinks s3wong is busy guarding the Alamo or participating the victory parade :-P
18:49:54 <banix> we didnt get to talk about service insertion but the reviews seem to be progressing
18:50:01 <SumitNaiksatam> banix: ok good
18:50:11 <SumitNaiksatam> #topic Open Discussion
18:50:35 <SumitNaiksatam> sorry my connection is a bit choppy, here so i am experience delays in the messages
18:50:46 <SumitNaiksatam> anything else we want to discuss today?
18:51:18 <SumitNaiksatam> or we can go back to catching up on the world cup! :-P
18:52:16 <SumitNaiksatam> okay so be on the lookout for rkukura’s mappingpatches, they will land by tomorrow
18:52:30 <SumitNaiksatam> and please also review my earlier patches
18:52:40 <SumitNaiksatam> thanks all!
18:52:42 <SumitNaiksatam> bye
18:52:45 <SumitNaiksatam> #endmeeting