18:02:55 <SumitNaiksatam> #startmeeting networking_policy
18:02:56 <openstack> Meeting started Thu Nov 13 18:02:55 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:59 <openstack> The meeting name has been set to 'networking_policy'
18:03:28 <SumitNaiksatam> #info meeting agenda https://wiki.openstack.org/wiki/Meetings/Neutron_Group_Policy#Nov_13th.2C_2014
18:03:41 <SumitNaiksatam> #topic Paris summit follow up
18:04:07 <SumitNaiksatam> I think the summit was pretty exciting from a GBP perspective
18:04:21 <SumitNaiksatam> thanks to everyone for contributing and participating
18:04:53 <SumitNaiksatam> #info GBP presentation at conference: #link https://www.openstack.org/summit/openstack-paris-summit-2014/session-videos/presentation/group-based-policy-extension-for-networking
18:05:10 <SumitNaiksatam> #info GBP design session etherpad: #link https://etherpad.openstack.org/p/kilo-gbp-design-summit-topics
18:05:20 <SumitNaiksatam> Youcef: welcome! ;-)
18:05:41 <SumitNaiksatam> rkukura: thanks for joining
18:05:44 <rkukura> hi - sorry I’m late
18:05:59 <rkukura> calendar didn’t stick with UTC
18:06:07 <SumitNaiksatam> any thoughts, feedback from the summit that we need to discuss up front?
18:06:26 <SumitNaiksatam> rkukura: yeah, i think most people have the issue, i should have sent a note out earlier
18:06:39 <SumitNaiksatam> so any feedback from the summit, that we want to discuss?
18:07:09 <SumitNaiksatam> (we will get into specific technical items next, just checking for any general comments)
18:08:00 <SumitNaiksatam> okay, seems like people are still catching up ;-)
18:08:14 <SumitNaiksatam> #topic GBP Juno milestones
18:08:43 <SumitNaiksatam> during the breakout session on thursday it was proposed that we have the following immediate milestones
18:08:47 <s3wong> well, even Kanzhe decides to join :-)
18:08:54 <Kanzhe> hi all.
18:09:14 <SumitNaiksatam> oh yeah, we volunteered Kanzhe for a work item
18:09:23 <SumitNaiksatam> i bet he has an update! ;-P
18:09:31 <SumitNaiksatam> Kanzhe: good to see you back
18:09:37 <SumitNaiksatam> so on the milestones
18:09:42 <Kanzhe> thanks.
18:10:05 <SumitNaiksatam> prior to the summit, we wrapped on juno-gbp-2 milestone
18:10:33 <SumitNaiksatam> the proposal is to do juno-gbp-3 on nov 28th, and release on dev 19th
18:11:31 <SumitNaiksatam> any issues with the above time lines (we will discuss next what we are targeting for those milestones)
18:12:07 <ivar-lazzaro> SumitNaiksatam: depends on the items :)
18:12:18 <SumitNaiksatam> ivar-lazzaro: yes, okay so we will defer the questions
18:12:25 <SumitNaiksatam> #topic Pending work items
18:13:06 <SumitNaiksatam> so based on the discussions and feedback during the summit, we will have to push some more essential features for juno
18:13:39 <SumitNaiksatam> let me quickly try and run through those
18:13:47 <SumitNaiksatam> feel free to interject at any time
18:14:07 <SumitNaiksatam> first thing we want to target is the resources’ renaming
18:14:42 <SumitNaiksatam> so i posted a patch for that: #link https://review.openstack.org/#/c/133949
18:14:57 <SumitNaiksatam> ivar-lazzaro: will need your help on a few UTs that are failing
18:15:00 <ivar-lazzaro> SumitNaiksatam: thanks for taking care of this!
18:15:10 <SumitNaiksatam> ivar-lazzaro: np
18:15:20 <SumitNaiksatam> we also need to refactor the client code for this
18:15:39 <SumitNaiksatam> i will post the patch later today (unless someone else wants to pick this up)
18:15:40 <ivar-lazzaro> SumitNaiksatam: at a first glance, It seems a problem related to the fact that APIC driver uses an external library for getting the work done
18:15:50 <SumitNaiksatam> ivar-lazzaro: ok
18:15:53 <ivar-lazzaro> SumitNaiksatam: and renaming also those calls is breaking things :)
18:16:27 <SumitNaiksatam> ivar-lazzaro: ah ok, i tried to do it in a way that the calls to the external libraries were not broken, but i might messed it up! :-(
18:17:03 <ivar-lazzaro> SumitNaiksatam: np, I'll try to fix it later today
18:17:27 <SumitNaiksatam> ivar-lazzaro has a spec for shared resources #link https://review.openstack.org/#/c/133603/
18:17:47 <SumitNaiksatam> this helps to target the external network use case
18:18:00 <SumitNaiksatam> kindly review that spec
18:18:32 <s3wong> SumitNaiksatam: is that targeting Juno also?
18:18:40 <ivar-lazzaro> yes please, especially let's try to understand together which resources we want to make "sharable" on the reference implementation
18:18:42 <SumitNaiksatam> s3wong: yes all this for Juno
18:18:52 <ivar-lazzaro> based on what neutron allows us to do ofc :)
18:19:12 <SumitNaiksatam> and by Juno we mean preferably Nov 28th, because that is feature
18:19:20 <SumitNaiksatam> *feature freeze
18:19:55 <SumitNaiksatam> rkukura is also working on the extensions loading mechanism for vendor drivers
18:20:00 <SumitNaiksatam> the spec is approved
18:20:14 <SumitNaiksatam> rkukura: is a patch posted for this?
18:20:21 <rkukura> not yet - next week
18:20:40 <SumitNaiksatam> rkukura: ok cool
18:21:09 <rkukura> Do we need extensions for all resources initially? Or just the ones with mappings?
18:21:11 <SumitNaiksatam> anyone planning to write the vendor drivers please take note of the extension loading mechanism (similar to that proposed in ML2)
18:21:41 <SumitNaiksatam> rkukura: ah, so you are planning to move the mapping to the driver as well?
18:21:58 <rkukura> SumitNaiksatam: That would be a 2nd phase, but maybe also next week
18:22:04 <SumitNaiksatam> rkukura: ok
18:22:21 <SumitNaiksatam> i think ivar-lazzaro and banix have requirements for the extension loading from drivers
18:22:23 <rkukura> Plan is for initial patch to support extensions for L3P, L2P, PTG, and PT only
18:22:30 <SumitNaiksatam> so they might be able to speak to this
18:22:33 <SumitNaiksatam> Cathy_: hi
18:22:46 <Cathy_> SumitNaiksatam: hi, sorry to join late
18:23:01 <SumitNaiksatam> Cathy_: no worries, the time shift was confusing for everyone
18:23:31 <SumitNaiksatam> ivar-lazzaro banix can you sync with rkukura offline on which resources you need support for?
18:23:36 <ivar-lazzaro> rkukura: what does that imply? Will contracts still be bound to SGs for all the drivers?
18:24:12 <banix> SumitNaiksatam: ok will do
18:24:16 <SumitNaiksatam> banix: thanks
18:24:23 <rkukura> ivar-lazzaro: We don’t expose the SG mapping, so shouldn’t be an issue for that
18:24:41 <rkukura> A followup patch would add support for extending whatever other resources we need
18:24:43 <ivar-lazzaro> rkukura: yeah just realized that, nevermind :)
18:24:56 <SumitNaiksatam> rkukura: ah, that would be ideal!
18:25:05 <ivar-lazzaro> rkukura: that's great!
18:25:05 <SumitNaiksatam> rkukura: thanks for that update
18:25:15 <SumitNaiksatam> next item ...
18:25:38 <SumitNaiksatam> s3wong is working on getting the updates to work for the policy rules and rule sets
18:26:00 <SumitNaiksatam> s3wong this would involve DB schema changes, right?
18:26:04 <s3wong> SumitNaiksatam: indeed
18:26:24 <SumitNaiksatam> just asking if this warrants a spec
18:26:36 <SumitNaiksatam> but dont want to introduce unnecessary process overhead
18:26:50 <SumitNaiksatam> we can have a separate design review session if required
18:27:08 <s3wong> SumitNaiksatam: yes, I need to have several more tables to get which SG a policy-rule/classifier/action maps to
18:27:16 <SumitNaiksatam> s3wong: makes sense
18:27:19 <s3wong> SumitNaiksatam: OK
18:27:32 <SumitNaiksatam> next item is incorporating the redirect action in the hierarchical contract composition
18:27:57 <SumitNaiksatam> magesh is not here, but he might be interested in doing that, i will follow up offline with him
18:28:03 <s3wong> (currently I am operating under the assumption that I don't need a separate spec for that... because TBH, it should have been done along with the last SG patch :-)  )
18:28:04 <rkukura> s3wong: have you looked into a joined query?
18:28:22 <ivar-lazzaro> rkukura: +1
18:28:24 <SumitNaiksatam> s3wong: fair enough :-)
18:28:25 <rkukura> s3wong: I agree a spec should not be needed
18:28:46 <s3wong> rkukura: no, but that does sound like a better thing to do...
18:29:23 <hemanthravi> SumitNaiksatam, i
18:29:35 <SumitNaiksatam> hemanthravi: hi, you made it :-)
18:29:39 <hemanthravi> SumitNaiksatam, will follow up magesh on the redirect...
18:29:55 <hemanthravi> SumitNaiksatam, forgot about the time change...call at 11
18:30:01 <SumitNaiksatam> hemanthravi: great thanks!
18:30:14 <SumitNaiksatam> s3wong: thanks for the update, anything more on that work item?
18:30:43 <s3wong> SumitNaiksatam: no, but will definitely get it done by Nov. 28th :-)
18:30:55 <SumitNaiksatam> s3wong: sweet, thanks! :-)
18:31:06 <SumitNaiksatam> next item - vendor drivers
18:31:16 <SumitNaiksatam> i believe ronak is not here
18:31:28 <SumitNaiksatam> i believe he is working on this
18:31:53 <SumitNaiksatam> banix: any chance that you will posting one for this release?
18:32:40 <banix> SumitNaiksatam: There is a colleague who is working on it and I will have to check and see how that is going. Have not been in close contact with that work.
18:32:51 <SumitNaiksatam> banix: no worries
18:33:02 <SumitNaiksatam> banix: please let us know if you/he needs any help on that
18:33:16 <banix> SumitNaiksatam: sure. thanks.
18:33:22 <SumitNaiksatam> banix: we have a couple of vendor drivers in, so we have some basic experience on that
18:33:37 <SumitNaiksatam> just noticed s3wong posted the ODL driver, #link https://review.openstack.org/134285
18:33:40 <banix> sounds good.
18:33:53 <s3wong> SumitNaiksatam: the ODL policy driver probably won't make the 11/28 cutoff (though I posted the spec under juno)
18:33:53 <SumitNaiksatam> s3wong: great that you got this in
18:34:07 <SumitNaiksatam> s3wong: lets work on that
18:34:07 <banix> the spec for it
18:34:52 <SumitNaiksatam> s3wong: is yapeng planning to help out with the implementation?
18:35:14 <s3wong> SumitNaiksatam: Yapeng is more focus on ODL side
18:35:20 <SumitNaiksatam> s3wong: ok got it
18:35:41 <SumitNaiksatam> s3wong: lets have a separate short session to review that spec, so that we can move ahead
18:35:44 <s3wong> he is looking into having another renderer and implement any gap between ODL and OpenStack GBP in ODL GBP
18:35:58 <SumitNaiksatam> s3wong: okay sounds good
18:36:24 <SumitNaiksatam> next major work item is testing
18:36:47 <SumitNaiksatam> we need to increase UT and FT coverage
18:37:00 <SumitNaiksatam> i will work on weeding out the problem areas
18:37:12 <nbouthors> s3wong: where can we find the specs for the ODL GBP driver requirements
18:37:15 <SumitNaiksatam> Kanzhe is looking at the scenarios that we would need to test
18:37:31 <SumitNaiksatam> nbouthors: #link https://review.openstack.org/134285
18:37:42 <s3wong> nbouthors: SumitNaiksatam posted a link above.. but here it is #link https://review.openstack.org/#/c/134285/
18:37:51 <nbouthors> ok thanks
18:37:58 <SumitNaiksatam> Kanzhe: probably you did not get a chance to look at this yet
18:38:09 <Kanzhe> SumitNaiksatam: Not yet.
18:38:27 <SumitNaiksatam> Kanzhe: np, some kind of a summary test plan would be good
18:38:31 <Kanzhe> Plan to start working on it later the week.
18:38:42 <SumitNaiksatam> Kanzhe: that way multiple people can work on it in parallel
18:38:44 <SumitNaiksatam> Kanzhe: thanks
18:39:01 <SumitNaiksatam> just the high level scenarios
18:39:02 <Kanzhe> SumitNaiksatam: sure.
18:39:11 <SumitNaiksatam> thanks
18:39:40 <SumitNaiksatam> that work items on client, ui and heat side
18:39:59 <SumitNaiksatam> some things are broken in the client (apart from the renaming)
18:40:14 <SumitNaiksatam> bugs are posted, so please feel free to pick them up
18:40:37 <SumitNaiksatam> uday is not here, but he is working on several UI pieces
18:40:55 <SumitNaiksatam> perhaps we can have a separate session to discuss what the team would like to see in the UI
18:41:06 <SumitNaiksatam> is susaant here?
18:41:37 <SumitNaiksatam> hemanthravi: i believe the heat patches are mostly merged now?
18:42:05 <hemanthravi> SumitNaiksatam, yes, will check if susaant pushed the devstack changes
18:42:15 <SumitNaiksatam> hemanthravi: ok thanks
18:42:52 <SumitNaiksatam> so the above is mostly what we want to focus for the juno release
18:43:02 <SumitNaiksatam> #topic Kilo work items
18:43:32 <SumitNaiksatam> Cathy_: Louis and nbouthors have been working on a number of specs
18:43:52 <SumitNaiksatam> they are all listed here: #link https://review.openstack.org/#/q/status:open+project:stackforge/group-based-policy-specs+branch:master,n,z
18:44:09 <SumitNaiksatam> so in parallel we will try to make progress on these spec reviews as well
18:44:53 <SumitNaiksatam> we have other features like policy tags which will be immediate priorities in Kilo
18:45:20 <SumitNaiksatam> but i dont want to get too far ahead of ourselves, we can revisit priorities and features when we are actually done with Juno
18:45:34 <s3wong> SumitNaiksatam: +1
18:45:37 <Cathy_> SumitNaiksatam: sounds good.
18:45:45 <SumitNaiksatam> we will discuss and have the Kilo topics as a standing agenda item in the meetings though, until then
18:46:03 <SumitNaiksatam> we should all be making progress in parallel, ideally! ;-)
18:46:31 <igordcard> SumitNaiksatam, +1
18:46:50 <SumitNaiksatam> igordcard: that would also include the traffic steering and classifiers :-)
18:46:57 <igordcard> probably it is already too late, but I would like to re-propose the traffic steering blueprint for Kilo
18:46:57 <Cathy_> We will submit another BP for integrating with Service Funcitons instantiated outside of GBP or SC, which we think is higher priority than the other BPs we proposed earlier on
18:47:02 <igordcard> SumitNaiksatam, exactly :)
18:47:10 <SumitNaiksatam> Cathy_: sounds good
18:47:39 <SumitNaiksatam> igordcard: we will have to focus on getting the current model to work correctly (with the current set of classifiers)
18:48:03 <Cathy_> SumitNaiksatam:ok
18:48:05 <SumitNaiksatam> igordcard: but yes, i agree, lets discuss steering part in parallel, and figure out the scope and applicability
18:48:25 <SumitNaiksatam> #action SumitNaiksatam to follow up with igordcard on steering spec
18:48:44 <Cathy_> SumitNaiksatam: for integrating with Service Funcitons instantiated outside of GBP or SC, we would like to target it at Kilo
18:48:51 <igordcard> SumitNaiksatam, alright :)
18:49:36 <SumitNaiksatam> Cathy_: yes, mandeep and tgraf (thomas) had some thoughts around this, so lets get everyone on the same page
18:49:55 <SumitNaiksatam> #action SumitNaiksatam to follow up with Cathy_ on SFC
18:49:57 <Cathy_> SumitNaiksatam: since in reality (based on my talk with other service function appliance companies) quite some SF will be instantiated outside GBP and SC
18:50:16 <SumitNaiksatam> Cathy_: agreed
18:50:39 <SumitNaiksatam> #topic Open Discussion
18:50:41 <Cathy_> SumitNaiksatam: I am looking forwward to talking with you. We will help develeping this.
18:51:04 <SumitNaiksatam> Cathy_: yes, hence added the AI for me :-)
18:51:08 <SumitNaiksatam> okay we have 9 mins
18:51:25 <SumitNaiksatam> we circle back to discussion on the timelines etc
18:51:42 <SumitNaiksatam> ivar-lazzaro: so does it sound reasonable?
18:52:10 <ivar-lazzaro> SumitNaiksatam: yes seems fair
18:52:22 <SumitNaiksatam> ivar-lazzaro: ok, doable? ;-)
18:52:27 <hemanthravi> Cathy_, we should also discuss if we can use SC to represent the SF instantiated outside
18:52:42 <ivar-lazzaro> SumitNaiksatam: the work is well distributed, apart from major blockers that may arise it seems a reasonable timeline
18:52:51 <Cathy_> hemanthravi: yes
18:52:53 <SumitNaiksatam> ivar-lazzaro: yeah
18:53:08 <SumitNaiksatam> one dependency might be rkukura’s extension loading for the vendor drivers
18:53:18 <SumitNaiksatam> oh i forgot to mention
18:53:24 <igordcard> The TS bp at its latest state is at https://review.openstack.org/#/c/92477, should its topic just be changed, or completely abandoned and recreated afterwards? Also, I'm not sure if gerrit allows changing the ownership...
18:53:30 <Cathy_> hemanthravi: I have some thought on this. Let's have a meeting to discuss it
18:53:35 <SumitNaiksatam> rkukura is working furiously on the packaging
18:53:38 <hemanthravi> Cathy_, ok
18:53:48 <rkukura> and my expense report ;)
18:53:56 <SumitNaiksatam> rkukura: :-)
18:54:14 <SumitNaiksatam> so rkukura would be working on the extension loading after that
18:54:24 <Cathy_> hemanthravi: SumitNaiksatam : will Sumit call for a seperate face-to-face meeting for the discussion?
18:54:28 <SumitNaiksatam> so we need to coordinate a bit so that we work in lock step here
18:54:35 <s3wong> SumitNaiksatam: no problem for rkukura, he still has THREE whole weeks :-)
18:54:36 <SumitNaiksatam> Cathy_: hemanthravi sounds good
18:54:43 <SumitNaiksatam> s3wong: :-)
18:54:54 <SumitNaiksatam> igordcard: to your question
18:54:56 <s3wong> SumitNaiksatam: actually TWO
18:55:06 <SumitNaiksatam> igordcard: note that your earlier spec was submitted in the neutron specs
18:55:14 <hemanthravi> rkukura, do the vendor drivers need to make any changes for the new mech
18:55:22 <SumitNaiksatam> igordcard: however, the GBP specs are now separate from the neutron specs
18:55:42 <SumitNaiksatam> igordcard: hence i was saying we need to understand which part is relevant where
18:56:30 <s3wong> SumitNaiksatam, igordcard: traffic steering is interesting for GBP; on one hand, we already have classifier in GBP, on the other, we operate on an abstraction level such than TS may be a bit low level
18:56:43 <SumitNaiksatam> s3wong: agree
18:56:48 <SumitNaiksatam> but we still need it
18:57:09 <s3wong> igordcard: so --- looking forward to seeing your spec in context of GBP :-)
18:57:11 <SumitNaiksatam> since the service chain should ideally leverage this
18:57:44 <SumitNaiksatam> igordcard: i can bring you up to speed if you are cofused between the projects and the processes ;-)
18:58:01 <SumitNaiksatam> igordcard: lets take it offline
18:58:12 <SumitNaiksatam> okay anything more to discuss to today?
18:58:19 <igordcard> SumitNaiksatam, Okay then
18:58:20 <hemanthravi> need to log off, bye
18:58:30 <SumitNaiksatam> okay thanks everyone for joining
18:58:33 <Cathy_> bye
18:58:38 <igordcard> Cya all
18:58:39 <SumitNaiksatam> till next week, bye!
18:58:43 <SumitNaiksatam> #endmeeting