18:02:06 <SumitNaiksatam> #startmeeting networking_policy
18:02:07 <openstack> Meeting started Thu Nov 20 18:02:06 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:11 <openstack> The meeting name has been set to 'networking_policy'
18:03:00 <SumitNaiksatam> #info meeting agenda https://wiki.openstack.org/wiki/Meetings/Neutron_Group_Policy#Nov_20th.2C_2014
18:04:04 <s3wong> no agenda for today's meeting :-)
18:04:12 <SumitNaiksatam> s3wong: refresh :-)
18:04:58 <SumitNaiksatam> as we are getting closer to the wrapping up the features, we need to start tracking bugs, packaging, etc
18:05:07 <SumitNaiksatam> so i have proposed a standing agenda for the meetings
18:05:09 <s3wong> SumitNaiksatam: I need to drop off @10:30am, so if there is any update for me, would you mind putting me up earlier? Thanks
18:05:14 <SumitNaiksatam> *standing items
18:05:18 <SumitNaiksatam> s3wong: sure
18:05:24 <SumitNaiksatam> will try to get to that quickly
18:05:48 <SumitNaiksatam> please feel free to add any other standing items as you deem relevant
18:06:08 <SumitNaiksatam> btw, any announcements that anyone would ike to share?
18:06:39 <SumitNaiksatam> #topics Bugs
18:07:09 <SumitNaiksatam> we have a long list of bugs that we need to start triaging and knocking off (by triaging i mean find owners)
18:07:24 <SumitNaiksatam> it will be difficult to do that bug scrub in this meeting today
18:07:57 <SumitNaiksatam> but i think as a practice we need to at least bring up the pending “critical” bugs in the meetings every week
18:08:19 <SumitNaiksatam> i would regard critical bugs as show stoppers, so they should be fixed asap
18:08:33 <SumitNaiksatam> #link https://bugs.launchpad.net/group-based-policy/+bug/1388635
18:09:02 <SumitNaiksatam> ivar-lazzaro: had posted a fix for this
18:09:18 <ivar-lazzaro> SumitNaiksatam: thanks for bringing this up!
18:09:28 <SumitNaiksatam> #bug 1388635
18:09:42 <SumitNaiksatam> oh wait, we probably dont have the bot for this meeting
18:09:49 <SumitNaiksatam> “intra EPG connectivity not working"
18:10:24 <SumitNaiksatam> ivar-lazzaro: did you link the patch to the LP bug?
18:10:43 <ivar-lazzaro> SumitNaiksatam: checking
18:11:07 <mageshgv> ivar-lazzaro:wrong bugid is referenced on the patch
18:11:10 <SumitNaiksatam> https://bugs.launchpad.net/group-based-policy/+bug/1388635
18:11:20 <ivar-lazzaro> SumitNaiksatam: yep, I have it linked to #1387981 and #1388635
18:11:21 <SumitNaiksatam> mageshgv: ah
18:11:25 <mageshgv> https://review.openstack.org/#/c/132485/
18:11:44 <SumitNaiksatam> mageshgv: thanks catching that, and also thanks for joining, its a fairly late hour for you!
18:12:03 <mageshgv> sumitNaiksatam: no problem
18:12:06 <ivar-lazzaro> Oh that's the wrong topic
18:12:07 <SumitNaiksatam> ivar-lazzaro: gerrit link?
18:12:19 <ivar-lazzaro> #link https://review.openstack.org/#/c/132485/
18:12:36 <banix> i think the way bug is referred to is incorrect
18:12:47 <banix> that’s why it doesnt show on LP
18:13:13 <SumitNaiksatam> banix: yeah, just dont need to prefix “bug/“
18:13:22 <ivar-lazzaro> yup
18:13:27 <ivar-lazzaro> I'll update asap
18:13:53 <SumitNaiksatam> ok anyway, but ivar-lazzaro promptly posted this fix on nov 2nd, but we are delinquent on the reviews
18:14:13 <SumitNaiksatam> not a good idea to let a critical sit around for that long! :-(
18:14:27 <SumitNaiksatam> kindly help review
18:15:22 <mageshgv> SumitNaiksatam: I will review it tomorrow
18:15:34 <SumitNaiksatam> mageshgv: great thanks, i will try to give it a shot today as well
18:15:46 <SumitNaiksatam> we will need at least one more core to look at it asap
18:16:17 <s3wong> SumitNaiksatam: I will take a look also
18:16:17 <SumitNaiksatam> s3wong: your updates fix is a bug fix or a bp?
18:16:21 <SumitNaiksatam> s3wong: thanks
18:16:29 <hemanthravi> SumitNaiksatam, i'll review ivar's fix
18:16:35 <SumitNaiksatam> hemanthravi: thanks
18:16:44 <s3wong> SumitNaiksatam: given that the fix has changes on resource mapping driver
18:17:01 <s3wong> SumitNaiksatam: I think we classified it as a "bug"
18:17:06 <SumitNaiksatam> s3wong: okay
18:17:14 <SumitNaiksatam> s3wong: so that goes against #link https://bugs.launchpad.net/group-based-policy/+bug/1383941 ?
18:17:22 <SumitNaiksatam> “rmd update rules operations”
18:17:54 <s3wong> SumitNaiksatam: yes, the description seems to fit
18:18:14 <SumitNaiksatam> s3wong: ok cool, so keep that in mind, that will be one high priority bug knocked off!
18:18:15 <s3wong> SumitNaiksatam: and it is assigned to ivar-lazzaro :-)
18:18:39 <s3wong> SumitNaiksatam: sure, working on it now with the latest branch (with the name changes)
18:18:45 <SumitNaiksatam> s3wong: sweet!
18:19:00 <SumitNaiksatam> so in the next few days i will reach out to folks in the team and do some bug assignments
18:19:08 <SumitNaiksatam> we got scrub the entire list
18:19:13 <SumitNaiksatam> *got to
18:19:14 <s3wong> SumitNaiksatam: shooting for patch in gerrit early next week
18:19:20 <SumitNaiksatam> s3wong: good
18:19:37 <SumitNaiksatam> so if you are uncomfortable with the assignment, please free to unassign it
18:19:52 <SumitNaiksatam> any other bugs that we need to discuss right now?
18:20:13 <SumitNaiksatam> ok moving on
18:20:27 <SumitNaiksatam> i will change the order of the agenda to accomodate s3wong’s request
18:20:33 <SumitNaiksatam> #topic New policy drivers
18:21:02 <SumitNaiksatam> on the ODL driver, some of us having been working in the background to get this going
18:21:13 <SumitNaiksatam> s3wong: based on the discussions we will need to update the spec
18:21:22 <s3wong> SumitNaiksatam: yes
18:21:45 <SumitNaiksatam> s3wong: any other update from you on that front?
18:22:15 <s3wong> SumitNaiksatam: looked into ODL ML2 mechanism driver to see how OpenStack connects to ODL controller
18:22:20 <SumitNaiksatam> s3wong: okay
18:22:37 <SumitNaiksatam> s3wong: we can discuss offline
18:22:44 <SumitNaiksatam> Nuage driver
18:22:48 <SumitNaiksatam> rms_13: there?
18:22:52 <SumitNaiksatam> s3wong: thanks for the update
18:22:57 <rms_13> yes
18:23:11 <s3wong> SumitNaiksatam: also, looked at ivar-lazzaro 's APIC driver to see how the gbp mapping db is being used for the L2/3 policy + EP/EPG mapping
18:23:12 <SumitNaiksatam> s3wong: feel free to take off whenever convenient ;-)
18:23:41 <SumitNaiksatam> s3wong: yes, also one convergence driver does something similar (overloading the resource mapping driver)
18:23:42 <s3wong> SumitNaiksatam: sure, I have another meeting in 7 minutes.. have fun, guys!
18:23:47 <SumitNaiksatam> s3wong: thanks
18:24:00 <SumitNaiksatam> rms_13: sorry, you planning another rev on the spec?
18:24:09 <rms_13> Yes. ETA tomorrow.
18:24:18 <rms_13> Hopefully the code will land by Monday as well
18:24:28 <SumitNaiksatam> rms_13: sweet, was just about to ask!
18:24:30 <rms_13> Got caught up in some internal nuage thing
18:24:37 <SumitNaiksatam> rms_13: np
18:24:50 <rms_13> No its on my TODO list...will get it
18:24:53 <SumitNaiksatam> rms_13: any blockers for you, any additional information you need?
18:25:12 <rms_13> None so far. Will have more questions probably starting tomorrow...will ask offline
18:25:15 <SumitNaiksatam> rms_13: perhaps it might help for you to follow the ODL dicussion
18:25:21 <SumitNaiksatam> rms_13: ok sure
18:25:25 <rms_13> cool. thx
18:25:26 <SumitNaiksatam> banix: hi there
18:25:35 <SumitNaiksatam> banix: any update on the IBM driver?
18:25:58 <banix> SumitNaiksatam: i do not think it will be happening in this cycle
18:26:09 <SumitNaiksatam> banix: okay np
18:26:20 <SumitNaiksatam> banix: you can still submit the spec against kilo
18:26:38 <banix> SumitNaiksatam: sure
18:26:46 <SumitNaiksatam> banix: some other specs have already been submitted targeted for kilo
18:26:49 <SumitNaiksatam> banix: thanks
18:27:06 <SumitNaiksatam> anyone else planning anything around the vendor drivers?
18:27:27 <SumitNaiksatam> we will touch on the driver extensions in the bp topic
18:27:41 <SumitNaiksatam> ok
18:27:44 <SumitNaiksatam> #topic Feature blueprints
18:28:11 <SumitNaiksatam> so update at my end - the renaming on the client and server is completed
18:28:17 <SumitNaiksatam> for better or worse!
18:28:35 <SumitNaiksatam> so we can officially start talking in terms of PT, PTG and PRS!
18:28:51 <ivar-lazzaro> SumitNaiksatam: yey!
18:29:00 * SumitNaiksatam cant’ see to get contracts out of his system! :-(
18:29:07 <SumitNaiksatam> ivar-lazzaro: :-)
18:29:29 <SumitNaiksatam> apologies to everyone else who had to rebase their patches on account of this change
18:29:50 <SumitNaiksatam> ivar-lazzaro: mostly they were your patches
18:30:10 <SumitNaiksatam> Heat renaming patches are already in review
18:30:21 <SumitNaiksatam> hemanthravi: are you on the hook for those?
18:30:44 <hemanthravi> SumitNaiksatam, yes will review the heat patches
18:30:53 <SumitNaiksatam> and osm?
18:31:17 <hemanthravi> will check with osm
18:31:30 <SumitNaiksatam> hemanthravi: ok, lets get this rolling asap
18:31:54 <SumitNaiksatam> the horizon patches have not yet been submitted, i had expected them to be submitted today
18:32:10 <SumitNaiksatam> the renamin is however finished in uday’s branch
18:32:26 <SumitNaiksatam> i will update the devstack so that we can get horizon and heat working as well with the renaming
18:32:45 <SumitNaiksatam> there are three other major features/bps that we are targeting
18:33:03 <SumitNaiksatam> first one is resources’ sharing
18:33:10 <SumitNaiksatam> #link https://review.openstack.org/133603
18:33:21 <SumitNaiksatam> second one is for external connectivity
18:33:30 <SumitNaiksatam> this spec has not been submitted
18:33:35 <SumitNaiksatam> the first one is required for the second
18:33:51 <SumitNaiksatam> ivar-lazzaro: you are leading both of those?
18:33:58 <ivar-lazzaro> SumitNaiksatam: yes
18:34:14 <SumitNaiksatam> ivar-lazzaro: okay, brave! :-)
18:34:30 <ivar-lazzaro> SumitNaiksatam: I've already posted a patch for the shared attribute, and I'm still working on a spec for the external connectivity
18:34:39 <SumitNaiksatam> ivar-lazzaro: the resources’ sharing spec has some review comments
18:34:41 <ivar-lazzaro> SumitNaiksatam: :)
18:35:09 <ivar-lazzaro> SumitNaiksatam: yes I'll address them by today
18:35:17 <SumitNaiksatam> i would like to make one high level clarification here
18:35:40 <SumitNaiksatam> the proposal is to make a change to the resource model (in terms of sharing of all resources)
18:35:56 <SumitNaiksatam> however, it is not mandatory for all drivers to support this
18:36:29 <SumitNaiksatam> if a particular driver does not support it, in this first iteration of GBP, the driver should throw an not-implemented exception
18:36:37 <SumitNaiksatam> ivar-lazzaro: please capture this in the spec
18:36:57 <ivar-lazzaro> SumitNaiksatam: sure
18:37:10 <SumitNaiksatam> this includes the neutron resource mapping driver, which has limited sharing capabilities
18:37:38 <SumitNaiksatam> any questions/thoughts on the above two
18:37:55 <SumitNaiksatam> i guess its difficult to talk about the external connectivity since there is no spec yet
18:38:21 <SumitNaiksatam> but i believe the idea is to introduce additions to the model so as to model the “external world"
18:38:30 <SumitNaiksatam> ivar-lazzaro: is that fair summary?
18:39:18 <ivar-lazzaro> SumitNaiksatam: perfect :)
18:39:24 <SumitNaiksatam> ok
18:39:39 <SumitNaiksatam> the third major feature is the “extensions loading via drivers"
18:39:55 <SumitNaiksatam> rkukura: your turn
18:40:20 <rkukura> nothing new on this - its been on hold, but I should be able to resume working on it today or tomorrow
18:40:30 <SumitNaiksatam> rkukura: sweet!
18:40:52 <SumitNaiksatam> so if you are planning on using this in your vendor drivers, its coming soon! :-)
18:41:33 <SumitNaiksatam> the other logistical detail that i wanted to bring up
18:41:49 <SumitNaiksatam> you should be seeing a “kilo” branch in the specs shortly
18:42:12 <SumitNaiksatam> so the specs which are not targeting for Juno, and have already been submitted, should be moved to kilo
18:42:23 <SumitNaiksatam> is louis or cathy here?
18:42:40 <SumitNaiksatam> okay i will reach out to them
18:43:03 <SumitNaiksatam> #action SumitNaiksatam to reach out to Louis to move gerrit specs to kilo
18:43:09 <igordcard> SumitNaiksatam, the same goes for TS right?
18:43:22 <SumitNaiksatam> igordcard: yes, and we will discuss right after this meeting as well
18:43:33 <SumitNaiksatam> igordcard: thanks for bringing that up
18:43:40 <SumitNaiksatam> anything else on the specs?
18:44:00 <SumitNaiksatam> ok
18:44:07 <SumitNaiksatam> #topic Packaging
18:44:11 <SumitNaiksatam> rkukura: over to you
18:44:52 <rkukura> OK, I’ve been working on the Fedora packaging, which will then be the basis for RDO and RHOS packaging on RHEL
18:45:07 <SumitNaiksatam> rkukura: nice!
18:45:17 <SumitNaiksatam> rkukura: were you able to get past that setup issue?
18:45:33 <rkukura> I’ve got server and client packages that install, but working on missing files that prevent the gbp-db-manage from succeeding
18:45:44 <rkukura> plus a bunch of other small packaging fixes
18:46:18 <rkukura> I’m currently using pre-rename commits, so I can do horizon and heat as well
18:46:27 <SumitNaiksatam> rkukura: ah good
18:46:37 <rkukura> but will switch to latest once we have renaming complete
18:46:50 <SumitNaiksatam> rkukura: so that you way you would have ironed out the packaging issues
18:47:05 <SumitNaiksatam> rkukura: and then we can iterate with regards to actual contents of the packages
18:47:09 <rkukura> the packages then need to go through a formal Fedora review process, but I’ve been working with the reviewer, so it shouldn’t take long
18:47:41 <rkukura> My goal is to make sure the API operations work with the initial packages that are reviewed
18:48:16 <rkukura> I’ll be filing a bug and posting a fix for files missing in the groub-based-policy repo when “python setup.py install” is run.
18:48:26 <SumitNaiksatam> rkukura: okay
18:48:28 <rkukura> thats about it on Fedora
18:48:47 <rkukura> I will also put up an RDO wiki page with instructions
18:49:02 <SumitNaiksatam> rkukura: so in terms of timelines, what is the latest that you can package fedora?
18:49:08 <rkukura> I can point these instructions initially at RPMs I’ve built and will put on fedorapeople.org
18:49:27 <SumitNaiksatam> rkukura: i mean having to account for the review process, etc.
18:49:27 <rkukura> SumitNaiksatam: not sure what you mean by “latest”?
18:49:59 <rkukura> I will get at least the client and server into review this week, hopefully all four
18:50:30 <SumitNaiksatam> rkukura: but between now and dev 19th we will be adding features and fixing bugs
18:50:51 <rkukura> Right, we can update the packages at any point to newer upstream commits
18:50:52 <SumitNaiksatam> rkukura: so new packages will be generated for those?
18:51:20 <SumitNaiksatam> rkukura: okay good
18:51:21 <rkukura> The initial packages will be 2014.2-0.1, then we bump to 2014.2.0.2
18:51:26 <SumitNaiksatam> rkukura: got it
18:51:29 <rkukura> Official Juno will be 2014.2-1
18:51:57 <rkukura> so we can have as many pre-release versions as we need
18:52:04 <SumitNaiksatam> rkukura: ok good, so they have a convention for this
18:52:21 <SumitNaiksatam> rkukura: thanks for the update, looks promising! :-)
18:52:30 <rkukura> yes - the ordering of the version strings is critical so newer always replaces older on updates
18:52:30 <SumitNaiksatam> any questions for rkukura?
18:52:47 <SumitNaiksatam> rkukura: got it, makes sense
18:53:06 <rkukura> One thing - do we have an upstream version for python-gbpclient?
18:53:19 <SumitNaiksatam> rkukura: by upstream you mean, pypi?
18:53:37 <rkukura> I mean like the 2.x.y version on python-neutronclient, etc.
18:53:54 <rkukura> The client libs don’t use the 2014.2 release versioning
18:54:23 <SumitNaiksatam> rkukura: okay, but that 2.x.y is an consequence of the package being present in pypi?
18:54:28 <rkukura> I’m guessing we should call our initial python-gbpclient 1.0, or maybe 0.1
18:54:33 <SumitNaiksatam> rkukura: or is it just a setup thing
18:54:38 <rkukura> Don’t know about pypi
18:54:55 <rkukura> I think this versioning is from the setup.py and setup.cfg
18:55:09 <rkukura> But its not set in the gdbclient rep
18:55:11 <rkukura> repo
18:55:15 <SumitNaiksatam> rkukura: yes there is a place where the version number gets set
18:55:18 <rkukura> gbp
18:55:22 <SumitNaiksatam> rkukura: its in the egginfo
18:55:32 <SumitNaiksatam> rkukura: okay let me circle back to you offline on this
18:55:38 <rkukura> ok
18:55:47 <SumitNaiksatam> #action rkukura and SumitNaiksatam to work on client version numbering
18:56:23 <SumitNaiksatam> rkukura: any other updates?
18:56:30 <rkukura> SumitNaiksatam: I’m seeing 2.3.9 in the egg-info
18:56:49 <SumitNaiksatam> rkukura: yeah this is copied over from the neutron client :-)
18:56:54 <SumitNaiksatam> rkukura: need to fix that
18:57:19 <rkukura> We probably should start with 1.0 or 0.1
18:57:28 <SumitNaiksatam> rkukura: makes sense
18:57:39 <SumitNaiksatam> okay couple of mins left
18:57:48 <SumitNaiksatam> rkukura: thanks for the update
18:57:54 <SumitNaiksatam> #topic Open Discussion
18:58:01 <SumitNaiksatam> one quick logistical update
18:58:02 <rkukura> I’m a bit concerned that we will make siginficant changes in kilo and won’t have full backward CLI compatability
18:58:10 <SumitNaiksatam> rkukura: okay
18:58:30 <SumitNaiksatam> neutron is cleaning up the subteams
18:58:44 <SumitNaiksatam> and we are listed in the meetings wiki page under the networking program
18:59:06 <SumitNaiksatam> so we will update the meetings wiki page to move this meeting to show up independently
18:59:17 <ivar-lazzaro> SumitNaiksatam: +1
18:59:39 <rkukura> SumitNaiksatam: Have you considered just writing a charter so we can stay in networking (for now)?
18:59:41 <SumitNaiksatam> we can rearrange as things evolve
18:59:56 <rkukura> I’ve drafted a chater for the ML2 subteam
19:00:12 <SumitNaiksatam> rkukura: i did draft one for adv services and fwaas
19:00:28 <SumitNaiksatam> rkukura: but i am not sure GBP
19:00:58 <rkukura> I’m still thinking we networking GBP is similar to adv svcs in networking - just a separate repo
19:01:00 <SumitNaiksatam> rkukura: since there are currently not patches or features being discussed on the neutron side in this context
19:01:18 <SumitNaiksatam> rkukura: okay we can discuss further
19:01:23 <SumitNaiksatam> we are one minute over
19:01:29 <SumitNaiksatam> thanks all for joining
19:01:34 <SumitNaiksatam> bye!
19:01:35 <rkukura> thanks SumitNaiksatam!
19:01:37 <rkukura> bye
19:01:38 <igordcard> cya all
19:01:39 <SumitNaiksatam> #endmeeting