18:01:00 <SumitNaiksatam> #startmeeting networking_policy
18:01:01 <openstack> Meeting started Thu Dec  4 18:01:00 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:04 <openstack> The meeting name has been set to 'networking_policy'
18:01:20 <SumitNaiksatam> #info meeting agenda https://wiki.openstack.org/wiki/Meetings/Neutron_Group_Policy#Dec_4th.2C_2014
18:01:45 <SumitNaiksatam> mageshgv: thanks for joining i know its late at your end!
18:02:02 <mageshgv> SumitNaiksatam: No problem
18:02:20 <SumitNaiksatam> we will try to keep this short today, not because we dont have enought to discuss, but because we need to go back and implement a bunch of pending stuff ;-P
18:02:41 <SumitNaiksatam> #topic Bugs
18:02:57 <SumitNaiksatam> rkukura:  for #link https://bugs.launchpad.net/group-based-policy/+bug/1394722
18:03:14 <SumitNaiksatam> rkukura: what do we need to do?
18:03:38 <rkukura> I’ll close that one as not-a-bug, since it works correctly when run inside a git repo
18:04:16 <SumitNaiksatam> rkukura: sweet, oh “invalid” critical bug, no fix required…don’t you love that? :-)
18:04:42 <SumitNaiksatam> ivar-lazzaro: right on cue
18:04:48 <ivar-lazzaro> Hi all
18:04:59 <SumitNaiksatam> ivar-lazzaro: #link https://bugs.launchpad.net/group-based-policy/+bug/1397721
18:05:14 <SumitNaiksatam> ivar-lazzaro: you raised this, so its your problem…just kidding
18:05:24 <ivar-lazzaro> SumitNaiksatam: ehe :)
18:05:25 <SumitNaiksatam> ivar-lazzaro: its great that you caught this issue
18:05:49 <SumitNaiksatam> ooops, hope i did not offend
18:05:50 <s3wong> ivar-lazzaro is trying to duck from the bug :-)
18:05:57 <SumitNaiksatam> s3wong: lol
18:06:08 <SumitNaiksatam> its really great that he figured this one out
18:06:21 <SumitNaiksatam> ivar-lazzaro: you got us worried there
18:06:38 <SumitNaiksatam> ivar-lazzaro: so, how do we go about fixing that one?
18:06:38 <ivar-lazzaro> SumitNaiksatam: yeah, It's IRC client empathy :)
18:06:45 <SumitNaiksatam> ivar-lazzaro: lol
18:07:31 <ivar-lazzaro> SumitNaiksatam: At a first glance it looks as simple as removing the SG rule whenever a PTG contract is removed
18:08:10 <SumitNaiksatam> #chair rkukura ivar-lazzaro s3wong mageshgv hemanthravi
18:08:11 <openstack> Current chairs: SumitNaiksatam hemanthravi ivar-lazzaro mageshgv rkukura s3wong
18:08:16 <ivar-lazzaro> SumitNaiksatam: We need to do that because of our "per-subnet" rule approach, which means that each PTG association/disassociation changes the PRS rules
18:08:17 <SumitNaiksatam> in case i drop off like ivar-lazzaro did :-)
18:08:43 <SumitNaiksatam> ivar-lazzaro: okay, so you have this on your radar?
18:08:54 <SumitNaiksatam> ivar-lazzaro: would like to get the fix merged before dec 12th
18:09:05 <ivar-lazzaro> SumitNaiksatam: yeah I can look at it
18:09:32 * SumitNaiksatam thinks ivar-lazzaro already has a million things on his radar, another one will not make that much of a difference ;-P
18:09:40 <SumitNaiksatam> ivar-lazzaro: thanks
18:09:49 <SumitNaiksatam> ok moving on to the pending features
18:10:01 <SumitNaiksatam> #topic Pending features
18:10:16 <SumitNaiksatam> #undo
18:10:17 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x3db0850>
18:10:34 <SumitNaiksatam> want to check with mageshgv with some of the service chain related bugs
18:10:41 <SumitNaiksatam> there are a bunch of them
18:10:45 <SumitNaiksatam> mageshgv: how is that coming along?
18:11:26 <mageshgv> SumitNaiksatam: yes, other than the Hierarchial contracts handling for redirect, others are mostly moinor
18:11:32 <mageshgv> minor
18:12:15 <SumitNaiksatam> mageshgv: okay, merge deadline is dec 12th, no pressure!
18:12:39 <mageshgv> SumitNaiksatam: Good, should be done by then
18:12:44 <SumitNaiksatam> mageshgv: you too have a ton of things on your plate, thanks for the great effort!
18:12:56 <SumitNaiksatam> banix: hi
18:13:02 <SumitNaiksatam> #topic Pending Features
18:13:16 <banix> SumitNaiksatam: hi
18:13:42 <SumitNaiksatam> we pretty much missed merging all the features that we had planned for Nov 28th
18:13:48 <SumitNaiksatam> for a combination of reasons
18:14:05 <SumitNaiksatam> the thanksgiving break did not help with getting reviewer attention either
18:14:31 <SumitNaiksatam> the features have already been discussed, and the patches are in review
18:14:56 <SumitNaiksatam> i have posted the links in the agenda, happy to bring up any of those for discussion here if needed
18:16:10 <SumitNaiksatam> the priority features under review are: Shared attribute on resources, External connectivity (both handled by ivar-lazzaro), Extensions Loading via drivers (by rkukura), and Policy Rule Update (by s3wong)
18:16:28 <SumitNaiksatam> s3wong: your patch is WIP, how is it coming along?
18:16:29 <s3wong> mine is more a bug than a feature :-)
18:16:48 <s3wong> SumitNaiksatam: actually it is a bug, and ivar-lazzaro made some comments on an official patch
18:16:51 <SumitNaiksatam> s3wong: we still need to close it :-)
18:17:28 <SumitNaiksatam> s3wong: lets us know if there are any blockers and we can help out accordingly
18:17:46 <s3wong> I have coded about half of his comments --- sorry, no time to do it due to day job duty. Will try to address all of ivar-lazzaro's comments and post another patch this weekend
18:17:50 <SumitNaiksatam> s3wong: i imagine the biggest blocker for you might be availability of cycles
18:18:16 <s3wong> SumitNaiksatam: oh well :-)
18:18:20 <SumitNaiksatam> s3wong: okay great, lets try to make sure that we weed out any technical issues before this weekend
18:18:36 <SumitNaiksatam> s3wong: so that you code peacefully over the weekend ;-P
18:18:46 <s3wong> SumitNaiksatam: at least someone else took over the implementation of ODL policy driver (won't have cycle to that for sure before the 12th)
18:19:01 <SumitNaiksatam> s3wong: yes
18:19:23 <SumitNaiksatam> mageshgv: the two sem-features that you have - Hierarchical Contracts and Policy Action update (for redirects)
18:19:45 <SumitNaiksatam> mageshgv: did not see patches posted for those, just want to check that i did not miss it
18:19:46 <s3wong> SumitNaiksatam: I looked over ivar-lazzaro's comments thoroughly just last night, I think they are all good comments, and I will address them in the next patch (not yet seeing any technical issue yet)
18:20:23 <mageshgv> SumitNaiksatam: I have posted the patch for Policy Action update
18:20:36 <mageshgv> #link https://review.openstack.org/#/c/138338/
18:20:53 <mageshgv> Hierarchical Contracts is pending
18:21:05 <SumitNaiksatam> s3wong: great, thanks!
18:21:23 <SumitNaiksatam> mageshgv: ah ok, somehow missed that
18:21:40 <SumitNaiksatam> mageshgv: i know why, you did not add us reviewers :-)
18:22:12 <SumitNaiksatam> folks, if you just add “group-based-policy-core” to the reviewer, it will add all the cores
18:22:13 <mageshgv> SumitNaiksatam: Got to test this once. Will remove WIP and add reviewers once done
18:22:23 <SumitNaiksatam> request you to do that when you post a patch
18:22:43 <SumitNaiksatam> mageshgv: sure, helps to add the reviewers right away so that it starts showing up their radar
18:23:05 <mageshgv> SumitNaiksatam: Alright. Will do that
18:23:07 <SumitNaiksatam> mageshgv: thanks for the update, and again awesome amount of work!
18:23:30 <SumitNaiksatam> we will skip kilo blueprint discussion for today, since we have burning issues
18:23:39 <SumitNaiksatam> #topic Policy Drivers
18:24:01 <SumitNaiksatam> we have patches posted for the ODL Policy driver: #link https://review.openstack.org/138556
18:24:15 <SumitNaiksatam> is yi or yapeng here by any chance?
18:24:46 <SumitNaiksatam> I dont see ronak here either, wanted to check on the progress of the Nuage driver
18:24:54 <SumitNaiksatam> #topic Packaging
18:24:57 <SumitNaiksatam> rkukura: over to you
18:25:14 <rkukura> Good progress on the Fedora packaging.
18:25:54 <rkukura> The server and client packages have been approved, the server package is committed into fedora SCM, and the client package should be committed in the next 10 minutes
18:26:20 <rkukura> I should then be able to update the RDO wiki page instructions to reference official builds of these
18:26:31 <rkukura> These are based on the latest post-renaming commits
18:26:58 <rkukura> The heat package will be next, and the horizon package will probably wait until the needed patches are merged.
18:27:03 <SumitNaiksatam> rkukura: awesome!!!
18:27:16 <SumitNaiksatam> is susaant here?
18:27:37 <SumitNaiksatam> rkukura: you had the question on the heat client dependency version number?
18:27:49 <rkukura> right
18:28:13 <SumitNaiksatam> perhaps hemanthravi can relay it to susaant
18:28:20 <hemanthravi> SumitNaiksatam, here with me
18:28:32 <SumitNaiksatam> hemanthravi: great
18:28:36 <rkukura> Is: Requires:	python-heatclient >= 0.2.9   correct?
18:29:15 <hemanthravi> rkukura, susant say's he'll check and send an e-mail out
18:29:33 <rkukura> thanks - I’ll commit the package with that, and can change it if needed
18:29:51 <SumitNaiksatam> hemanthravi: rkukura: thanks
18:30:38 <SumitNaiksatam> rkukura earlier updated that he is waiting for the UI patches to be merged
18:30:57 <SumitNaiksatam> he will be trying a dry run with the patches in review though
18:31:16 <SumitNaiksatam> so on the UI front, actually there is pretty good progress
18:31:27 <SumitNaiksatam> uday is working hard on fixing the pending bugs
18:31:45 <SumitNaiksatam> but the UI is mostly functional now with the features that we have in place as of today
18:31:56 <SumitNaiksatam> rkukura: any other updates on the packaging side?
18:32:13 <hemanthravi> rkukura, >= 0.2.9 is correct (susaant)
18:32:21 <rkukura> Not from me. Who’s doing the Ubuntu side?
18:32:26 <rkukura> hemanthravi: thanks!
18:32:38 <SumitNaiksatam> rkukura: not sure :-(
18:33:02 <SumitNaiksatam> #action SumitNaiksatam to check back on ubuntu packaging
18:33:29 <SumitNaiksatam> rkukura: thanks for that update, and great work getting this packaged!
18:33:35 <SumitNaiksatam> #topic Open Discussion
18:33:45 <rkukura> OK, would be good to find out whether we will need to deal with depending on python-neutron client 2.3.9 and 2.3.10 or not.
18:33:59 <SumitNaiksatam> rkukura: absolutely, i will follow up
18:34:15 <SumitNaiksatam> I know we are rushing a bit here today, but i am sure everyone will appreciate getting a few mins back, since we have a lot on our plates
18:34:24 <SumitNaiksatam> anything more that anyone wanted to discuss today?
18:35:07 <SumitNaiksatam> okay then, thanks everyone
18:35:12 <SumitNaiksatam> we are finishing in record time
18:35:20 <rkukura> thanks SumitNaiksatam!
18:35:21 <SumitNaiksatam> please keep the reviews going!
18:35:26 <SumitNaiksatam> bye
18:35:30 <SumitNaiksatam> #endmeeting