18:01:09 <SumitNaiksatam> #startmeeting networking_policy
18:01:10 <openstack> Meeting started Thu Apr 16 18:01:09 2015 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:11 <banix> hi
18:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:14 <openstack> The meeting name has been set to 'networking_policy'
18:01:47 <SumitNaiksatam> #info agenda https://wiki.openstack.org/wiki/Meetings/GroupBasedPolicy#April_16th.2C_9th.2C_2015
18:02:11 <igordcard_> hello
18:02:12 <SumitNaiksatam> #chairs rkukura banix igordcard s3wong ivar-laz_
18:02:21 <ivar-laz_> hi
18:02:33 <SumitNaiksatam> #chair rkukura banix igordcard s3wong ivar-laz_
18:02:34 <openstack> Current chairs: SumitNaiksatam banix igordcard ivar-laz_ rkukura s3wong
18:02:42 <SumitNaiksatam> in case i drop off
18:03:05 <SumitNaiksatam> so upfront, i wanted to discuss the kilo-3 release
18:03:15 <SumitNaiksatam> we were due for that milestone now
18:03:26 <SumitNaiksatam> however, we are bit behind on the deliverables
18:03:39 <SumitNaiksatam> so i have proposed that we push out this milestone by at least a couple of weeks
18:03:52 <SumitNaiksatam> let me know if there are any objections
18:04:10 <SumitNaiksatam> i dont see any point into getting into RC phase and still be implementing features
18:04:30 <rkukura> SumitNaiksatam: Does anything require we do 3 milestones? Could we do 4?
18:04:40 <SumitNaiksatam> rkukura: thats a good point
18:04:56 <SumitNaiksatam> i think we could do 4 milestones
18:05:04 <rkukura> My point is that it would be nice to have a kilo-X milestone that actually works with kilo neutron, etc., for packaging purposes ASAP
18:05:07 <SumitNaiksatam> if that is what everyone prefers
18:05:19 <SumitNaiksatam> rkukura: good point
18:05:30 <SumitNaiksatam> what do others think
18:05:48 <SumitNaiksatam> i like this idea of doing a k-3 now and adding another milestone before RC
18:05:56 <SumitNaiksatam> that way pacakges can be tested with k-3
18:06:44 <SumitNaiksatam> so i hear no objections :-)
18:06:59 <rkukura> Are we also pushing out our kilo-RC1?
18:07:03 <SumitNaiksatam> ok then, i will release k-3 today and we will plan on having a k-4 in a months time
18:07:13 <SumitNaiksatam> rkukura: yes, this will delay the release
18:07:24 <SumitNaiksatam> or at least thats what it appears like
18:07:29 <rkukura> makes sense
18:08:19 <SumitNaiksatam> ok so done
18:08:38 <SumitNaiksatam> lets start with the standing items
18:08:42 <SumitNaiksatam> #topic Bugs
18:09:12 <SumitNaiksatam> the only critical at this point is: #link https://bugs.launchpad.net/group-based-policy/+bug/1432779
18:09:13 <openstack> Launchpad bug 1432779 in Group Based Policy "redirect actions don't work with external policies" [Critical,In progress] - Assigned to Ivar Lazzaro (mmaleckk)
18:09:27 <SumitNaiksatam> ivar-lazzaro has posted the patch, waiting for our review
18:09:47 <SumitNaiksatam> oh sorry its been +A'ed
18:09:57 <SumitNaiksatam> its stuck in the merge queue
18:10:09 <rkukura> it says merged
18:10:11 <SumitNaiksatam> it was rather, its merged now
18:10:12 <SumitNaiksatam> yeah
18:10:23 <SumitNaiksatam> good, so no criticals
18:10:37 <SumitNaiksatam> ivar-lazzaro: do you need to discuss #link https://bugs.launchpad.net/group-based-policy/+bug/1443606
18:10:39 <openstack> Launchpad bug 1443606 in Group Based Policy "backward incompatible db migration changes" [Undecided,In progress] - Assigned to Ivar Lazzaro (mmaleckk)
18:10:41 <rkukura> nice to have that in kilo-3!
18:10:50 <SumitNaiksatam> rkukura: yeah
18:11:08 <ivar-lazzaro> There's also a backport for that
18:11:14 <ivar-lazzaro> https://review.openstack.org/#/c/170972/
18:11:28 <rkukura> actually, we need to sort out our DB migrations before we do kilo-3 if we are going to package it
18:11:50 <SumitNaiksatam> rkukura: ok
18:11:52 <ivar-lazzaro> rkukura: https://review.openstack.org/#/c/173051/
18:12:11 <SumitNaiksatam> rkukura: do you mind reviewing and closing on this today
18:12:16 <SumitNaiksatam> it looks good to me
18:12:35 <rkukura> I see modified migrations
18:12:45 <ivar-lazzaro> As discussed on the ML, we will merge the "broken migration" first and we fix that right after
18:13:10 <ivar-lazzaro> the reason is that we have a broken patch already merged in master that is waiting for backport
18:13:22 <ivar-lazzaro> does it make sense?
18:13:24 <SumitNaiksatam> ivar-lazzaro: ok
18:13:48 <SumitNaiksatam> ivar-lazzaro: can you nag us on getting these reviewed and merged today? ;-)
18:13:59 <ivar-lazzaro> SumitNaiksatam: ok :)
18:14:10 <ivar-lazzaro> rkukura: you had a -1 on this #link https://review.openstack.org/#/c/170972/
18:14:16 <rkukura> ivar-lazzaro: Does the patch you linked undo previous changes to existing migrations, or is it changing existing migrations?
18:14:18 <SumitNaiksatam> if you can specify the order in which they need to be reviewed, that it will be easier (just to avoid have to figure this out)
18:14:39 <ivar-lazzaro> rkukura: undo broken migrations and create new ones
18:14:44 <rkukura> ivar-lazzaro: great!
18:14:49 <rkukura> I will review today
18:15:00 <ivar-lazzaro> rkukura: SumitNaiksatam: this first #link https://review.openstack.org/#/c/170972/
18:15:19 <ivar-lazzaro> then #link https://review.openstack.org/#/c/173051/
18:15:30 <ivar-lazzaro> and finally the juno packport of ^^^
18:15:38 <ivar-lazzaro> s/packport/backport
18:15:41 <SumitNaiksatam> i think my job is done :-P
18:15:58 <ivar-lazzaro> SumitNaiksatam: not yet! Backport still has to come :D
18:16:08 <rkukura> My concern is to make sure that for both juno and kilo, once someome installs GBP packages, installing updated packages for the same release doesn’t break the installation
18:16:12 <SumitNaiksatam> ivar-lazzaro: okay, i will look out for that
18:16:28 <ivar-lazzaro> rkukura: yeah that's the objective
18:16:58 <ivar-lazzaro> rkukura: #link https://review.openstack.org/#/c/173051/ should provide that
18:17:12 <ivar-lazzaro> rkukura: although it doesn't fix the downgrade problem
18:17:30 <ivar-lazzaro> rkukura: but i think we concluded that we don't care about that for now, right?
18:17:36 <SumitNaiksatam> btw, there was an issue with the gate yesterday, and some patches which were +A’ed did not merge (the queue was reset)
18:17:36 <rkukura> Normally, DB schema changes wouldn’t be allowed on a stable branch, but I think we are agreeing they are this time, as long as we keep all the migrations that are getting backported at the head of the chain on master
18:17:46 <SumitNaiksatam> i am referring to the stable/juno branch
18:17:50 <rkukura> I don’t think OpenStack supports downgrades any more
18:18:12 <ivar-lazzaro> rkukura: nice!
18:18:27 <SumitNaiksatam> okay lets take this discussion to the gerrit reviews, but if possible lets close on this today
18:18:34 <rkukura> SumitNaiksatam: +1
18:18:41 <SumitNaiksatam> rkukura: need your help on that
18:18:50 <SumitNaiksatam> any other bugs that we need to discuss in this meeting?
18:18:59 <rkukura> SumitNaiksatam: will do
18:19:06 <SumitNaiksatam> rkukura: thanks much
18:19:16 <SumitNaiksatam> moving on
18:19:19 <SumitNaiksatam> #topic Functional/integration tests
18:19:44 <SumitNaiksatam> i added a patch to be able to run jishnu’s test package
18:19:47 <SumitNaiksatam> https://review.openstack.org/#/c/174267/
18:19:59 <SumitNaiksatam> the tests failed, so i am investigating why
18:20:50 <SumitNaiksatam> also the integration tests job broke on the stable/juno branch last week after we merged the kilo-sync client patch
18:20:52 <rkukura> SumitNaiksatam: What is the timeframe for moving these tests to a proper repo?
18:21:24 <SumitNaiksatam> rkukura: as soon as anyone finds time to refactor and repurpose them match the coding conventions
18:21:35 <rkukura> SumitNaiksatam: thanks
18:21:36 <SumitNaiksatam> rkukura: i started on that path, but its on the backburner
18:21:46 <SumitNaiksatam> rkukura: it was taking significant time
18:21:56 <SumitNaiksatam> but, that is definitely the plan
18:22:08 <SumitNaiksatam> so regarding the gate job for stable/juno
18:22:23 <SumitNaiksatam> i have put a tag on the client, prior to the kilo-sync merge patch
18:22:53 <SumitNaiksatam> so stable/juno installation should be using the client with that tag/release, which is 0.9.1
18:23:10 <SumitNaiksatam> perhaps this should ahve been discussed in the packaing topic
18:23:20 <SumitNaiksatam> #topic Packaging
18:23:34 <SumitNaiksatam> rkukura: wanted to bring that your attention
18:23:55 <rkukura> rkukura: OK
18:24:08 <SumitNaiksatam> effectively we have a client release for juno, 0.9.1 (after which we updated the client to work with kilo)
18:24:38 <SumitNaiksatam> rkukura: anything else to discuss on packaging?
18:24:55 <rkukura> nothing new this week
18:25:29 <rkukura> I’d like to get stable/juno and kilo fedora packages out ASAP, but am on PTO for the next week
18:26:00 <SumitNaiksatam> rkukura: okay
18:26:08 <rkukura> but I may be able to make some progress once we’ve sorted the migrations and created the releases
18:26:14 <SumitNaiksatam> rkukura: okay
18:26:21 <SumitNaiksatam> #topic GBP Project Proposal
18:26:31 <SumitNaiksatam> no progress on the proposal, its still WIP
18:27:00 <SumitNaiksatam> however, since we are in the pipeline, we have been graciously offered 5 design summit sessions in a work room setup
18:27:31 <SumitNaiksatam> design summit sessions are only allocated to OpenStack projects, or the ones which are under consideration
18:27:52 <SumitNaiksatam> so we have to be thanful to thierry and the organizers for offering us the opportunity
18:27:55 <SumitNaiksatam> lets plan
18:28:10 <SumitNaiksatam> i will setup up an etherpad, please put your ideas on session topics there
18:28:21 <SumitNaiksatam> any one have questions on this?
18:28:52 <SumitNaiksatam> ok
18:29:03 <SumitNaiksatam> #topic Feature Branch
18:29:17 <SumitNaiksatam> the “feature/refactor” branch is in place now
18:29:38 <SumitNaiksatam> for the neutron REST refactor effort and also for any subsequent work on the independent server
18:29:45 <SumitNaiksatam> #link https://review.openstack.org/#/q/status:open+project:stackforge/group-based-policy+branch:feature/refactor,n,z
18:30:02 <SumitNaiksatam> Yi: noticed that you were able to post your patch, great!
18:30:29 <SumitNaiksatam> yapeng_: Yi: anything to discuss here?
18:30:44 <Yi> most things went well
18:30:47 <yapeng_> so far so good. thanks for setting it up.
18:30:56 <Yi> the only exception is the test-policy
18:31:03 <Yi> working on it now
18:31:13 <SumitNaiksatam> yi: yapeng_: thanks so much for your patience on this, it was a bit of a learning experience for everyone
18:31:24 <SumitNaiksatam> Yi: ah okay
18:31:43 <Yi> Ivar is helping on that
18:31:52 <Yi> should be fixed soon
18:32:44 <SumitNaiksatam> ivar-lazzaro: thanks for the help!
18:32:54 <SumitNaiksatam> #topic Kilo sync
18:33:03 <SumitNaiksatam> #link https://review.openstack.org/#/c/165377
18:33:13 <SumitNaiksatam> this activity was completed over the weekend
18:33:24 <SumitNaiksatam> and we are not in sync with openstack kilo components
18:33:46 <SumitNaiksatam> any questions on this?
18:33:57 <ivar-lazzaro> SumitNaiksatam: you mean "now in sync" ?
18:34:05 <SumitNaiksatam> magesh is not here (who did the work on this)
18:34:19 <SumitNaiksatam> ivar-lazzaro: oh shoot :-), yes i meant are “now” in sync
18:34:27 <rkukura> Are we in sync for all four GBP components?
18:34:29 <SumitNaiksatam> so ivar-lazzaro is the only one paying attention :-P
18:34:44 <SumitNaiksatam> rkukura: good question
18:34:51 <SumitNaiksatam> rkukura: we are in sync for server and client
18:35:02 <SumitNaiksatam> automation patch is in review
18:35:37 <SumitNaiksatam> i think for UI we should be good, but havent checked
18:35:53 <SumitNaiksatam> by automation i meant, GBP Heat
18:36:31 <SumitNaiksatam> #topic Floating IP support
18:36:34 <SumitNaiksatam> #link https://review.openstack.org/167174
18:36:48 <SumitNaiksatam> magesh informs that he is getting closer
18:37:02 <SumitNaiksatam> he will update the spec patch as well
18:37:29 <SumitNaiksatam> #topic Reviewing Specs
18:37:33 <SumitNaiksatam> #link https://review.openstack.org/#/q/status:open+project:stackforge/group-based-policy-specs+branch:master,n,z
18:37:46 <SumitNaiksatam> we have some patches in this queue for review
18:37:53 <SumitNaiksatam> *ready for review and merge
18:38:06 <SumitNaiksatam> rkukura: s3wong banix: can you take a look?
18:38:22 <s3wong> SumitNaiksatam: sure
18:38:24 <SumitNaiksatam> igordcard: thanks for posting the updates to the structure
18:38:27 <banix> will do
18:38:27 <SumitNaiksatam> s3wong: thanks
18:38:30 <SumitNaiksatam> banix: thanks
18:39:06 <rkukura> SumitNaiksatam: I’ll review, but probably not immediately
18:39:09 <igordcard_> SumitNaiksatam, ;)
18:39:19 <SumitNaiksatam> rkukura: these should be quick ones though
18:39:45 <rkukura> ok
18:39:47 <SumitNaiksatam> #topic Vancouver Summit
18:40:15 <SumitNaiksatam> ivar-lazzaro and rkukura: over to you for the “hands on lab” discussion
18:40:24 <SumitNaiksatam> you want to brief the team on the plans?
18:40:33 <ivar-lazzaro> SumitNaiksatam: sure
18:40:40 <SumitNaiksatam> we are hoping the whole team can participate on this
18:41:15 <ivar-lazzaro> As you know we are having the GBP lab hands-on on thursday, the more GBP developers are there to help the better
18:41:50 <ivar-lazzaro> as for today we are discussing how to deliver a GBP installation to all the participants without relying too much on the conference network
18:42:33 <ivar-lazzaro> the usb-stick approach seems to be the most viable for now, but ideas/suggestions on the subject are very welcome :)
18:43:12 <ivar-lazzaro> another point is deciding how we will drive the hands on, and whether it should include an installation section or not
18:44:05 <ivar-lazzaro> if you feel like you want to participate these discussions, let me know and I'll include you in the loop (of course I'll still be reporting news every week at the meeting)
18:45:09 <ivar-lazzaro> I have nothing else for now
18:45:18 <ivar-lazzaro> rkukura: want to add anything?
18:46:24 <rkukura> just that we’ve also been discussing focusing on the app-deployer and net-admin roles
18:46:49 <ivar-lazzaro> rkukura: right!
18:47:01 <ivar-lazzaro> rkukura: want to expand on that?
18:47:42 <rkukura> we were thinking of having participants work in pairs, with one in each role
18:48:11 <rkukura> this would make sense if we had them using shared hardware, but maybe not if they are using usb sticks on their own laptops
18:48:24 <rkukura> just kicking around ideas at this point, no decisions made
18:48:31 <rkukura> thats it for me
18:49:44 <rkukura> I think SumitNaiksatam may have dropped off. Anything else on the summit?
18:50:15 <rkukura> #action SumitNaiksatam to create etherpad for summit topics
18:50:47 <rkukura> Looks like we’ve covered the agenda
18:50:53 <rkukura> #topic Open Discussion
18:51:13 <rkukura> Anything to discuss?
18:51:40 <ivar-lazzaro> I was wondering if we plan on doing some code sprint at some point
18:51:57 <ivar-lazzaro> but with the summit approaching I guess that will happen for Liberty
18:51:59 <rkukura> ivar-lazzaro: post-summit?
18:52:48 <rkukura> Might make sense to do a sprint focusing on the stand-alone server
18:52:52 <ivar-lazzaro> definitively, an early cycle sprint could be useful to get the ball rolling on the server refactor
18:53:25 <rkukura> anything else, or should we wrap up early?
18:53:39 <s3wong> +1
18:53:49 <rkukura> thanks everyone!
18:53:51 <rkukura> #endmeeting