15:02:01 <slaweq> #startmeeting neutron_ci
15:02:01 <openstack> Meeting started Tue May 25 15:02:01 2021 UTC and is due to finish in 60 minutes.  The chair is slaweq. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:05 <openstack> The meeting name has been set to 'neutron_ci'
15:02:07 <slaweq> welcome (again) :)
15:02:15 <bcafarel> o/ again
15:02:26 <obondarev> hi
15:02:28 <lajoskatona> o/
15:02:34 <slaweq> First of all Grafana dashboard: http://grafana.openstack.org/dashboard/db/neutron-failure-rate
15:02:41 <slaweq> please open and we can move on
15:02:44 <ralonsoh> hi
15:03:00 <slaweq> we don't have any action items from last week
15:03:05 <slaweq> so let's skip that topic today
15:03:08 <slaweq> #topic Stadium projects
15:03:15 <slaweq> lajoskatona: any updates about stadium ci?
15:03:34 <lajoskatona> not much, only the ovs changes
15:03:43 <lajoskatona> I mean the ones to use ovs explicitly
15:03:58 <slaweq> those should be approved quickly I hope
15:04:55 <slaweq> ok, so let's quickly move to the next topic than
15:05:00 <slaweq> #topic Stadium projects
15:05:08 <slaweq> bcafarel: any updates/issues with stable branches?
15:05:47 <bcafarel> all good from what I checked :)
15:06:14 <bcafarel> (beware I still have a few unread emails, but so far so good)
15:06:18 <slaweq> only good news so far :)
15:06:25 <slaweq> that's great meeting
15:06:28 <slaweq> thank You
15:06:46 <slaweq> so let's move on to the next topic
15:06:48 <slaweq> #topic Grafana
15:07:45 <slaweq> from graphs I think that neutron-tempest-dvr-ha-multinode-full job is not set to ovs explicitly
15:07:51 <slaweq> and is now running with ML2/ovn
15:08:11 <slaweq> as its failure rate is going up in exactly same way as neutron-tempest-plugin-api job :)
15:08:24 <obondarev> :D
15:08:43 <bcafarel> parent: tempest-multinode-full-py3 sounds like it yes
15:08:45 <slaweq> obondarev: it's Your favorite job, can You check it? :)
15:09:06 <obondarev> slaweq, I will :)
15:09:10 <slaweq> thx a lot
15:09:21 <obondarev> sure
15:09:28 <slaweq> #action obondarev to check neutron-tempest-dvr-ha-multinode-full and switch it to ML2/OVS
15:09:48 <slaweq> also neutron-rally-task job is in same situation
15:10:12 <slaweq> but there is patch https://review.opendev.org/c/openstack/neutron/+/791365 for that already
15:10:39 <slaweq> but we will need neutron-tempest-plugin fix first
15:10:48 <slaweq> and functional tests fix from ralonsoh
15:11:57 <slaweq> that are all issues which I see on the grafana currently
15:12:10 <slaweq> anything else You want to highlight maybe?
15:13:31 <slaweq> ok, let's move on
15:13:37 <slaweq> #topic fullstack/functional
15:13:50 <slaweq> I found only one new issue related to functional jobs
15:13:55 <slaweq> https://bugs.launchpad.net/neutron/+bug/1929518
15:13:56 <openstack> Launchpad bug 1929518 in neutron "Functional db migration tests broken" [Critical,Confirmed] - Assigned to Rodolfo Alonso (rodolfo-alonso-hernandez)
15:14:02 <slaweq> and ralonsoh already took care of it
15:14:06 <slaweq> thx ralonsoh
15:14:12 <ralonsoh> yw
15:15:10 <slaweq> but now I think that we will need to combine it with https://review.opendev.org/c/openstack/neutron/+/791365
15:15:19 <slaweq> otherwise it will never pass gate :/
15:15:51 <slaweq> so we should:
15:16:17 <slaweq> 1. merge fix for neutron-tempest-plugin-api job https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/791255
15:16:36 <slaweq> 2. combine https://review.opendev.org/c/openstack/neutron/+/792945 and https://review.opendev.org/c/openstack/neutron/+/791365 into one patch
15:16:40 <slaweq> and then we should be good
15:16:48 <slaweq> or am I missing something here?
15:16:49 <bcafarel> sounds right yes
15:17:03 <ralonsoh> I vote for 1
15:17:19 <ralonsoh> that should solve neutron ci too
15:17:21 <slaweq> ralonsoh: it's not two possibilities to choose
15:17:24 <ralonsoh> right?
15:17:37 <ralonsoh> I though that solved neutron CI too
15:17:38 <slaweq> it's like action items to do and order of them :)
15:17:39 <ralonsoh> my bad
15:18:21 <slaweq> np :)
15:18:31 <slaweq> obondarev: lajoskatona can You maybe check https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/791255 ?
15:18:36 <slaweq> and approve it hopefully
15:18:43 <ralonsoh> we can update https://review.opendev.org/c/openstack/neutron/+/791365 then
15:18:46 <slaweq> so that will be in the gate already
15:18:51 <ralonsoh> I'll abandon my patch
15:19:12 <slaweq> ralonsoh: as You want, You can also update Your patch and we can abandon mine :)
15:19:31 <ralonsoh> don't worry, I'll update yours in a couple of mins
15:19:43 <slaweq> thx a lot
15:20:13 <obondarev> slaweq, ralonsoh, is it correct that alternative to https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/791255 is to switch job API job to OVS?
15:20:24 <ralonsoh> yes
15:20:26 <slaweq> obondarev: yes
15:20:39 <slaweq> actually I even had such patch proposed but I abandoned it
15:20:40 <ralonsoh> there is an abandoned patch
15:20:42 <ralonsoh> right
15:20:50 <slaweq> as ralonsoh convinced me to go with his approach :)
15:20:51 <obondarev> so that could avoid test skip, right?
15:20:57 <ralonsoh> yes
15:21:16 <ralonsoh> but, to be honest, the scope of this test is reduced
15:21:17 <obondarev> so why not? :)
15:21:43 <slaweq> there is only one test skipped and it should be soon available on ovn backend too
15:21:52 <ralonsoh> because OVS is already tested, this feature is not frequently used and it will be integrated in OVN soon
15:22:21 <obondarev> ok let me check, can continue meanwhile
15:22:22 <ralonsoh> I prefer to check OVN. This feature has not received patches in a long time
15:23:10 <lajoskatona> So wait with https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/791255 ?
15:24:04 <obondarev> actually no, I just approved it
15:24:07 <obondarev> :)
15:24:14 <bcafarel> :)
15:24:14 <slaweq> thx :)
15:24:32 <lajoskatona> ok
15:24:43 <slaweq> ok, next topic then
15:24:45 <slaweq> #topic Tempest/Scenario
15:24:56 <slaweq> I found one new (for me at least) issue recently
15:25:01 <slaweq> https://bugs.launchpad.net/neutron/+bug/1929523
15:25:02 <openstack> Launchpad bug 1929523 in neutron "Test tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_subnet_details is failing from time to time" [High,Confirmed]
15:25:09 <slaweq> and failure examples
15:25:11 <slaweq> https://fc42fc060b9d19761c9e-19b00ab3af46f59a1799d97d7ae09a21.ssl.cf2.rackcdn.com/783748/4/gate/neutron-ovn-tempest-slow/9dbdc07/testr_results.html
15:25:13 <slaweq> https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_567/785895/1/gate/neutron-tempest-slow-py3/567fc7f/testr_results.html
15:25:18 <slaweq> did You saw it already maybe?
15:26:24 <slaweq> or anyone have cycles to check that?
15:26:33 <ralonsoh> I think there is a patch from Candido
15:26:36 <ralonsoh> let me check
15:27:08 <ralonsoh> https://review.opendev.org/c/openstack/tempest/+/779756
15:27:32 <slaweq> so it didn't help :/
15:27:37 <slaweq> as it was merged 2 weeks ago
15:27:46 <slaweq> and failures which I saw were from this week
15:28:16 <ralonsoh> I'll ping him again, but I remember testing with him this patch
15:28:25 <ralonsoh> and was quite solit
15:28:28 <ralonsoh> solid*
15:28:36 <slaweq> maybe it's a bit different issue?
15:29:01 <ralonsoh> I don't think so, what we test is the content of resolv.conf
15:29:11 <slaweq> in this case retrieved dns list is empty
15:29:20 <slaweq> testtools.matchers._impl.MismatchError: {'1.2.3.4'} != set(): Looking for servers: ['1.2.3.4']. Retrieved DNS nameservers: [] From host: 172.24.5.177.
15:29:45 <ralonsoh> hmmm maybe the host needs a bit of time
15:29:48 <slaweq> and in Candido's patch description the issue was that additinal server was included
15:30:43 <ralonsoh> ok, I'll ping him
15:30:50 <slaweq> thx a lot
15:31:23 <slaweq> #action ralonsoh to talk with ccamposr about issue https://bugs.launchpad.net/neutron/+bug/1929523
15:31:24 <openstack> Launchpad bug 1929523 in neutron "Test tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_subnet_details is failing from time to time" [High,Confirmed]
15:32:07 <slaweq> and that was all what I had for today :)
15:32:14 <slaweq> periodic jobs are running fine
15:32:29 <slaweq> do You have anything else to discuss today?
15:32:41 <slaweq> or if not, I will give You 28 minutes back
15:33:09 <bcafarel> nothing from me :)
15:33:16 <ralonsoh> no thanks
15:33:34 <obondarev> nope
15:34:25 <slaweq> ok, thx for attending the meeting today
15:34:32 <slaweq> see You all online :)
15:34:34 <slaweq> o/
15:34:35 <bcafarel> o/
15:34:36 <lajoskatona> o/
15:34:36 <slaweq> #endmeeting