15:00:42 <slaweq> #startmeeting neutron_ci
15:00:42 <opendevmeet> Meeting started Tue Jul 20 15:00:42 2021 UTC and is due to finish in 60 minutes.  The chair is slaweq. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:42 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:42 <opendevmeet> The meeting name has been set to 'neutron_ci'
15:00:47 <ralonsoh> hello
15:00:47 <slaweq> welcome (again) :)
15:01:12 <obondarev> hi
15:01:48 <slaweq> lajoskatona is off today, bcafarel is probably around so I think we can start :)
15:01:54 <slaweq> Grafana dashboard: http://grafana.openstack.org/dashboard/db/neutron-failure-rate
15:02:06 <bcafarel> o/ yup still around :)
15:02:31 <slaweq> #topic Actions from previous meetings
15:02:37 <slaweq> ralonsoh to check if there is better way to check dns nameservers in cirros
15:02:53 <ralonsoh> yeah, still checking that
15:02:57 <ralonsoh> I really have no idea
15:03:01 <ralonsoh> at least in cirros
15:03:17 <ralonsoh> there is only one place, /etc/nameserver.conf
15:04:16 <ralonsoh> please, any idea on this one is welcome
15:05:04 <slaweq> ralonsoh: I don't have idea for now but I will check it more deeply
15:05:12 <ralonsoh> thanks
15:06:35 <slaweq> #action slaweq to check dns nameserver issues in cirros
15:06:38 <bcafarel> is there a LP/mail recap somewhere on that one? details are a bit fuzzy in my memory
15:07:02 <ralonsoh> https://bugs.launchpad.net/tempest/+bug/1914229
15:07:24 <ralonsoh> that was the first attempt https://review.opendev.org/c/openstack/tempest/+/779756
15:07:54 <ralonsoh> and that's mine https://review.opendev.org/c/openstack/tempest/+/794776, but not valid for cirros
15:08:03 <bcafarel> ah yes in tempest now I remember thanks
15:08:33 <slaweq> thx for links
15:08:37 <slaweq> I will take a look
15:09:13 <slaweq> ok, as there is no Lajos today I think we can skip stadium projects' ci
15:09:21 <slaweq> so let's move to
15:09:23 <slaweq> #topic Stable branches
15:09:49 <bcafarel> lower count of backports these days probably caused by summer
15:10:10 <bcafarel> but the created ones got in without issues, stable CI is quite good atm :)
15:10:48 <slaweq> \o/
15:10:50 <slaweq> thx
15:10:57 <slaweq> I like such info :)
15:11:02 <slaweq> so we can move on
15:11:07 <slaweq> #topic Grafana
15:12:03 <slaweq> seems like grafana looks pretty ok
15:12:25 <slaweq> except gaps with no data points in last few days
15:13:14 <bcafarel> gerrit was updated/restarted recently if I recall correctly
15:13:24 <ralonsoh> yes
15:13:32 <slaweq> yes, and that could be the reason
15:13:40 <slaweq> thx bcafarel for reminder of it
15:13:48 <opendevreview> Bence Romsics proposed openstack/neutron master: doc: Do not use dvr_snat on computes  https://review.opendev.org/c/openstack/neutron/+/801503
15:13:59 <ralonsoh> hehehe ^^
15:14:04 <slaweq> thx rubasov :)
15:14:35 <bcafarel> that was fast :)
15:15:01 <rubasov> sorry, I forgot that this should have been brought to the meeting
15:15:06 <slaweq> ok, getting back to grafana now - I think we need to update names of the jobs as we made some changes recently
15:15:13 <slaweq> any volunteer to do it?
15:15:20 <slaweq> rubasov: no problem at all :)
15:15:33 <ralonsoh> slaweq, that was done
15:15:44 <slaweq> ahh, right ralonsoh
15:15:46 <ralonsoh> I pushed a patch for this
15:15:46 <slaweq> sorry
15:15:49 <ralonsoh> np
15:15:55 <slaweq> yes, now I see that names are correct
15:15:57 <slaweq> sorry :)
15:16:10 <slaweq> I'm still in half PTO mode probably
15:16:18 <ralonsoh> hehehe
15:16:40 <bcafarel> working between PTO is hard :)
15:16:45 <slaweq> ok, so if there is nothing else regarding grafana, I think we can move on
15:16:49 <slaweq> bcafarel: true
15:17:23 <slaweq> regarding functional/fullstack tests I don't have new issues for today
15:17:43 <slaweq> I just want to say that https://review.opendev.org/c/openstack/neutron/+/799781 is merged so fullstack mtu update test should be failing anymore
15:18:03 <slaweq> if You will see it failing again, it will means that this patch didn't fix it properly
15:18:20 <opendevreview> Szymon Wróblewski proposed openstack/neutron master: Use payloads for FloatingIP AFTER callbacks  https://review.opendev.org/c/openstack/neutron/+/801453
15:18:21 <opendevreview> Szymon Wróblewski proposed openstack/neutron master: Improve content of FloatingIP AFTER callbacks  https://review.opendev.org/c/openstack/neutron/+/798009
15:18:30 <slaweq> #topic Tempest/Scenario
15:18:37 <ralonsoh> I'll keep an eye on this
15:18:40 <slaweq> I today opened new bug https://bugs.launchpad.net/neutron/+bug/1936911
15:18:42 <slaweq> thx ralonsoh
15:19:13 <slaweq> I saw this same test failing in linuxbridge job couple of times
15:19:25 <slaweq> I think we should blacklist it for now in that job
15:19:38 <slaweq> and maybe there will be someone who will want to check and fix it
15:19:53 <ralonsoh> could be something similar to your patch for OVS
15:19:58 <ralonsoh> deleting the existing conntrack
15:20:05 <ralonsoh> but this is just a guess
15:20:16 <ralonsoh> in any case, I won't work on this now
15:21:02 <slaweq> but this happens just sometimes so maybe some race
15:21:04 <slaweq> idk
15:21:09 <slaweq> but I also don't have time for that
15:21:21 <slaweq> I will propose patch to blacklist that test in that one job for now
15:21:27 <ralonsoh> at least for LB
15:21:31 <slaweq> yes
15:21:38 <ralonsoh> because that was a patch for testing a feature in OVS
15:21:50 <slaweq> #action slaweq to blacklist failing test_established_tcp_session_after_re_attachinging_sg in LB job
15:22:15 <slaweq> ok
15:22:17 <slaweq> next one
15:22:33 <slaweq> I again sow issue with FIP not being updated to DOWN state: https://24eb112626298d97a016-f30969e550292dfd0d7e868e05815d65.ssl.cf1.rackcdn.com/787876/5/check/neutron-tempest-plugin-scenario-openvswitch/83c13d7/testr_results.html
15:22:55 <slaweq> I don't remember if we have bug opened for that but I see it from time to time in various jobs
15:23:01 <slaweq> not very often but still
15:23:07 <slaweq> did You saw it too?
15:23:16 <slaweq> or maybe You have any idea what can be wrong there?
15:23:23 <ralonsoh> I don't remember it
15:24:49 <slaweq> ok, I will check if we have LP for that and I will open one if there is no ay
15:24:50 <slaweq> *any
15:25:03 <slaweq> #action slaweq to check FIP set to DOWN issue
15:25:33 <slaweq> that are all issues which I had for today
15:25:48 <slaweq> do You have any other issues You would like to discuss today?
15:25:56 <ralonsoh> no
15:26:25 <slaweq> one last thing I have for You
15:26:38 <slaweq> please review my patches https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/795929 and https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/795492/
15:26:52 <slaweq> thx in advance
15:27:05 <bcafarel> added to the pile :)
15:27:09 <slaweq> thx
15:27:21 <ralonsoh> sure
15:27:25 <slaweq> and if there are no other topics, I will give You back more than 30 minutes today :)
15:27:27 <bcafarel> slaweq: additional question on https://review.opendev.org/c/openstack/neutron/+/799781 (fullstack fix) is it OK to backport? I saw such failure at least in wallaby
15:27:43 <slaweq> bcafarel: yes, I want to propose backports for it
15:27:48 <slaweq> but I didn't had time yet
15:27:58 <slaweq> it's on my todo :)
15:28:21 <bcafarel> ack thanks :)
15:28:25 <slaweq> thx for attending the meeting
15:28:30 <ralonsoh> bye
15:28:32 <slaweq> have a great evening
15:28:43 <slaweq> and remember that next week's meeting will be cancelled
15:28:49 <slaweq> so see You in 2 weeks :)
15:28:52 <bcafarel> enjoy the PTL PTO then
15:28:55 <slaweq> #endmeeting