15:00:06 <slaweq> #startmeeting neutron_ci
15:00:06 <opendevmeet> Meeting started Tue Aug 24 15:00:06 2021 UTC and is due to finish in 60 minutes.  The chair is slaweq. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:07 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:07 <opendevmeet> The meeting name has been set to 'neutron_ci'
15:00:22 <slaweq> hi (again) :)
15:00:31 <obondarev> hi
15:00:37 <ralonsoh> hi
15:00:44 <slaweq> Grafana dashboard: http://grafana.openstack.org/dashboard/db/neutron-failure-rate
15:00:45 <bcafarel> that was a short break :)
15:00:51 <thomasb06> hi
15:00:54 <lajoskatona> Hi
15:01:01 <slaweq> let's do it quick as ralonsoh needs to leave early today :)
15:01:08 <slaweq> #topic Actions from previous meetings
15:01:16 <slaweq> obondarev to update grafana after promoting dvr-ha job to be voting
15:01:43 <obondarev> https://review.opendev.org/c/openstack/project-config/+/805594
15:01:54 <obondarev> not sure if it's all needed however
15:02:14 <obondarev> I mean that I might missed something
15:02:26 <slaweq> thx obondarev
15:02:34 <slaweq> I think it's ok
15:02:39 <bcafarel> for graph itself probably not, but it is nice to have proper labels :)
15:03:02 <slaweq> next one
15:03:04 <slaweq> ralonsoh to send patches to use smaller flavors and concurency 1 for advanced scenario tests
15:03:11 <ralonsoh> and bcafarel
15:03:25 <ralonsoh> https://review.opendev.org/q/79c679683dd93c1df412f81533af6bf72e2395d0
15:03:30 <ralonsoh> first one is merged
15:03:38 <ralonsoh> please check bcafarel's one
15:03:52 <ralonsoh> I think with this patch we can close the bug (for now)
15:04:03 <ralonsoh> the concurrency patch won't be needed
15:04:36 <slaweq> looks good, thx bcafarel and ralonsoh
15:04:52 <slaweq> so, next one
15:04:54 <slaweq> ralonsoh to check UT failing with neutron-lib master
15:05:10 <ralonsoh> done, one sec
15:05:23 <ralonsoh> https://review.opendev.org/c/openstack/neutron-lib/+/805395
15:05:24 <ralonsoh> and merged
15:05:36 <ralonsoh> nonono
15:05:44 <lajoskatona> salweq: You reported another one today: https://bugs.launchpad.net/neutron/+bug/1940905
15:05:46 <ralonsoh> https://review.opendev.org/c/openstack/neutron-lib/+/804894
15:05:49 <ralonsoh> ^^ this patch
15:06:20 <lajoskatona> I checked and based on opestack health page it looks ok, though I am not sure if openstack health is healthy....
15:06:22 <ralonsoh> there is patch for this bug
15:06:43 <slaweq> thx ralonsoh for fixing that one bug
15:07:04 <slaweq> lajoskatona yes, but I though it was failing even today and yesterday with this new issue
15:07:06 <slaweq> let me check it
15:07:21 <slaweq> https://zuul.openstack.org/build/7760210f28514e6fb3e0258cbfcbd4b8
15:07:23 <slaweq> see here
15:07:30 <slaweq> it's from today morning
15:07:36 <ralonsoh> https://review.opendev.org/c/openstack/neutron/+/805627
15:07:38 <ralonsoh> this patch
15:08:00 <ralonsoh> that fixes the problem with the qos rule types constant
15:08:29 <lajoskatona> ok
15:08:37 <slaweq> ralonsoh and what about test_versions issue, like https://4982338ebecb97a12f63-bcc0089d8984128efe3d45fe2388916e.ssl.cf5.rackcdn.com/periodic/opendev.org/openstack/neutron/master/openstack-tox-py36-with-neutron-lib-master/a100726/testr_results.html ?
15:08:45 <slaweq> it happened e.g. yesterday
15:08:49 <lajoskatona> so openstack health is behind and out of sunc
15:08:50 <lajoskatona> sync
15:08:59 <slaweq> do You know what could cause this?
15:09:18 <ralonsoh> slaweq, I think this problem is solved with https://review.opendev.org/c/openstack/neutron/+/805627
15:09:26 <slaweq> ok
15:09:31 <slaweq> thx for taking care of it
15:09:37 <slaweq> I will link that patch to that bug
15:10:14 <slaweq> ok, that are all actions from last week
15:10:17 <slaweq> let's move on
15:10:24 <slaweq> #topic Stadium projects
15:10:35 <slaweq> lajoskatona anything to discuss here?
15:10:52 <lajoskatona> there's a few patches for tap-as-a-service
15:11:05 <lajoskatona> i.e.: https://review.opendev.org/c/openstack/tap-as-a-service/+/803422
15:11:22 <lajoskatona> https://review.opendev.org/c/openstack/tap-as-a-service/+/804707
15:12:07 <lajoskatona> but otherwise quiet (except the vpnaas bug for memory leak)
15:12:09 <slaweq> ok, I will review them tonight or tomorrow morning
15:12:22 <bcafarel> half stadium and half stable, vpnaas gate fixes victoria https://review.opendev.org/c/openstack/neutron-vpnaas/+/803455 and ussuri https://review.opendev.org/c/openstack/neutron-vpnaas/+/746024
15:12:49 <bcafarel> lajoskatona: now that you are full stable core you can probably update your +1 there now :)
15:13:13 <lajoskatona> bcafarel: yeah, I can, just seen that once I checked them :-)
15:13:44 <slaweq> thx
15:14:00 <slaweq> and ci of other stadium projects is ok, right?
15:14:05 <slaweq> no new issues there I hope
15:14:26 <lajoskatona> no
15:14:35 <slaweq> great, thx lajoskatona
15:14:41 <slaweq> let's move on
15:14:46 <slaweq> #topic Stable branches
15:14:59 <slaweq> bcafarel any new issues/updates?
15:15:27 <bcafarel> overall it looks good, from what I checked since coming back from PTO
15:15:38 <bcafarel> only the already mentioned https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/805864
15:16:04 <slaweq> thx
15:16:25 <bcafarel> so overall you are leaving CI in nice shape for next PTL :)
15:16:32 <slaweq> so let's move on
15:16:34 <slaweq> #topic Grafana
15:16:58 <slaweq> I was looking at dashboard today and I noticed that it's not up to date
15:17:09 <slaweq> so I proposed https://review.opendev.org/c/openstack/project-config/+/805809 with many changes
15:17:24 <slaweq> I will rebase it on top of obondarev's patch
15:17:36 <slaweq> but please review it when You will have some time
15:18:45 <amotoki> I noticed that functional job in neutorn-lib is covered last week. Is it better to add it?
15:18:52 <amotoki> * in grafana
15:19:19 <amotoki> woops ** is not covered
15:19:45 <amotoki> I mean https://grafana.opendev.org/d/C5Wot6PMk/neutron-lib-failure-rate
15:20:08 <slaweq> * amotoki TBH I didn't check that dashboard for long time :/
15:20:19 <slaweq> but yes, we should add it there
15:20:55 <amotoki> hehe
15:20:59 <slaweq> and probably also neutron-tempest-plugin-api as this also runs in neutron-lib gate/check
15:21:08 <slaweq> I will do it
15:21:12 <slaweq> thx amotoki
15:21:24 <slaweq> #action slaweq to update neutron-lib grafana dashboard
15:22:01 <slaweq> from other things I just noticed now that neutron-ovn-tempest-slow is going very high with failure rates
15:22:14 <slaweq> did You maybe already checked it?
15:22:53 <ralonsoh> one problem was related to the new image
15:22:56 <bcafarel> I need to check some logs to confirm it, but probably same issue as seen in wallaby
15:23:06 <ralonsoh> exactly
15:23:27 <slaweq> Flavor with name ntp_image_384M already exists.
15:23:29 <slaweq> yes
15:23:35 <ralonsoh> (my bad...)
15:23:46 <slaweq> ok, so we need to merge that bcafarel's fix fast
15:23:52 <slaweq> and we should be good with that :)
15:23:56 <slaweq> thx once again
15:24:14 <slaweq> that's all from me regarding grafana
15:24:52 <slaweq> and regarding other issues in functional/fullstack or tempest jobs, I didn't found anything new what we should discuss today
15:25:31 <slaweq> in functional job we are still hitting the ovn related issue https://bugs.launchpad.net/neutron/+bug/1938766
15:25:46 <slaweq> from what jlibosva told me - that is most likely issue in openvswitch
15:26:04 <slaweq> so he is going to check what earlier version of ovs we could use to unblock our gate
15:26:11 <slaweq> and we will probably go with such workaround
15:26:32 <slaweq> thx amotoki for help with that one too
15:27:06 <slaweq> do You have any other issues You would like to discuss today?
15:27:17 <ralonsoh> (I need to leave now, see you tomorrow)
15:27:33 <slaweq> if not, I think we can all finish earlier and ralonsoh will be able to leave without losing anything :)
15:27:43 <slaweq> see You ralonsoh
15:27:46 <ralonsoh> heheh thanks
15:28:34 <bcafarel> :)
15:29:53 <slaweq> ok, I guess that this silence means "we want to go home now!!" :)
15:30:09 <slaweq> so thx for attending the meeting today and see You all online
15:30:12 <obondarev> \o/
15:30:15 <slaweq> #endmeeting