15:01:00 <ykarel> #startmeeting neutron_ci
15:01:00 <opendevmeet> Meeting started Tue May  7 15:01:00 2024 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:00 <opendevmeet> The meeting name has been set to 'neutron_ci'
15:01:05 <mlavalle> \o
15:01:07 <ykarel> Ping list: bcafarel, lajoskatona, mlavalle, mtomaska, ralonsoh, ykarel, jlibosva, elvira
15:01:07 <lajoskatona> o/
15:02:01 <slaweq> o/
15:03:39 <ykarel> hello everyone
15:03:53 <ykarel> let's start with topics, some people are out on PTOs
15:04:02 <ykarel> #topic Actions from previous meetings
15:04:10 <ykarel> mlavalle to check failures in test_ovn_nb_sync_off and test_ovn_nb_sync_repair functional tests
15:04:38 <mlavalle> didn't have time to do additional checking
15:04:49 <mlavalle> what job do you want me to look at?
15:05:09 <ykarel> can check
15:05:10 <ykarel> https://3b505bf25709a9122a8a-48a55ed00d52551138f2a4465777f377.ssl.cf1.rackcdn.com/917131/5/check/neutron-functional-with-uwsgi/287f932/testr_results.html
15:05:29 <mlavalle> ok, I'll look at this
15:05:51 <ykarel> and https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_7f6/periodic/opendev.org/openstack/neutron/master/neutron-functional-with-pyroute2-master/7f6e7f8/testr_results.html
15:06:16 <ykarel> k moving to next
15:06:19 <ykarel> slawek to check test_router_fip_qos_after_admin_state_down_up sometime in 2 weeks
15:06:26 <ykarel> this was after 2 weeks so can skip
15:06:51 <ykarel> but havent see those issues this week
15:06:57 <ykarel> ykarel to check test_in_tenant_traffic failure in ovs job
15:06:58 <slaweq> yes, I didn't had time for it yet
15:07:09 <ykarel> np slaweq
15:07:25 <ykarel> for test_in_tenant_traffic, it was not seen again
15:07:36 <ykarel> and i couldn't spot anything wrong in logs for that
15:08:16 <ykarel> for now will just keep an eye on this if we see more failures for that
15:08:28 <ykarel> #topic Stable branches
15:08:42 <ykarel> not much activity in stable
15:08:53 <ykarel> all good except grenade skip level on stable/2023.2 due to zed transition to unmaintained
15:09:03 <ykarel> #topic Stadium projects
15:09:10 <ykarel> all green in periodic
15:09:13 <lajoskatona> all green this week
15:09:26 <lajoskatona> few interesting reviews:
15:09:42 <lajoskatona> one for fwaas: https://review.opendev.org/c/openstack/neutron-fwaas/+/916968
15:10:01 <lajoskatona> and perhaps slweq's for precommit-hook: https://review.opendev.org/q/topic:%22pre-commit-hook%22
15:10:31 <lajoskatona> that's it from me for stadiums
15:11:13 <ykarel> thx lajoskatona
15:11:31 <ykarel> #topic Rechecks
15:11:42 <ykarel> nothing bad here
15:11:51 <ykarel> 2 bare rechecks out of 11
15:12:15 <ykarel> quite less activity this week
15:12:30 <ykarel> #topic Tempest/Scenario
15:12:38 <ykarel> test_delete_server_while_in_building_state
15:12:47 <ykarel> https://b04549659f81127bccd5-1b102124c6fd0b6d71635117190cffc0.ssl.cf1.rackcdn.com/917262/2/check/neutron-ovs-tempest-multinode-full/a21ea6a/testr_results.html
15:13:00 <ykarel> looks nova specific
15:13:02 <ykarel> oslo_db.exception.DBReferenceError: (pymysql.err.IntegrityError) (1452, 'Cannot add or update a child row: a foreign key constraint fails (`nova_cell0`.`instance_actions`, CONSTRAINT `fk_instance_actions_instance_uuid` FOREIGN KEY (`instance_uuid`) REFERENCES `instances` (`uuid`))')
15:14:16 <lajoskatona> yes nova seems suspicious
15:14:43 <ykarel> on an another failure too in test_live_block_migration
15:14:48 <ykarel> https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_397/916112/6/gate/neutron-ovs-tempest-multinode-full/3978b33/testr_results.html
15:14:59 <ykarel> failed as libvirt.libvirtError: unable to connect to server at 'np0037423811:49152': Connection refused
15:15:13 * slaweq will be back in about 5 minutes
15:15:24 <ykarel> so both nova specific, we likely need to report these to nova
15:15:30 <ykarel> bugs
15:15:38 <ykarel> not sure if they are something known
15:16:06 <ykarel> any volunteer for these bug reports?
15:16:39 <ykarel> k i will check and report these
15:16:52 <ykarel> #action ykarel to check and report nova bugs for the issue in tempest jobs
15:16:59 <ykarel> #topic Periodic
15:17:18 <ykarel> skip level grenade broken after zed transitioned to unmaintained
15:17:19 <ykarel> https://zuul.openstack.org/builds?job_name=neutron-ovn-grenade-multinode-skip-level&job_name=neutron-ovs-grenade-multinode-skip-level&project=openstack%2Fneutron&branch=stable%2F2023.2&skip=0
15:17:31 <ykarel> for the current issue i pushed https://review.opendev.org/c/openstack/neutron/+/918378
15:18:06 <ykarel> still some projects not switched to unmaintained so it still fails
15:18:21 <ykarel> but we can merge above patch and watch for any fixes
15:18:39 <ykarel> please have a look
15:19:01 <ykarel> #topic Grafana
15:19:02 <ykarel> https://grafana.opendev.org/d/f913631585/neutron-failure-rate
15:19:09 <ykarel> let's have a quick look at grafana
15:20:27 <ykarel> it looks good to me, minor spikes in check, but those looks patch specific
15:20:40 <ykarel> anything to add?
15:20:46 <mlavalle> not from me
15:21:05 <lajoskatona> nothing from me
15:21:10 <ykarel> #topic On Demand
15:21:28 <ykarel> anything you would like to raise here ?
15:21:37 <slaweq> nothing from me
15:23:19 <ykarel> k will take silence as no
15:23:25 <ykarel> thx everyone for joining
15:23:40 <ykarel> let's close early and have everyone 36 minutes back
15:23:44 <ykarel> #endmeeting