15:04:19 <ykarel> #startmeeting neutron_ci
15:04:19 <opendevmeet> Meeting started Tue Jun 18 15:04:19 2024 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:19 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:19 <opendevmeet> The meeting name has been set to 'neutron_ci'
15:04:25 <ykarel> Ping list: bcafarel, lajoskatona, mlavalle, mtomaska, ralonsoh, ykarel, jlibosva, elvira
15:04:49 <ykarel> hello everyone
15:05:07 <ykarel> it's on IRC today
15:05:25 <bcafarel> o/
15:05:56 <mlavalle> \o
15:07:20 <ykarel> k let's start with topics
15:07:55 <ykarel> #topic Actions from previous meetings
15:08:04 <ykarel> slaweq to add ovn grenade to check queue
15:08:22 <ykarel> slaweq mentioned will not be around for the meeting
15:08:30 <ykarel> he pushed https://review.opendev.org/c/openstack/neutron/+/921835, which already merged
15:08:35 <ykarel> thx slaweq
15:08:42 <ykarel> mlavalle to check failures in test_direct_route_for_address_scope
15:08:59 <mlavalle> I checked it. Didn't happen agein the entire week
15:09:07 <mlavalle> I think it was a one of
15:09:41 <ykarel> ok did find something in logs what triggered the issue?
15:10:01 <mlavalle> it was a time out
15:10:12 <mlavalle> pinging
15:10:35 <ykarel> hmm ok just checked so logs would not have much for that
15:10:36 <mlavalle> more than a timeout, responses didin'r arrive to pinfs
15:10:48 <mlavalle> pings
15:10:59 <mlavalle> yeah, so not much to investigate
15:11:22 <ykarel> k if we see it again can try to see if can reproduce locally
15:11:26 <ykarel> thx mlavalle for checking
15:11:27 <mlavalle> for now, it must have been a network
15:11:35 <mlavalle> problem
15:11:46 <ykarel> ykarel to check test_metadata_proxy_rate_limiting_ipv6
15:11:58 <ykarel> Reported https://bugs.launchpad.net/neutron/+bug/2069744
15:12:11 <ykarel> Proposed https://review.opendev.org/c/openstack/neutron/+/922218
15:12:20 <ykarel> please review when get a chance
15:12:39 <ykarel> ykarel to check tempest failures in enforce-scope job
15:12:53 <ykarel> Same issue as https://bugs.launchpad.net/neutron/+bug/2045549
15:13:02 <ykarel> Proposed https://github.com/cirros-dev/cirros/pull/116
15:13:33 <ykarel> if that do not merge soon, we can considering moving affected jobs to older cirros version i.e 0.5.3
15:13:47 <ykarel> seen around 15 failures in last 2 weeks
15:14:17 <ykarel> and the issue in itself exists from quite long, likely from time we switched to cirros 0.6.0+
15:14:41 <ykarel> that's it on this
15:14:43 <ykarel> lajoskatona to check fullstack failure  test_configurations_are_synced_towards_placement
15:15:17 <ykarel> seems lajos not around today, will readd action
15:15:26 <ykarel> #action lajoskatona to check fullstack failure  test_configurations_are_synced_towards_placement
15:15:47 <ykarel> #topic Stable branches
15:16:20 <ykarel> bcafarel, any update here?
15:16:42 <ykarel> couple of patches merged in stable branches, overall looks good
15:16:45 <bcafarel> stable branches behaved while I was on PTO last week :) looking good in the recent backports (I have not checked periodic yet)
15:16:59 <ykarel> unmaintained branches have some issues
15:17:18 <ykarel> will check those later
15:17:21 <ykarel> thx bcafarel
15:17:30 <ykarel> #topic Stadium projects
15:17:37 <ykarel> sfc/bagpipe still broken
15:17:47 <ykarel> known issues
15:17:48 <ykarel> - https://bugs.launchpad.net/neutron/+bug/2068727
15:17:48 <ykarel> - https://bugs.launchpad.net/neutron/+bug/2067452
15:18:01 <ykarel> #topic Rechecks
15:18:16 <ykarel> just 1 bare recheck out of 16
15:18:20 <ykarel> let's keep doing it
15:18:30 <ykarel> #topic fullstack/functional
15:18:30 <mlavalle> +1
15:18:39 <ykarel> test_agent_list
15:18:50 <ykarel> https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_076/periodic/opendev.org/openstack/neutron/master/neutron-functional-with-oslo-master/0763173/testr_results.html
15:18:56 <ykarel> https://storage.bhs.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_7c1/921609/1/check/neutron-functional-with-uwsgi/7c14741/testr_results.html
15:19:11 <ykarel> seen twice in master and victoria, so need to check what's triggering this
15:19:18 <ykarel> any volunteer to check this?
15:19:27 <mlavalle> I'll check it
15:19:37 <mlavalle> in fact I saw it last  night
15:19:55 <ykarel> thx mlavalle
15:20:13 <ykarel> #action mlavalle to check failures for test_agent_list ft test
15:20:22 <ykarel> test_floatingip_mac_bindings
15:20:32 <ykarel> seen once https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_e4e/921942/1/gate/neutron-functional-with-uwsgi/e4e2d01/testr_results.html
15:20:55 <ykarel> old bug where there were some fixes pushed https://bugs.launchpad.net/neutron/+bug/1955008
15:21:12 <ykarel> will just update that for now
15:21:24 <ykarel> #topic Rally jobs
15:21:56 <ykarel> rally jobs broken in unmaintained branches https://bugs.launchpad.net/neutron/+bug/2069704
15:22:28 <ykarel> i think we could just drop these from unmaintained branches
15:22:37 <bcafarel> I wonder if keeping rally jobs is worth it for unmaintained
15:22:47 <bcafarel> ok you typed faster ykarel :)
15:23:07 <ykarel> will you send patches to drop those :?
15:23:24 <bcafarel> can do!
15:23:28 <ykarel> thx bcafarel
15:23:47 <ykarel> #action bcafarel to drop rally jobs from yoga/xena
15:24:03 <ykarel> #topic Periodic
15:24:13 <ykarel> devstack-tobiko-neutron broken on bobcat+ releases running on ubuntu-jammy
15:24:19 <ykarel> https://zuul.openstack.org/builds?job_name=devstack-tobiko-neutron&project=openstack%2Fneutron&branch=master&branch=stable%2F2024.1&branch=stable%2F2023.2&skip=0
15:24:43 <ykarel> It's already fixed today by https://review.opendev.org/c/x/tobiko/+/922184 from Eduardo
15:24:47 <opendevreview> Merged openstack/neutron-vpnaas master: Fix neutron wsgi module location  https://review.opendev.org/c/openstack/neutron-vpnaas/+/922189
15:25:16 <ykarel> unmaintained/zed fips 9-stream jobs broken
15:25:30 <ykarel> https://zuul.openstack.org/builds?job_name=neutron-ovn-tempest-ovs-release-fips&job_name=neutron-ovs-tempest-fips&project=openstack%2Fneutron&branch=unmaintained%2Fzed&skip=0
15:25:38 <ykarel> we can drop these too
15:25:49 <ykarel> anyone willing to send patch for these?
15:26:27 <ykarel> k i will send that
15:26:43 <ykarel> #action ykarel to send patch to drop fips jobs from unmaintained branches
15:26:51 <ykarel> #topic Grafana
15:26:56 <ykarel> https://grafana.opendev.org/d/f913631585/neutron-failure-rate
15:27:03 <ykarel> let's have quick look here too
15:27:53 <ykarel> some spikes in gate and that's related to cirros issue above
15:28:48 <ykarel> there are some spikes in pep8 but that's related to patch as seen in previous meeting
15:29:13 <ykarel> some other spikes too but those looks related to patches itself
15:29:18 <ykarel> anything to add?
15:29:40 <bcafarel> all good from me
15:30:03 <mlavalle> same here
15:30:09 <ykarel> ok
15:30:19 <ykarel> #topic On Demand
15:30:31 <ykarel> anything would like to raise here?
15:31:14 <mlavalle> noting from me
15:33:23 <bcafarel> jumping in another meeting, so good timing (and nothing either)
15:33:40 <ykarel> thx mlavalle bcafarel for joining
15:33:44 <ykarel> #endmeeting