15:00:44 <ykarel> #startmeeting neutron_ci
15:00:44 <opendevmeet> Meeting started Tue Jun 25 15:00:44 2024 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:44 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:44 <opendevmeet> The meeting name has been set to 'neutron_ci'
15:00:59 <ykarel> Ping list: bcafarel, lajoskatona, mlavalle, mtomaska, jlibosva, elvira
15:01:12 <ykarel> This will be video meeting this time: https://meetpad.opendev.org/neutron-ci-meetings
15:02:10 <lajoskatona> o/
15:04:14 <ykarel> #topic Actions from previous meetings
15:04:22 <ykarel> lajoskatona to check fullstack failure test_configurations_are_synced_towards_placement
15:04:40 <ykarel> #action lajoskatona to check fullstack failure test_configurations_are_synced_towards_placement
15:04:48 <ykarel> mlavalle to check failures for test_agent_list ft test
15:06:24 <ykarel> bcafarel to drop rally jobs from yoga/xena
15:06:36 <ykarel> https://review.opendev.org/q/If4b446dfe8a063e03676b8d90bbbb529f4c39d19
15:06:52 <ykarel> ykarel to send patch to drop fips jobs from unmaintained branches
15:07:06 <ykarel> Fixed instead https://review.opendev.org/q/I967de13094ff6df46737a22d4e1758f9900dfbc9
15:07:24 <ykarel> #topic Stable branches
15:07:37 <ykarel> all good
15:07:55 <ykarel> #topic Stadium projects
15:08:02 <ykarel> sfc/bagpipe known ones
15:08:02 <ykarel> - https://bugs.launchpad.net/neutron/+bug/2068727
15:08:03 <ykarel> - https://bugs.launchpad.net/neutron/+bug/2067452
15:08:09 <ykarel> dynamic-routing new one, fails with:- ImportError: cannot import name 'wsgi' from 'neutron.api'
15:09:47 <ykarel> https://review.opendev.org/c/openstack/releases/+/922742
15:10:45 <ykarel> #topic Rechecks
15:11:23 <ykarel> Gaudenz Stein
15:11:28 <ykarel> LIU Yulong
15:12:55 <ykarel> #topic fullstack/functional
15:12:59 <ykarel> test_get_all_devices
15:13:04 <ykarel> https://4e4f74ba0fe7370e7ace-9d0c56098ff0d689b3a7fb800d2686c1.ssl.cf1.rackcdn.com/922282/1/gate/neutron-functional-with-uwsgi/f4bb2ba/testr_results.html
15:13:08 <gaudenz_> What's up?
15:13:40 <ykarel> gaudenz_, we were checking bare rechecks and we noticed you had multiple of those
15:14:19 <ykarel> we expect everyone before rechecks checks the failure cause, if it's something new raise over irc , report bug etc
15:14:36 <gaudenz_> Yeah for my two open reviews the CI seemd to be quite unstable. It was always another job failing and I could not identify anything related to the change.
15:14:40 <ykarel> https://bugs.launchpad.net/neutron/+bug/1997341
15:15:25 <ykarel> test_fip_connection_for_address_scope
15:15:33 <ykarel> https://storage.bhs.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_892/periodic/opendev.org/openstack/neutron/master/neutron-functional/892e892/testr_results.html
15:16:11 <ykarel> test_l2_agent_restart
15:16:20 <ykarel> fails at _assert_ping_during_agents_restart
15:16:26 <ykarel> https://1b2a29b80eddd4e0b174-eda1a0c854fb13a0abbfe9e278c5ab06.ssl.cf2.rackcdn.com/922119/1/gate/neutron-functional-with-uwsgi/3622d92/testr_results.html
15:16:27 <ykarel> https://86ddc5b3525cc8a57bd5-84709aab2060acc1565f07c661aff448.ssl.cf1.rackcdn.com/922119/1/check/neutron-fullstack-with-uwsgi/4213115/testr_results.html
15:16:27 <ykarel> https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_e5d/888098/15/check/neutron-fullstack-with-uwsgi/e5d8147/testr_results.html
15:16:27 <ykarel> https://storage.bhs.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_6c6/922470/1/check/neutron-fullstack-with-uwsgi/6c63681/testr_results.html
15:16:29 <ykarel> https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_522/periodic/opendev.org/openstack/neutron/master/neutron-fullstack/52235b5/testr_results.html
15:16:32 <ykarel> https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_14b/922074/4/check/neutron-fullstack-with-uwsgi/14bece8/testr_results.html
15:16:35 <ykarel> Looks triggered by https://review.opendev.org/c/openstack/neutron/+/919834
15:17:50 <gaudenz_> I was just about to look into this. There are some improvements to it in https://review.opendev.org/c/openstack/neutron/+/917429
15:18:31 <gaudenz_> The systemd change just got merged before I was able to include these changes to it. But I did not yet check if the failures listed here are related to it.
15:18:39 <ykarel> gaudenz_, will you propose the fix for that? or we have to revert in meanshile
15:19:17 <ykarel> #action ykarel to open bug for fullstack failures
15:19:24 <gaudenz_> ykarel: Do you mean I should split the systemd unit related changes from https://review.opendev.org/c/openstack/neutron/+/917429? I would prefer if someone could review this and just merge the HA router test.
15:20:54 <ykarel> gaudenz_, if thats fixing it should be enough we can priroite that, thanks
15:20:57 <ykarel> #topic Tempest/Scenario
15:21:04 <ykarel> https://bugs.launchpad.net/neutron/+bug/2045549
15:21:28 <gaudenz_> I belive the l2_agent_restart test should be fixed by this.
15:21:36 <ykarel> thx
15:21:40 <gaudenz_> Not sure about the other failures.
15:21:44 <ykarel> #topic Periodic
15:21:56 <ykarel> gaudenz_, all failures were for l2_agent_restart test
15:22:04 <ykarel> https://storage.bhs.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_f31/periodic/opendev.org/openstack/neutron/master/neutron-ovs-tempest-fips/f318184/testr_results.html
15:22:30 <ykarel> #topic Grafana
15:22:35 <ykarel> https://grafana.opendev.org/d/f913631585/neutron-failure-rate
15:23:50 <ykarel> https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/922728
15:24:21 <ykarel> https://2dfe92361451b97fe3b2-ea1b996598061886e0c0a8d1c7e56346.ssl.cf2.rackcdn.com/922728/1/check/neutron-tempest-plugin-ovn/d16f88c/controller/logs/ovn-controller_log.txt
15:24:33 <ykarel> #topic On Demand
15:25:46 <ykarel> #endmeeting