15:02:26 <ykarel> #startmeeting neutron_ci
15:02:26 <opendevmeet> Meeting started Tue Jul  2 15:02:26 2024 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:26 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:26 <opendevmeet> The meeting name has been set to 'neutron_ci'
15:02:33 <ykarel> Ping list: bcafarel, lajoskatona, mlavalle, mtomaska, ralonsoh, ykarel, jlibosva, elvira
15:03:49 <lajoskatona> o/
15:04:48 <slaweq> o/
15:05:00 <bcafarel> o/
15:05:12 <haleyb> o/
15:07:52 <ykarel> hello everyone, let's start with topics from last week
15:07:53 <ykarel> #topic Actions from previous meetings
15:08:01 <ykarel> lajoskatona to check fullstack failure test_configurations_are_synced_towards_placement
15:08:40 <ykarel> lajoskatona, you got chance to check that?
15:08:48 <lajoskatona> I checked quickly this week, and since than no occurance of it
15:09:15 <ykarel> yeap me too not noticed again but it happens from time to time
15:09:28 <lajoskatona> by the logs timeing issue with the fake placement API in the fullstack framework
15:09:53 <lajoskatona> yes, that's true
15:11:24 <lajoskatona> actually those tests are quite shaky as a fake placement service isrunning to answer API calls from Neutron
15:14:34 <ykarel> do you think if increasing timeout will help here?
15:15:29 <lajoskatona> ykarel: i can check that if there can be a place to increase timeout
15:15:39 <lajoskatona> you can add an AP for that
15:16:07 <ykarel> #action lajoskatona to check timeout increase for test_configurations_are_synced_towards_placement
15:16:10 <ykarel> thx lajoskatona
15:16:27 <ykarel> ykarel to open bug for fullstack failures
15:16:34 <ykarel> https://launchpad.net/bugs/2070390
15:16:47 <ykarel> fix for this already merged, and not seen the failure again
15:16:55 <ykarel> #topic Stable branches
15:17:00 <ykarel> bcafarel, any updates here?
15:17:41 <bcafarel> all good from what I saw (it was quiet on backports front also this week)
15:19:20 <ykarel> k thx
15:19:27 <ykarel> #topic Stadium projects
15:19:40 <ykarel> sfc/bagpipe still red
15:19:41 <ykarel> - https://bugs.launchpad.net/neutron/+bug/2068727
15:19:41 <ykarel> - https://bugs.launchpad.net/neutron/+bug/2067452
15:20:23 <lajoskatona> yes, I pushed a u-c bump patch for exabgp: https://review.opendev.org/c/openstack/requirements/+/923311
15:20:47 <lajoskatona> I just realized that is needed :-(
15:20:52 <lajoskatona> but I had no time for sfc
15:22:35 <ykarel> ohkk i thought those deps update happens automatically for master branch, may be something changed
15:23:01 <lajoskatona> I expected the same :-)
15:23:22 <ykarel> so we thought right as there is patch for that https://review.opendev.org/c/openstack/requirements/+/922558/
15:23:29 <ykarel> including all other updates
15:24:33 <lajoskatona> ohhh, ok so automatic bump is still there, but fails on something
15:25:04 <lajoskatona> on a lot of things
15:25:31 <ykarel> yeap there are support removed for older python versions
15:25:49 <ykarel> just checked voluptuous py3.8 drop, but there could be other deps issue
15:25:54 <lajoskatona> not sure if we can push the sole exabgp bump to fix our gate or have to wait anyway for the group bump
15:26:06 <ykarel> i think we can push that's totally fine
15:27:13 <lajoskatona> +1, I will update the big bump patch to avoid coflict
15:27:30 <ykarel> k thx
15:27:33 <ykarel> let's move
15:27:34 <ykarel> #topic Rechecks
15:27:53 <ykarel> all good here, and had just 2/22 bare rechecks
15:28:02 <ykarel> #topic fullstack/functional
15:28:13 <ykarel> test_get_all_devices (stable/2023.1)
15:28:21 <ykarel> https://storage.bhs.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_aac/periodic/opendev.org/openstack/neutron/stable/2023.1/neutron-functional/aacd179/testr_results.html
15:28:31 <ykarel> Found old bugs Old bugs:- https://launchpad.net/bugs/2012510 and https://bugs.launchpad.net/neutron/+bug/1997341
15:28:52 <ykarel> and for one of them there were some stabilization bits pushed, which not backported to stable/2023.1
15:28:59 <ykarel> so we may try backport for those
15:29:13 <ykarel> anyone willing to check and propose those?
15:30:22 <ykarel> k i will do check and propose those
15:30:42 <ykarel> #action ykarel to check backports for test_get_all_devices functional test failures
15:30:50 <ykarel> #topic Tempest/Scenario
15:30:59 <ykarel> openstacksdk-functional-devstack-networking
15:31:07 <ykarel> https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_858/periodic/opendev.org/openstack/neutron/master/openstacksdk-functional-devstack-networking/858cdaa/testr_results.html
15:31:12 <ykarel> https://fbb34ddc02d1f109337c-ebf431c06382d97dfdf40c8495b34507.ssl.cf5.rackcdn.com/922829/1/check/openstacksdk-functional-devstack/202851a/testr_results.html
15:31:34 <ykarel> seen only in master periodic once, but looking opensearch seen similar failures in other openstacksdk jobs
15:31:40 <slaweq> I will check them as this is my change which probably broke it
15:31:56 <ykarel> thx slaweq
15:32:24 <ykarel> from timing i thought to also check https://review.opendev.org/c/openstack/devstack/+/922630 if that triggered it
15:32:39 <ykarel> #action slaweq to check failures in openstacksdk-functional jobs
15:32:58 <ykarel> #topic Grafana
15:33:10 <ykarel> https://grafana.opendev.org/d/f913631585/neutron-failure-rate
15:33:18 <ykarel> let's also have quick look here too
15:36:21 <ykarel> looks good there are some spikes in check but those looks patch specific as different jobs failing
15:36:40 <ykarel> anything to add?
15:37:04 <slaweq> nope
15:37:07 <lajoskatona> nope
15:37:53 <ykarel> #topic On Demand
15:38:13 <ykarel> anyting you would like to raise here?
15:38:55 <lajoskatona> nothing from me
15:39:13 <slaweq> nothing from me neighter
15:39:41 <ykarel> just that we are considering moving this meeting to Monday an hour earlier, ralonsoh will check/confirm that next week
15:39:52 <ykarel> may be will have more participants with that
15:40:18 <ykarel> thx everyone for joining
15:40:21 <ykarel> #endmeeting