14:02:02 <ykarel> #startmeeting neutron_ci
14:02:02 <opendevmeet> Meeting started Mon Aug 26 14:02:02 2024 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:02 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:02 <opendevmeet> The meeting name has been set to 'neutron_ci'
14:02:08 <ykarel> Ping list: bcafarel, lajoskatona, haleyb, slawek, mlavalle, mtomaska, ralonsoh, jlibosva, elvira
14:02:08 <mlavalle> \o
14:02:29 <slaweq> o/
14:02:33 <ralonsoh> hello
14:02:38 <lajoskatona> o/
14:04:18 <lajoskatona> is this an IRC or a viceo meeting today?
14:04:25 <ykarel> Hello everyone this is our first meeting since Meeting time change, it's IRC today
14:04:46 <ykarel> We can start with the topics
14:04:47 <ykarel> #topic Actions from previous meetings
14:04:55 <ykarel> ralonsoh to check failures in postgres job
14:05:07 <ralonsoh> I'm still reviewing that, sorry
14:05:15 <ralonsoh> (I didn't have much time)
14:05:24 <ykarel> k thx
14:05:35 <ykarel> will reassing for this week
14:05:41 <ykarel> #action ralonsoh to check failures in postgres job
14:05:48 <ykarel> slawek to check for sfc failures in coming weeks and have some conclusion for dalmatian release
14:05:57 <ykarel> https://review.opendev.org/q/topic:%22bug/2068727%22
14:06:00 <slaweq> fix is merged already
14:06:11 <slaweq> and gate for networking-sfc is fixed now
14:06:17 <lajoskatona> thanks, good news
14:06:18 <ykarel> i proposed to revert non-voting to job back to voting
14:06:32 <slaweq> thx ykarel
14:06:34 <ralonsoh> and I proposed https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/927109
14:06:39 <ralonsoh> on top of the RPC change
14:06:49 <ykarel> thx slaweq ralonsoh
14:07:13 <slaweq> thx ralonsoh
14:07:28 <ykarel> thats it from previous week action items
14:07:32 <ykarel> #topic Stable branches
14:07:51 <ykarel> Bernard is out for couple of weeks
14:08:00 <ykarel> In general there was not much activity on stable
14:08:08 <ykarel> ovs-rally job broken, needs backports https://review.opendev.org/q/topic:%22bug/2076430%22
14:08:16 <lajoskatona> small thing: on some stable branches the rally job is failing
14:08:18 <ykarel> postgres periodic job broken, rodolfo looking into that
14:08:20 <lajoskatona> ahh, yes that one
14:08:28 <ykarel> tox-py311(non-voting) broken post move to ubuntu-noble https://review.opendev.org/c/opendev/base-jobs/+/926360
14:09:07 <ykarel> lajoskatona, yes would require release for oslo serialization backports to clear that
14:09:41 <ykarel> #topic Stadium projects
14:09:52 <lajoskatona> ykarel: ack, when https://review.opendev.org/c/openstack/oslo.serialization/+/927026 is merged to 2023.1, I will propose releasa patch
14:10:02 <ykarel> lajoskatona, thx
14:10:17 <ykarel> #info finally neutron-sfc green
14:10:26 <ykarel> neutron-vpnaas had a failure https://zuul.openstack.org/build/5991943b070f46608c524fe8d8847746
14:10:27 <lajoskatona> vpnaas job failed, not sure if it was just an accident or have to fix it
14:10:43 <lajoskatona> I just quickly checked before the meeting
14:10:45 <ykarel> lajoskatona, can you check if it's one time thing or a real issue
14:11:07 <lajoskatona> sure, please add the AP for my nam
14:11:11 <lajoskatona> name---^
14:11:14 <ykarel> #action lajoskatona to check neutron-vpnaas periodic failure
14:11:15 <ykarel> thx
14:11:30 <lajoskatona> just a quick question for Ubuntu Noble
14:11:49 <lajoskatona> all jobs were changed?
14:12:02 <lajoskatona> I mean to use nobe node-set?
14:12:04 <ykarel> most of the jobs we set nodeset explicitly
14:12:17 <ykarel> so not all changed, only the ones which do not set nodeset explicitly
14:12:44 <lajoskatona> ack, I suppose we have time for those to change after the release?
14:13:51 <ykarel> the failure is seen in stable release, i not digged much
14:14:16 <ykarel> job is non voting there, but would be good to clear that, i added it for later section, we can check there
14:14:25 <lajoskatona> ack
14:14:55 <ykarel> #topic Rechecks
14:15:51 <ykarel> overall good here, bare rechecks 0/8
14:16:02 <ykarel> Let's check out failures
14:16:03 <ykarel> #topic fullstack/functional
14:16:07 <ykarel> test_fip_connection_for_address_scope
14:16:09 <ykarel> seen twice
14:16:16 <ykarel> https://7a8791b91414025d7f9e-ee680e3b8cf506c3665caad0d1bd3d66.ssl.cf2.rackcdn.com/periodic/opendev.org/openstack/neutron/master/neutron-functional-with-sqlalchemy-master/4cfe98e/testr_results.html
14:16:22 <ykarel> https://c972f4bb262ae2d5c5d6-598e1d61c0aab85aa3b67b337ca2c556.ssl.cf2.rackcdn.com/periodic/opendev.org/openstack/neutron/master/neutron-functional-with-uwsgi-fips/9d219de/testr_results.html
14:16:33 <ykarel> The test was re enabled last year https://review.opendev.org/c/openstack/neutron/+/896728 and we hit the failures some times
14:17:07 <ykarel> any volunteer to check it further?
14:17:12 <ralonsoh> I'll do it
14:17:21 <ykarel> thx ralonsoh
14:17:38 <ykarel> #action ralonsoh to check test_fip_connection_for_address_scope ft failure
14:17:44 <ykarel> test_agent_delete
14:17:51 <ykarel> Fails like KeyError: 'e7284c3b-5cce-48b0-bf97-5e12e80071ef'
14:17:58 <ykarel> also seen twice
14:17:59 <ykarel> https://3635896206e8229762ea-81b7edb0863976b5a5111fb4b7624783.ssl.cf1.rackcdn.com/925376/2/check/neutron-functional-with-uwsgi/9b6f08b/testr_results.html
14:18:03 <ykarel> https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_50c/926079/4/gate/neutron-functional-with-uwsgi/50c72c0/testr_results.html
14:18:37 <ralonsoh> I can check it too
14:18:54 <ykarel> thx ralonsoh
14:19:00 <ykarel> #action ralonsoh to check test_agent_delete ft failure
14:19:08 <ykarel> #topic Tempest/Scenario
14:19:24 <ykarel> still saw a failure with pagination api test after recent fix
14:19:36 <ykarel> pushed https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/927103
14:19:40 <ykarel> please have a look
14:19:53 <ykarel> #topic Periodic
14:20:12 <ykarel> https://zuul.openstack.org/builds?job_name=tox-py311&project=openstack/neutron failing since switch to ubuntu-noble
14:20:26 <ykarel> Any volunteer to check/clear that?
14:20:42 <ralonsoh> I'll do it
14:20:45 <ykarel> we may need to override nodeset or switch to openstack-tox-py311
14:21:03 <ykarel> likely require additional backport for bandit which was done in stable/2023.2
14:21:07 <ykarel> thx much ralonsoh
14:21:21 <ykarel> #action ralonsoh to check tox-py311 failures
14:21:36 <ykarel> #topic Grafana
14:21:42 <ykarel> https://grafana.opendev.org/d/f913631585/neutron-failure-rate
14:21:53 <ykarel> let's have a quick look here too
14:23:52 <ykarel> overall looks good, check queue has couple of spikes, but from what i checked most of those were patch specifics
14:24:24 <lajoskatona> and the py311 failure is also visible and discussed already
14:25:24 <ykarel> yes but that was on stable branch so different dashboard we seeing above
14:25:56 <ykarel> #topic On Demand
14:26:03 <ykarel> anything else you would like to raise here?
14:26:08 <mlavalle> I have a topic / concern
14:26:19 <ykarel> yes please
14:27:19 <mlavalle> I think that when we fall to standard time in the northern hemisphere, red Hatters will have a meeting clash between this one and the internal one we have on Mondays
14:27:41 <mlavalle> just a heads up
14:28:31 <slaweq> yes, You are right mlavalle, I noticed it last week when I added this meeting to my calendar
14:28:48 <ralonsoh> we can propose that change in November (Nov 4 is the first clash)
14:29:14 <ralonsoh> the quorum of this meeting is reduced enough to be flexible on this
14:29:45 <ykarel> thx mlavalle for raising it, yes let's revisit that time
14:30:35 <mlavalle> that's all from me
14:30:50 <ykarel> ok then let's close early and have every one 30 minutes back
14:30:53 <ykarel> thx everyone for joining
14:30:56 <ykarel> #endmeeting