15:00:36 <ykarel> #startmeeting neutron_ci
15:00:36 <opendevmeet> Meeting started Mon Nov  4 15:00:36 2024 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:36 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:36 <opendevmeet> The meeting name has been set to 'neutron_ci'
15:00:43 <ykarel> Ping list: bcafarel, lajoskatona, slawek, mlavalle, mtomaska, ralonsoh, ykarel, jlibosva, elvira
15:00:52 <lajoskatona> o/
15:01:42 <bcafarel> o/ (in other meetings so may be laggy)
15:03:33 <ralonsoh> hi!
15:04:05 <lajoskatona> do we have video meeting today? Or IRC?
15:04:17 <slaweq> hi
15:04:19 <ralonsoh> ups, right
15:04:26 <ralonsoh> I thought it was IRC only
15:05:21 <ykarel> IRC
15:05:33 <lajoskatona> ok, thanks
15:05:40 <ykarel> k let's start with the topics
15:06:01 <ykarel> #topic Actions from previous meetings
15:06:07 <ykarel> ykarel to check tempest issue in stable/unmaintained branches with py3.8 cleanup
15:06:26 <ykarel> pushed https://review.opendev.org/q/topic:%22bug/2085886%22
15:06:55 <ykarel> even after this have still some failure in ironic jobs, but those are periodic ones, atleast stable/2023.1 gate is unblocked now
15:07:24 <ykarel> ykarel to check grafana dashboard issue
15:07:34 <ykarel> I checked and it looked fine, it was an oversight last week as mistook number of runs with failures
15:07:56 <ykarel> Also pushed https://review.opendev.org/c/openstack/project-config/+/934052 to have a cleanup of job recently moved
15:08:04 <ykarel> so have a look
15:08:17 <ykarel> slawek to check https://bugs.launchpad.net/neutron/+bug/2083609
15:08:17 <ykarel> #topic Stable branches
15:08:23 <ykarel> #undo
15:08:23 <opendevmeet> Removing item from minutes: #topic Stable branches
15:08:39 <slaweq> sorry, I still didn't had time to check it yet
15:08:54 <slaweq> and as I don't happen very often I didn't treat it with highest priority
15:09:06 <slaweq> I will get to it at some point for sure :)
15:09:15 <ykarel> ok np, yes not happening quite frequent
15:09:26 <ykarel> will re add for now
15:09:31 <ykarel> so we just don't miss it
15:09:43 <ykarel> #action slawek to check https://bugs.launchpad.net/neutron/+bug/2083609
15:09:55 <ykarel> #topic Stable branches
15:10:04 <ykarel> bcafarel, any update?
15:10:11 * bcafarel waits to see if there is another #undo :)
15:10:20 * ykarel :)
15:10:30 <bcafarel> jokes apart, better than last week from what I saw (mostly thanks to you ykarel)
15:10:43 <bcafarel> 2023.1 unblocked, and progress on unmaintained py3.8 support
15:10:55 <bcafarel> newer branches, backports CI was mostly good
15:11:18 <ykarel> thx for the updates bcafarel
15:11:28 <ykarel> #topic Stadium projects
15:11:32 <ykarel> all green in periodic
15:11:35 <lajoskatona> all green
15:11:51 <lajoskatona> apart from that, I joined in the modernization work
15:11:55 <lajoskatona> https://review.opendev.org/q/topic:%22pyupgrade%22+owner:katonalala@gmail.com
15:12:25 <lajoskatona> to keep these projects in sync with core Neutron, so if you have time please check these projects' open reviews
15:12:42 <ykarel> thx lajoskatona for the updates
15:13:20 <ykarel> lajoskatona, so all those PRs are with automation or still required some manual updates?
15:13:37 <ykarel> i recall tom mentioned there were some manual bits required for octavia
15:14:19 <haleyb> there were definitely some manual updates for my neutron changes
15:14:36 <haleyb> and i guess we should do neutron-lib as well?
15:15:30 <ykarel> yes i think all project should be adopted including neutron-lib
15:15:48 <lajoskatona> yes, it is manual
15:16:16 <lajoskatona> or at least have to check what the tool did and fix where messed it up
15:16:53 <ykarel> thx lajoskatona for confirming
15:17:53 <lajoskatona> I hope I can continue this week for other stadiums
15:17:58 <haleyb> i can look at neutron-lib in all the spare time i have this week :-)
15:18:04 <ykarel> these pyupgrade bits i think can be coordinated in neutron meeting to not overlap
15:18:09 <ykarel> thx haleyb lajoskatona
15:19:40 <ykarel> #topic Rechecks
15:19:54 <opendevreview> Rodolfo Alonso proposed openstack/neutron master: Add Neutron API eventlet experimental jobs  https://review.opendev.org/c/openstack/neutron/+/931012
15:20:06 <ralonsoh> (sorry)
15:20:26 <ykarel> we still have couple of rechecks due to know issue
15:20:36 <ykarel> not much activity this week, and have 0/3 bare rechecks
15:20:48 <ykarel> #topic Tempest/Scenario
15:20:56 <ykarel> test_trunk_subport_lifecycle random failures in master since wsgi switch
15:21:03 <ykarel> https://bugs.launchpad.net/neutron/+bug/2085543
15:21:07 <ralonsoh> --> https://review.opendev.org/c/openstack/neutron/+/933836/3
15:21:13 <ralonsoh> that is solving this issue
15:21:30 <ralonsoh> there is a testing patch on top of it
15:21:44 <ykarel> thx ralonsoh , that's the main issue for the CI for now, seeing this quite frequently across ovn jobs
15:21:55 <ralonsoh> yes
15:22:01 <opendevreview> Merged openstack/neutron-fwaas master: Add note about requirements lower bounds  https://review.opendev.org/c/openstack/neutron-fwaas/+/933527
15:22:28 <ykarel> Other related failures where router or router interface not found while deleting, could be linked to one of the other wsgi switch related patches
15:22:36 <ykarel> - https://storage.bhs.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_eb6/periodic/opendev.org/openstack/neutron/master/neutron-ovn-tempest-ovs-master/eb6d44f/testr_results.html
15:22:36 <ykarel> - 2024-11-01 03:32:15,318 113867 INFO     [tempest.lib.common.rest_client] Request (RoutersTest:_run_cleanups): 404 DELETE https://158.69.64.156/networking/v2.0/routers/4506dff7-0d22-40a6-a2ca-e28dbabcb2bc 90.100s
15:22:36 <ykarel> - https://4d23b6e5972044413c22-8c13a3592446d4bae7da2f9bb43833cd.ssl.cf2.rackcdn.com/periodic/opendev.org/openstack/neutron/master/neutron-ovn-tempest-full-multinode-ovs-master/7955bb2/testr_results.html
15:22:37 <ykarel> - Request (NetworksTestDHCPv6:test_dhcp_stateful_router): 404 PUT https://200.225.47.26/networking/v2.0/routers/250874bf-6b34-41fd-a864-6482717a2ef8/remove_router_interface 90.509s
15:22:57 <ykarel> ralonsoh, if you can confirm if ^ will also be addressed by this or your other patches?
15:23:06 <ralonsoh> nope
15:23:18 <ykarel> so need seperate bug for these?
15:23:22 <ralonsoh> yes
15:23:42 <ykarel> ok i can report it
15:24:00 <opendevreview> Lajos Katona proposed openstack/neutron-tempest-plugin master: Add test job for firewall_v2 backend OVN  https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/905421
15:24:11 <ykarel> #action ykarel to open bug for router related tests failing
15:24:25 <ykarel> #topic Periodic
15:24:36 <ykarel> https://zuul.openstack.org/builds?job_name=ironic-tempest-ipa-wholedisk-bios-agent_ipmitool-tinyipa&branch=stable%2F2023.1&skip=0
15:25:03 <ykarel> this the one i mentioned before, testing a patch in ironic pinning the branchless projects
15:25:44 <ykarel> apart from these unmaintained yoga/zed also have patches up linked before
15:25:53 <ykarel> for xena i still need to check last failures
15:26:16 <ykarel> that's it on failures
15:26:22 <ykarel> #topic Grafana
15:26:29 <ykarel> https://grafana.opendev.org/d/f913631585/neutron-failure-rate
15:26:38 <ykarel> let's also have quick look here as well
15:29:56 <ykarel> looks normal, with functional and tempest know issues we can see the spikes
15:30:23 <ralonsoh> agree
15:30:38 <lajoskatona> pattern looks ok, like previous weeks
15:31:27 <ykarel> #topic On Demand
15:31:33 <ykarel> anything else you would like to raise?
15:31:41 <ralonsoh> no thanks
15:31:54 <lajoskatona> nothing from me
15:31:58 <mlavalle> is this the meeting time until further notice?
15:32:20 * mlavalle tryring to adapt to standard time
15:34:52 <ykarel> mlavalle, yes will continue on this new time until there is a change
15:35:00 <ykarel> thx everyone for joining
15:35:12 <ykarel> #endmeeting