15:04:02 <ykarel> #startmeeting neutron_ci
15:04:02 <opendevmeet> Meeting started Mon Mar  3 15:04:02 2025 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:02 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:02 <opendevmeet> The meeting name has been set to 'neutron_ci'
15:04:12 <ykarel> Ping list: bcafarel, lajoskatona, slawek, mlavalle, mtomaska, ralonsoh, ykarel, jlibosva, elvira
15:04:13 <mlavalle> \o
15:04:16 <ykarel> Ping list: bcafarel, lajoskatona, slawek, mlavalle, mtomaska, ralonsoh, ykarel, jlibosva, elvira
15:04:16 <ykarel> This will be video meeting this time: https://meetpad.opendev.org/neutron-ci-meetings
15:04:59 <haleyb> o/
15:05:42 <ykarel> #topic Actions from previous meetings
15:05:57 <ykarel> ralonsoh to check privsep related failure in functional job
15:07:24 <ykarel> ralonsoh to check pyroute2 functional failures
15:07:44 <ykarel> ralonsoh to confirm failure with oslo master function job
15:09:33 <ykarel> [oslo][release][requirements] RFE for oslo.db and oslo.service
15:10:14 <ykarel> #topic Stable branches
15:11:17 <ykarel> #topic Stadium projects
15:11:20 <lajoskatona> o/
15:11:26 <ykarel> all green
15:11:32 <ykarel> anything to add lajoskatona ^
15:11:47 <lajoskatona> not really, sorry for being late
15:12:03 <opendevreview> Rodolfo Alonso proposed openstack/neutron master: DNM - Test errors in ``neutron-functional-with-pyroute2-master``  https://review.opendev.org/c/openstack/neutron/+/942859
15:12:08 <ykarel> np
15:12:26 <ykarel> #topic Rechecks
15:13:05 <ykarel> 8/66 bare rechecks
15:13:06 <ykarel> #topic fullstack/functional
15:13:16 <ykarel> random failure in functional job when running with 1 concurrency(as the selected CI node only have 1 CPU)
15:13:37 <ykarel> https://zuul.openstack.org/build/fa6220543bb1489cac8e0f7d79af3387
15:14:30 <ykarel> some tests marked unstable as part of https://bugs.launchpad.net/oslo.service/+bug/2100001
15:14:44 <ykarel> wait until true fullstack
15:14:51 <ykarel> - https://f5cea6bf47b564905a60-76ad47885070581f857a540cadaa6a6d.ssl.cf2.rackcdn.com/periodic/opendev.org/openstack/neutron/master/neutron-fullstack-fips/55ce719/testr_results.html
15:14:51 <ykarel> - https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_734/periodic/opendev.org/openstack/neutron/master/neutron-fullstack/734e815/testr_results.html
15:14:51 <ykarel> - https://a5add638f395680c501b-5a2e25cd3e2f3adbdcbfdb283f832c7a.ssl.cf1.rackcdn.com/942530/2/gate/neutron-fullstack/945b6e9/testr_results.html
15:16:33 <ykarel> #topic Tempest/Scenario
15:16:43 <ykarel> - https://6680d19461a57172eaa9-71ec100da363a5820f9bef22bce9fb5d.ssl.cf5.rackcdn.com/periodic/opendev.org/openstack/neutron/master/neutron-ovs-tempest-with-os-ken-master/30c29c2/testr_results.html
15:16:43 <ykarel> - https://fc891d7e1f0b0d1ecc9c-5406e7d03d51190d7ee83b25b2acffe7.ssl.cf2.rackcdn.com/periodic/opendev.org/openstack/neutron/master/neutron-ovs-tempest-with-os-ken-master/3d07efc/testr_results.html
15:16:43 <ykarel> - https://e6aae367021d38c9d4db-1eee5d6654f19bfbb50f61b5642c3fcd.ssl.cf2.rackcdn.com/periodic/opendev.org/openstack/neutron/master/neutron-ovs-tempest-with-oslo-master/5db5fe8/testr_results.html
15:18:17 <ykarel> #action ykarel to check and open bug for ovs tempest failures
15:18:25 <ykarel> #topic grenade
15:19:06 <ykarel> https://619f8ab8e7929f66bd5b-cf1861da2efffc8db9fe7bd2fe123be5.ssl.cf1.rackcdn.com/periodic/opendev.org/openstack/neutron/master/neutron-ovs-grenade-dvr-multinode/ab5df5a/controller/logs/grenade.sh_log.txt
15:19:58 <ykarel> #action ykarel to open bug for ping failure post upgrade in grenade jobs
15:20:14 <ykarel> #topic Periodic
15:20:23 <ykarel> https://zuul.openstack.org/builds?job_name=neutron-functional-with-pyroute2-master&project=openstack/neutron
15:20:34 <ykarel> Being tracked in https://bugs.launchpad.net/neutron/+bug/2100261
15:20:40 <ykarel> #topic Grafana
15:20:45 <ykarel> https://grafana.opendev.org/d/f913631585/neutron-failure-rate
15:23:55 <ykarel> test_established_tcp_session_after_re_attachinging_sg
15:25:03 <ykarel> #action ykarel to open bug for tempest failure in test_established_tcp_session_after_re_attachinging_sg
15:26:40 <ykarel> #topic On Demand
15:27:01 <haleyb> i had one item
15:27:20 <haleyb> last friday i think, frickler had commented about a CI failure
15:27:21 <haleyb> https://zuul.opendev.org/t/openstack/build/6fb3e27b3cec415bb4d08cdfab6a1a03
15:27:39 <haleyb> recheck got past it, but has that one been seen before?
15:27:57 <haleyb> py3.12 job
15:28:14 <haleyb> not sure if it was eventlet-related
15:29:45 <ralonsoh> could be, yes
15:30:26 <ykarel> me don't recall seeing that in past, may be some one else know
15:30:41 <ralonsoh> this could be related to https://review.opendev.org/c/openstack/neutron/+/939095/4/neutron/tests/unit/notifiers/test_batch_notifier.py
15:30:47 <haleyb> i did not file a bug since i couldn't find it anywhere else
15:30:53 <ralonsoh> I remember having some problems when testing that
15:31:04 <ralonsoh> we can increase a bit the time.sleep(o)
15:31:13 <ralonsoh> to sleep(0.1)
15:31:34 <haleyb> yes, that was his comment as well, but i shrugged
15:32:13 <ralonsoh> once we remove eventlet from the testing jobs, we won't need that
15:32:20 <ralonsoh> so for now we can increase this time
15:32:40 <haleyb> right, should i file a bug and increase both of those sleep() calls?
15:32:57 <ralonsoh> yes, just a bit (0.1 or 0.2)
15:34:06 <haleyb> 0.15 :-p i'll just pick one and run some rechecks to make sure it is clean
15:34:15 <ralonsoh> perfect
15:34:29 <haleyb> that's all i had
15:34:37 <ralonsoh> ykarel, haleyb, I think we can close the meeting
15:34:57 <ykarel> would be good to have a bug and todo cleanup for that unless all the cleanups will be taken care by any other bug
15:35:37 <ralonsoh> right, the _notify method
15:36:08 <ralonsoh> that is a very bad design (and I did that)
15:36:35 <ralonsoh> hold on
15:36:45 <ralonsoh> the test case class removes the mocks after the test
15:36:54 <ralonsoh> so no, at the end of the test it won't be patches
15:36:58 <ralonsoh> patched*
15:40:44 <ykarel> ack can be tracked offline
15:40:48 <ykarel> thx everyone for joining
15:40:51 <ykarel> #endmeeting