14:01:20 <ykarel> #startmeeting neutron_ci
14:01:20 <opendevmeet> Meeting started Mon May 19 14:01:20 2025 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:20 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:20 <opendevmeet> The meeting name has been set to 'neutron_ci'
14:01:25 <ykarel> Ping list: bcafarel, lajoskatona, slawek, mlavalle, mtomaska, ralonsoh, ykarel, jlibosva, elvira
14:01:27 <mlavalle> \o
14:01:32 <slaweq> o/
14:01:56 <cbuggy> o/
14:02:27 <lajoskatona> o/
14:02:55 <haleyb> o/
14:03:17 <mlavalle> what's the meetpad url for the meeting?
14:03:52 <ykarel> it's IRC today
14:03:53 <ykarel> https://etherpad.opendev.org/p/neutron-ci-meetings
14:04:12 <ykarel> and meetpad url for reference is https://meetpad.opendev.org/neutron-ci-meetings
14:04:18 <mlavalle> thanks
14:04:27 <ralonsoh> hello
14:05:07 <ykarel> hi everyone, let's start with the topics
14:05:08 <ykarel> #topic Actions from previous meetings
14:05:15 <ykarel> ralonsoh to send patch to drop devstack-tobiko-neutron from zed and 2023.1
14:05:25 <ykarel> #link https://review.opendev.org/q/topic:%22remove-devstack-tobiko-neutron%22
14:05:33 <ykarel> thx ralonsoh for those patches
14:05:38 <ralonsoh> yw
14:05:41 <ykarel> ykarel to check https://bugs.launchpad.net/neutron/+bug/2110004
14:06:08 <ykarel> i checked the logs but couldn't spot what's wrong, so started with some test patches
14:06:18 <ykarel> will update the bugs as i progress on those
14:06:33 <ykarel> #topic Stable branches
14:06:56 <ykarel> Bernard not around currently
14:07:09 <ykarel> but all good in stable, except a periodic issue in stable/2024.2
14:07:22 <ykarel> #topic Stadium projects
14:07:26 <ykarel> all green in periodic
14:07:32 <ykarel> lajoskatona any thing to add?
14:07:38 <lajoskatona> nothing
14:07:48 <lajoskatona> some patches from slaweq for rbac for fwaas
14:08:12 <lajoskatona> and from me for rback n-d-r and vpnaas *I had to reshape them to have unit tests)
14:08:54 <lajoskatona> that's it for stadiums
14:09:51 <ykarel> thx lajoskatona
14:10:02 <slaweq> for fwaas it all works fine in ci
14:10:39 <ykarel> thx slaweq
14:10:41 <ykarel> #topic Rechecks
14:10:59 <slaweq> I also did https://review.opendev.org/c/openstack/neutron-fwaas/+/950156 to switch stable/2025.1 branch of fwaas to use correct job's definition from neutron-tempest-plugin
14:11:13 <ykarel> #undo
14:11:13 <opendevmeet> Removing item from minutes: #topic Rechecks
14:11:18 <slaweq> just FYI
14:11:37 <ykarel> k lets move to next topic now :)
14:11:48 <ykarel> #topic Rechecks
14:11:51 <ykarel> we still have some rechecks for intermittent issues in functional, fullstack jobs
14:12:08 <ykarel> for bare rechecks, we had 1/18 bare rechecks
14:12:17 <ykarel> so let's keep avoiding bare rechecks
14:12:21 <mlavalle> that's good
14:12:28 <lajoskatona> +1
14:12:38 <ykarel> Let's check failures now
14:12:39 <ykarel> #topic fullstack/functional
14:12:45 <ykarel> test_pb_type_empty
14:12:57 <ykarel> Fails as ovsdbapp.backend.ovs_idl.idlutils.RowNotFound: Cannot find Port_Binding with logical_port=caaaf17d-2abc-4a42-be40-d01671b42cb3
14:13:08 <ykarel> https://9c08bb97d91554639aeb-1e695c46ce38568fe2b9076122bc0b06.ssl.cf1.rackcdn.com/openstack/65b243a8fac74507a9afa16b4e3aa0fc/testr_results.html
14:13:32 <ralonsoh> I don't think I correctly implemented this one
14:13:37 <ralonsoh> I can open a LP bug and check
14:13:47 <ykarel> k thx ralonsoh
14:14:22 <ykarel> from what i saw looks like northd got busy and was not processing lsp created that time
14:14:46 <ykarel> 2025-05-12T17:53:49.304Z|01105|timeval|WARN|Unreasonably long 1033ms poll interval (3ms user, 2ms system)
14:14:59 <ralonsoh> then we'll need an active wait or an event check
14:17:48 <ykarel> ok
14:18:04 <ykarel> #action ralonsoh to check failure in test_pb_type_empty functional test
14:18:13 <ykarel> test_trunk_creation_with_no_subports
14:18:22 <ykarel> Fails as oslo_privsep.daemon.FailedToDropPrivileges: privsep helper command exited non-zero (96)
14:18:30 <ykarel> https://1962bf82da409b31742b-97bb40c6f1fba9143f6a2ea19df7d61e.ssl.cf2.rackcdn.com/openstack/a13f73c6a17a4b2097b43bdcd9ff4412/testr_results.html
14:19:08 <ykarel> From old logs can see it was seen also in feb but in test test_trunk_creation_with_subports
14:19:27 <ykarel> so not a frequent failure
14:19:29 <lajoskatona> I can check this one
14:19:41 <lajoskatona> anyway I spent some time recently with trunks :-)
14:20:05 <ykarel> #action lajoskatona to check failure in test_trunk_creation_with_no_subports functional test
14:20:10 <ykarel> thx lajoskatona
14:20:20 <ykarel> test_subport_delete
14:20:38 <ykarel> failed while waiting for lsp event
14:20:39 <ykarel> https://fe6d6d8568001e0da1b7-c29773bdeee4530a738751d9e026e2a7.ssl.cf2.rackcdn.com/openstack/ddcc8ac3867c412cb4187fc1262dda57/testr_results.html
14:21:51 <ykarel> any volunteer to check this?
14:22:05 <ralonsoh> I can check this one, the event is a bit broad
14:22:08 <ralonsoh> with no conditions
14:22:17 <ralonsoh> (and the name is not correct)
14:22:59 <ykarel> thx ralonsoh
14:23:10 <ykarel> #action ralonsoh to check issue with test_subport_delete functional test
14:23:24 <ykarel> #topic Periodic
14:23:30 <ykarel> openstaksdk job 2024.2 broken https://zuul.openstack.org/builds?job_name=openstacksdk-functional-devstack-networking&project=openstack%2Fneutron&branch=stable%2F2024.2&skip=0
14:23:45 <ykarel> with https://review.opendev.org/c/openstack/designate/+/949094
14:23:57 <ykarel> reported it in #openstack-dns
14:24:10 <ykarel> #topic Grafana
14:24:24 <ykarel> let's also have quick look on https://grafana.opendev.org/d/f913631585/neutron-failure-rate
14:25:03 <opendevreview> Eduardo Olivares proposed x/whitebox-neutron-tempest-plugin master: test_attach_qos_port_to_vm_with_another_port: Create VMs on different hosts  https://review.opendev.org/c/x/whitebox-neutron-tempest-plugin/+/950296
14:26:48 <ykarel> in gate we have a failure in ovn job which timed out running tests
14:28:04 <ykarel> apart from that looks good
14:28:45 <ykarel> there are spikes in check but those are known random issues or patch specific failures
14:28:48 <ykarel> anything to add?
14:28:56 <lajoskatona> nothing from me
14:30:56 <ykarel> k let's move then
14:31:02 <ykarel> #topic On Demand
14:31:08 <ykarel> anything else you would like to raise?
14:31:18 <ralonsoh> no thanks
14:31:21 <lajoskatona> nope, thanks
14:33:31 <slaweq> nothing from me
14:33:35 <ykarel> k then, thx everyone for joining, and let's close early and have everyone almost 27 minutes back
14:33:38 <ykarel> #endmeeting