14:02:29 <ykarel> #startmeeting neutron_ci
14:02:29 <opendevmeet> Meeting started Mon Jun  2 14:02:29 2025 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:29 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:29 <opendevmeet> The meeting name has been set to 'neutron_ci'
14:02:34 <ykarel> Ping list: bcafarel, lajoskatona, slawek, mlavalle, mtomaska, ralonsoh, ykarel, jlibosva, elvira
14:02:35 <mlavalle> \o
14:02:45 <ralonsoh> hello
14:02:59 <ralonsoh> IRC today, if I'm not wrong?
14:03:24 <ykarel> yeap IRC today
14:03:51 <slaweq> o/
14:06:58 <ykarel> hi everyone, let's start with action items from previous week
14:07:11 <ykarel> lajoskatona to check if some debug logs can be added to isolate this further
14:07:32 <ykarel> lajoskatona, around?
14:09:01 <lajoskatona> o/
14:09:07 <lajoskatona> sorry, I lost my watch it seems
14:09:15 <lajoskatona> no time for that one
14:09:32 <ykarel> ack lajoskatona will readd
14:09:44 <ykarel> #action lajoskatona to check if some debug logs can be added to isolate this further
14:09:51 <ykarel> lajoskatona to check bagpipe job timeout and increase if needed
14:10:00 <lajoskatona> but I opened a bug for ti to track: https://bugs.launchpad.net/neutron/+bug/2112123
14:10:27 <ykarel> thx lajoskatona
14:10:30 <lajoskatona> for that I increased the timeout, I mean for bagpipe
14:10:36 <ykarel> yes with https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/950895
14:10:54 <ykarel> thx la
14:11:05 <ykarel> thx lajoskatona
14:11:47 <ykarel> moving to next
14:11:50 <ykarel> ralonsoh  to check issue with test_subport_delete functional test
14:12:01 <ralonsoh> the patch is merged (let me find it)
14:12:19 <ralonsoh> https://review.opendev.org/c/openstack/neutron/+/951119
14:13:02 <ykarel> thx ralonsoh , so we need this backport too?
14:13:11 <ralonsoh> yes, I'll propose them
14:13:16 <ykarel> thank you
14:13:23 <ykarel> ralonsoh to push patch to switch to jammy-minimal and skip test test_multicast_between_vms_on_same_network
14:13:30 <ykarel> #link https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/951149
14:13:34 <ralonsoh> right
14:13:38 <ykarel> thx ralonsoh for this too
14:13:45 <ykarel> #topic Stable branches
14:13:53 <ykarel> not much activity on stable this week
14:14:24 <ykarel> and wrt periodics had an issue in 2024.2 related to designate, will add about it later
14:14:40 <ykarel> #topic Stadium projects
14:14:46 <ykarel> vpnaas failure https://zuul.openstack.org/buildset/d4880a2bb4bd42f49c5dfd69ef76be6e
14:15:00 <ykarel> Looks broken with https://review.opendev.org/c/openstack/neutron/+/949135 ?
14:15:12 <ykarel> lajoskatona, may be you checked this ^
14:15:27 <lajoskatona> I saw only in one of my patches the same issue
14:15:49 <lajoskatona> but good hin,t let me check it
14:16:01 <ralonsoh> that's a problem...
14:16:15 <ralonsoh> we need to refactor the vpnaas code ASAP then
14:16:57 <lajoskatona> yes,the eventlet removal hits stadiums also
14:17:06 <lajoskatona> I check vpnaas
14:17:57 <ykarel> ack will add action item for you lajoskatona
14:18:06 <lajoskatona> +1
14:18:07 <ykarel> #action lajoskatona to check vpnaas failures
14:18:19 <ykarel> #topic Rechecks
14:18:44 <ykarel> we still have some rechecks and bare recheck wise it was 0/11
14:18:57 <ykarel> so let's keep avoiding bare rechecks
14:19:10 <ykarel> #topic fullstack/functional
14:19:16 <ykarel> test_keepalived_multiple_sighups_does_not_forfeit_primary
14:19:24 <ykarel> FileNotFoundError: [Errno 2] No such file or directory: '/tmp/tmpxacozir5/tmp964czp4l/ha_confs/bd3760d4-5712-4ebc-b61a-0c2bfe73776a/state'
14:19:30 <ykarel> https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_363/openstack/363ea9e92c7b41479040e17145fac53b/testr_results.html
14:19:39 <ykarel> different failure in same test https://storage.bhs.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_85e/openstack/85e1e528f77847c895246bf2915c99a4/testr_results.html
14:20:24 <ykarel> not a new issue, we have seen this in past too
14:20:29 <ralonsoh> I would say not to spend too much time on this test
14:20:33 <ralonsoh> --> https://review.opendev.org/c/openstack/neutron/+/938404
14:20:38 <ralonsoh> I'm skipping it here
14:20:48 <ralonsoh> because we are in the middle of the eventlet deprecation
14:21:01 <ralonsoh> and with this patch this code requires kernel threads
14:21:02 <ykarel> thx ralonsoh
14:21:40 <ykarel> test_ha_router_failover_graceful
14:21:47 <ykarel> https://storage.bhs.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_2f0/openstack/2f0385f7d56c49cd83da45efadf59b70/testr_results.html
14:22:01 <mlavalle> I've been investigating that type of failure specifically
14:22:09 <ykarel> known issue https://bugs.launchpad.net/neutron/+bug/2104019
14:22:13 <ykarel> thx mlavalle
14:22:25 <ykarel> #topic Tempest/Scenario
14:22:28 <opendevreview> Merged openstack/neutron stable/2025.1: Delete the metadata agent file from the eventlet directory  https://review.opendev.org/c/openstack/neutron/+/950385
14:22:36 <ykarel> random failures in test_multicast_between_vms_on_same_network and similar test
14:22:49 <ykarel> should be fixed now with https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/951149 merged
14:22:55 <ykarel> #topic grenade
14:23:02 <ykarel> skip level grenade jobs fixed with https://review.opendev.org/c/openstack/neutron/+/950856
14:23:12 <ykarel> #topic Periodic
14:23:19 <ykarel> stable/2024.2 openstacksdk job still broken, pushed https://review.opendev.org/q/topic:%22update-oslo-utils%22 to clear it
14:23:36 <ykarel> #topic Grafana
14:23:45 <ykarel> https://grafana.opendev.org/d/f913631585/neutron-failure-rate
14:23:50 <ykarel> let's have quick look here too
14:25:53 <ralonsoh> there are some spikes, but patch related
14:26:28 <ykarel> yeap, and some random failures in functional that's are known ones
14:27:35 <ykarel> #topic On Demand
14:27:42 <ykarel> anything else you would like to raise?
14:27:46 <ralonsoh> no
14:28:36 <lajoskatona> nothing from me
14:30:02 <ykarel> ok in that clase, let's close early and have everyone almost 30 minutes back
14:30:04 <ykarel> thx all
14:30:07 <ykarel> #endmeeting