14:01:30 <ykarel> #startmeeting neutron_ci
14:01:30 <opendevmeet> Meeting started Mon Jul 28 14:01:30 2025 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:30 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:30 <opendevmeet> The meeting name has been set to 'neutron_ci'
14:01:36 <ykarel> Ping list: bcafarel, lajoskatona, slawek, mlavalle, mtomaska, ralonsoh, ykarel, jlibosva, elvira
14:01:42 <ykarel> Meeting is IRC today
14:01:45 <mtomaska> o/
14:01:47 <ralonsoh> hello
14:01:50 <slaweq> o/
14:02:03 <elvira> o/
14:02:37 <bcafarel> o/
14:02:42 <lajoskatona> o/
14:03:40 <ykarel> Hello everyone let's start with the topics
14:03:41 <ykarel> #topic Actions from previous meetings
14:03:50 <ykarel> ykarel to report the bug for test_subport_delete
14:04:00 <ykarel> #link https://bugs.launchpad.net/neutron/+bug/2117405
14:04:24 <ykarel> #topic Stable branches
14:04:30 <ykarel> bcafarel, any update ?
14:04:44 <ykarel> as per periodic it was all good
14:04:51 <bcafarel> all good overall indeed
14:04:53 <ykarel> except unmaintained/wallay
14:05:08 <ykarel> ack thx for the update
14:05:16 <ykarel> #topic Stadium projects
14:05:20 <ykarel> all green in periodics
14:05:26 <ykarel> lajoskatona anything to add?
14:05:30 <lajoskatona> all green, and some patches was merged last week,
14:05:41 <lajoskatona> so seems to be ok as I see
14:06:16 <ykarel> k thx for the update lajoskatona
14:06:34 <ykarel> #topic Rechecks
14:07:11 <ykarel> still few rechecks, bare recheck wise all good 0/7 bare rechecks
14:07:41 <ykarel> https://review.opendev.org/c/openstack/neutron/+/945497 had comment from Julia that it broke ironic jobs
14:08:07 <ralonsoh> but that was for Ironic
14:08:34 <ykarel> not sure if a bug is reported and anything to be fixed on neutron side
14:08:53 <ralonsoh> I'll check with Julia today (or tomorrow morning)
14:09:00 <ralonsoh> and I'll create the corresponding bug for Neutron, if needed
14:09:16 <ykarel> ok looks https://bugs.launchpad.net/ironic/+bug/2118780
14:09:27 <ykarel> grenade job
14:09:36 <ykarel> thx ralonsoh
14:10:13 <ykarel> #topic fullstack/functional
14:10:20 <ykarel> test_subport_delete
14:10:26 <ykarel> https://d6e1f78c8bf69cb17ff8-e9858f2cd7cb620f684618f2ae76d049.ssl.cf5.rackcdn.com/openstack/78c61f7c63b74002aec78ff5d7238b6b/testr_results.html
14:10:32 <ykarel> Known issue https://bugs.launchpad.net/neutron/+bug/2117405
14:10:43 <ykarel> #topic Tempest/Scenario
14:10:46 <ralonsoh> yes, I have this bug assigned but I didn't have time
14:11:12 <ykarel> ralonsoh, ack seen twice for now, not impacting that much so you can take some time on this
14:11:40 <ykarel> For tempest seen test_create_router_update_external_gateways twice
14:11:48 <ykarel> https://469f0c3d38d99d01911d-1134cbbc9f8768ad587f4fe701953efd.ssl.cf5.rackcdn.com/openstack/0fa406bb16ef449e8853b6f26b9639a4/testr_results.html
14:11:54 <ykarel> https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_df4/openstack/df40908e34174e46ae81bb358ad73706/testr_results.html
14:12:08 <ykarel> once in stable/2024.2 and in master
14:12:35 <ykarel> anyone would like to check this?
14:12:52 <ralonsoh> I can do it
14:13:14 <ykarel> ack thx ralonsoh
14:13:23 <ykarel> #action ralonsoh to check test_create_router_update_external_gateways
14:13:33 <ykarel> #topic Periodic
14:13:58 <ykarel> multinode mix provider fix https://review.opendev.org/c/zuul/zuul/+/955545, no failure since saturday, will keep an eye this week tooope
14:14:16 <ykarel> devstack tobiko job in master broken https://zuul.openstack.org/builds?job_name=devstack-tobiko-neutron&project=openstack%2Fneutron&branch=master&skip=0
14:14:27 <ykarel> and this uncovered some bugs in ovn agent
14:14:38 <ykarel> all being tracked in couple of bugs
14:14:39 <ykarel> - https://bugs.launchpad.net/neutron/+bug/2118398
14:14:39 <ykarel> - https://bugs.launchpad.net/neutron/+bug/2118902
14:14:39 <ykarel> - https://bugs.launchpad.net/neutron/+bug/2118876
14:14:39 <ykarel> - https://bugs.launchpad.net/neutron/+bug/2118893
14:15:12 <ykarel> thx ralonsoh for looking some of these already
14:15:42 <ykarel> - unmaintained/wallaby fullstack failure https://zuul.openstack.org/builds?job_name=neutron-fullstack&project=openstack%2Fneutron&branch=unmaintained%2Fwallaby&skip=0
14:16:19 <ykarel> seen similar failure twice, but in similar fullstack-uwsgi job passed in check pipeline
14:17:10 <ykarel> considering quite old unmaintained release, we may drop these job or switch to uwsgi job if that's stable
14:17:11 <ralonsoh> is wallaby fullstack cannot be fixed in 1 hour, I'll propose to delete this job
14:17:14 <ykarel> wdyt?
14:17:51 <lajoskatona> +1 for removing fullstack on unmaintained if we cant fix it
14:18:01 <ralonsoh> +1 to remove
14:18:18 <bcafarel> I saw similar failure in last victoria backport https://review.opendev.org/c/openstack/neutron/+/955588 (passed after recheck)
14:18:47 <lajoskatona> by the way similar cleanup from elodilles for xena: https://review.opendev.org/c/openstack/neutron/+/955867
14:18:50 <bcafarel> and given unmaintained status/efforts +1 to remove (Wallaby and Victoria most proably)
14:19:03 <ralonsoh> I'm ok with this ^^
14:19:16 <ykarel> thx bcafarel for sharing that, so even -uwsgi is impacted
14:19:29 <ykarel> Ok then let's drop these jobs in victoria/wallaby
14:19:48 <ykarel> i will send these patches
14:20:05 <ykarel> #action ykarel to send patches to drop fullstack jobs in victoria/wallaby as agreed
14:20:19 <ykarel> #topic Grafana
14:20:30 <ykarel> Let's also have quick look on https://grafana.opendev.org/d/f913631585/neutron-failure-rate
14:21:08 <ykarel> all looks normal to me, anything to add here?
14:21:29 <ralonsoh> no, thanks
14:21:57 <lajoskatona> nothing from me
14:22:15 <ykarel> k let's move
14:22:20 <ykarel> #topic On Demand
14:22:31 <ykarel> anything else for CI you would like to raise?
14:24:28 <lajoskatona> no thanks
14:27:03 <ykarel> ack in that case let's close early and have everyone almost half an hour back
14:27:07 <ykarel> #endmeeting