14:01:01 <ykarel> #startmeeting neutron_ci
14:01:01 <opendevmeet> Meeting started Mon Sep  8 14:01:01 2025 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:01 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:01 <opendevmeet> The meeting name has been set to 'neutron_ci'
14:01:07 <ykarel> Ping list: bcafarel, lajoskatona, slawek, mlavalle, mtomaska, ralonsoh, ykarel, jlibosva, elvira
14:01:14 <ralonsoh> hello
14:01:16 <ykarel> It's IRC today
14:01:16 <mtomaska> o/
14:01:37 <haleyb> o/
14:01:58 <mlavalle> \o
14:02:10 <slaweq> o/
14:03:02 <mlavalle> ralonsoh: I've been working with Helen on that patch, so yes, I'll check it
14:03:24 <lajoskatona> o/
14:03:42 <ykarel> Hello everyone, let's start with action items from last week
14:03:45 <ykarel> #topic Actions from previous meetings
14:03:51 <ykarel> ykarel to check if 2121696 still a thing
14:04:07 <ykarel> Not seen again and is closed, it was only see for three days on a specific provider
14:04:20 <ykarel> #topic Stable branches
14:04:27 <ykarel> all good in stable except few intermittent functional failures
14:04:51 <ykarel> and not many patches open in stable for review apart from few FT fixes
14:04:57 <ykarel> #topic Stadium projects
14:05:04 <ykarel> vpnaas, bgpvpn failures
14:05:09 <ykarel> vpnaas https://zuul.openstack.org/build/affce6ee846b4a71ae31ad64f2d90c32
14:05:09 <ykarel> - Looks infra
14:05:14 <ykarel> bgpvpn https://zuul.openstack.org/build/5ca6225fddb444328ea365625b374b09
14:05:14 <ykarel> - broken with https://review.opendev.org/c/openstack/horizon/+/953302
14:05:14 <ykarel> - revert https://review.opendev.org/c/openstack/horizon/+/959909
14:05:27 <ykarel> lajoskatona, anything to add here?
14:06:09 <lajoskatona> yes, wanted to say the same that seems like not project related issue
14:06:27 <lajoskatona> but to be sure I can push wip patch to check
14:07:05 <ykarel> yes i have seen that in another CI job as well so concluded as infra but good to cross check
14:07:40 <lajoskatona> for Horizon, that can be discussed tomorrow on the team meeting but I broke some horizon plugins (manila-ui and fwaas-dashboard) with the last SDK patch, so it happened :-(
14:07:43 <ykarel> so we just need to get that horizon revert merged for stadium
14:08:14 <lajoskatona> yes I have to double check an follow if they need new release or similar
14:08:29 <ykarel> ok thx lajoskatona
14:08:47 <ykarel> #topic Rechecks
14:09:15 <ykarel> not much activity this week, and just 1/8 bare recheck, 1 in neutron-fwaas-dashboard impacted by the above horizon patch
14:09:32 <ykarel> let's check failures now
14:09:33 <ykarel> #topic fullstack/functional
14:09:37 <ykarel> test_create_bridges
14:09:41 <ykarel> https://8efeb3f9a97b47933ce3-5a97607e4573b334b582a5ecc4c19d48.ssl.cf1.rackcdn.com/openstack/e3d86eaf98fb4495b01df2cf0a5e4697/testr_results.html
14:09:46 <ykarel> cherry picks https://review.opendev.org/q/I36a32c7b6eb44aa2ac315b1e51d54ee662c1d189 and https://review.opendev.org/q/I2bcf6c264dcec4ceaadebf14dbd20cd13750e20f
14:09:52 <ykarel> test_ha_router_failover_graceful
14:09:58 <ykarel> https://3c7bfb46267d4ec2bf72-eb074e4d266b226b76de64a5b482d977.ssl.cf5.rackcdn.com/openstack/45297d9ea840494c922ba0a14f1da899/testr_results.html
14:10:07 <ykarel> cherry picks https://review.opendev.org/q/I4555ed821865db724c4e5fc502648fe71d5febea
14:10:13 <ykarel> test_fip_connection_for_address_scope
14:10:22 <ykarel> cherry picks https://review.opendev.org/q/Idff5aa32df45592992312347ad2eaa424391909a
14:10:30 <ykarel> test_subport_delete
14:10:37 <ykarel> https://3961ade18a9532d30a37-449df4e845769ef2b91c503daa7699ef.ssl.cf2.rackcdn.com/openstack/12bb4b13cbb6423aa9a8939be1cd0b78/testr_results.html
14:10:48 <ykarel> Looks same as Known issue https://bugs.launchpad.net/neutron/+bug/2117405
14:11:17 <ralonsoh> but even with https://review.opendev.org/c/openstack/neutron/+/956336 is failing?
14:11:28 <ykarel> yes
14:11:39 <ralonsoh> from what patch is this ^^ result?
14:11:58 <ykarel> periodic pipeilne
14:12:11 <ykarel> from 3rd sept
14:13:15 <ykarel> reopened that bug
14:14:08 <ralonsoh> ok, I'll check it
14:14:18 <ykarel> thx ralonsoh will add it to action items
14:14:33 <ykarel> #action ralonsoh to check https://bugs.launchpad.net/neutron/+bug/2117405
14:14:38 <ykarel> test_initialize_network_segment_range_support_parallel_execution
14:14:53 <ykarel> https://441c51878568ace86c8b-5c978d7497c891806a9511dfe6eee904.ssl.cf5.rackcdn.com/openstack/18b4b3d447d54a6e815260f656b845af/testr_results.html
14:15:00 <ralonsoh> ^ I'm working on this
14:15:05 <ykarel> we have seen that in past
14:15:21 <ralonsoh> there is a WA and a proper fix (but for 2026.1) with a DB migration
14:15:38 <ykarel> https://bugs.launchpad.net/neutron/+bug/2122107
14:15:52 <ralonsoh> yes
14:15:58 <ykarel> wanted to confirm as that mentioned eventlet patch failures
14:15:58 <ralonsoh> the quick fix: https://review.opendev.org/c/openstack/neutron/+/960006
14:16:20 <ykarel> ok thx
14:16:21 <ralonsoh> yes, this is mainly happening in the eventle-removal patch for UT/FTs
14:16:53 <ykarel> ok
14:17:07 <ykarel> #topic Tempest/Scenario
14:17:15 <ykarel> test_create_list_show_delete_interfaces_by_fixed_ip
14:17:20 <ykarel> https://7c5a6878b54b82b3118b-c97ff25e28cfcd419d5c31c30ea913eb.ssl.cf2.rackcdn.com/openstack/7671d49738ea4fc1a351681e29a20899/testr_results.html
14:17:27 <ykarel> https://bd83a0d8d3e96efcf262-e998c5625939f617052baaae6f827bb8.ssl.cf1.rackcdn.com/openstack/2a73892aee234029841d8fe3bf789f32/testr_results.html
14:17:42 <ykarel> Seeing similar failures post pyroute2 bump 0.9.4 last week
14:17:52 <ykarel> reopened https://bugs.launchpad.net/os-vif/+bug/2109396
14:18:10 <ykarel> gibi also discussion this on #openstack-release
14:18:51 <ykarel> periodic ones all good apart from what already discussed
14:18:58 <ykarel> #topic Grafana
14:19:11 <ykarel> https://grafana.opendev.org/d/f913631585/neutron-failure-rate?orgId=1&from=now-7d&to=now&timezone=utc
14:19:16 <ykarel> let's have quick look here as well
14:21:12 <ykarel> there some spikes on 4th sept, that time had some infra related failures
14:22:55 <ykarel> apart from that looks fine, check failures looks mostly patch specific
14:22:59 <ykarel> anything to add here?
14:23:54 <lajoskatona> nothing from me
14:23:59 <ykarel> ok let's move to last then
14:24:01 <ykarel> #topic On Demand
14:24:04 <mlavalle> not from me
14:24:11 <ykarel> anything else you would like to raise for CI?
14:24:26 <ralonsoh> no thanks
14:24:39 <lajoskatona> no thanks
14:26:11 <ykarel> ok thx, in that case let's close early and have everyone almost half an hour back
14:26:14 <ykarel> thx everyone for joining
14:26:17 <ykarel> #endmeeting