15:30:42 <mestery> #startmeeting neutron-drivers
15:30:43 <openstack> Meeting started Wed Jun 10 15:30:42 2015 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:47 <openstack> The meeting name has been set to 'neutron_drivers'
15:30:56 <mestery> #link https://wiki.openstack.org/wiki/Meetings/NeutronDrivers Agenda
15:31:03 <mestery> #topic Action Item Review
15:31:15 <mestery> I had an action item to sort out Lt. vs. drivers. I'm still working on it :)
15:31:19 <mestery> I'll take that for next week too
15:31:27 <mestery> #action mestery to sort out neutron-drivers vs. Lts. and the path forward
15:31:43 <mestery> HenryG: You had an item to bring up bug 1460720 in an L3 meeting and discuss with carl_baldwin, did that happen by chance?
15:31:46 <openstack> bug 1460720 in neutron "Add API to set ipv6 gateway" [Undecided,New] https://launchpad.net/bugs/1460720 - Assigned to Abishek Subramanian (absubram)
15:33:34 <carl_baldwin> mestery: It didn’t happen.
15:33:40 <mestery> carl_baldwin: :)
15:33:45 <mestery> carl_baldwin: OK, lets hope it does this week then.
15:33:58 <carl_baldwin> I’ll keep it on the agenda.
15:34:01 <mestery> #action HenryG to make sure Bug 1460720 is discussed during an upcoming L3 meeting with carl_baldwin and team
15:34:02 <openstack> bug 1460720 in neutron "Add API to set ipv6 gateway" [Undecided,New] https://launchpad.net/bugs/1460720 - Assigned to Abishek Subramanian (absubram)
15:34:05 <HenryG> Yeah, sorry abotu that. Will try again.
15:34:10 <mestery> HenryG: No worries :)
15:34:25 <mestery> #topic Specific Spec Review
15:34:33 <mestery> Lets see about this.
15:34:34 <mestery> I spent an hour going through specs this morning.
15:34:36 <mestery> Yikes.
15:34:40 <mestery> There is a LOT there.
15:34:45 <mestery> I only made it through maybe 15-20 specs.
15:34:56 <mestery> Lets start with some specs from carl_baldwin :)
15:35:04 <mestery> #link https://review.openstack.org/#/c/172244/ Routing Networks
15:35:13 <mestery> This one is important because it satisfies the network segment RFE as well
15:35:18 <mestery> And operators really want that solved
15:35:24 <mestery> carl_baldwin: Thansk for the re-spin on this one!
15:35:48 <carl_baldwin> mestery: I’m not sure it gets the whole network segment rfe but it gets much closer.
15:36:03 <carl_baldwin> I hesitate to promise to deliver both
15:36:16 <mestery> carl_baldwin: If it moves us in that direction it's a win-win I think
15:36:26 <carl_baldwin> But, they have the ability to map to network segments which both can use.
15:36:50 <mestery> I'd like to highlight that one for other drivers (amotoki dougwig marun) to review this week.
15:36:57 <mestery> carl_baldwin: ++
15:37:11 <amotoki> mestery: sure
15:37:17 <mestery> Continuing on our "carl_baldwin spec review path" :)
15:37:20 <mestery> #link https://review.openstack.org/#/c/16961 Address Scopes
15:37:25 <mestery> kevinbenton had some comments on this one carl_baldwin
15:37:39 <dougwig> i think address scopes is ready, minus the name being non-intuitive.
15:37:48 <mestery> dougwig: ++
15:37:52 <carl_baldwin> mestery: Still going through those comments.  I was distracted by something else yesterday.
15:38:09 <mestery> carl_baldwin: Not a problem, I think once you address kevinbenton's comments dougwig and I can merge it and you can get rolling
15:38:25 <carl_baldwin> dougwig: Any better suggestions yet?
15:38:51 <dougwig> no, i keep thinking of the royal Network (used) or NetworkGroup (not any more intuitive.)
15:38:54 <marun> link looks wrong
15:39:12 <mestery> #undo
15:39:13 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x9a23150>
15:39:15 <mestery> #link https://review.openstack.org/180267 Address Scopes
15:39:18 <mestery> marun: there it is
15:39:23 <marun> danke
15:39:26 <mestery> :)
15:39:34 <mestery> marun: I am here to serve ;)
15:40:59 <mestery> Next up on the highlight list (and not a carl_baldwin spec):
15:41:04 <mestery> #link https://review.openstack.org/#/c/94612/ VLAN Aware VMs
15:41:26 <mestery> I see russellb provided some recent comments on this one
15:41:31 * carl_baldwin could’ve written that one.
15:41:35 <mestery> rofl
15:42:33 <mestery> Does anyone have objections to the main tenant of htis spec: the idea of subports
15:43:16 <dougwig> did this spec get updated with the sort of consensus from the summit?
15:43:17 <amotoki> I have a bit different view on this. we can use the similar model for vlan aware VMs as L2GW if l2gw takes a logical port as a member.
15:43:40 <amotoki> but it is just my thought at the moment.
15:43:57 <amotoki> am looking through the spec now.
15:44:26 <mestery> amotoki: Interesting thought
15:44:33 <mestery> dougwig: That's also unclear to me
15:44:47 <dougwig> i'll take a look.
15:44:51 <dougwig> too
15:45:19 <mestery> thanks dougwig
15:45:33 <mestery> #link https://review.openstack.org/#/c/169612 Availability Zones
15:46:02 <mestery> This one needs a little work yet, but seems like something worth pursuring
15:46:56 <mestery> The current implementation patch is here:
15:47:03 <mestery> #link https://review.openstack.org/#/c/183369 Availability Zones Implementation
15:47:04 <mestery> It's not that huge
15:47:47 <mestery> And finally
15:47:51 <mestery> #link https://review.openstack.org/#/c/184857/ Get Me a Network
15:47:56 <amotoki> there are many/several use cases for AZ. The proposed spec has a limited scope, but we tend to see more by "AZ".
15:48:13 <mestery> amotoki: Agreed on both fronts
15:48:51 <dougwig> is get me a network ready for review, or does it still need someone to own it?
15:49:25 <mestery> dougwig: It still needs an owner, from the meeting Monday I thought someone had volunteered
15:49:27 <mestery> Let me look at the log
15:50:21 <mestery> dougwig: armax had volunteered in the meeting I see
15:51:02 <amotoki> in the spec review, mark, zzelle and vikram volunteered for contributing.
15:51:04 <mestery> I'll keep on that and ensure we do find an owner.
15:51:07 <mestery> #action mestery to find owner for "Get Me a Network" spec
15:51:18 <mestery> amotoki: Yes! We need an explicit owner however :)
15:51:37 <amotoki> mestery: exactly :)
15:51:43 <mestery> OK, anyone want to bringup another spec?
15:51:46 * mestery waits for 60 seconds
15:52:14 <dougwig> one.
15:53:08 <mestery> dougwig: which one?
15:53:09 <dougwig> lib split spec.  since it's now in-tree, and going to evolve, and the spec has objections that they want to see more of what it's going to be, would that make more sense to do with the new process?  document the use cases, and then show the files in the first commit/devref doc?
15:53:33 <dougwig> i think it's probably the same work to work up the first lib patch than to rewrite that spec.
15:53:45 <mestery> dougwig: I'm torn on this one. It's a lib-split, so I can see moving forward with the spec as-is, but devref doc may make sense too. I'd lean towards the latter rather than the former.
15:54:03 <mestery> dougwig: Abandon and move on to a patch then?
15:54:06 <dougwig> how about i vastly trim the spec, and move half into devref?
15:54:11 <mestery> ++
15:54:28 <dougwig> i'll get a re-spin today.
15:55:24 <mestery> thanks
15:55:43 <marun> ++
15:56:14 <mestery> OK moving along
15:56:42 <mestery> I suggest we do RFE reviews offline unless anyone wants to discuss a specific one here. Thoughts?
15:57:35 <dougwig> i assume most of them are non-contentious, e.g., this group doesn't want to see lbaas RFE's, so that's fine by me.
15:57:48 <mestery> ++
15:57:51 <mestery> Done!
15:57:51 <dougwig> i do need a quick primer on what states/milestones you want things put into when they're approved, though.
15:58:04 <mestery> dougwig: Don't do that, the new release process maps them after they merge
15:58:08 <mestery> Lazy releases
15:58:12 <mestery> I mean, you can map them if you want, but don't have to
15:58:15 <dougwig> right, but they have to go from NEW -> ?
15:58:18 <mestery> Ah
15:58:23 <mestery> Ping me and I'll take care of that for you
15:58:50 <mestery> OK, thanks folks!
15:58:52 <mestery> #endmeeting