15:30:22 <mestery> #startmeeting neutron-drivers
15:30:23 <openstack> Meeting started Wed Jul 1 15:30:22 2015 UTC and is due to finish in 60 minutes. The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:26 <openstack> The meeting name has been set to 'neutron_drivers'
15:30:27 <mestery> dougwig is here
15:30:39 <mestery> amotoki carl_baldwin kevinbenton: Yo!
15:30:44 * mestery pokes armax as well if he wants to listen in
15:30:46 * carl_baldwin here
15:30:57 <mestery> #link https://wiki.openstack.org/wiki/Meetings/NeutronDrivers Agenda
15:31:12 <mestery> Lets see if we can keep this short, all in favor of that?
15:31:16 <mestery> #topic Specific Specs
15:31:16 <dougwig> second
15:31:28 <mestery> #link https://review.openstack.org/196803 Really Get Me a Network
15:31:39 <mestery> So, it turns out we didn't satisfy jay and monty's requests
15:31:43 <mestery> Thus, I think we need this one
15:31:53 <mestery> And we need to do the backend-API work to really create or use existing resources
15:31:59 * mestery lets folks digest this
15:33:03 * carl_baldwin needs to read
15:33:09 <mestery> :)
15:33:34 <mestery> #action neutron-drivers to review "Really Get Me a Network" update
15:33:41 <mestery> Next up
15:33:47 <mestery> #link https://review.openstack.org/#/c/196812/ Segmented, L3-only networks
15:33:54 <mestery> carl_baldwin: This is your spec, and the meat of our meeting today :)
15:33:59 <mestery> I should say, devref, not spec
15:34:06 <dougwig> that spec really comes down to the ages old neutron/nova-net issue of do we keep trying to tell people what they *really* want (get me a network)
15:34:25 <carl_baldwin> Yes, I thought I’d start small and get consensus there before adding to it.
15:34:40 <mestery> dougwig: Yup
15:34:43 <mestery> carl_baldwin: Makes sense to me
15:35:25 <mestery> carl_baldwin: I like the idea of starting small here, and I like the idea of L3-only networks
15:36:12 <carl_baldwin> I see there are comments from kevinbenton that I need to digest
15:36:20 <mestery> carl_baldwin: Also regXboi :)
15:36:55 <carl_baldwin> Most of kevinbenton ’s comment look fine. Will go read the comment from regXboi again.
15:36:59 <mestery> #action neutron-drivers to review "Segmented, L3-only networks"
15:37:01 <mestery> thanks carl_baldwin
15:37:18 <mestery> #topic Open Discussion
15:37:28 <mestery> #action mestery to move this meeting to a time when kevinbenton can attend and when everyone else is awake
15:37:39 <mestery> Promise to do it next week
15:37:48 <mestery> Anything else or should we go back heads down? ;)
15:38:59 * carl_baldwin has nothing more
15:39:23 <dougwig> are there any new RFE's to sort through?
15:39:57 <mestery> dougwig: Looking
15:40:14 <mestery> https://bugs.launchpad.net/neutron/+bug/1370033
15:40:14 <openstack> Launchpad bug 1370033 in neutron "Admin should be able to manually select the active instance of a HA router" [Medium,New] - Assigned to yong sheng gong (gongysh)
15:41:13 <mestery> I think a slim spec to document the API change for that one should be ok
15:41:17 <mestery> I've commented in the bug itself.
15:42:21 <mestery> https://bugs.launchpad.net/neutron/+bug/1468803
15:42:21 <openstack> Launchpad bug 1468803 in neutron "Modular L2 Agent" [Undecided,New]
15:43:13 <dougwig> i'm not sure i need to see a spec on 033.
15:43:33 <mestery> Because the API change is so small?
15:43:41 <dougwig> 803 likely needs to be encouraged to start at spec/devref, to build consensus if nothing else.
15:43:54 <mestery> dougwig: Comment in there for 803
15:43:56 <mestery> https://bugs.launchpad.net/neutron/+bug/1468493
15:43:56 <openstack> Launchpad bug 1468493 in neutron "Unify Open vSwitch and Linux Bridge agent configuration file sections/options" [Undecided,New]
15:43:56 <dougwig> aye. it's not a huge loss if the code review doesn't work on that api change.
15:44:29 <mestery> 493 LGTM
15:44:31 <mestery> https://bugs.launchpad.net/neutron/+bug/1468236
15:44:31 <openstack> Launchpad bug 1468236 in neutron "enable neutron support distributed DHCP agents" [Undecided,New]
15:44:34 <dougwig> can we broaden 493 to be "why do we have 93,467 config files for neutron? have you people never heard of [sections]?"
15:44:45 <dougwig> :)
15:45:22 <mestery> Seems like a separte spec
15:45:24 <mestery> *separate
15:45:33 <mestery> 236 seems reasonable as well
15:45:48 <mestery> Our first contentious one: https://bugs.launchpad.net/neutron/+bug/1468366
15:45:48 <openstack> Launchpad bug 1468366 in neutron "RFE - Packet logging API for Neutron" [Undecided,New] - Assigned to Yushiro FURUKAWA (y-furukawa-2)
15:47:06 <mestery> https://bugs.launchpad.net/neutron/+bug/1469322
15:47:06 <openstack> Launchpad bug 1469322 in neutron "Associating a floatingip with a dual stack port requires the fixed-address to be specified" [Undecided,New]
15:47:37 <dougwig> i'm not sure packet tracing should go through syslog...
15:48:07 <carl_baldwin> +1
15:48:10 <mestery> agreed
15:48:11 <mestery> 322 seems like a no brainer
15:48:13 <mestery> lets get it in
15:48:46 <mestery> And finally: https://bugs.launchpad.net/neutron/+bug/1469668
15:48:46 <openstack> Launchpad bug 1469668 in neutron "Add a neutron port-scheduler component" [Undecided,New] - Assigned to Kevin Benton (kevinbenton)
15:48:46 <carl_baldwin> +1
15:49:41 <mestery> I've marked all of them confirmed at this point since we've at least acknowledged them.
15:49:55 <dougwig> i trust kevin to run with 668
15:49:57 <mestery> Please review them and if you want to approve them, move them to triaged and leave a comment
15:50:10 <mestery> dougwig: Move it to triaged then and note he can move forward
15:50:18 <dougwig> mestery: ok
15:50:24 <mestery> dougwig: Also give it a priority, maybe high?
15:50:41 <mestery> OK, anything else before we close?
15:50:43 <haleyb> mestery: sorry for being late, but i did have more comments on "really get me a network", will just add them to the comments
15:50:51 <mestery> haleyb: Thanks sir!
15:52:00 <mestery> OK, thanks folks!
15:52:01 <mestery> #endmeeting