15:00:48 <mestery> #startmeeting neutron-drivers
15:00:49 <openstack> Meeting started Tue Aug  4 15:00:48 2015 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:53 <openstack> The meeting name has been set to 'neutron_drivers'
15:00:57 <dougwig> my doc ordered me off red bull, so we'll see how much patience i have.
15:01:27 <mestery> lol
15:01:32 <mestery> #link https://wiki.openstack.org/wiki/Meetings/NeutronDrivers#Agenda Agenda
15:01:36 <mestery> So, since it's just me and you dougwig ...
15:01:46 <mestery> #topic Liberty-3 Review Backlog and Apocalypse
15:01:51 <mestery> This is all I had this week
15:02:04 <mestery> Because honestly, at this point, accepting new RFEs isn't high on my list
15:02:05 <mestery> :)
15:02:17 <dougwig> how bad is the backlog? i haven't looked since getting back from vacation.  i didn't want to ruin my mellow.
15:02:24 <mestery> yeah, it's bad
15:02:29 * mestery #link https://launchpad.net/neutron/+milestone/liberty-3
15:02:40 <mestery> 28 blueprints
15:02:46 <mestery> #info 28 blueprints left to merge in Liberty
15:03:19 <mestery> So, I guess we just need to focus and review.
15:03:22 <dougwig> ok, well, that'll never hapen.
15:03:35 <mestery> #info Plan is to fold QoS back into mast week of 8/10
15:03:40 <dougwig> do we have a list of what we really want to make it, or what's far enough along?
15:03:45 <mestery> #info Plan is to fold pecan back into master week of 8/17
15:03:52 <mestery> Go with priority there
15:03:55 <dougwig> ok
15:04:13 <mestery> So
15:04:14 <mestery> question dougwig
15:04:16 <mestery> Octacvia
15:04:19 <mestery> How is it coming?
15:04:21 <mestery> Is it ready to be default?
15:04:26 * carl_baldwin wanders in
15:04:27 <dougwig> i will have an answer for you later today.
15:04:31 <mestery> carl_baldwin: Hey man! :)
15:04:35 <mestery> OK
15:04:43 <dougwig> i suspect that it's not quite there for liberty, but let me circle with folks and come back.
15:04:48 <mestery> #action dougwig to get a readout on Octavia and go/no-go for Liberty
15:04:59 <mestery> carl_baldwin: We're discussing Liberty-3 items: https://launchpad.net/neutron/+milestone/liberty-3
15:05:07 <mestery> Because that's all we should be focusing on now, there is a lot to merge yet
15:05:28 <carl_baldwin> mestery: ack
15:06:15 <mestery> dougwig: https://blueprints.launchpad.net/neutron/+spec/neutron-lib
15:06:17 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/neutron-lib
15:06:21 <mestery> What's the status of that one?
15:06:23 <mestery> It's critical :)
15:06:40 <dougwig> the status is that i'm a terrible person.  safe to kick to M?
15:06:53 <mestery> lol
15:07:00 <mestery> I think we may have to, I'll let you decide :)
15:07:28 <mestery> I need your opinions on this one carl_baldwin and dougwig
15:07:29 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/reference-implementation-split
15:07:31 <dougwig> i will likely get the first commit into gerrit before M, but I don't think it's reasonable for to expect it to land or to do a big churn right at the end.
15:07:36 <mestery> Shall we try to do this post Liberty-3? That is the best option now.
15:07:44 <mestery> dougwig: Sounds fair
15:07:51 <mestery> Unless we do it during the freeze along with mine
15:08:30 <dougwig> doing the ref split during the freeze would not leave the packagers much time to react.
15:08:46 <mestery> That's true, but doing it before that will kill anything which wants to merge into the things being split
15:08:46 <carl_baldwin> +1
15:08:50 <mestery> So, not sure how to proceed
15:08:54 <mestery> Early Mitaka?
15:09:00 <dougwig> i think it's early M.
15:09:12 <mestery> Yeah, sadly, me too :(
15:09:13 <carl_baldwin> agree
15:09:14 <mestery> Nuts
15:09:25 * carl_baldwin feels the pain
15:09:29 <mestery> #info Move neutron-lib and reference-split into Mitaka :(
15:09:31 <mestery> OK, I'll move those
15:09:34 <dougwig> so then you're a terrible person too.  :)
15:09:42 <mestery> Every. Single. Day.
15:10:21 <mestery> OK
15:10:27 <mestery> Any other high priority ones?
15:10:33 <mestery> carl_baldwin: What about the DNS work mlavelle is doing?
15:10:36 <mestery> Will those make Liberty?
15:10:59 <carl_baldwin> mestery: I’ve reviewed an early implementation and heard reports of good progress while I was out.  Planning to review today.
15:11:10 <carl_baldwin> I think there is a good chance.
15:11:29 <mestery> Ack
15:11:30 <mestery> OK
15:11:31 <mestery> cool!
15:11:56 <HenryG> carl_baldwin: do you think we can get ipv6 PD in too?
15:12:19 <carl_baldwin> HenryG: I’ve been sadly absent for a couple of weeks.  Have you reviewed them lately?
15:12:36 <carl_baldwin> HenryG: I was trying to prioritize them before I left on leave.
15:12:38 <HenryG> carl_baldwin: yes, the first patch is ready IMO
15:13:15 <mestery> HenryG: Thanks for keeping an eye on that :)
15:13:21 <carl_baldwin> HenryG: I will add that to my list today.
15:13:21 <haleyb> HenryG: this one?  https://review.openstack.org/#/c/158697/
15:13:40 <HenryG> haleyb: yes
15:14:01 <mestery> haleyb: Is there a LP BP for your "Get Me a Network" thing? http://specs.openstack.org/openstack/neutron-specs/specs/liberty/get-me-a-network.html
15:14:12 <mestery> haleyb: If not, can you create one? I'd like to track that as Critical as well.
15:14:13 <mestery> :)
15:14:15 <mestery> No pressure
15:14:18 <mestery> Or anything ;)
15:14:28 * haleyb wishes he was still on vacation :)
15:14:46 <haleyb> i'll create a blueprint
15:15:29 <mestery> lol
15:15:31 <mestery> thanks haleyb!
15:15:38 <mestery> #action haleyb to create LP BP for "Get Me a Network"
15:16:02 <mestery> carl_baldwin: One other question for you: Any idea how the "DVR + L3 HA" work is coming along?
15:16:22 <carl_baldwin> mestery: Sadly I’m not up to date on that one either.
15:16:45 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1365473
15:16:45 <uvirtbot> Launchpad bug 1365473 in neutron "Unable to create a router that's both HA and distributed" [High,In progress]
15:16:46 <openstack> Launchpad bug 1365473 in neutron "Unable to create a router that's both HA and distributed" [High,In progress] - Assigned to Adolfo Duarte (adolfo-duarte)
15:16:47 <uvirtbot> Launchpad bug 1365473 in neutron "Unable to create a router that's both HA and distributed" [High,In progress] https://launchpad.net/bugs/1365473
15:16:48 <mestery> carl_baldwin: No worries, we'll figure it out :)
15:17:28 <haleyb> mestery: was the routed networks BP approved last week?  i see a couple reviews up for it but nothing in the minutes
15:17:47 <haleyb> https://bugs.launchpad.net/neutron/+bug/1472704
15:17:47 <openstack> Launchpad bug 1472704 in neutron "Support networks that work through routing instead of bridging" [Undecided,In progress] - Assigned to Neil Jerram (neil-jerram)
15:17:47 <carl_baldwin> haleyb: It is back on the drawing board.
15:17:48 <mestery> haleyb: It most definitely should not have been, can you find the link?
15:17:49 <uvirtbot> Launchpad bug 1472704 in neutron "Support networks that work through routing instead of bridging" [Undecided,In progress]
15:17:50 <uvirtbot> Launchpad bug 1472704 in neutron "Support networks that work through routing instead of bridging" [Undecided,In progress] https://launchpad.net/bugs/1472704
15:18:05 <mestery> See comment #3 there
15:18:11 <carl_baldwin> haleyb: Oh, that is different than what I was thinking.
15:18:44 <carl_baldwin> But, I think that one’s fate is somewhat tied to the fate of the network segments one.
15:18:48 <mestery> Yes
15:18:51 <mestery> carl_baldwin: +1000.5
15:19:22 <carl_baldwin> mestery: Just round up, I can’t do decimals in that context.  ;)
15:19:27 <mestery> rofl
15:19:41 <mestery> carl_baldwin: You and I are going to talk network segments later today and try to resolve that to see what can be done in Liberty yet
15:19:44 <mestery> I remain hopeful
15:19:46 <mestery> But realistic too :)
15:20:14 <haleyb> it was in reference to https://review.openstack.org/#/c/206079/
15:20:17 <carl_baldwin> mestery: You’re more optimistic than I am (or less informed maybe).  I’m hoping for M.
15:20:29 <mestery> rofl
15:20:35 <mestery> carl_baldwin: Yeah, that's likely, but even some groundwork going into Liberty may be positive.
15:20:43 <mestery> I'm ever vigilant carl_baldwin :D
15:20:50 * mestery pokes dougwig and hands him a red bull
15:21:04 <carl_baldwin> mestery: Agreed.  Work has not stopped but it is back to the drawing board to see if there is a better way.
15:21:14 <mestery> carl_baldwin: Excellent!
15:21:19 <mestery> #topic Open Discussion
15:21:29 <mestery> Anything else this week or should I give you all 39 minutes back?
15:21:29 <mestery> :)
15:22:30 <carl_baldwin> I was asked to inquire about https://bugs.launchpad.net/neutron/+bug/1468366
15:22:30 <openstack> Launchpad bug 1468366 in neutron "RFE - Packet logging API for Neutron" [Undecided,Confirmed] - Assigned to Yushiro FURUKAWA (y-furukawa-2)
15:22:30 <uvirtbot> Launchpad bug 1468366 in neutron "RFE - Packet logging API for Neutron" [Undecided,Confirmed]
15:22:32 <uvirtbot> Launchpad bug 1468366 in neutron "RFE - Packet logging API for Neutron" [Undecided,Confirmed] https://launchpad.net/bugs/1468366
15:22:47 <mestery> carl_baldwin: HenryG had a good point on that one, it's not clear that one belongs in Neutron itself
15:23:12 <carl_baldwin> mestery: I missed that from HenryG
15:23:18 <mestery> carl_baldwin: It was just this morning :)
15:23:42 <carl_baldwin> I don’t feel so bad then.
15:23:59 <mestery> :)
15:24:13 <mestery> OK, thanks for attending and lets focus on reviews! We don't have much time left :)
15:24:16 <carl_baldwin> Between mestery and HenryG, could the rfe bug be updated with this?
15:24:17 <mestery> So lets see what else we can land now :)
15:24:29 <mestery> carl_baldwin: Yes, I'll do that.
15:24:38 <carl_baldwin> Thanks!
15:25:17 <mestery> OK, thanks folks!
15:25:19 <mestery> #endmeeting