15:04:09 <armax> #startmeeting neutron-drivers
15:04:10 <openstack> Meeting started Tue Oct  6 15:04:09 2015 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:14 <openstack> The meeting name has been set to 'neutron_drivers'
15:04:41 <kevinbenton> #startvote what's for lunch
15:04:41 <openstack> Only the meeting chair may start a vote.
15:04:54 * mestery waves
15:05:10 <dougwig> O/
15:05:14 <amotoki> hi
15:05:16 <kevinbenton> dougwig, armax: it can be short
15:05:24 <kevinbenton> i think we just had more rfe's from last week to look at
15:05:36 <kevinbenton> but we can defer if everyone is wiped out from that intense neutron meeting...
15:05:40 <armax> sounds good
15:06:02 <armax> kevinbenton: what intense neutron meeting?
15:06:14 <kevinbenton> the one right before this one
15:06:29 <armax> #link v
15:06:31 <armax> #undo
15:06:32 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x98141d0>
15:06:36 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=rfe
15:07:02 * carl_baldwin was just going ask what url shortener armax uses
15:07:06 <armax> is anyone of you guys thinking that this rfe process is working?
15:07:52 <armax> I can see that’s easier for some people to submit ideas
15:07:55 <armax> so that’s a positive
15:07:58 <armax> effect
15:08:07 <amotoki> It is a bit difficult to track the status of each bugs. someone proposes a patch before we discuss it.
15:08:20 <carl_baldwin> It helped for the routed networks request from operators.
15:08:21 <HenryG> I think it's a little hard to track sometimes when multiple patches apply
15:08:49 <dougwig> i'm on record as preferring -specs, simply because the tooling is more queue oriented. i think the non-dev community prefers the rfe's.
15:09:14 <carl_baldwin> There are deficiencies around the tooling.  Launchpad isn’t quite geared for it.
15:09:16 <kevinbenton> maybe we should just not allow patches to directly reference an RFE?
15:09:44 <amotoki> it lowers the hurdle to request features. it is a good point of RFE.
15:09:49 <amotoki> kevinbenton: +1
15:10:17 <kevinbenton> right, we need a way to allow features requests to be submitted but block the normal bug processes...
15:10:22 <carl_baldwin> kevinbenton: I don’t have an opinion either way.  Just wondering what that solves and what the alternative is.
15:10:30 <HenryG> "Promote" an RFE to a blueprint when it is accepted?
15:10:52 <kevinbenton> or maybe just have RFEs be filed as blueprints to begin with?
15:11:05 <armax> I think the process has some benefits
15:11:47 <armax> but I would like to split the phases where we are asked to provide feedback
15:11:54 <armax> and the phase where the actual work happens
15:12:13 <armax> I don’t want RFE bugs linger for ever
15:13:01 <armax> so maybe once the drivers team ‘approves’/gives a thumb up we change the tag?
15:13:07 <armax> from rfe to rfe-approved?
15:13:09 <armax> and move on?
15:13:20 <armax> so that this list shrinks https://bugs.launchpad.net/neutron/+bugs?field.tag=rfe
15:13:33 <armax> if we are doing a good job at vetting stuff?
15:13:35 <carl_baldwin> +1 to a shrinking list.
15:13:43 <armax> if people don’t pull their weight together
15:13:46 <armax> there’s nothing we can do
15:14:09 <kevinbenton> yeah, tag change sounds nice
15:14:10 <armax> and I don’t want to look to have bugs I have already seen littering my dashboard
15:14:21 <kevinbenton> that way people messing with the status don't interfere
15:14:46 <armax> so if you guys think it’s a good idea
15:14:49 <HenryG> +1 to tag change, good idea
15:14:55 <amotoki> +1 for changing tags
15:14:59 <armax> and since I am gonna have to make another policy change :)
15:15:00 <carl_baldwin> +1
15:15:04 <armax> mestery: ^
15:15:37 <armax> and go over the bug list to tag those that we have already ‘blessed'
15:15:48 <armax> so that we keep our sanity over time
15:16:12 <kevinbenton> +!
15:16:55 <dougwig> i like it, the status kludge is messy.
15:17:06 <armax> hopefully this has no impact to users filing these RFE's
15:17:14 <armax> so it’s not like we’re going backwards
15:17:19 <kevinbenton> dougwig: the fact that you had to invent a decoder ring probably should have been a red flag :)
15:17:28 * mestery catches up
15:17:29 <armax> we’re making a positive iterative improvement
15:17:51 <mestery> armax: I like that idea
15:18:00 <armax> ok, I’ll do that right after this meeting
15:18:05 <armax> put a patch up for you to review
15:18:17 <mestery> armax: Good idea, it's a cleaner method, as dougwig said, the status kludge was messy
15:18:41 <armax> so do we want to call it ‘a day’ and wait for a cleaned list of bugs to talk about?
15:18:43 <armax> hint hint
15:18:59 * carl_baldwin okay with that
15:19:18 <armax> unless there’s something pressing I think we should discuss
15:19:24 <HenryG> I would like to know about my rfe ...
15:19:31 <armax> what about it?
15:19:32 <kevinbenton> HenryG: which one?
15:19:32 <amotoki> one question: how do we handle RFE for neutron subprojects? when it was submitted it was a reasonable RFE but now we have a separate project.
15:19:38 <HenryG> https://bugs.launchpad.net/neutron/+bug/1501380
15:19:38 <openstack> Launchpad bug 1501380 in neutron "Evolution of options and features in neutron-db-manage" [Medium,Confirmed]
15:19:52 <amotoki> HenryG: go ahead first
15:20:07 <HenryG> Is that the wrong way to abuse an rfe?
15:20:12 <armax> amotoki: if the RFE affects the Neutron sides of thing then we should keep it tracked in Neutron
15:20:22 <HenryG> Should I file individual bugs?
15:20:25 <armax> HenryG: probably
15:20:42 <armax> amotoki: otherwise no
15:20:59 <amotoki> armax: one example is https://bugs.launchpad.net/neutron/+bug/1450617
15:20:59 <openstack> Launchpad bug 1450617 in neutron "Neutron extension to support service chaining" [Undecided,Triaged] - Assigned to cathy Hong Zhang (cathy-h-zhang)
15:21:08 <armax> HenryG: it sounds to me that what you want to do is sensible no matter what
15:21:17 <armax> HenryG: so you shouldn’t seek the oversight of the drivers team
15:21:24 <armax> but the core team would do
15:21:34 <armax> amotoki: me looks
15:21:42 <HenryG> armax: OK, will do separate bugs instead. Thanks
15:21:48 <armax> amotoki: ok, I’ll clean that one up
15:22:05 <armax> amotoki: that was clearly filed when the subproject didn’t even exist
15:22:19 <armax> that’s stuff that’s lingering and needs to be cleaned
15:22:22 <armax> anything else?
15:22:32 <vikram_> amotoki: +1
15:22:32 <mestery> nothing from me
15:22:54 <amotoki> armax: yes. I wonder how we handle it: which status is best: Invalid, Won't fix????
15:23:34 <armax> amotoki: we can target the networking-sfct launchpad project
15:23:37 <armax> and remove it from neutron
15:23:46 <amotoki> ah.... good idea!
15:23:58 <amotoki> I totally forgot this option.
15:24:17 <armax> yup
15:24:33 <dougwig> motion to adjourn?
15:24:40 <armax> adjuourn
15:24:47 <mestery> ++
15:24:51 <amotoki> ++
15:24:58 <armax> #action I’ll polish the RFE bugs up too
15:25:00 <armax> bear with me
15:25:21 <armax> #endmeeting