15:02:58 <haleyb> #startmeeting neutron_dvr
15:02:59 <openstack> Meeting started Wed Mar 23 15:02:58 2016 UTC and is due to finish in 60 minutes.  The chair is haleyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:03 <openstack> The meeting name has been set to 'neutron_dvr'
15:03:08 <haleyb> #chair Swami
15:03:09 <openstack> Current chairs: Swami haleyb
15:03:20 <haleyb> #topic Announcements
15:03:58 <haleyb> Only thing I had was that RC1 is cut, RC2 probable from what I've seen
15:04:19 <haleyb> Did we have anything we need to target at RC2 ?
15:04:28 <jschwarz_> yes
15:04:35 <jschwarz_> one sec
15:04:35 <Swami> I just saw a bug that jschwarz_ has filed
15:04:56 <jschwarz_> https://bugs.launchpad.net/neutron/+bug/1560945
15:04:57 <openstack> Launchpad bug 1560945 in neutron "Unable to create DVR+HA routers" [Undecided,In progress] - Assigned to John Schwarz (jschwarz)
15:05:08 <Swami> also probably if the fixed ip patch gets into good shape that would be a good candidate .
15:05:28 <jschwarz_> I'm looking for armax to get his attention to see if this is an RC blocker
15:05:42 <haleyb> being pedantic lets jump to bugs
15:05:45 <haleyb> #topic Bugs
15:05:46 <jschwarz_> I have a patch for this but it was just something in cooked up in 2 seconds, so reviews will be very helpful
15:05:53 <Swami> haleyb: thanks
15:06:09 <Swami> This week we have seen just this one bug that jschwarz_ posted.
15:06:11 <haleyb> https://review.openstack.org/#/c/296394/
15:06:18 <armax> jschwarz_: this looks like an rc candidate
15:06:22 <haleyb> we can talk about jschwarz_ first
15:06:28 <jschwarz_> :)
15:06:29 <haleyb> that was the review, right?
15:06:35 <Swami> haleyb: yes
15:07:04 <armax> jschwarz_: please add a test, this someone crept in as a demonstration of the fact that perhaps we don’t have stellar covereage
15:07:07 <armax> coverage
15:07:16 <armax> I was also looking for documentation in this area
15:07:24 <haleyb> being nitpicky, can we just put a better description in the commit message too?
15:07:25 <armax> and I have seen none so far
15:07:33 <jschwarz_> armax, will do. I'll be in touch with the people once I do
15:07:40 <Swami> armax: documentation is on its way, adolfo is working on it, he might post a patch
15:07:46 <armax> might?
15:07:48 <armax> oh boy
15:08:01 <jschwarz_> haleyb, yes
15:08:02 <armax> jschwarz_: btw time is running out
15:08:09 <haleyb> s/might/will
15:08:13 <jschwarz_> armax, when do we want the RC to be cut?
15:08:19 <armax> I think we had today at latest
15:08:23 <Swami> armax: yes he will post a patch.
15:08:33 <jschwarz_> armax, it's at the top of my list, then
15:08:43 <Swami> armax: will make sure that gets into the review queue today.
15:08:44 <armax> I need to touch base with sc68cal too if he wants https://review.openstack.org/#/c/295917/ in
15:08:48 <armax> but that’s a separate topic
15:09:00 <armax> jschwarz_: thanks for testing this
15:09:05 <jschwarz_> welcome
15:09:29 <armax> btw jschwarz_ you sure that this happens on rc1 too?
15:09:41 <jschwarz_> armax, I tested on upstream master
15:09:44 <jschwarz_> I can make sure
15:10:02 <armax> I assume the two not to be radically different, but it’d be nice to see where the regression came from or if anyone can confirm why this is happening
15:10:23 <jschwarz_> once I'll have the next revision I'll bisect to see
15:10:34 <jschwarz_> it was working fine a few months back when we first introduced the DVRHA routers
15:11:15 <Swami> was it introduced recently then
15:11:17 <armax> jschwarz_: that would be awesome
15:11:57 <jschwarz> I'll start working on this now then and be in touch once I have results
15:12:01 * jschwarz switched PCs
15:12:22 <Swami> jschwarz: thanks
15:12:38 <Swami> This the only new bug we had this week.
15:13:08 <Swami> The next one is the #link https://bugs.launchpad.net/neutron/+bug/1462154
15:13:10 <openstack> Launchpad bug 1462154 in neutron "With DVR Pings to floating IPs replied with fixed-ips if VMs are on the same network" [High,In progress] - Assigned to Swaminathan Vasudevan (swaminathan-vasudevan)
15:13:10 <haleyb> jschwarz: thanks for fixing, ping when you have a new review out
15:13:31 <Swami> This one has a patch from Xiao
15:13:47 <Swami> #link https://review.openstack.org/#/c/285982/
15:13:56 <Swami> haleyb: I think you have already reviewed it.
15:14:57 <Swami> I did test this patch and it seems to work.
15:15:27 <haleyb> Swami: yes, that one loop didn't look right, although it probably works just fine since there is a port there if a FIP is present
15:15:59 <haleyb> but a slight refactor would make it more solid
15:16:02 <Swami> haleyb: yes I agree with you comment.
15:16:30 <Swami> haleyb: makes sense
15:16:39 <haleyb> is Xiao around?
15:16:59 <Swami> haleyb: I don't think he is
15:17:39 <haleyb> Swami: if you're fine with my change in the comment i'll update since it's been 19 hours with no movement
15:18:14 <Swami> haleyb: I think I am ok with your comment, just push in your version, I can test it and then we can push it.
15:18:33 <haleyb> @action haleyb to update https://review.openstack.org/#/c/285982/ based on his comments
15:18:38 <haleyb> doh
15:18:46 <haleyb> #action haleyb to update https://review.openstack.org/#/c/285982/ based on his comments
15:19:18 <haleyb> Swami: so what about https://review.openstack.org/#/c/246855/ ?  that's also linked to that bug
15:20:06 <Swami> haleyb: no that is not in a good shape and is not required anymore if this goes in.
15:20:19 <haleyb> ah, i see carl_baldwin 's comment "This will not merge!" so will -1 workflow it
15:20:54 <carl_baldwin> What'd I do?
15:21:30 <haleyb> carl_baldwin: nothing, i just noticed your comment in a review
15:21:46 <haleyb> "This will not merge!" :)
15:22:26 <haleyb> two competing patches to fix bug 1462154
15:22:27 <openstack> bug 1462154 in neutron "With DVR Pings to floating IPs replied with fixed-ips if VMs are on the same network" [High,In progress] https://launchpad.net/bugs/1462154 - Assigned to Swaminathan Vasudevan (swaminathan-vasudevan)
15:23:08 <carl_baldwin> haleyb: Right, but the depends-on was removed.
15:23:22 <carl_baldwin> haleyb: It was the depends-on that I said would never merge.
15:23:57 <haleyb> doh again
15:24:57 <Swami> I dont' any other new bugs to discuss.
15:25:38 <haleyb> anyone else have any bugs?
15:26:14 <haleyb> #topic Gate Failures
15:26:39 <Swami> I do see that the multinode jobs failing rate is high
15:26:53 <haleyb> https://goo.gl/L1WODG is showing the multinode job failure at 40-50%
15:27:21 <haleyb> This spiked starting 3/21
15:27:51 <Swami> I did see there were bunch of failures with respect to "volume_boot_pattern" yesterday.
15:29:04 <haleyb> Is that a nova or cinder thing?
15:29:25 <Swami> I am not sure
15:30:54 <haleyb> I will look through some recent jobs and look for failures in the logs, but anyone else that wants to help is welcome
15:31:19 <Swami> haleyb: thanks
15:31:45 <Swami> haleyb: there might be more failures, but this is the one I noticed were it had 800 to 900 failures
15:31:59 <haleyb> obviously the plan is to get these jobs voting again, but they haven't been stable for more than a week
15:32:14 <Swami> haleyb: Yes, that was our plan.
15:32:20 <haleyb> Swami: logstash?  maybe i'll start there
15:32:47 <Swami> haleyb: yes
15:32:56 <Swami> the numbers that i provided was from logstash
15:34:24 <haleyb> #topic Open Discussion
15:34:54 <haleyb> if there are no other issues i'll give people 25 minutes back
15:35:15 <Swami> haleyb: I think we don't have any other topics to discuss at this time.
15:36:08 <haleyb> ok, let's try and get that DVR+HA fix and the SNAT fix in
15:36:22 <Swami> haleyb: sure
15:36:32 <haleyb> thanks for coming everyone
15:36:34 <Swami> also I will make sure we have the HA docs up
15:36:50 <haleyb> #endmeeting