15:05:36 <haleyb> #startmeeting neutron_dvr
15:05:36 <openstack> Meeting started Wed Jan  4 15:05:36 2017 UTC and is due to finish in 60 minutes.  The chair is haleyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:41 <openstack> The meeting name has been set to 'neutron_dvr'
15:06:15 <haleyb> #topic Announcements
15:07:12 <haleyb> I need to find a link, but we are in the final "sprint" for Ocata
15:08:18 <haleyb> So let's get any open reviews in order quickly
15:09:02 <haleyb> PTG is also approaching quickly, week of Feb 20th
15:09:11 <haleyb> jschwarz: are you attending?
15:09:21 <jschwarz> haleyb, afraid not :<
15:09:26 <jschwarz> haleyb, are you?
15:10:08 <haleyb> jschwarz: i am not, vacation conflict :)
15:10:22 <jschwarz> haleyb, :< is swami attending?
15:11:27 <haleyb> I don't know but will ask him
15:11:57 <haleyb> any announcements from anyone?
15:12:16 <jschwarz> if anyone == self: no_announcements()
15:12:51 <haleyb> i'm assuming there is someone lurking, but lets move on then
15:12:56 <haleyb> #topic Bugs
15:13:11 <haleyb> Looks like only one new bug since last meeting
15:13:13 <haleyb> https://bugs.launchpad.net/neutron/+bug/1653633
15:13:14 <openstack> Launchpad bug 1653633 in neutron "fwaas v1 with DVR: l3 agent can't restore the NAT rules for floatingIP" [Undecided,Incomplete]
15:13:36 <jschwarz> I'm not aware of any critical bugs that popped up during the Christmas time off thingy
15:13:56 <jschwarz> is fwaas even supported?
15:14:19 <haleyb> I will triage that bug, might be on an older release, doesn't seem to even involve fwaas
15:14:59 <haleyb> #action haleyb to triage https://bugs.launchpad.net/neutron/+bug/1653633
15:15:00 <openstack> Launchpad bug 1653633 in neutron "fwaas v1 with DVR: l3 agent can't restore the NAT rules for floatingIP" [Undecided,Incomplete]
15:15:15 * haleyb remembered about action
15:15:27 <jschwarz> :D
15:17:10 <haleyb> I need to go through the wiki and remove stale bugs, won't go through them all now since we're just getting back
15:17:26 <haleyb> jschwarz: any HA bugs/issues that need attention?
15:17:40 <jschwarz> haleyb, yes
15:18:01 <jschwarz> haleyb, https://bugs.launchpad.net/neutron/+bug/1647432 is in need of reviews
15:18:03 <openstack> Launchpad bug 1647432 in neutron "Multiple SIGHUPs to keepalived might trigger re-election" [High,In progress] - Assigned to John Schwarz (jschwarz)
15:18:16 <jschwarz> it has a patch at the gate for around a month now, already approved once by kevinbenton
15:19:12 <haleyb> i will look, remembering it now
15:19:25 <haleyb> #action haleyb review https://review.openstack.org/#/c/407099/
15:20:51 <haleyb> jschwarz: anything else?
15:20:57 <jschwarz> haleyb, nope :)
15:21:26 <haleyb> #topic Gate
15:22:01 <haleyb> I proposed a patch to make the dvr-multinode job voting, https://review.openstack.org/#/c/410973/
15:22:22 <haleyb> i need to update based on feedback, then hopefully it can move forward
15:22:32 <jschwarz> haleyb, oh yay :)
15:23:17 <haleyb> how is the HA job coming?  https://review.openstack.org/#/c/383827/
15:23:24 <haleyb> anilvenkata: ^^
15:23:52 <anilvenkata> haleyb, couldn't get time for that
15:23:58 <anilvenkata> haleyb, will be doing in this week
15:24:27 <haleyb> anilvenkata: no problem, thanks!
15:24:41 <anilvenkata> haleyb, jschwarz thanks Brian and John
15:26:19 <haleyb> #topic Open Discussion
15:26:24 <jschwarz> haleyb, anilvenkata, gtg soon, but https://review.openstack.org/#/c/357966/ and https://review.openstack.org/#/c/386077/ are 2 important patches that could really use the attention. They solve some nice bugs and present an awesome refactor to the scheduler (respectively) and I hope we can get it through soon :)
15:27:06 <anilvenkata> jschwarz, haleyb agree
15:27:17 <jschwarz> haleyb, I agree with anilvenkata
15:27:19 <jschwarz> XD
15:27:31 <haleyb> jschwarz: ok, i'll take a look at those, think you just revived one, right?
15:27:32 <anilvenkata> they are important patches for fixing races
15:27:43 <jschwarz> haleyb, yes, the 357966 one
15:27:46 <anilvenkata> and making HA better
15:28:07 * haleyb had too many emails to digest yesterday
15:28:27 <haleyb> anything else to discuss?  else we'll end early
15:28:28 <jschwarz> but it's a relatively straightforward revert with a good reason (has some non-revertible end-cases that require the re-creation of HA routers) and is safe to put in since https://review.openstack.org/#/c/317949/ merged
15:28:44 <jschwarz> 317949 pretends to solve almost all the races in the scheduler
15:28:54 <jschwarz> other than that, I'm good :)
15:29:00 * jschwarz is running into a meeting room
15:29:58 <haleyb> ok, i'll update the wiki and review, ping me if i'm slow to review
15:30:10 <haleyb> #endmeeting