14:00:38 <sc68cal> #startmeeting neutron_ipv6
14:00:38 <openstack> Meeting started Tue Jan 28 14:00:38 2014 UTC and is due to finish in 60 minutes.  The chair is sc68cal. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:42 <openstack> The meeting name has been set to 'neutron_ipv6'
14:01:22 <sc68cal> Agenda is pretty light today
14:01:23 <xuhanp> hello
14:01:29 <shshang> hola!
14:01:39 <shshang> Good morning, Good evening!
14:01:51 <shshang> Hi, Sean, Hi, Xu Han!
14:01:53 <simon-AS559> Good afternoon from Zurich
14:02:05 <shshang> Zurich! Wow
14:02:15 <shshang> Good afternoon, Simon
14:02:36 <sc68cal> #topic recap actions from last meeting
14:02:54 <sc68cal> #link http://eavesdrop.openstack.org/meetings/neutron_ipv6/2014/neutron_ipv6.2014-01-21-14.00.html last week's summary
14:03:32 <sc68cal> shshang: Do you have the link handy for the new blueprint, for the two attributes? not sure if I have it in my history
14:03:49 <shshang> let me check. 1 sec
14:04:35 <sc68cal> Ah - I got it
14:04:44 <shshang> https://blueprints.launchpad.net/neutron/+spec/ipv6-two-attributes
14:04:51 <sc68cal> #link https://blueprints.launchpad.net/neutron/+spec/ipv6-two-attributes IPv6 two attributes blueprint
14:05:49 <sc68cal> That was pretty much our action items for last week, thank you shshang for registering the BP
14:06:03 <shshang> np, Sean. My pleasure!
14:06:04 <sc68cal> and thank you everyone for participating on the mailing list discussion
14:06:19 <aveiga> #link http://lists.openstack.org/pipermail/openstack-dev/2014-January/025573.html ML Link to attribute names
14:06:31 <aveiga> shshang: would you be able to update the BP for the new names?
14:06:44 <shshang> Yup, I will
14:06:45 <aveiga> I believe the ML came to a consensus on them
14:06:47 <aveiga> thanks
14:06:57 <shshang> yw, aveiga!
14:07:12 <sc68cal> Awesome.
14:07:17 <sc68cal> #topic blueprints
14:07:29 <shshang> If we already reached the consensus, can we discuss the action items?
14:07:54 <sc68cal> sure - what did you have in mind?
14:08:13 <shshang> I will quickly wrap up the dnsmasq, but that is only one piece of the puzzle
14:08:29 <xuhanp> sc68cal, will you rebase your existing code to this new blueprint?
14:08:51 <shshang> xuhanp mentioned last time, IBM team can help on the backend side. I think that's an excellent idea
14:09:01 <xuhanp> sure.
14:09:05 <xuhanp> we can do that.
14:09:06 <aveiga> we also need someone to do the api/db changes
14:09:11 <sc68cal> xuhanp: Yes - I plan on rebasing and adding the second attribue
14:09:26 <aveiga> and neutron-client
14:09:39 <shshang> yah, neautron-client is another part
14:09:43 <xuhanp> dozy has some code already, can just rebase.
14:09:47 <xuhanp> for client
14:09:49 <shshang> IBM team did great job before
14:10:06 <xuhanp> dzyu, sorry, typo
14:10:07 <shshang> yes, that will be great if daozhao can rebase the client code
14:10:39 <sc68cal> #action sc68cal rebase review to add second API attribute
14:10:49 <xuhanp> it's chinese new year this week, but we can probably start early next week
14:11:00 <shshang> so we have coverage for client, dnsmasq, db, how are about API?
14:11:12 <sc68cal> I'd probably hit the API too
14:11:23 <shshang> so we have coverage for client, dnsmasq, db, how are about API?
14:11:26 <sc68cal> since my old review hits it for the one attribute
14:11:36 <shshang> xuhanp, happy chinese horse year to you and your team!
14:11:52 <xuhanp> thanks, shshang !
14:12:02 <xuhanp> is DB my team's focus?
14:12:04 <shshang> I should be able to get dnsmasq code out for review this week
14:12:09 <xuhanp> just want to be double confirm that.
14:12:35 <shshang> yes, if you guys have bandwidth.
14:12:42 <sc68cal> My old review covered the DB changes too, remember
14:12:51 <sc68cal> I don't want to break it up into too many small pieces
14:12:59 <xuhanp> sc68cal, yeah. you are right
14:13:03 <sc68cal> otherwise it's going to be a hassle to get things reviewed
14:14:04 <shshang> So Sean, you want to work on the DB side?
14:14:14 <shshang> I am fine either way
14:14:20 <sc68cal> Yeah, I'll hammer it out and post in a couple of hours or so
14:15:12 <sc68cal> I plan on implementing the two attributes as Enum in the DB
14:15:17 <sc68cal> *Enums
14:15:34 <sc68cal> and the values as strings
14:15:39 <shshang> to summarize, I will post dnsmasq code, Sean will cover DB/API, xuhanp team will cover client. Is this accurate?
14:15:40 <xuhanp> sc68cal, sounds great that we can get that reviewed really soon!
14:16:03 <shshang> who can cover horizon?
14:16:08 <xuhanp> shshang, by dnsmasq you mean the namespace, routing things, right?
14:16:15 <shshang> yes
14:17:17 <sc68cal> We probably need to register a BP for it
14:17:32 <sc68cal> I know I had a BP for horizon for the dhcp_mode KW
14:17:51 <sc68cal> either we update that one or create a new one. I favor creating a new one so someone else can own / manage it
14:18:01 <shshang> +1
14:18:19 <shshang> we definitely need a owner for horizon piece. otherwise, it will go limbo
14:18:42 <xuhanp> anyone has any experience with horizon?
14:19:24 <shshang> not me....:(
14:19:41 <sc68cal> I've done a lot of work with Django - so I can assist
14:19:57 <sc68cal> help bring someone up to speed
14:20:32 <shshang> how are about this, put that action item to my name for now
14:20:47 <shshang> I should have some breathing room next week, so I can work on it
14:20:53 <shshang> but I do need your help, Sean. :)
14:21:31 <sc68cal> No problem, would be glad to help answer q's
14:21:47 <shshang> I only have one question, which is "teach me". :D
14:21:53 <sc68cal> Can do :)
14:22:16 <sc68cal> #action shshang register BP for horizon for two subnet ipv6 attributes
14:22:35 <shshang> In the meanwhile, we can also send email to ML. If there is anybody else who is more qualified to me, then I can hand it over to him/her.
14:23:00 <sc68cal> +1
14:23:03 <xuhanp> sc68cal, do you need any help on the iptables rule work we talked last time?
14:23:23 <sc68cal> yeah - if you want to pick that off and work on it be my guest
14:23:44 <xuhanp> I may need some more details from you to start the work.
14:23:52 <xuhanp> but glad to help on that one
14:24:15 <sc68cal> Yeah I'd rather put that back on the queue so someone can pick it up
14:24:52 <xuhanp> sure. talk to you later on IRC or just here when open topics?
14:24:54 <sc68cal> I'm in #openstack-neutron so we can collaborate there, walk you through what we need to change
14:25:03 <xuhanp> sounds great
14:25:25 <sc68cal> unless there are any other BP's we can do open discussion?
14:26:30 <xuhanp> we need da zhao's address calculation code rebase as well, right?
14:26:43 <shshang> yes, that part is unchanged
14:26:45 <xuhanp> on sc68cal's coming rebase code
14:26:52 <xuhanp> I will let him know.
14:27:15 <xuhanp> probably need to wait for next week as well because of the holiday
14:27:45 <xuhanp> but I guess we can get Sean's code reviewed first
14:27:55 <shshang> true
14:29:11 <xuhanp> if it's open discussion, I have one question may sounds silly
14:29:23 <sc68cal> #topic open discussion
14:29:29 <xuhanp> are we going to support NAT64 by L3?
14:29:46 <xuhanp> I was asked about this the other day but not sure about the answer
14:29:54 <shshang> Not right now....
14:29:55 <xuhanp> since we have some requirements on that.
14:30:16 <xuhanp> so I guess that's our mid/long term goal?
14:30:23 <aveiga> is this in regard to http://lists.openstack.org/pipermail/openstack-dev/2014-January/023265.html ?
14:30:56 <aveiga> I think that is something longer term that needs to be decided on, whether it should be internal to neutron, run as a service VM, or be an external project
14:31:34 <aveiga> if it's something you need immediately, I'd recommend running a service VM or a load-balancer running a reverse proxy
14:32:21 <xuhanp> that's what I thought, aveiga, just want to confirm. Thanks
14:32:40 <aveiga> it wouldn't hurt to discuss option on the mailing list, though
14:32:43 <aveiga> it's worth considering
14:32:58 <aveiga> I'd considered doing IPv-6 only tenant networks by default as well
14:33:04 <aveiga> we're not ready yet, though
14:33:54 <simon-AS559> Discussing this on the ML is a good idea.
14:34:13 <xuhanp> yep.
14:34:14 <simon-AS559> I'd expect the Terastream (Deutsche Telekom) people to be interested in NAT64-like mechanisms as well.
14:34:33 <aveiga> bring it up, hammer out some plans
14:34:42 <aveiga> when you have somthing with solid consensus, let's talk milestones
14:35:24 <shshang> +1
14:35:28 <xuhanp> I will bring that up once get back from holiday
14:35:35 <aveiga> I doubt NAT-64 would be radically different from a NAT-44 implementation either, so maybe it's worth rolling a new project for translations
14:36:42 <xuhanp> also some new protocols may need to be involved. like 6 in 4 tunnel
14:37:33 <xuhanp> will be interesting to check that in details.
14:37:44 <aveiga> yeah, so bring it up on the ML.  If enough people want different things from it, it  warrants its own project
14:37:52 <aveiga> or at least neutron sub-project
14:38:27 <shshang> we can have an internal vote before the upcoming summit. :D
14:39:37 <xuhanp> shshang, aveiga thanks for the advice. Will bring that up in ML
14:40:16 <sc68cal> Anything else for today?
14:40:40 <shshang> xuhanp, hope you and your team enjoy the holiday and days off!
14:40:53 <xuhanp> thank you!
14:42:06 <xuhanp> sc68cal, do you have time now for the iptables rule discussion in #openstack-neutron?
14:42:32 <sc68cal> yeah
14:42:52 <xuhanp> I will move there then. Thank you for that!
14:43:03 <sc68cal> ok - till next week everyone
14:43:10 <aveiga> o/
14:43:20 <shshang> Thanks and Bye! //waving
14:43:29 <xuhanp> bye, everyone
14:43:29 <simon-AS559> Bye
14:43:48 <sc68cal> #endmeeting