13:59:48 <sc68cal> #startmeeting neutron_ipv6
13:59:49 <openstack> Meeting started Tue Jun 24 13:59:48 2014 UTC and is due to finish in 60 minutes.  The chair is sc68cal. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:52 <openstack> The meeting name has been set to 'neutron_ipv6'
14:00:14 <sc68cal> #topic blueprints
14:01:39 <sc68cal> Here's what's scheduled for J-2
14:01:40 <sc68cal> https://launchpad.net/neutron/+milestone/juno-2
14:03:04 <sc68cal> It looks like we need to have that updated, to reflect what we are currently working on
14:05:10 <HenryG> Sorry I am late
14:05:24 <sc68cal> Do we have any new blueprints to discuss?
14:05:26 <BrianB__> It's missing a few BP
14:05:57 <xuhanp> sc68cal, I've update the SLAAC spec to stateful/stateless
14:05:58 <xuhanp> https://review.openstack.org/#/c/99595/
14:06:09 <xuhanp> it still has Mark's -2 on it.
14:07:05 <xuhanp> And I am not sure if we should set this stateful/stateless spec be dependent on the RADVD spec
14:07:41 <sc68cal> xuhanp: it may be worth abandoning that review and creating another
14:08:13 <xuhanp> sc68cal, that may work :-)
14:08:31 <sc68cal> since that review was originally targeted to slaac/slaac and the -2 from mark is significant, since they wanted us to not have dnsmasq advertise routes
14:08:41 <sc68cal> and work on radvd instead
14:08:50 <sc68cal> that may be useful for historical purposes
14:09:31 <aveiga> xuhanp: dnsmasq shouldn't be dependant on radvd
14:09:41 <xuhanp> sc68cal, ok that makes sense. I've already got some comments. will see what I can do.
14:09:49 <sc68cal> BrianB__: do you know which BPs are missing?
14:09:50 <aveiga> just make the dependancy "assuming an RA is present" since provider nets can do RAs too
14:09:52 <xuhanp> aveiga, that's what I thought.
14:10:24 <xuhanp> aveiga, ok. will modify that.
14:11:21 <dane_leblanc> sc68cal: I don't see RADVD and the multi prefix in the J2 blueprint list
14:11:39 <aveiga> dane_leblanc: the RADVD is still pending +2
14:12:34 <sc68cal> hmm yeah https://blueprints.launchpad.net/neutron/+spec/neutron-ipv6-radvd-ra has no series goal
14:13:11 <sc68cal> #action sc68cal get https://blueprints.launchpad.net/neutron/+spec/neutron-ipv6-radvd-ra set to the correct Juno milestone
14:15:22 <sc68cal> OK - do we have anything else to discuss in the blueprint topic
14:16:25 <dane_leblanc> Have you had a chance to review my comments for multiple prefix BP?
14:16:28 <BrianB__> sc68cal, sorry could not find the link I was ref to radvd and http://wikicentral.cisco.com/display/OPENSTACK/Blueprint+ideas
14:17:25 <BrianB__> https://review.openstack.org/98217
14:17:48 <sc68cal> looks like that wikicentral times out for me
14:18:13 <BrianB__> sorry c&p error
14:18:42 <sc68cal> dane_leblanc: I'll take a look at your comments
14:19:15 <xuhanp> I will review that spec too.
14:19:17 <sc68cal> at this point it looks like there is either bugs in sphinx or something because the references come out a little broken, but I've seen a couple specs like that
14:19:18 <dane_leblanc> sc68cal: Thanks, that BP is stalled with -1
14:21:30 <sc68cal> HenryG: how is https://review.openstack.org/#/c/101306/ going
14:22:01 <HenryG> Looks like just nits remaining
14:22:15 <xuhanp> I just gave a -1 today. Sorry about that late comment
14:22:27 <HenryG> I will address them and ask for approval
14:22:42 <HenryG> xuhanp: np
14:23:27 <sc68cal> dane_leblanc: I think once we get the radvd implementation underway we'll be able to give more bandwidth to other reviews, like your multi prefix bp
14:24:44 <sc68cal> #topic code review
14:25:14 <sc68cal> Any reviews that need eyeballs?
14:25:56 <xuhanp> sc68cal, I can use some reviews on https://review.openstack.org/#/c/101433/
14:26:12 <sc68cal> I try and keep a list current for the main meeting - to get cores focused on specific reviews - https://wiki.openstack.org/wiki/Network/Meetings#IPv6_.28sc68cal.29
14:26:31 <sc68cal> xuhanp: cool I'll add that to the list
14:26:46 <xuhanp> and this one:  https://review.openstack.org/#/c/80932/
14:27:00 <xuhanp> I think it's listed as the dependency of the RADVD implementation
14:28:04 <sc68cal> xuhanp: agree
14:28:51 <Shixiong_> xuhanp, do you need me to review those two code submissions?
14:29:15 <Shixiong_> 101433, and 80932?
14:29:21 <xuhanp> Shixiong_, sure. these are two Ipv6 related bugs
14:29:23 <xuhanp> thanks
14:29:44 <Shixiong_> ok, will do
14:31:00 <sc68cal> cool - any others that I need to bring to core's attention?
14:32:21 <sc68cal> #topic bugs
14:32:44 <sc68cal> https://bugs.launchpad.net/neutron/+bugs?field.tag=ipv6
14:33:59 <sc68cal> If you've reported a bug and don't see it in that list, please add the ipv6 tag to it :)
14:35:26 <sc68cal> any other bugs to discuss? otherwise we'll do open discussion
14:36:37 <sc68cal> #topic open discussion
14:40:36 <sc68cal> If there's nothing else, I'll give everyone back 20 minutes. I'm always in #openstack-neutron if you need me
14:41:31 <sc68cal> See everyone next week!
14:41:34 <sc68cal> #endmeeting