14:06:18 <sc68cal> #startmeeting neutron_ipv6
14:06:19 <openstack> Meeting started Tue Aug 19 14:06:18 2014 UTC and is due to finish in 60 minutes.  The chair is sc68cal. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:06:22 <openstack> The meeting name has been set to 'neutron_ipv6'
14:06:26 <xuhanp> hello
14:06:40 <sc68cal> xuhanp: hello!
14:07:38 <HenryG> o/
14:08:44 <sc68cal> xuhanp: I saw the comments on your review, regarding the NEC CI system
14:09:12 <xuhanp> sc68cal, yep. got some comments about dnsmasq version check
14:10:15 <xuhanp> and seems the nec CI has been fixed already:  https://review.openstack.org/#/c/106299/
14:11:04 <sc68cal> agree - looks like we're ready to merge
14:11:51 <HenryG> The complaint was that Ubuntu 12.04 has some old version of dnsmasq. But can't that be fixed with apt-get install update?
14:12:13 <HenryG> Maybe I misunderstand operations issues.
14:12:36 <sc68cal> Most likely the cloud-archive will need to have a newer version of dnsmasq
14:12:46 <sc68cal> https://wiki.ubuntu.com/ServerTeam/CloudArchive
14:13:04 <sc68cal> we deploy on 12.04 and utilize
14:14:25 <HenryG> Isn't zigo the person to help us out there?
14:14:39 <zigo> Hi!
14:14:44 <zigo> How may I help? :)
14:14:59 <zigo> With dnsmasq?
14:15:01 <HenryG> zigo: hi
14:15:06 <sc68cal> no, zigo packages for debian I believe
14:15:26 <sc68cal> I did forward him the e-mail as a heads up
14:15:32 <amotoki> hi, according to the log, it seems you are talking about dnsmasq versoin.
14:15:42 <zigo> http://archive.gplhost.com/debian/pool/juno-backports/main/d/dnsmasq/
14:15:45 <zigo> It's there already.
14:15:48 <HenryG> amotoki: yes
14:16:09 <xuhanp> amotoki, thanks for removing your -1 and fixing the Nec CI
14:16:15 <zigo> Then there's someone working on an official Debian Wheezy backport (as per a debian-backport@lists.debian.org post).
14:16:47 <zigo> But I believe you need it for Ubuntu 12.04 ?
14:16:53 <zigo> Or for what?
14:17:31 <zigo> FYI, I do Debian stuff, I have no power to do anything on cloud-archive ...
14:17:50 <HenryG> sorry zigo :(
14:17:52 <amotoki> I think Ubuntu Cloud Archive does not support Juno on 12.04.
14:18:16 <zigo> amotoki: That is correct. And the plan is to *not* support it. Same for my Juno packages btw.
14:18:54 <zigo> Both Canonical guys and myself did some Precise packages because of customers needs, but at some point, they are required to upgrade to 14.04.
14:18:58 <sc68cal> amotoki: I believe you are correct. 12.04 is going to stay on Icehouse I think.
14:19:35 <zigo> It's actually a pain to do all the backporting work (not only Python modules, but also all stuff like kernel, OVS, etc.).
14:19:40 <sc68cal> guess everyone who wants OpenStack and ipv6 will have to upgrade to 14.04 too :(
14:20:05 <zigo> sc68cal: Or switch to Debian? :)
14:20:20 <amotoki> sc68cal: precisely speaking, everyone who wants to use dhcp-agent in Juno needs to upgrade to 14.04.
14:21:00 <sc68cal> zigo: hahaha yes, or switch to debian :)
14:21:12 <amotoki> :)
14:22:41 <sc68cal> I might need to bring this topic up in the infra meeting or 3rd party CI
14:22:57 <sc68cal> since people might be using 12.04 for CI systems like NEC does
14:23:53 <amotoki> Actually I built dnsmasq package from ubuntu and put my local repo. NEC CI picks dnsmasq from there.
14:25:17 <sc68cal> amotoki: true, that is one way to fix :) we'll just need to give everyone a lot of warning about this
14:25:48 <amotoki> The thing we need to bring up is that neutron CI requires Ubuntu 14.04 (12.04 no longer works with customized package).
14:26:02 <sc68cal> agree
14:26:38 <amotoki> I honestly wonder why other CI's didn't break. They all use ubuntu 14.04 or Redhat variants....
14:26:38 <sc68cal> I'll add a reminder for myself to bring this up in the main neutron meeting
14:26:52 <amotoki> sc68cal: good idea.
14:27:21 <HenryG> I know our CI has switched to 14.04
14:27:53 <HenryG> sc68cal: that is what the #action thing is for :)
14:28:05 <amotoki> kyle and mark already agree with the direction on dev ML, so it must be just a notice.
14:28:36 <sc68cal> HenryG: agree -
14:28:53 <amotoki> #action sc68cal report dnsmasq 2.63 requirement for dhcp-agent in the weekly neutron meeting
14:29:14 <sc68cal> I think you need to be chair for it to stick
14:29:21 <sc68cal> so excuse the copy and paste :)
14:29:25 <sc68cal> #action sc68cal report dnsmasq 2.63 requirement for dhcp-agent in the weekly neutron meeting
14:29:54 <HenryG> So while we have amotoki here ...
14:30:20 <HenryG> Can we talk about IPv6 in Horizon?
14:30:27 <amotoki> sure
14:30:34 <sc68cal> go for it ;)
14:30:38 * HenryG searches for the review ...
14:31:20 <amotoki> https://review.openstack.org/#/c/74453/ ?
14:31:31 <HenryG> https://review.openstack.org/74453
14:31:34 <HenryG> yes
14:33:09 <HenryG> So mainly I want to bring attention to the review because most of us don't go looking outside neutron much.
14:33:34 <HenryG> Please review it. At least the parts that you recognize.
14:33:46 <sc68cal> +1
14:33:57 <HenryG> One question I have about it ...
14:34:04 <amotoki> The easiest way is just to run the review :-)
14:34:36 <HenryG> Do we want to expose the raw attribute names in the UI?
14:35:13 <HenryG> Or give them "English" labels instead? "IPv6 RA Mode" etc?
14:35:40 <sc68cal> s/English/Localized/g
14:35:43 <amotoki> What I concern is ipv6 ra and address modes have a lot of constraints. there are 10 combos
14:35:55 <amotoki> my idea is just to make them dropdown list.
14:36:30 <HenryG> amotoki: yes, and markmcclain has plans to tweak the attributes to avoid that
14:36:58 <amotoki> or abishek is doing in antother approach. I can implement my idea so that you can test it.
14:37:20 <amotoki> i feel same as markmcclain :-)
14:37:55 <sc68cal> do we have a spec for the tweaking of attributes?
14:38:33 <amotoki> HenryG: do you see any?
14:39:04 <HenryG> sc68cal: I have not seen a spec yet, only some doodling on a whiteboard at the midcycle
14:39:48 <HenryG> Given how much other stuff markmcclain has on his plate, I don't expect anything before kilo
14:40:30 <sc68cal> ok
14:41:05 <HenryG> What I may do is take the doodles and draft something, then run it by markmcclain to see if he will allow me to post the spec
14:41:19 <amotoki> I would like to implement the dropdown menu version of Horizon support. It will be appreciated if you feedback on it and suggest better lablings :-)
14:41:26 <amotoki> i will talk with abishek on it.
14:41:36 <sc68cal> amotoki: dropdown sounds reasonable to me
14:41:49 <HenryG> amotoki: Have you posted a review yet?
14:42:09 <amotoki> HenryG: not yet. will be avaialble in a couple of days.
14:42:26 <HenryG> amotoki: sounds good. Add me as reviewer so I see it
14:42:26 <sc68cal> HenryG: ok. I'll try and keep an open mind. But I'm sort of exhausted by the API debate
14:42:40 <sc68cal> We seem to have it every cycle....
14:44:19 <HenryG> sc68cal: Don't worry, it's not really changing any of the work we have achieved.
14:45:01 <amotoki> BTW, does the list in neutron meeting wiki cover all pending reviews related to IPv6? I am not a specialist of IPv6 but i can.
14:46:09 <sc68cal> yes it usually has a up to date list.
14:46:52 <amotoki> thanks
14:47:48 <HenryG> sc68cal: Not sure what else is on the agenda, but we should point out the bug list.
14:47:53 <HenryG> https://bugs.launchpad.net/neutron/+bugs?field.tag=ipv6
14:48:08 <HenryG> Several new bugs have been filed.
14:49:14 <sc68cal> thanks f
14:49:18 <sc68cal> *for the reminder
14:57:26 <sc68cal> if there isn't anything else, I'll see everyone next week!
14:58:22 <sc68cal> #endmeeting