15:02:03 <sc68cal> #startmeeting neutron_ipv6
15:02:04 <openstack> Meeting started Tue Feb 17 15:02:03 2015 UTC and is due to finish in 60 minutes.  The chair is sc68cal. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:07 <openstack> The meeting name has been set to 'neutron_ipv6'
15:03:14 <sc68cal> My agenda is pretty light - so we'll go quickly through bps, bugs, and code reviews then give the majority of the time over to open discussion
15:03:37 <sc68cal> #topic blueprints
15:03:44 <sc68cal> #link https://launchpad.net/neutron/+milestone/kilo-3 K-3 blueprints
15:04:24 <sc68cal> Make sure if you have a blueprint slated for K-3 you've pushed something into Gerrit
15:04:46 <sc68cal> per mestery's e-mail on the ML last week, even if it's WIP it'll help prepare reviewers
15:04:56 <mestery> sc68cal: ++
15:05:05 <sc68cal> and maybe get some of the mandatory nit-picking and bike-shedding out of the way
15:05:13 <sc68cal> early
15:06:15 <sc68cal> unless we have any BPs to discuss, I'll move on
15:06:33 <sc68cal> I plan on talking about baoli's e-mail on the ML in open discussion
15:06:35 <ihrachyshka> sc68cal, when will we discuss dibbler patches issue?
15:06:52 <sc68cal> :)
15:07:00 <sc68cal> #topic code reviews
15:07:26 * sc68cal digs up his bookmarks
15:07:46 <sc68cal> dane_leblanc has some stuff in gerrit that we need to all take a look at, around the l3 agent
15:08:15 <sc68cal> https://review.openstack.org/149068
15:08:45 <dane_leblanc> sc68cal: That's actually one of the patches for the multi-prefix blueprint
15:08:56 <sc68cal> Yep :)
15:09:09 <dane_leblanc> Although the topic lists it as  a bug because it's a partial fix for that
15:09:19 <ihrachyshka> wow, it's huge
15:09:33 <sc68cal> I happen to disagree with the people -1'ing it for size
15:10:00 <dane_leblanc> ihrachyshka: Yes, it changed some things in the port dictionary that unfortunately spread far and wide
15:10:06 <sc68cal> honestly it's just a big piece of work, to refactor the L3 agent to make it not bug out when dual stack ports are added
15:10:16 <aveiga> dane_leblanc: pardon my ignorance of the code, but does this expecet a GUA for IPv6?
15:10:25 <aveiga> how will you issue an RA?
15:10:46 <dane_leblanc> You can set up for SLAAC on the gateway port
15:11:17 <aveiga> even with DHCPv6 though, you need to send a LLA-source RA to provide the M and/or O bits
15:11:40 <sc68cal> I'm mostly looking for this patch to help solve https://bugs.launchpad.net/neutron/+bug/1401728
15:11:42 <openstack> Launchpad bug 1401728 in neutron "Routing updates lost when multiple IPs attached to router" [Medium,In progress] - Assigned to Sean M. Collins (scollins)
15:12:00 <dane_leblanc> aveiga: This is for the M and/or O bits on the external network?
15:12:10 <aveiga> no, for the VMs
15:12:48 <dane_leblanc> aveiga: The internal networks and router interfaces will be addressed with another commit being worked on by dboik
15:13:15 <aveiga> oh, this is setting the GUA of the external? My apologies for the confusion. Carry on
15:14:01 <dboik> aveiga: This one is for internal ports https://review.openstack.org/#/c/156360/
15:14:18 <aveiga> dboik: thanks!
15:15:53 <sc68cal> any other reviews folks want to discuss or bring to the group's attention?
15:17:10 <sc68cal> #topic bugs
15:17:19 <sc68cal> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=ipv6 IPv6 tagged bugs
15:18:07 <sc68cal> #action sc68cal needs to triage more bugs
15:19:26 <sc68cal> dane_leblanc: I'm taking a look at ndisc6, per https://bugs.launchpad.net/neutron/+bug/1357068
15:19:28 <openstack> Launchpad bug 1357068 in neutron "Arping doesn't work with IPv6" [Undecided,In progress] - Assigned to Dane LeBlanc (leblancd)
15:20:11 <sc68cal> I think what is going to need to be done is create a new helper binary for Neutron to do NDP packet sending
15:20:28 <sc68cal> and pick an apropriate packet injection library
15:21:19 <haleyb> sc68cal: why do we need this if we're routing? i.e. no floating ipv6
15:22:09 <haleyb> arping is only used when we add a FIP, right?
15:22:19 <sc68cal> I think for HA routers there is still a need, but that's a good point
15:22:28 <SridharG> sc68cal: also I think it Router Advt would serve the same purpose isnt it?
15:23:03 <haleyb> i know in baoli's spec there is mention of doing an NA, but that's not been implemented
15:23:13 <sc68cal> I know dane_leblanc 's patches also help remove some of those arping errors
15:23:28 <sc68cal> by guarding the code path with an ip version check
15:23:35 <haleyb> yes, i think that one patch removes all the arping errors
15:23:45 * haleyb needs to review again
15:24:00 <sc68cal> basically dane_leblanc is the superstar now
15:24:16 <dane_leblanc> sc68cal: Whhaaa?
15:24:37 <sc68cal> joking ;)
15:25:09 <dane_leblanc> sc68cal: I'll have to look deeper into what the bug is asking for, I only know some of the arping errors are addressed with my patch set.
15:25:18 <haleyb> and i can understand how it got so large as i started pulling the thread on fixing just the arp issue and went down the rabbit hole...
15:27:09 <sc68cal> yep - it gets nasty quick in the l3 agent
15:27:29 <SridharG> I'm still a bit confused on why we need arpping for HA IPv6 routers when RA would serve the purpose..
15:27:41 <SridharG> this was discussed earlier - http://lists.openstack.org/pipermail/openstack-dev/2014-August/044340.html
15:27:42 <aveiga> +1 to SridharG
15:27:47 <SridharG> am I missing something?
15:27:56 <sc68cal> no, you are probably correct
15:28:05 <SridharG> I have verified this locally in my setup and see that it works.
15:29:21 <sc68cal> ok, we'll circle back on this once the L3 fixes are in, and see if there is anything we need to do
15:29:39 <sc68cal> hopefully just guarding all the arping code paths with a version check will get us in the clear
15:30:06 <haleyb> i think it was robert's "IPv6 DVR routers" patches that needed ndisc6, https://review.openstack.org/#/c/143917/ and associated spec
15:30:06 <sc68cal> then plot out the code paths for sending an RA when needed
15:30:36 <SridharG> haleyb: +1
15:32:32 <sc68cal> any other bugs before I open the floor?
15:33:50 <sc68cal> #topic open discussion
15:35:19 <rackertom> Hello all. Just a quick Q.
15:36:02 <rackertom> What seems to be the most popular IPv6 config in use or as requested by users? SLAAC, DHCPv6, some manual option? Or a wonky combination of all of the above?
15:37:20 <sc68cal> I don't think we've ever had a survey about ipv6 deployment configs
15:37:41 <HenryG> rackertom: I think you should ask on the general ML, or the operators ML.
15:37:56 <HenryG> sc68cal: ++, give rackertom an action item ;)
15:38:12 <rackertom> I'm just now dipping my toe into this community, so I've quietly attended a couple of these meetings to get the feel and tone.
15:38:27 <rackertom> I'll gladly join the ML and survey
15:38:44 <sc68cal> It would be great to get an ipv6 question for how people are deploying ipv6 in the openstack user survey they do every summut
15:38:50 <sc68cal> *summit
15:38:54 <aveiga> sc68cal: +1
15:39:13 <aveiga> who runs that survey?
15:39:18 <rackertom> sc68cal: Agreed. I think it would let everybody here know which features hold more priority generally speaking
15:39:18 <sc68cal> I think ttx
15:39:22 <aveiga> give me an action item to reach out
15:39:44 <sc68cal> honestly i'd be ok with an unofficial surveymonkey survey shared with the operators
15:39:55 <sc68cal> or google doc thingy
15:40:08 <sc68cal> *google form
15:40:15 <aveiga> sc68cal: can you give me an action item to reach out to Tom Fifield regarding surveying operators?
15:40:20 <sc68cal> aveiga: will do
15:40:39 <HenryG> awesome, thanks aveiga!
15:40:52 <sc68cal> #action aveiga reach out to those responsible for surveying operators about gathering IPv6 deployment information
15:42:18 <HenryG> ihrachyshka: about the dibbler thing - john-davidge is here and can give an update
15:43:00 <john-davidge> ihrachyshka: happy to answer any questions
15:43:35 <ihrachyshka> john-davidge, so how do we plan to get patches in u/s dibbler?
15:44:18 <john-davidge> aveiga: I think Henry said you had contact with the dibbler maintainers?
15:44:41 <aveiga> john-davidge: I worked with the original author a while back
15:44:55 <aveiga> I don't know if he'll accept the pull request or not, but I can ask
15:45:15 <john-davidge> ihrachyshka: Also, we are cureently looking into isc_dhcp as an alternative to dibbler. So far it seems to have everything we need without any updates required, but we're not 100% on that just yet
15:45:44 <john-davidge> aveiga: thanks, I linked to the repo with our updates in the thread on the ML
15:45:57 <aveiga> john-davidge: that might be the faster route (isc)
15:46:12 <aveiga> john-davidge: yup, I have a tab opened here :)
15:46:32 <john-davidge> aveiga: Yes, if ISC has everything we need already then the dibbler updates wont hold us up
15:46:42 <ihrachyshka> john-davidge, I have some exp with isc code, so in case you need help, I can try.
15:47:14 <john-davidge> ihrachyshka: Great! I might send you an email if we get stuck :)
15:47:18 <ihrachyshka> john-davidge, cool, so the best thing would be to use smth working from stock
15:47:37 <john-davidge> ihrachyshka: Exactly, yes
15:47:44 <ihrachyshka> those dibbler patches scare me this time in cycle
15:47:48 <aveiga> It might help to know that the guy who wrote dibbler works at ISC :-P
15:48:06 <john-davidge> aveiga: aha, it's all coming together!
15:49:25 <john-davidge> ihrachyshka: just trying to get ISC to play nice with running a custom script after PD assignment now
15:50:20 <baoli> ihrachyshka: do you foresee the same issues with ISC as we listed with dibbler on the thread?
15:51:17 <ihrachyshka> baoli, nah, I haven't actually checked what you need, my exp was more in bind9, so what I meant was help with coding in case smth arises. but no, I don't know whether they have all needed.
15:51:46 <ihrachyshka> but you said above that it seems like everything is in place, right?
15:51:48 <baoli> ihrachyshka: ok, no problem. we'll find out soon.
15:52:37 <baoli> ihrachyshka, we're still in the process of evaluation.
15:53:01 <john-davidge> ihrachyshka: so far a lot of the features we need are there, but we'll know about everything soon
15:53:25 <ihrachyshka> ack, thanks for looking into alternatives
15:58:21 <sc68cal> ok everyone, if there isn't anything else, I'll see everyone next week!
15:59:59 <sdake_ws> sc68cal can you #endmeeting pls?
16:00:37 <sdake_ws> #endmeeting
16:00:44 <openstack> sdake_ws: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
16:01:01 * sdake_ws groans
16:01:25 <haleyb> #endmeeting neutron_ipv6
16:01:32 <haleyb> i had to try :(
16:01:43 <sc68cal> #endmeeting