15:01:48 <carl_baldwin> #startmeeting neutron_l3
15:01:49 <openstack> Meeting started Thu Feb 27 15:01:48 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:53 <openstack> The meeting name has been set to 'neutron_l3'
15:02:03 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:02:31 <carl_baldwin> I don't have anything to announce so I'll go in to the agenda
15:02:50 <carl_baldwin> #topic DVR
15:03:05 <carl_baldwin> Is Swami around today?
15:03:34 <carl_baldwin> There was nothing new from the DVR meeting yesterday as Swami had a conflict
15:03:58 <haleyb> i don't see swami on any channels
15:04:14 <carl_baldwin> hi Swami
15:04:15 <Swami> hi
15:04:39 <carl_baldwin> You're right on time.  Anything you want to say about DVR?
15:04:59 <Swami> We are working on the Design doc.
15:05:29 <Swami> The L2 design doc is probably ready for review, but still we need to complete the L3 design doc
15:05:48 <Swami> I am planning to push at least the L2 design doc by the end of this week for the community review.
15:06:02 <carl_baldwin> Good progress.  I'll be watching for it.
15:06:37 <Swami> I don't have anything else from my side.
15:06:43 <carl_baldwin> I'm anxious to see it.
15:06:47 <carl_baldwin> Thank you.
15:06:57 <Swami> Carl: Thanks for running the DVR meeting yesterday
15:07:11 <carl_baldwin> It was lonely.  :'(
15:07:23 <Swami> Yes I did see the logs.
15:07:36 <carl_baldwin> #topic HA Routers
15:07:52 <carl_baldwin> If I'm not mistaken, safchain is on vacation still.
15:08:20 <carl_baldwin> Review of the HA routers code is in progress.
15:08:33 <carl_baldwin> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/l3-high-availability,n,z
15:09:08 <carl_baldwin> #help Reviews needed.
15:09:23 <Swami> carl: I will review it.
15:09:44 <carl_baldwin> safchain has stopped in from time to time to respond to reviews.
15:10:16 <carl_baldwin> There was proposal by amuller to follow up with active/active.  It is worth a peak.
15:10:21 <carl_baldwin> Let me find the link.
15:11:06 <carl_baldwin> #link https://docs.google.com/document/d/1UsmwdNST1Ni_UP8nhewKdKkNre3MkZ9fO481l-fRjnA/edit
15:11:20 <Swami> carl: I had a question related to the HA for routers. When DVR is available the current router HA will be of limited use other than the HA for the Service node where we have the default SNAT, how do we address this.
15:13:33 <carl_baldwin> I've wondered that myself.  I think it depends on the usefulness of other services that require a centralized L3 component like SNAT and VPN.
15:14:29 <Swami> probably it would be a great idea for the Juno summit to have a discussion on what are the components that have to be centralized and we can work on HA for those components or services.
15:15:57 <carl_baldwin> I would like to have that discussion.  Do you think that HA for those components would build off of the current HA routers proposal?
15:16:36 <Swami> I was thinking on those lines, but I need to validate
15:16:43 <carl_baldwin> #idea Have a discussion at the Juno summit about HA for centralized L3 services.
15:16:55 <Swami> The HA infrastructure can be utilized.
15:17:55 <Swami> I will try to write up some content for the HA in centralized service nodes.
15:18:14 <carl_baldwin> It does raise a question about the usefulness of the active/active proposal ^ as well.  Will that work for all centralized services?
15:18:23 <carl_baldwin> Thanks Swami
15:18:52 <carl_baldwin> #topic L3 Agent Consolidation
15:19:01 <carl_baldwin> Is yamahata around?
15:19:16 <yamahata> yes
15:19:48 <yamahata> The code is ready.
15:19:59 <carl_baldwin> I started a review of your code but need to finish.  I will review this week.
15:20:09 <carl_baldwin> #link https://review.openstack.org/#/c/57627/
15:20:28 <carl_baldwin> yamahata: Anything else to add?
15:20:39 <yamahata> nothing else.
15:20:58 <carl_baldwin> #help review code
15:21:10 <carl_baldwin> #topic Service Type Framework
15:21:12 <Swami> swami: will do
15:21:23 <carl_baldwin> Is Gary around?
15:22:52 <carl_baldwin> Doesn't look like it.  I'll defer discussion about this until next week.  I hope I got his irc handle correct.
15:23:39 <carl_baldwin> #topic Dynamic Routing
15:24:32 <carl_baldwin> This is a topic I've been interested in.  I wanted to see if we could get any momentum on it for the Juno summit.
15:24:41 <Swami> carl: Is there a sub-team currently working on Dynamic routing, I thought that this was not the path that we were taking based on the icehouse summit discussions.
15:25:24 <carl_baldwin> #link https://blueprints.launchpad.net/neutron/+spec/bgp-dynamic-routing
15:25:54 <carl_baldwin> I remember the discussion at the summit was a bit unfocused and it was decided that it was not ready.
15:26:32 <carl_baldwin> Mark's note on the blueprint was that it should be deferred.
15:26:48 <Swami> the decision at that time was to use the VM footprint and have all the dynamic routing handled in the VM.
15:27:42 <carl_baldwin> That may work for some use cases.
15:28:54 <carl_baldwin> As I recall, there was no agreement at the summit about what use case we were all talking about.
15:30:20 <carl_baldwin> I think what needs to be done is to clarify the use case that the above blueprint is addressing and then create new bps for other use cases.
15:30:53 <Swami> sounds good
15:31:29 <carl_baldwin> #action carl_baldwin will clarify the description of the use case in the current bp to avoid the same confusion.
15:32:33 <carl_baldwin> The use case I've got interest in is different.  It is announcing floating ips to northbound routers on ext-net.  At least a few people at the summit had this in mind as well.
15:34:07 <Swami> sounds reasonable
15:34:29 <carl_baldwin> Swami: thanks for the information.  I'll start working on that in a separate blueprint.
15:35:26 <carl_baldwin> #topic DNS lookup of instances
15:35:42 <carl_baldwin> This is the last topic that I have for today.
15:36:16 <carl_baldwin> It has been a pain point for us and I noticed a discussion about it in #openstack-neutron
15:36:24 <carl_baldwin> #link http://eavesdrop.openstack.org/irclogs/%23openstack-neutron/%23openstack-neutron.2014-02-21.log
15:36:32 <carl_baldwin> ^ See conversation around 2014-02-21T00:19:20
15:37:13 <carl_baldwin> I'd like to generate some interest around working on two things:
15:37:47 <carl_baldwin> 1.  Reconciling instances hostnames and DNS names possibly with nova display name
15:38:03 <carl_baldwin> #link https://bugs.launchpad.net/nova/+bug/1175211
15:38:32 <carl_baldwin> 2.  Integrate floating ip create/update/delete with external DNS service (e.g. DNSaaS)
15:40:17 <carl_baldwin> I have started thinking about it on my own and will begin working on a bp.  If anyone reading this now or later from the logs has interest, contact me.
15:40:27 <Swami> carl: i need to drop off
15:40:49 <carl_baldwin> Swami: no problem.  I think we're about finished.
15:40:57 <Swami> thanks
15:40:59 <carl_baldwin> #topic General Discussion
15:41:31 <carl_baldwin> Is there anything anyone would like to bring up?
15:44:27 <carl_baldwin> If there is nothing else, I will wish you all well.  Until next time.
15:44:35 <carl_baldwin> #endmeeting