15:02:37 <carl_baldwin> #startmeeting neutron_l3
15:02:38 <openstack> Meeting started Thu Apr 3 15:02:37 2014 UTC and is due to finish in 60 minutes. The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:41 <openstack> The meeting name has been set to 'neutron_l3'
15:02:56 <carl_baldwin> #topic Announcements
15:03:05 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:03:21 <carl_baldwin> The deadline to submit design session topics is April 20th.
15:03:56 <carl_baldwin> I'm going to be shifting my energies for the next week to getting a couple of blueprints written and posted so that I can submit mine.
15:04:59 <carl_baldwin> #topic l3-high-availability
15:05:23 <carl_baldwin> safchain: I saw that there is a conference session on this on the agenda.
15:05:59 <safchain> carl_baldwin, yes
15:06:28 <carl_baldwin> "High availability in Neutron - Getting the L3 agent right" - I look forward to it.
15:06:44 <safchain> carl_baldwin, I probably lead it with Emilien
15:06:57 <carl_baldwin> Any update this week?
15:07:17 <carl_baldwin> I know Icehouse has shifted focus away from yours and many others' patches.
15:07:18 <safchain> nothing this week :(
15:07:45 <carl_baldwin> Thanks.
15:07:59 <carl_baldwin> I don't see Swami on yet. So, I'll skip to dynamic routing.
15:08:12 <carl_baldwin> #topic bgp-dynamic-routing
15:08:28 <nextone92> I've updated the document to reflect the discussion on GatewaySpec
15:08:47 <nextone92> the dynamic routing will be used at the edge of OpenStack instead of at each neutron router
15:08:53 <carl_baldwin> nextone92: I read mostly through it but have not finished it yet. Had an Icehouse RC1 issue come up. :(
15:09:17 <carl_baldwin> Have you received much feedback about that?
15:09:28 <nextone92> No problem, I think some of the schema sections may be too detailed and changed as part of the development
15:09:35 <carl_baldwin> I'm a fan but I'm curious about others' reactions.
15:10:38 <nextone92> I haven't received other feedback about the document...
15:11:17 <carl_baldwin> I haven't heard anything at all about the use case descriptions that I posted, either. Maybe it will take until after Icehouse winds down before others want to look at new work.
15:11:44 <nextone92> Looking forward to hearing feedback about it
15:11:53 <nextone92> I had a quick question about the conference
15:12:11 <nextone92> it would be be great to have an opportunity to discuss this document with the Neutron team
15:12:13 <carl_baldwin> I was just going to ask about the summit.
15:12:46 <nextone92> Could you recommend the best approach to add this document to discussion :)
15:13:59 <carl_baldwin> I'm not sure as I've not submitted anything myself. I think that adding some specifics around the use cases we're targeting will help focus the discussion.
15:14:43 <nextone92> Okay, that's a good idea
15:14:43 <carl_baldwin> It seems that being too vague about dynamic routing is a pitfall we should avoid.
15:16:31 <carl_baldwin> I think the place to start will be the use case document I created. I need to iterate on that one more time to be sure things are clearly spelled out. Then, maybe you can look at writing a design session proposal?
15:16:59 <nextone92> That sounds good Carl!
15:17:27 <carl_baldwin> #action carl_baldwin will iterate on use case document for clarity and then ping nextone92
15:17:46 <carl_baldwin> #link https://wiki.openstack.org/wiki/Neutron/DynamicRoutingUseCases
15:18:18 <carl_baldwin> #action carl_baldwin will finish review of bhp-dynamic-routing blueprint updates
15:18:25 <carl_baldwin> nextone92: anything else?
15:18:52 <nextone92> I think that's it, I will try to think of any other use cases and discuss with you
15:19:07 <carl_baldwin> Great, thanks.
15:19:35 <carl_baldwin> #topic L3 Agent Performance with Wrapper Overhead
15:20:03 <carl_baldwin> ajo: YorikSar: any updates?
15:20:12 <YorikSar> Hi
15:20:42 <YorikSar> I've been ironing my first patch to Neutron and tried to push the second one with new rootwrap.
15:20:58 <carl_baldwin> YorikSar: I have started a proper review of https://review.openstack.org/#/c/82787/. I'm sorry that my comments to date have been hasty and not well thought out.
15:21:40 <YorikSar> I ran into sad problem: Python on Jenkins nodes is really old (2.7.3) and there's a bug preventing use of BaseManager, but I believe I have a workaround for that.
15:22:25 <YorikSar> And I'm working on exception handling as it looks like xmlrpclib support is very basic in multiprocessing.
15:23:24 <YorikSar> I've got a lot of useful comments from Rosella for Neutron part.
15:24:04 <YorikSar> And I'll really appreciate any set of eyes looking at those change requests.
15:24:19 <carl_baldwin> Sounds like you're making progress. I just found the second openstack/neutron review that you mentioned.
15:24:41 <carl_baldwin> #link https://review.openstack.org/#/c/84667/
15:25:09 <YorikSar> carl_baldwin: Oh... It should've just worked, but Python version struck.
15:25:10 <carl_baldwin> I see that you also created a bp for it in both neutron and oslo. "rootwrap-daemon-mode"
15:25:25 <YorikSar> Yeah, forgot about blueprint :)
15:25:47 <carl_baldwin> So, for those who are following the work:
15:26:00 <carl_baldwin> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/rootwrap-daemon-mode,n,z
15:26:28 <YorikSar> I think once my second patch will work I'll start pushing changes to other projects to get more feedback there.
15:26:35 <carl_baldwin> Wait, this link is better:
15:26:37 <carl_baldwin> https://review.openstack.org/#/q/status:open+topic:bp/rootwrap-daemon-mode,n,z
15:26:48 <YorikSar> All links to all change requests are in blueprint (on etherpad)
15:27:03 <carl_baldwin> Great.
15:27:11 <carl_baldwin> Anything else this week?
15:27:29 <YorikSar> Nope. That's all I guess
15:27:51 <YorikSar> I've dealt with almost all distractions, so I should continue faster now.
15:27:51 <carl_baldwin> Thanks, YorikSar
15:28:04 <carl_baldwin> Swami: ping
15:28:10 <Swami> carl: hi
15:28:24 <carl_baldwin> #topic neutron-ovs-dvr
15:28:30 <carl_baldwin> Any updates?
15:28:58 <Swami> Hi we have posted the first WIP code for the DVr
15:29:11 <Swami> This will address the extensions to the L3 plugin to support the DVR
15:29:31 <Swami> #link https://review.openstack.org/#/c/84223/
15:29:33 <amuller> Hooray :)
15:29:41 <carl_baldwin> Great work!
15:29:51 <Swami> By next week we will have the L2 Agent code and L3 Agent code up
15:30:10 <Swami> I have already received some review comments and I will address this by this week.
15:30:18 <carl_baldwin> I hope feedback will be constructive.
15:30:30 <Swami> We have completed the East-West and moving on to the North-South implementation.
15:30:43 <Swami> Yes early feedback will be very helpfull for us to refine.
15:30:57 <Swami> Thats all I have from the DVR team.
15:32:04 <carl_baldwin> Thanks for the update. Good progress. I think seeing the WIP gives the community a great deal of confidence in the progress being made.
15:32:25 <Swami> carl: Yes that is right.
15:32:59 <carl_baldwin> #topic Open Discussion
15:33:10 <carl_baldwin> No updates on any other agenda items that I have.
15:35:22 <carl_baldwin> That is all I have this week.
15:35:51 <carl_baldwin> Thanks everyone for your work. Have a great week.
15:36:29 <safchain> carl_baldwin, Thx you too
15:36:41 <Swami> carl: Thanks
15:37:03 <carl_baldwin> #endmeeting