15:01:32 <carl_baldwin> #startmeeting neutron_l3
15:01:32 <openstack> Meeting started Thu Jun 12 15:01:32 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:36 <openstack> The meeting name has been set to 'neutron_l3'
15:01:46 <yamamoto> hi
15:01:56 <carl_baldwin> #topic Announcements
15:02:18 <carl_baldwin> Juno-1 is today.
15:02:27 <chuckC> hi
15:02:32 <devvesa> hi
15:03:25 <carl_baldwin> If you’re going to the mid-cycle sprint for nova/neutron parity, you’ll want to have booked your travel.  Kyle sent an email about the hotel block.
15:03:34 <carl_baldwin> #link https://etherpad.openstack.org/p/neutron-juno-mid-cycle-meeting
15:04:19 <carl_baldwin> #topic Bugs
15:04:28 <carl_baldwin> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=l3-ipam-dhcp
15:04:47 <carl_baldwin> I haven’t seen any new bugs of High Importance or higher.
15:06:06 <carl_baldwin> I don’t see Swami here.  We’ll leave DVR for last.
15:06:16 <carl_baldwin> #topic l3-high-availability
15:06:22 <carl_baldwin> safchain: hi
15:06:45 <safchain> carl_baldwin, hi
15:06:46 <carl_baldwin> Anything new this week?  Looks like there were a few questions on the blueprint.
15:07:28 <safchain> carl_baldwin, started to discuss with the dvr team, trying to address some comments
15:07:39 <safchain> carl_baldwin, feel free to add yours
15:08:10 <carl_baldwin> I have not revisited the bp this week.  I will do so today.
15:08:21 <safchain> carl_baldwin, seems there is a lot of dependencies with the dvr, I will have to rebase my proposal on it
15:08:24 <carl_baldwin> #action carl_baldwin will revisit l3-high-availability bp
15:08:30 <carl_baldwin> safchain: anything else?
15:08:40 <safchain> carl_baldwin, ok for me
15:09:19 <carl_baldwin> safchain: thanks
15:09:28 <carl_baldwin> #topic neutron-ipam
15:09:37 <seizadi> Hi
15:09:41 <carl_baldwin> seizadi: hi
15:09:52 <carl_baldwin> roaet_: ping
15:10:07 <seizadi> We have a few reviewers of the bp but no comments.
15:10:15 <carl_baldwin> seizadi: I did an initial read through of your blueprint but have not finished my comments.
15:10:33 <carl_baldwin> I added a handful of reviewers to it as well.
15:10:49 <seizadi> Great, we are trying to meet the Juno2 date but need the comments to scope the effort
15:10:51 <carl_baldwin> I think Juno-1 may have taken reviewers’ energies this week.
15:11:03 <seizadi> OK
15:11:25 <seizadi> That
15:11:35 <seizadi> is it for this week.
15:11:55 <carl_baldwin> seizadi: One thought that I had when I read through it is that I think I’d like to see IPAM decoupled from the DHCP implementation.
15:12:41 <carl_baldwin> I realize that they may be coupled in some external implementations but decoupling them wont’ prevent an implementation from implementing both.
15:12:45 <carl_baldwin> Any thoughts?
15:12:50 <seizadi> Yes, we wanted to decouple DHCP and DNS from bp. If there is anything like that point it out. We might have missed something. I will look at it again.
15:13:50 <carl_baldwin> I will read through it again and add my comments soon.
15:14:12 <carl_baldwin> #action carl_baldwin will also review neutron-ipam bp.
15:14:18 <carl_baldwin> seizadi: anything else?
15:14:19 <seizadi> The IPAM driver is abstract class, we will have couple implements one that does what the current functionality and one that will talk to our Infoblox solution.
15:14:40 <seizadi> No other update.
15:14:52 <carl_baldwin> seizadi: thanks
15:15:10 <carl_baldwin> #topic bgp-dynamic-routing
15:15:40 <carl_baldwin> nextone92: devvesa: ping
15:15:49 <devvesa> hi
15:16:21 <devvesa> nextone92 is not available today
15:16:30 <carl_baldwin> okay.  Updates?
15:16:41 <yamamoto> hi
15:16:53 <devvesa> I summited a new patch based on the conversation we had after the meeting
15:16:56 <carl_baldwin> yamamoto: hi
15:16:56 <devvesa> about the use cases
15:17:27 <devvesa> but i've been busy in other stuff this week and I haven't played with the Ryu bgp speaker
15:17:39 <carl_baldwin> devvesa: Yes, I need to review that update as well.  I’ve had juno-1 blinders on for a week or so.
15:17:56 <yamamoto> ryu team is working on new api which is hopefully easier to use than the current one
15:18:06 <yamamoto> http://sourceforge.net/p/ryu/mailman/message/32434586/
15:18:59 <devvesa> but I understand the current bgp speaker is part of the whole ryu library
15:19:13 <devvesa> are you planning to update the neutron dependency?
15:19:26 <yamamoto> ?
15:19:55 <devvesa> i mean, ryu is a dependency of neutron, right?
15:20:17 <yamamoto> ryu plugin and ofagent depends on ryu
15:21:04 <yamamoto> neutron’s requirement.txt doesn’t have ryu
15:21:07 <yamamoto> do you mean this?
15:21:10 <devvesa> yes
15:21:18 <devvesa> ok, then forget it
15:21:34 <carl_baldwin> yamamoto:  Do you need input from us for this work?
15:21:46 <yamamoto> the current practice is install ryu with pip when using ofagent or ryu plugin
15:22:06 <yamamoto> yes we love to hear opinions from neutron folks
15:23:21 <carl_baldwin> yamamoto: Could the speaker be broken out into a library?
15:23:41 <yamamoto> what do you mean?  packaging?
15:23:48 <carl_baldwin> More or less, yes.
15:24:23 <yamamoto> bgp-only library is preferable?
15:24:58 <carl_baldwin> We’ll have a core piece of neutron depending on ryu so I think it would be added as a formal dependency.  I’m just wondering if that would be easier with a bpg-only library.
15:25:13 <carl_baldwin> I’m not really stating any requirements yet.  Just thinking out loud to get your thoughts.
15:25:20 <devvesa> yamamoto: that would be great for me
15:25:23 <yamamoto> ok, i’ll discuss the possibility with the rest of ryu folks
15:25:35 <carl_baldwin> yamamoto: Thanks.
15:25:45 <yamamoto> but installing the whole ryu and just using only bgp part should be fine
15:25:48 <devvesa> btw, yamamoto: do you think is better that i use the current development branch with the new API
15:25:58 <yamamoto> unless you concern disk space :-)
15:26:15 <carl_baldwin> devvesa: Will you be able to review their new API?
15:26:20 <yamamoto> devvesa yes
15:26:46 <yamamoto> but the patch i mentioned with the above url has not been merged yet
15:27:02 <yamamoto> i’ll tell you when it’s merged
15:27:06 <devvesa> great
15:27:25 <devvesa> when do you estimate it will be?
15:28:00 <yamamoto> hopefully by early next week
15:28:03 <carl_baldwin> devvesa: A review of the unmerged code would be good.  If we have any feedback, it could be worked in before merge.
15:28:51 <devvesa> ok!
15:28:52 <yamamoto> yea, the patch above have a comment which has a usage example
15:29:26 <devvesa> #link http://sourceforge.net/p/ryu/mailman/message/32434586/
15:29:34 <devvesa> (better to come back later)
15:29:57 <yamamoto> we want to hear on which event you want callbacks
15:29:57 <carl_baldwin> #action devvesa will review BGP speaker API.
15:30:31 <carl_baldwin> devvesa: Feel free to pull me in for discussion.  I’ll be a bit scarce over the next week but I’ll check in on email.
15:30:46 <carl_baldwin> Anything else on this topic?
15:30:53 <yamamoto> nothing from me
15:30:58 <devvesa> nothing from me neither
15:31:24 <carl_baldwin> yamamoto: devvesa: thank you.
15:31:45 <devvesa> thanks to you
15:32:01 <carl_baldwin> #topic neutron-ovs-dvr
15:32:28 <yamamoto> thank you
15:32:34 <carl_baldwin> A lot of the DVR team are on vacation this week.
15:32:47 <carl_baldwin> Is anyone here to represent the DVR team?
15:33:16 <carl_baldwin> I can give a report.
15:33:42 <carl_baldwin> A few patches on the dvr topic merged for juno-1.  However, the bulk of the work is still under review.
15:35:17 <carl_baldwin> The team has completed all of the features internally and are busy pushing patches up now.
15:36:27 <carl_baldwin> This is a top priority for the Neutron team.
15:36:30 <carl_baldwin> #link https://review.openstack.org/#/q/topic:bp/neutron-ovs-dvr,n,z
15:36:57 <carl_baldwin> I put some notes for reviewers on the this link:
15:37:08 <carl_baldwin> #link https://wiki.openstack.org/wiki/Neutron/DVR/HowTo
15:37:29 <carl_baldwin> I’ve started adding notes about the deployment of DVR as well to this page.
15:38:15 <carl_baldwin> I’m building a reference two-node devstack system.  If anyone would like help building a system of their own, I can give you access to mine to use as reference.
15:38:23 <carl_baldwin> Contact me out of band for details.
15:39:00 <carl_baldwin> chuckC: Related to this topic, is there anything that you have to discuss?
15:39:32 <chuckC> not much, still getting my 2-node devstack system going
15:39:46 <chuckC> I'll be helping out with system testing
15:40:29 <carl_baldwin> chuckC: That will be great.
15:41:10 <carl_baldwin> Are there others with interest in testing the DVR code?
15:42:19 <carl_baldwin> chuckC: I can work with you on this a bit.  I’ll be continuing to work on my reference system.
15:42:24 <chuckC> We need help from folks with related experience
15:42:43 <chuckC> carl_baldwin: thanks
15:42:57 <carl_baldwin> chuckC: noted, I will engage a few cores with testing skills for discussion.
15:44:22 <carl_baldwin> #topic Open Discussion
15:45:07 <pcm_> carl_baldwin: For client validation removal. See you signed up for that. Thanks!
15:45:30 <pcm_> carl_baldwin: Should the resolution be to convert the enum attributes to strings?
15:45:41 <carl_baldwin> pcm_: Did I miss your topic?
15:45:49 <pcm_> Sure, but np
15:46:18 <carl_baldwin> #topic l3-svcs-vendor-*
15:46:27 <carl_baldwin> Sorry for the oversight.
15:46:32 <pcm_> np
15:46:49 <pcm_> BP for vendor validation was approved. Appreciated the reviews.
15:47:14 <carl_baldwin> pcm_: Great.
15:47:30 <pcm_> Having a bit of problem with UT for VPN code for this. Making changes now. Hope to push out Fri or Mon
15:47:37 <carl_baldwin> pcm_: I might have missed something in my patch.
15:47:39 <pcm_> (side tracked by other items)
15:48:24 <pcm_> For the client side validation removal, I saw you sign up for it. Thanks! Is there a patch out?
15:48:50 <carl_baldwin> pcm_: Did you see the patch I put up?  I think what I did was to effectively remove the enum and accept any string.
15:49:11 <carl_baldwin> #link https://review.openstack.org/#/c/99437/
15:49:27 <pcm_> carl_baldwin: Not yet. Will look for it. Cool I was wondering if that would be the right thing to do (enum->string)
15:50:09 <pcm_> Will review today.
15:50:30 <pcm_> Appreciate you grabbing that. I've been swamped. :(
15:50:39 <pcm_> That's all I have.
15:50:45 <carl_baldwin> It was a really easy change.  That’s why I took it on.  I needed something easy to get through because I was stuck on everything else I was trying to do yesterday.  :)
15:51:20 <pcm_> :)
15:51:33 <carl_baldwin> pcm_: Let me know if you want to discuss about the unit tests.  I’ll be around today but not tomorrow.
15:51:42 * pcm_ knows exactly what you mean from this week
15:52:34 <pcm_> carl_baldwin: Will do. I think I have it sorted out. Purely an issue with mocking.
15:52:50 <carl_baldwin> Cool.  Let me know.
15:52:59 <pcm_> Will certainly seek you and others out!
15:53:08 <carl_baldwin> pcm_: Thanks for your report.  I won’t leave you out next time.
15:53:19 <pcm_> no problemo
15:53:31 <carl_baldwin> #topic Open Discussion
15:55:37 <carl_baldwin> Thanks everyone.
15:55:44 <carl_baldwin> #endmeeting