15:01:06 <haleyb> #startmeeting neutron_l3
15:01:06 <openstack> Meeting started Thu Jun 19 15:01:06 2014 UTC and is due to finish in 60 minutes. The chair is haleyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:10 <openstack> The meeting name has been set to 'neutron_l3'
15:01:20 <chuckC> o/
15:01:24 <yamamoto> hi
15:01:32 <haleyb> hi - i'm standing in for carl today, so be gentle :)
15:01:41 <devvesa> hi
15:02:10 <haleyb> #topic Announcements
15:02:50 <haleyb> i don't have any specific announcements, i'll just re-post that the interim meeting is coming up soon if you haven't made plans yet
15:03:23 <haleyb> #topic Bugs
15:03:40 <salv-orlando> aloha
15:03:43 <haleyb> Are there any bugs anyone wants to discuss?
15:05:52 <haleyb> #topic l3-high-availability
15:06:53 <chuckC> I don't see safchain
15:06:56 <haleyb> i don't see sylvain here so i'll come back to it later if necessary
15:07:04 <haleyb> #topic neutron-ipam
15:07:16 <seizadi> hi,
15:07:20 <haleyb> hi
15:07:40 <seizadi> I got some comment mostly formatting errors and I am going through and fixing them.
15:08:25 <seizadi> We are still on track to meet Juno-2 milestone.
15:08:48 <seizadi> Looking for all the comments from community.
15:09:19 <seizadi> That's it from me.
15:09:48 <haleyb> ok, thanks. i did notice the gerrit link on the subteam page leads to an empty page, don't know if that can be fixed by tagging your specs review differently
15:10:38 <seizadi> Can you send me the link, I can followup?
15:10:44 <chuckC> the link to the ipam spec on the agenda page is bad
15:10:59 <haleyb> sure, https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:11:12 <seizadi> from L3 Meeting page?
15:11:35 <chuckC> seizadi: yes
15:11:44 <haleyb> yes, there's a Gerrit Topics link there i clicked to see your spec, but it shows nothing
15:11:44 <seizadi> If I can edit the wiki I will fix it.
15:12:11 <haleyb> if not let me or carl know
15:12:17 <seizadi> OK
15:12:59 <haleyb> i think it might just be how you tag the review, but i don't know
15:13:33 <haleyb> #action seizadi will get gerrit topic link on subteam page to work
15:13:43 <haleyb> #topic bgp-dynamic-routing
15:14:19 <devvesa> hi
15:14:59 <devvesa> the state is the same than the last week, we are waiting for Carl's review
15:15:08 <yamamoto> hi
15:15:17 <devvesa> yamamoto: hi
15:15:31 <yamamoto> ryu team is working on ipv6 peering and advertizement
15:15:51 <haleyb> devvesa: thanks, carl is out this week
15:16:42 <devvesa> haleyb: yes! I've seen the mail
15:17:05 <haleyb> yamamoto: thanks, is there a spec for that? didn't it on the subteam page
15:17:46 <yamamoto> no, i’m just talking about ryu bgp implementation which might be used by the bgp-dynamic-routing bp.
15:17:57 <haleyb> ah, ok, thanks
15:19:12 <yamamoto> are orange folks here? they might want to introduce their bgp speaker.
15:20:27 <yamamoto> devvesa: what’s the status of your poc?
15:20:45 <devvesa> i'm going to send a mail to ryu's mailing list today with some thoughts and ideas
15:21:16 <yamamoto> thank you very much. we loves to hear that!
15:21:23 <devvesa> currently I'm connecting ryu's with a quagga's bgpd daemon with your example code
15:21:35 <devvesa> but I haven't spend the time I would like to it
15:23:33 <haleyb> anything else on bgp?
15:24:01 <yamamoto> nothing from me
15:24:11 <devvesa> not me neither
15:24:18 <haleyb> ok, thanks, i'll move to next topic
15:24:22 <haleyb> #topic neutron-ovs-dvr
15:24:25 <yamamoto> thanks
15:24:50 <haleyb> There was no DVR meeting this week, and i believe most of the team is out
15:25:28 <armax> haleyb: yes
15:25:30 <haleyb> I am continuing to work on our multi-node devstack systems, but time has not cooperated as I expected
15:25:39 <armax> but there’s still some progress being made
15:26:02 <armax> as far as the patches withe the bulk of the feature
15:26:20 <armax> also, we’re preparing a recording that shows the feature in actio
15:26:20 <armax> n
15:26:29 <armax> so that people can better visualize what’s going on
15:26:36 <armax> that’s all I have
15:26:58 <chuckC> haleyb: I have volunteered to help with dvr testing, and have multi-node devstack working without dvr, if that might help
15:28:47 <haleyb> chuckC: we have the same here, and were doing a baremetal install as well. I was hoping to at least get some patches out this week just to enable it in local.conf, maybe tomorrow
15:29:29 <haleyb> armax: thanks, and it seems like there is still some active reviewing on the patches so that is good
15:29:34 <chuckC> haleyb: ok to chat outside channel?
15:29:50 <haleyb> sure, ping me after meeting
15:29:54 <armax> haleyb: btw I was going to collate all patches in a single branch
15:29:59 <armax> for easier consumption
15:30:15 <armax> however I am waiting for the last bits to come alone before that’s complete
15:30:41 <armax> haleyb: I think there are still a few loose ends that need to be tied
15:31:17 <armax> haleyb: up and then I’ll publish it here https://wiki.openstack.org/wiki/Neutron/DVR/HowTo
15:31:30 <haleyb> armax: that would be great getting things on one branch, would make installing them into devstack easier
15:31:32 <armax> haleyb, chuckC: if you have localrc to share, gotchas etc
15:31:40 <armax> please post it to that wiki page ^
15:32:02 <yamamoto> i peeked some of dvr changes and got a little surprised that it was big and intrusive than i expected.
15:32:18 <armax> haleyb: yes
15:32:40 <armax> haleyb: also we need to figure if something needs to go to devstack itself
15:33:02 <armax> haleyb: especially when more automated tests are introduced
15:33:51 <haleyb> armax: at a minimum something like "q-dvr" to turn-on the correct flags, but it's not just one option from my reading
15:35:47 <armax> we’ll see...
15:35:56 <armax> these days everything can be controlled by a local.conf
15:36:10 <armax> so that might be a setting for a new experimental jenkins job
15:36:22 <armax> haleyb: need to cordinate with openstack-infra
15:38:10 <haleyb> yes, once we can get it enabled consistently we need to look at the testing side more
15:38:48 <armax> anyhoo that’s all from me
15:38:56 <haleyb> ok, thanks
15:39:21 <haleyb> #topic l3-svcs-vendor-*
15:39:50 <haleyb> i don't see pcm
15:40:19 <haleyb> did notice he did update https://review.openstack.org/#/c/96946/ the other day
15:40:35 <haleyb> #link https://review.openstack.org/#/c/96946/
15:40:52 <haleyb> #topic Open Discussion
15:42:12 <haleyb> anyone have anything else they want to discuss? otherwise you can have 20 minutes back for reviews :)
15:42:41 <yamamoto> earlier end of meeting is fine for me as it’s midnight here :)
15:42:51 <yamamoto> nothing from me
15:43:18 <haleyb> ok then, thanks everyone
15:43:20 <haleyb> #endmeeting