15:02:18 <carl_baldwin> #startmeeting neutron_l3
15:02:19 <openstack> Meeting started Thu Jul  3 15:02:18 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:23 <openstack> The meeting name has been set to 'neutron_l3'
15:02:28 <carl_baldwin> #topic Announcements
15:02:59 <carl_baldwin> The mid-cycle sprint is next week.  I will probably not run this meeting but should be very active on IRC.
15:03:14 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:03:35 <carl_baldwin> Juno-2 is just about 3 weeks away.
15:03:49 <carl_baldwin> Did everyone see the post about the bp submission deadline?
15:04:05 <devvesa> i did
15:04:15 <carl_baldwin> #link http://lists.openstack.org/pipermail/openstack-dev/2014-July/039138.html
15:04:53 <carl_baldwin> I’ll turn some extra attention toward the BGP and IPAM blueprints today.
15:05:16 <carl_baldwin> The BPG blueprint is doing pretty well I think.  At least I understand what will be done I think.
15:05:31 <devvesa> thanks!
15:05:44 <carl_baldwin> The IPAM bp may need a little more fleshing out with detail from my perspective.
15:06:02 <seizadi> I got some comments last night and I will update today.
15:06:17 <carl_baldwin> It has already been proposed, so it has until the 20th to get in to shape.
15:06:36 <carl_baldwin> seizadi: great.  ping me when you update and I’ll read it more thoroughly today.
15:06:44 <carl_baldwin> viveknarasimhan: hi
15:06:50 <carl_baldwin> yisun: hi
15:06:55 <viveknarasimhan> hi carl
15:07:15 <carl_baldwin> #topic neutron-ovs-dvr
15:07:33 <carl_baldwin> Great progress here so far this week.
15:08:12 <carl_baldwin> I have had some success with my own two-node devstack deployment.  I did a handful of hand fixes but then I was able to get a pingable floating ip.
15:08:48 <carl_baldwin> I’m very pleased to bring something that I have been able to get to work to the mid-cycle meeting.
15:09:16 <carl_baldwin> viveknarasimhan: armax: mrsmith: any progress updates?
15:09:38 <viveknarasimhan> carl
15:09:44 <viveknarasimhan> i responded to few review comments
15:10:09 <viveknarasimhan> rest of time i spent on getting dvr work over OOO
15:10:11 <carl_baldwin> Great, I haven’t had a chance to look this morning.
15:10:20 <mrsmith> I've replied to comments as well
15:10:34 <mrsmith> worked with armax on simplifying the agent cfg
15:10:50 <mrsmith> getting the 3 cfg options down to one "mode" option with three modes
15:11:00 <mrsmith> seems like a good change - to simplify
15:11:10 <carl_baldwin> Yes, armax mentioned that.  I think it will be an intuitive improvement.
15:11:14 <mrsmith> I plan to push updates to l3-scheduler and l3-agent for the same
15:11:26 <mrsmith> today that is
15:11:47 <viveknarasimhan> also request specific trigger tha tled to the attribute exception on update_port_postcommit
15:12:17 <mrsmith> carl_baldwin: was there an open question on port host binding ?
15:12:18 <carl_baldwin> Great!  We’ll need to coordinate a change to the howto wiki but I can probably do that when I push the update to my github branche.
15:12:21 <carl_baldwin> *branch
15:12:41 <carl_baldwin> mrsmith: You mean the schema problem?
15:12:42 <yamamoto> do you have a plan to update l2 doc etc?
15:12:57 <mrsmith> carl_baldwin: yes
15:13:04 <carl_baldwin> yamahata: to which l2 doc are you referring?
15:13:25 <carl_baldwin> viveknarasimhan: I think I put all that I know about the exception in the comments.  We can talk after if you need.
15:13:26 <yamamoto> https://docs.google.com/document/d/1depasJSnGZPOnRLxEC_PYsVLcGVFXZLqP52RFTe21BE/edit?pli=1#heading=h.5w7clq272tji
15:13:28 <viveknarasimhan> yes yamamoto
15:13:35 <viveknarasimhan> i could not update that due to permission issue
15:13:46 <viveknarasimhan> i will put an errata document and attach it to blueprint and ping you
15:14:04 <viveknarasimhan> i will update with new rules that we did for good performace improvement on the data path
15:14:12 <yamamoto> can't you just copy and update?
15:14:27 <viveknarasimhan> that is what i did
15:14:33 <viveknarasimhan> copied it , updating the rules
15:14:47 <viveknarasimhan> i will post you by tomorrow
15:14:52 <yamamoto> thank you
15:15:28 <carl_baldwin> viveknarasimhan: Is it appropriate to update the spec in neutron-specs?  I would prefer the updates go there if possible.
15:15:45 <viveknarasimhan> ok i will update it in neutron-specs
15:16:04 <yamamoto> i prefer to put the updated doc near the code
15:16:04 <viveknarasimhan> but first i put modified word doc for yamamoto
15:16:17 <yamamoto> eg. comment in code or README or something like that
15:16:21 <carl_baldwin> It will have to go through review but that should be much easier than the initial merge of the spec.
15:17:13 <carl_baldwin> yamamoto: that may also be appropriate.  I’ll let you guys decide.
15:17:29 <yamamoto> neutron-specs is fine for me.  we can copy it into README etc later
15:17:57 <carl_baldwin> mrsmith: I am thinking of implementing the conversion from legacy router to distributed as a follow-on patch.  Do you have any objection.
15:17:58 <carl_baldwin> ?
15:18:21 <mrsmith> sounds good... thats what we were planning... follow on dev
15:18:23 <carl_baldwin> I was thinking I could have some time for it at the mid-cycle sprint next week.
15:18:48 <viveknarasimhan> mike as per our earlier discussion , are we allowing conversion both ways (legacy to dist and vice-versa) , or is it just one-way path for simplicity?
15:18:51 <carl_baldwin> mrsmith: Okay, I will plan to implement it.
15:19:11 <mrsmith> eventually we want to support both ways
15:19:12 <carl_baldwin> viveknarasimhan: I’m planning on doing only the one way initially.
15:19:19 <mrsmith> +1
15:19:26 <carl_baldwin> But, will look at supporting the other way at a later time.
15:19:28 <mrsmith> piece by piece... ;)
15:19:33 <viveknarasimhan> ok
15:19:49 <mrsmith> carl_baldwin: do you think it will affect more than l3-agent?
15:20:04 <carl_baldwin> Yes, I do but I haven’t scoped out the whole thing yet.
15:20:06 <mrsmith> as in, l3-plugin and l3-sched may have impact?
15:20:10 <mrsmith> ok
15:20:27 <mrsmith> I assume it would affect those modules as well
15:20:30 <carl_baldwin> Yes.  The scheduler and plugin will most likely need some work.
15:20:31 <viveknarasimhan> l3-plugin, cli, l3-sched, l3-agent all of them have impact
15:20:37 <mrsmith> :)
15:20:42 <yamamoto> are you talking about live-conversion?
15:20:47 <viveknarasimhan> l2-agent may operate as is
15:20:51 <carl_baldwin> The cli is minimal.  Actually, the cli pretty much works already.
15:21:21 <carl_baldwin> yamamoto: Yes.  Though there may be a hiccup in the routing.
15:21:32 <viveknarasimhan> yes, conversion when router is running, packets may drop minimally
15:21:51 <carl_baldwin> viveknarasimhan: Yes, it should be minimal.
15:22:15 <carl_baldwin> Anything else for DVR?
15:23:01 <carl_baldwin> #topic l3-high-availability
15:23:02 <mrsmith> no...
15:23:05 <viveknarasimhan> nope..
15:23:41 <carl_baldwin> safchain: I was going to add this back to the agenda since armax has taken an interest in driving it to completion.  But, I don’t see armax around.
15:24:19 <safchain> Yes we plan to work on it with him and maybe Amuller
15:24:35 <carl_baldwin> I have an interest as well because I think it is long overdue.  I’ll be a second core reviewer on it.
15:24:54 <safchain> I hope I will be able to get more bandwidth to work on it
15:24:57 <safchain> ok great
15:25:11 <yamamoto> i have some interest because ryu has vrrp impl.
15:25:23 <carl_baldwin> Great to see some interest and I hope to see it get through soon after DVR merges.
15:25:47 <carl_baldwin> yamamoto: great.  The bp needs to merge first.  Let’s get that in by the 20th deadline.
15:26:31 <carl_baldwin> Anything else?
15:26:41 <yamamoto> nothing from me
15:26:42 <safchain> yamahata, so the bp was about using keepalived as a first impl but open to another one/driver
15:26:49 <safchain> ok for me
15:26:51 <yamamoto> safchain: yes i know
15:27:32 <safchain> yamahata, I have to sync with you to understand the ryu impl
15:27:36 <carl_baldwin> cool, let’s have discussion on the bp review.  armax and I will divert attention to that to get it merged.
15:27:55 <carl_baldwin> #topic pluggable-ext-net
15:28:45 <carl_baldwin> Nothing much to say here except that I will be starting this work on top of the DVR code.  Need the bp to merge by the 20th as well.
15:29:01 <carl_baldwin> #topic l3-svcs-vendor-*
15:29:05 <carl_baldwin> pcm_: hi
15:29:43 <viveknarasimhan> carl
15:29:51 <viveknarasimhan> one more thing related to DVR
15:30:08 <carl_baldwin> viveknarasimhan: sure.
15:30:16 <viveknarasimhan> will speak about it at end of session so not to interrupt current topic
15:30:35 <carl_baldwin> pcm_: Anything new here?  Looks like you’re still working through an oslo issue?
15:30:48 <pcm_> hi. Yes need review of https://review.openstack.org/#/c/102351/
15:31:01 <pcm_> Waiting for oslo new release to be avail.
15:31:18 <pcm_> but have tested locally with new oslo version.
15:31:23 <carl_baldwin> pcm_: Right, I actually have some draft comments I never finished.
15:31:33 <pcm_> thanks!
15:31:44 <carl_baldwin> #action carl_baldwin will review https://review.openstack.org/#/c/102351/.
15:31:55 <carl_baldwin> Need anything on the oslo issue?
15:32:00 <carl_baldwin> pcm_: ^
15:32:43 <pcm_> not sure. Wondering what they (infra) need to do to make the prerelease available.
15:33:15 <carl_baldwin> Has the bug been fixed in the code?  Just needs release?
15:33:34 <carl_baldwin> I see.
15:34:05 <carl_baldwin> It may just be a matter of time to release and then update Neutron requirements.
15:34:16 <pcm_> yes
15:34:16 <carl_baldwin> Have you validated the fix locally using the new release?
15:35:32 <carl_baldwin> pcm_: ^
15:35:54 <pcm_> yes (sorry in two meetings)
15:36:06 <yamamoto> <- wondering what "^" means
15:36:49 <carl_baldwin> yamamoto: It is pointing to the previous message.  I do that when I realize that I forgot to include his nick to grab his attention.
15:37:09 <yamamoto> ah i see.  it's an arrow.  thanks
15:37:16 <carl_baldwin> #topic neutron-ovs-dvr
15:37:22 <carl_baldwin> viveknarasimhan: You had one more thing?
15:38:09 <viveknarasimhan> yeah carl
15:38:25 <viveknarasimhan> there is a racing issue between l2-pop tunnel-bridge access and DVR tunnel-bridge access
15:38:39 <viveknarasimhan> there was a review posted to address this concurrency issue
15:38:47 <carl_baldwin> Do you have a link?
15:39:07 <viveknarasimhan> https://review.openstack.org/#/c/77578/
15:39:23 <viveknarasimhan> this changeset needs to be honed back for DVR
15:39:48 <viveknarasimhan> as bulk rules addition for l2-pop doesn't work well with bulk rules addition by DVR at the same time on the tun-br
15:39:49 <yamamoto> modfying flows in rpc handlers is prone to race
15:40:20 <viveknarasimhan> well, existing l2-pop logic does it that way
15:40:21 <carl_baldwin> viveknarasimhan: “honed back?”
15:40:37 <viveknarasimhan> we need to pick up that review and drive it to completion ('honed back' )
15:40:48 <yamamoto> viveknarasimhan: yes i know.  modular l2 agent folks are talking about having a dedicated thread
15:41:07 <viveknarasimhan> that would be best
15:41:25 <viveknarasimhan> right now it is a subprocess, but feedign data to that subprocess is not guaranteed
15:41:33 <viveknarasimhan> some flows lost, when both write to tun-br
15:42:02 <yamamoto> having a lock can be a short term fix?
15:42:16 <carl_baldwin> I’ll make a note of this in the subteam page and I’ll work it in to my github branch as well.
15:42:32 <carl_baldwin> viveknarasimhan: Thanks for bringing this to our attention.  We can discuss the details in the review.
15:42:36 <viveknarasimhan> i can help work with you after internal commits get over
15:42:59 <carl_baldwin> #action carl_baldwin will work https://review.openstack.org/#/c/77578/ in to the current DVR work.
15:43:09 <carl_baldwin> viveknarasimhan: Great.
15:43:11 <carl_baldwin> Anything else?
15:43:16 <viveknarasimhan> thanks carl. that is it.
15:43:36 <carl_baldwin> #topic bgp-dynamic-routing
15:43:39 <carl_baldwin> devvesa: hi
15:43:41 <devvesa> hi
15:44:43 <carl_baldwin> I’ll take one more look at PS9 but I think I’m close to +2.  We’ll need to find another core to give it a fresh set of eyes.
15:45:10 <devvesa> i'll ping Nachi again
15:45:20 <yamamoto> any update on poc code?
15:45:26 <carl_baldwin> devvesa: Yes, Nachi.
15:45:39 <devvesa> yamamoto: not this week
15:45:55 <devvesa> yamamoto: i've seen the new Ryu release, I'll give a try next week
15:46:24 <yamamoto> we (ryu team) plan to work on filtering support.
15:47:04 <yamamoto> do you have an idea when you will need the functionality?
15:47:24 <devvesa> with the next-hop and password features i can be busy for a while with the development
15:47:52 <carl_baldwin> devvesa: How do you feel about hitting juno-3 with a complete implementation?
15:47:53 <yamamoto> ok.  let me know if you want us hurry.
15:48:18 <devvesa> carl_baldwin: this was my initial idea, to be able to finish before juno-3
15:48:38 <carl_baldwin> #link https://wiki.openstack.org/wiki/Juno_Release_Schedule
15:49:02 <devvesa> actually, I will have vacations just after juno-3... so I must finish then
15:49:19 <carl_baldwin> devvesa:  sounds good.
15:49:47 <devvesa> i will upload WIP patches anyway. so you can follow the evolution
15:50:03 <carl_baldwin> yamamoto: devvesa:  You can work backwards from there to decide when that feature will be needed to complete development.
15:50:11 <carl_baldwin> devvesa: That will be great.
15:50:23 <carl_baldwin> devvesa: yamamoto: Anything else?
15:50:31 <yamamoto> nothing from me
15:50:38 <devvesa> nothing from me neither
15:50:51 <carl_baldwin> Thanks.
15:51:00 <carl_baldwin> #topic neutron-ipam
15:51:03 <carl_baldwin> seizadi: hi
15:51:21 <seizadi> We have had comments and I have been turning them around, got some more last night that I will update the bps.
15:51:21 <seizadi> Still on track for Juno-2, now there is a hard deadline for bp, I will make sure I turn around the latest comments today.
15:51:21 <seizadi> We are also working on Thrid Party CI so that we can submit our External IPAM solution in addition to Default IPAM for Juno-2.
15:51:22 <seizadi> We heard from Atlanta Summit from Community that IPv6 was desirable for IPAM, been looking at the IPv6 support to test for IPAM. Find IPv6 support not driven like other projects as a focus effort. The wiki page is here: https://wiki.openstack.org/wiki/Neutron/IPv6#Blueprints
15:52:05 <seizadi> We will test what is in Juno, but have concern about having complete IPv6 functionality in Juno.
15:53:32 <carl_baldwin> seizadi: Your concern is noted.  Please design with IPv6 in mind.  Current IPv6 functionality should still work with the implementation.  However, I realize it is a moving target at the moment.
15:53:53 <carl_baldwin> Don’t be so concerned about it that you cannot make forward progress on the rest.
15:54:10 <carl_baldwin> I will look over the reviews with an eye on IPv6.
15:54:38 <seizadi> OK, we are tracking the patches some are not merged yet
15:55:06 <carl_baldwin> seizadi: What is the link to your bp?
15:55:40 <seizadi> It is on L3 Meeting page
15:56:07 <carl_baldwin> I’m having trouble hitting launchpad again for some reason.
15:56:28 <seizadi> https://review.openstack.org/#/c/97986/
15:56:29 <carl_baldwin> Am I the only one that gets a lot of DNS failures when trying to go to launchpad?
15:57:14 <yamamoto> seizadi: you should fix the topic
15:57:45 <carl_baldwin> yamamoto: Thanks, I was about the suggest the same.
15:58:04 <seizadi> OK
15:58:08 <yamamoto> launchpad is working for me
15:58:55 <seizadi> Here is the other bp https://review.openstack.org/#/c/97967/
15:58:57 <carl_baldwin> #link https://review.openstack.org/#/c/97967/
15:59:02 <carl_baldwin> seizadi: :)
15:59:07 <chuckC> last minute or so
15:59:34 <carl_baldwin> seizadi: Be sure the topic is correct on this one as well.
15:59:52 <seizadi> Ok
15:59:59 <carl_baldwin> git review sometimes mangles topics if you have the word blueprint in your commit message.
16:00:10 <carl_baldwin> chuckC: Thanks, did you have anything?
16:00:14 <chuckC> I posted the Link Aggregation spec https://review.openstack.org/103765.  I think it's relevant for the L3 team because the main short-term issue is around DHCP.
16:00:47 <chuckC> The main issue is booting baremetal node from one of a set of interfaces and end up with the same ip address regardless of which
16:00:48 <yamamoto> i saw someone writing "|3lueprint" or such for poor gerrit
16:00:48 <carl_baldwin> chuckC: I’ll have a look.
16:01:04 <chuckC> carl_baldwin: thanks
16:01:19 <carl_baldwin> chuckC: I’ll have a look.
16:01:31 <carl_baldwin> Anything else?  We’re out of time.
16:01:38 <yamamoto> nothing from me
16:01:50 <carl_baldwin> Great work all around.  Thanks everyone!
16:01:55 <carl_baldwin> #endmeeting