15:01:34 <carl_baldwin> #startmeeting neutron_l3
15:01:37 <openstack> Meeting started Thu Jul 24 15:01:34 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:41 <openstack> The meeting name has been set to 'neutron_l3'
15:01:42 <carl_baldwin> #topic Announcements
15:01:49 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:02:08 <carl_baldwin> I haven’t had a chance to update the agenda but it isn’t too far off.
15:02:30 <carl_baldwin> I think today is Juno-2.  I’m sure the gate queue is nice and long.
15:03:03 <pcm_> Kyle mentioned they did Juno-2 yesterday
15:03:21 <carl_baldwin> I missed that.
15:03:45 <pcm_> Heard it at, I think, Adv Svcs meeting.
15:04:08 <yamamoto> i heard it at ml2 meeting
15:04:39 <carl_baldwin> Cool.
15:05:06 <carl_baldwin> #topic neutron-ovs-dvr
15:05:52 <carl_baldwin> Looks like we’ve had 5/7 of the original patches merge now.
15:06:11 <armax> carl_baldwin: yes, pendind ML2+L3 Sched
15:06:23 <carl_baldwin> Still blocked with -2
15:06:47 <armax> the few others outstanding are not in the critical path for getting started with DVR
15:06:51 <carl_baldwin> armax: any more update on that?
15:06:57 <armax> carl_baldwin: true, I spoke with Bob yesterday
15:07:39 <armax> armax: I’ll poke him again, we’ve agreed that he’ll review the patch and see if he spots anything else that might prevent this patch from moving forward
15:08:15 <armax> carl_baldwin: but from his initial reaction he seems okay to lift the -2
15:08:30 <armax> carl_baldwin: we’ve gone through a number of iterations after his initial feedback
15:08:32 <Swami> hi
15:08:56 <carl_baldwin> That would be great.  I think we need to merge these 2 patches so that we can use trunk to test.
15:09:02 <armax> and vivek and I are a lot more confident that this ML2 does what it’s supposed to do
15:09:03 <carl_baldwin> Swami: hi
15:09:22 <carl_baldwin> armax: That is goodness.
15:09:49 <armax> carl_baldwin: also 3rd party Tests seem to be happy on the latest PS (44)
15:10:00 <armax> carl_baldwin: so I am pretty positive we are ready to nail this one
15:10:06 <armax> carl_baldwin: but then you’re never know ;)
15:10:08 <armax> you'll
15:10:57 <carl_baldwin> We’ll still need to iterate a bit to get it right.
15:11:49 <armax> carl_baldwin: right. There are other things we need to refine
15:12:03 <armax> carl_baldwin: but it makes sense to do them as follow-up work for now
15:12:20 <armax> carl_baldwin: as they kind of go beyond dvr proper
15:12:31 <carl_baldwin> armax: agreed.  I think we’ll be able to tackle them at a faster pace with the patches merged.
15:12:50 <armax> carl_baldwin: for instance I am pursuing the idea of a binding manager
15:13:02 <armax> carl_baldwin: to break out the port binding logic out of the ML2 plugin
15:13:37 <armax> carl_baldwin: rkukura had an initial positive reaction to the idea, but I need more work around this area
15:13:53 <carl_baldwin> armax: That could be a good.  I’d like to see a short description of how that will work.
15:14:18 <armax> I have an initial patch here: https://review.openstack.org/#/c/109046/
15:15:02 <carl_baldwin> I do remember seeing that one show up yesterday but have not looked at it.  I will have a look today.
15:15:45 <carl_baldwin> I still have an action item to create bug reports for the follow up items that we have.  I will do that today.
15:16:01 <armax> I need more work, but an input would be good
15:16:03 <carl_baldwin> #action carl_baldwin will create bugs to follow up on
15:16:13 <carl_baldwin> armax: Thanks I will have a look.
15:16:21 <amuller> Sorry I'm late there was a siren heh
15:16:32 <carl_baldwin> amuller: hi
15:17:04 <carl_baldwin> I’m going to be working on namespace cleanup as well.  I think I can get that knocked out quickly.
15:17:36 <carl_baldwin> We’ve also got some working on for migration of legacy to distributed.
15:18:16 <armax> carl_baldwin: I am sure the more we test this the more issues will find :)
15:18:19 <amuller> carl_baldwin: router_delete_namespaces still causes issues last time I checked on RHEL 7 sadly, you're working on Ubuntu?
15:18:57 <carl_baldwin> amuller: I think most of us are working on Ubuntu.
15:19:23 <carl_baldwin> amuller: what are the issues you’re seeing?
15:19:28 <armax> btw devstack patch https://review.openstack.org/#/c/103180/
15:19:31 <armax> merged last night
15:19:53 <carl_baldwin> amuller: are the issues related to dvr?
15:19:59 <amuller> carl_baldwin: No
15:20:17 <amuller> carl_baldwin: Before DVR... There's still issues with deletion of namespaces on Red Hat based distros
15:21:10 <carl_baldwin> amuller: I’ll tack that on to the end of the agenda.
15:21:23 <carl_baldwin> Any other DVR updates?
15:21:45 <Swami> hi carl_baldwin and armax
15:21:54 <carl_baldwin> Swami: hi
15:22:02 <Swami> I have pushed a Neutronclient patch that fixes a problem
15:22:10 <Swami> Please take a look at it.
15:22:33 <Swami> A recent fix by Assaf, will not allow us to define a router as "legacy' if the default it "distributed".
15:22:45 <amuller> *coughs*
15:22:51 <carl_baldwin> Swami: I have it up this morning and was looking at it.
15:22:53 <Swami> https://review.openstack.org/#/c/109180/2
15:23:05 <carl_baldwin> Thanks for the link.
15:23:08 <Swami> I think Armando is also in the loop on this.
15:23:46 <armax> Swami: yes, sorry for the snafus
15:23:55 <Swami> armax: its ok.
15:24:05 <armax> amuller and enikanorov_ have an initial feedback
15:24:08 <Swami> This issue helped us find out the other problem on the plugin side.
15:24:24 <amuller> So something good came out of my stupidness :)
15:24:42 <carl_baldwin> Swami: What was the other issue on the plugin side?
15:24:43 <armax> Swami: I’d be tempted to reinstate the old behavior and see if we can fix the misleading help in line
15:25:06 <Swami> carl_baldwin: just to bring you up to speed
15:25:17 <armax> carl_baldwin: it looks like the override of the router type happens only when it’s dvr by default
15:25:28 <Swami> on the plugin side also the code does not allow us to override the "distributed" flag if the default is set to "true".
15:25:32 <armax> carl_baldwin: sorry it is NOT
15:25:58 <armax> so it works in the case dvr is switched off by default
15:26:14 <armax> but it doesn’t when it is on by default
15:26:28 <carl_baldwin> Ah, I think I understand.  Is there a patch up to fix?
15:26:53 <armax> not yet, Swami and I are coordinating this one internally first
15:27:02 <Swami> Yes I do have a patch, I shared it with Armax, but I will work with him to finalize.
15:27:32 <Swami> carl_baldwin: just to be clear, I don't have a patch that is in the gerrit.
15:27:50 <Swami> I do have an internal patch and will work with Armax on this
15:28:11 <armax> Swami: let’s sync up offline
15:28:16 <carl_baldwin> Why not in gerrit?  We should probably have a bug filed and a patch in gerrit.  Otherwise, things get lost.
15:28:21 <Swami> armax: thanks will do.
15:28:25 <armax> we will
15:28:38 <armax> carl_baldwin: swami sent me an email last night at 12.20am pacific :)
15:28:53 <carl_baldwin> great.
15:29:23 <carl_baldwin> Any other DVR updates?
15:29:25 <armax> carl_baldwin: we will, but we don’t want to steer attention from the last two outstanding patches
15:29:48 <armax> carl_baldwin: I think we talked long enough ;) this is an L3 meeting after all
15:30:06 <carl_baldwin> Keep up the good work.  Thanks.
15:30:12 <carl_baldwin> #topic l3-high-availability
15:30:25 <carl_baldwin> safchain: Are you around?
15:30:28 <safchain> yes
15:30:40 <carl_baldwin> Any updates?
15:31:13 <safchain> yes, started to address comments on the first patch, now pass the UT
15:31:30 <armax> safchain: great progress on that
15:31:30 <safchain> amuller, made a great job on rebasing every patches
15:31:38 <armax> safchain: I’ll review it one more time today
15:31:43 <armax> and the others
15:31:43 <safchain> armax, thx
15:31:47 <amuller> armax: only rebases right now
15:31:58 <armax> amuller: ok
15:32:08 <safchain> currently working on the scheduler part
15:32:23 <amuller> <-- working on the agent side patches
15:32:29 <carl_baldwin> safchain: I will review as well.
15:33:03 <safchain> yes there are still remaining comments from armax that maybe need to be addressed
15:33:16 <carl_baldwin> Has anyone, by chance, tried this with DVR snat yet?
15:33:26 <amuller> Not yet Carl
15:33:32 <safchain> no
15:33:36 * carl_baldwin was just wondering
15:33:53 <amuller> We'll get there
15:33:54 <carl_baldwin> It would take some work since neither has merged.
15:34:09 <carl_baldwin> Anything else to discuss?
15:34:15 <safchain> ok for me
15:34:50 <carl_baldwin> safchain: amuller:  thanks.
15:35:06 <carl_baldwin> #topic l3-svcs-vendor-*
15:35:10 <carl_baldwin> pcm_: Any update here?
15:35:23 <pcm_> Reference VPN code made it into J2
15:35:44 <carl_baldwin> Great.
15:35:45 <pcm_> Csico VPN code is waiting for reviewers. Could use some eyes, please: #link https://review.openstack.org/#/c/107473/1
15:36:19 <pcm_> Looks like that'll go in J-3
15:36:51 <carl_baldwin> pcm_: Thanks.  I will take a look soon.
15:36:51 <pcm_> After that, I'll be asking if other services need this and can work with people apply.
15:37:06 <pcm_> to apply
15:37:13 <carl_baldwin> pcm_: Sounds like a plan.
15:37:30 <pcm_> that's all from me
15:37:35 <carl_baldwin> pcm_: Thanks.
15:37:38 <pcm_> np
15:37:49 <carl_baldwin> #topic bgp-dynamic-routing
15:38:08 <carl_baldwin> devvesa: nextone92: Are you around?
15:38:56 <carl_baldwin> I’ll ping them late.
15:38:58 <carl_baldwin> later.
15:39:44 <carl_baldwin> I don’t think any of the other topics have had any progress recently.  I’ll skip them this week.
15:40:15 <yamamoto> a short update on ryu bgp: we have infilter code now.  (not merged to ryu master yet though)
15:40:16 <carl_baldwin> #topic router_delete_namespaces
15:40:21 <carl_baldwin> #undo
15:40:22 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x2d1f110>
15:40:33 <carl_baldwin> yamamoto: sorry, go ahead.
15:40:50 <yamamoto> that's all from me :-)
15:40:57 <carl_baldwin> yamamoto: Thanks.
15:41:04 <carl_baldwin> #topic router_delete_namespaces
15:41:18 <carl_baldwin> amuller: You have the floor.
15:42:00 <amuller> This is more of a distro issue, and I haven't looked deeply into this at all
15:42:11 <amuller> But we tried internally to enable the auto delete flag for l3 and dhcp agents
15:42:22 <carl_baldwin> Can you describe what you’re seeing?
15:42:26 <amuller> Saw a bunch of errors in the log, waved our hands, let out a few juicy swear words and moved on
15:42:54 <amuller> I'll put it on my list to revisit this sometime next week
15:43:06 <amuller> I'll report a RHBZ probably
15:43:07 <carl_baldwin> amuller: Have you read through this:  https://bugs.launchpad.net/neutron/+bug/1052535
15:43:34 <amuller> A few times :)
15:44:05 <carl_baldwin> Any “Device or resource busy” errors?
15:44:21 <amuller> Probably, I don't have the logs handy this was a while ago
15:44:31 <amuller> If/when I'll have something conrete I'll get back to you
15:45:39 <carl_baldwin> amuller: Great.  Assuming the problem is what I think, please look in the bug for information about the iproute update that is needed to allow clean deletion of namespaces.
15:45:44 <carl_baldwin> Let me know.
15:45:48 <amuller> Will do, thanks.
15:46:04 <carl_baldwin> #topic Open Discussion
15:47:32 <carl_baldwin> If there is nothing else, I’ll give you back some time.
15:47:46 <carl_baldwin> Thanks for all you do!
15:47:51 <pcm_> bye
15:47:53 <carl_baldwin> #endmeeting