15:01:36 <carl_baldwin> #startmeeting neutron_l3
15:01:37 <openstack> Meeting started Thu Sep  4 15:01:36 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:40 <carl_baldwin> #topic Announcements
15:01:41 <openstack> The meeting name has been set to 'neutron_l3'
15:01:55 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:02:34 <carl_baldwin> I’d like a short meeting today.
15:02:59 <carl_baldwin> Juno-3 should be available today.  I know the cut-offs are always difficult.
15:03:36 <carl_baldwin> I did not get a chance to update the agenda on the wiki.  I don’t know where the week went (actually I do, I took two days off.).
15:03:50 <carl_baldwin> Any other announcements?
15:04:04 <yamamoto_> nothing from me
15:04:22 <carl_baldwin> #topic neutron-ovs-dvr
15:04:49 <carl_baldwin> Swami: mrsmith: viveknarasimhan: armax:  What is the latest on DVR?
15:06:45 <carl_baldwin> the backlog was getting down and has creeped up a little bit in the last week or two.  It still is pretty much under control though.
15:07:08 <carl_baldwin> I think the reason for the creep was that we had our attention diverted to getting new features in to juno-3.
15:07:18 <yamamoto_> i wonder if there's much point to discuss dvr progress here while it has its own dedicated meeting
15:07:56 <carl_baldwin> yamamoto_: We’ve needed it in the past but now that it is slowing and stabilizing, you may be right.
15:08:06 <mrsmith> real quick - I am focused on the migration patch and the newly split up snat fixes patch
15:08:13 <mrsmith> to me those are priorities
15:08:27 <carl_baldwin> yamamoto_: Still, we report progress up through the L3 team so it is good to touch on it.
15:08:54 <yamamoto_> carl_baldwin: fine.  just wondering
15:08:56 <mrsmith> the migration patch depends on the snat fixes so hopefully we will get those thru soon
15:09:14 <carl_baldwin> mrsmith: Right.  I think I will take my co-author line off of the snat patches so that I can +2 them.  I’ve been thruogh them pretty thoroughly.
15:09:20 <mrsmith> depends = it needs the fixes to fully function
15:09:37 <mrsmith> carl_baldwin: gotcha
15:09:58 <carl_baldwin> mrsmith: understood.  I will be hitting DVR bugs again as a priority (only behind wrapping up L3 HA).
15:10:17 <yamamoto_> carl_baldwin: isn't it better to find another core reviewer if you are actually a co-author?
15:10:56 <mrsmith> I believe carl mostly just split up the big patch into smaller ones
15:10:59 <carl_baldwin> yamamoto_: I was only an author in the sense that I split the original patch up and did very minor fixups.  It was a bit of a stretch to add the co-author line, I’ll admit.
15:11:32 <yamamoto_> carl_baldwin: ok it makes sense.  thank you
15:11:50 <carl_baldwin> yamamoto_: You’re right though.  Credit should be given where it is due.
15:12:39 <carl_baldwin> On the other hand, “It is amazing what you can accomplish if you do not care who gets the credit.” - Harry S. Truman (I think)
15:12:40 <carl_baldwin> :)
15:12:54 <carl_baldwin> Anyway, back to the meeting.
15:12:57 <carl_baldwin> Anything more on DVR?
15:13:31 <yamamoto_> nothing from me
15:13:45 <carl_baldwin> #topic l3-high-availability
15:13:59 <carl_baldwin> amuller: Do you have a report?
15:14:09 <amuller> Sylvain is addressing comments on the server side patches
15:14:19 <carl_baldwin> Welcome back, safchain
15:14:23 <safchain> hi
15:14:25 <amuller> I'm working on the agent patches, improving our functional tesitng
15:14:28 <amuller> testing*
15:14:49 <safchain> I'm addressing comments about the vr_ids management
15:15:05 <amuller> Maru and John Schwarz have been dealing with the inconsistent failures at the gate, and have already fixed it, but it'll take a while to merge because of the gate
15:15:09 <carl_baldwin> safchain: Which patch?  I didn’t notice the comments.
15:15:22 <safchain> base classes
15:15:33 <safchain> around the _set_vr_id method
15:16:43 <safchain> carl_baldwin, https://review.openstack.org/#/c/64553
15:16:46 <carl_baldwin> safchain: right.  I see it.
15:17:37 <carl_baldwin> That is good feedback.
15:17:48 <safchain> carl_baldwin, so I introduced a new table for the allocations
15:18:01 <amuller> Darragh O'Reilly reported an issue in the keepalived.conf after we add FIPs, trying to reproduce and test it
15:18:01 <safchain> I mean vr_id allocation per ha network
15:19:16 <carl_baldwin> safchain: Feel free to ping me if you need anything or when you have something ready for review.
15:19:19 <amuller> Also we have a bug tag now and a bunch of bugs to go with: https://bugs.launchpad.net/neutron/+bugs?field.tag=l3-ha
15:19:29 <amuller> some are closer to RFE
15:19:31 <safchain> carl_baldwin, ok, thx
15:20:21 <carl_baldwin> amuller: I will start to work on triage and assigning importance.
15:20:42 <carl_baldwin> amuller: Thanks for gathering them together and posting the query.
15:21:07 <amuller> carl_baldwin: the feature is targeted to RC1
15:21:16 <amuller> when do we expect to merge the original 3 feature patches?
15:21:27 <amuller> RC1 is too late imo
15:21:37 <amuller> we need to deal with stability, bugs, testing
15:22:07 <amuller> RC1 is on the 25th
15:22:22 <carl_baldwin> amuller: I agree.  This is now my top priority to turn these reviews around.
15:22:59 <amuller> alright
15:23:06 <carl_baldwin> I feel the base classes patch is in pretty decent shape.
15:23:10 <amuller> now that Sylvain is back it should go faster too
15:23:27 <carl_baldwin> For the other two, I made my comments and I don’t feel that there are any hard issues in there from my perspective.
15:23:30 <safchain> amuller, yes I hope
15:24:17 <carl_baldwin> Please ping me as soon as new patches are ready for review so that we can turn them around quickly.
15:24:23 <amuller> Sounds good
15:24:31 <carl_baldwin> amuller: anything else?
15:24:49 <amuller> working with Maru on the agent side failover functional test
15:25:05 <carl_baldwin> #action carl_baldwin will triage L3 HA bugs
15:25:11 <amuller> I think it's pretty cool, it's a step to having multiple L3 agents on a single machine
15:25:16 <amuller> so we can test this in Tempest as well
15:25:30 <amuller> also we've been talking about integration testing in-tree
15:25:41 <carl_baldwin> amuller: That sounds cool.
15:25:50 <amuller> if we can get multiple L3 agents up it'll help with that as well, should help DVR and L2pop as well
15:25:58 <amuller> other features that require multiple agents
15:26:21 <safchain> amuller, carl_baldwin yes that is really something that we need
15:26:38 <carl_baldwin> I hope you can raise the bar for testing in the project.
15:26:53 <amuller> it's all marun_ guiding things
15:27:33 <amuller> Aiming for the failover testing in the next week-ish, and in-tree integration testing probably for early Kilo
15:27:44 <amuller> That's it for me
15:28:18 <carl_baldwin> amuller: Great, thanks for the update.
15:28:36 <carl_baldwin> #topic bgp-dynamic-routing
15:29:11 <yamamoto_> was it deferred to kilo?
15:29:11 <carl_baldwin> devvesa: ping
15:29:18 <amuller> yamamoto_: it was
15:29:30 <yamamoto_> why?
15:30:08 <carl_baldwin> yamamoto_: Reviewer bandwidth, really.
15:30:48 <carl_baldwin> I guess it was more than that.  Juno had a lot of work done in it and we can only pack so much in.
15:31:47 <carl_baldwin> This will be our first priority to open up Kilo development.
15:32:12 <yamamoto_> is it a candidate of neutron-incubator?
15:32:49 <carl_baldwin> yamamoto_: It was a candidate but I’ll admit that I’ve fallen a bit behind in the neutron incubator discussion.
15:33:50 <yamamoto_> i just hope neutron-incubator stuff doesn't defer this further.
15:34:08 <amotoki> it really depends on the community discussion. we also need to consider L3 is tightly coupled with L2 and many folks regard it as a part of core.
15:34:55 <carl_baldwin> yamamoto_: If neutron-incubator is not ready, I will continue with dynamic routing in the main repository.
15:35:57 <yamamoto_> carl_baldwin: it makes sense
15:36:40 <carl_baldwin> #topic Kilo
15:37:48 <carl_baldwin> I don’t have much time to get in to it today but we should probably have Kilo in the back of our minds and start discussing what we would like the main themes to be.  So, I’m going to add a Kilo topic to the weekly agenda.
15:38:22 <seizadi> The design sessions are still not open, http://summit.openstack.org/
15:38:47 <amuller> Redesign the L3 agent, since we added distributed and HA routers it's an unmaintainable mess
15:38:51 <yamamoto_> seizadi: when it will?
15:38:55 <amuller> I think that's a strong candidate for early Kilo
15:39:20 <mrsmith> amuller: +1 refactor l3-agent
15:39:22 <yamamoto_> amuller: +1
15:39:43 <carl_baldwin> amuller: +1, I have had some refactors in mind myself.
15:39:54 <amuller> structure it somehow, add more classes, enough with these 'if distributed, if not distributed, if ha, if not ha' nonsense
15:40:12 <carl_baldwin> Hopefully we can have a good idea of where to start when Kilo opens.
15:40:13 <amotoki> amuller: +1. I hope it includes vpn-agent merging into l3-agent.
15:40:44 <carl_baldwin> amuller: Exactly.
15:40:49 <Swami> +1
15:41:09 <carl_baldwin> amotoki: vpn merging noted
15:42:15 <mrsmith> splitting up process_router() is another candidate
15:42:19 <mrsmith> it is getting huge
15:42:25 <amuller> we could start with that yeah
15:42:32 <seizadi> yamamoto: I will post when I see it open, I thought if Carl finds out design summit schedule for Kilo through Openstack communication, we can discuss on this topic.
15:42:49 <carl_baldwin> mrsmith: +1
15:43:19 <carl_baldwin> The ML will probably be the best place to watch for it to open.
15:43:30 <yamamoto_> mrsmith: +1
15:43:43 <carl_baldwin> It can’t be too much longer.  We’ve only got two months until the summit.
15:44:08 <carl_baldwin> #topic Open Discussion
15:44:22 <carl_baldwin> Anything else?
15:44:34 <yamamoto_> nothing from me
15:44:39 <amotoki> one question on relationship between DVR and L3-HA.
15:44:49 <amotoki> Are they exclusive? just confirmation.
15:44:53 <amuller> for now, yes
15:45:05 <amuller> we just didn't get to it yet
15:45:11 <carl_baldwin> #link https://bugs.launchpad.net/neutron/+bug/1365473
15:45:33 <amotoki> I am now planning to write a small patch in horizon and I need some constraint check for them.
15:45:47 <amotoki> *small patch to support L3-HA
15:45:54 <amuller> next patchset for the models patch should block the creation of a rotuer that's both HA and distributed
15:45:57 <amuller> router*
15:46:00 <seizadi> If anyone is on the IPv6 subcommittee I like to talk to them we are having trouble with IPv6 integration. I looked at their meeting notes but not much notes.
15:46:48 <mrsmith> rajeev wanted me to ask for reviewers on a couple of his patches
15:47:01 <mrsmith> https://review.openstack.org/#/c/116412/
15:47:29 <mrsmith> https://review.openstack.org/#/c/112146/23
15:48:03 <amotoki> i think sc68cal is the right contact.
15:48:15 <carl_baldwin> mrsmith: noted
15:49:12 <carl_baldwin> Okay, my time is up.  I’ll be back online in a bit.
15:49:15 <carl_baldwin> #endmeeting