15:02:14 <carl_baldwin> #startmeeting neutron_l3
15:02:14 <openstack> Meeting started Thu Oct  9 15:02:14 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:18 <openstack> The meeting name has been set to 'neutron_l3'
15:02:36 <carl_baldwin> #topic Announcements
15:03:16 <carl_baldwin> I don’t think I have any announcements except that Juno RC2 is being work on, I believe.
15:04:12 <carl_baldwin> Any announcements?
15:04:25 <carl_baldwin> #topic Bugs
15:04:50 <carl_baldwin> I did follow up with more triage since the last meeting.  That was my action item.
15:05:04 <carl_baldwin> I haven’t seen any concerning bugs pop up since then.
15:05:14 <carl_baldwin> Are there any bugs that need to be brought up?
15:05:43 <matrohon> hi! I need one more core review on this : https://review.openstack.org/#/c/116924/
15:06:12 <matrohon> I'd like it to merge in juno :)
15:06:47 <carl_baldwin> matrohon: I’ll add it to my queue.
15:07:05 <carl_baldwin> matrohon: Is it tagged for juno potential?
15:07:19 <matrohon> carl_baldwin : yes it is tagged. thanks
15:07:23 <carl_baldwin> ok
15:08:09 <carl_baldwin> Any other bugs?
15:08:29 <carl_baldwin> #topic l3-high-availability
15:08:35 <carl_baldwin> safchain: amuller: ping
15:08:44 <carl_baldwin> Anything new here to report or discuss?
15:08:56 <jschwarz> a muller is out o PTO (holiday, i'm no supposed to be here either ;p)
15:09:11 <safchain> hi
15:09:21 <safchain> nothing special this week
15:09:42 <carl_baldwin> safchain: Thanks.  Feel free to ping me if you need something.
15:09:43 <jschwarz> I would like to discuss the ns_name issue as it relates to the HA functional tests
15:09:55 <safchain> carl_baldwin, thx
15:10:13 <jschwarz> #link https://review.openstack.org/#/c/123434/2/neutron/agent/l3_agent.py
15:10:20 <carl_baldwin> jschwarz: almost there.
15:10:27 <jschwarz> sorry then :)
15:10:34 <carl_baldwin> #topic bgp-dynamic-routing
15:10:37 <carl_baldwin> devvesa: ping
15:10:48 <devvesa> carl_baldwin: hi
15:11:26 <carl_baldwin> devvesa: good discussions this week.  Any progress on the bp?
15:11:52 <devvesa> been busy this morning. I'm considering your idea about promoting ips or networks to advertise them
15:12:24 <devvesa> also I think that modeling the edge router is not needed since it is not useful for your use case
15:12:27 <carl_baldwin> devvesa: One request.  Could you link that testing page that you gave me a link to to the L3 subteam page in the bgp-dynamic-routing section?
15:12:43 <devvesa> sure.
15:13:09 <devvesa> #link https://wiki.openstack.org/wiki/Neutron/DynamicRouting/TestingDynamicRouting
15:13:31 <devvesa> oh, now I've read 'to the subteam page' :)
15:13:34 <devvesa> I'll do
15:13:57 <carl_baldwin> devvesa: The modelling change that I thought was most important was that advertised routes associate with routers.  Any more thoughts on that?
15:14:54 <carl_baldwin> #action devvesa will link dynamic routing testing page to subteam page.
15:15:01 <devvesa> to me the advertised routes should be associated to the routing instance, which is the instance that is 'deployed' in the dr_agent
15:15:37 <devvesa> but we can discuss it more in the spec
15:16:01 <carl_baldwin> devvesa: Let me think about that a little more.  Maybe I don’t fully understand the scope of the RoutingInstance object.  I’ll review the spec again.
15:17:09 <carl_baldwin> It still seems natural to associate with the router because the router is what will be handling the route and it has the next hop for the route as a property of the router (its public address).
15:17:20 <carl_baldwin> devvesa: Thanks for your work on this.
15:17:42 <carl_baldwin> #topic L3 Agent Refactoring
15:17:58 <carl_baldwin> jschwarz: hi
15:18:02 <jschwarz> carl_baldwin, hi
15:18:20 <jschwarz> would be happy if you'd have a look at the link i posted above
15:18:25 <carl_baldwin> Sorry to have ruffled some feathers here.  It seems we have two conflicting efforts going on with the L3 agent.
15:18:26 <jschwarz> https://review.openstack.org/#/c/123434/2/neutron/agent/l3_agent.py
15:19:05 <jschwarz> that's quite alright, and I do realise your intentions on this. I realise the current state isn't the best one
15:19:30 <jschwarz> the earlier patchset I linked contains what I believe you're looking for
15:19:49 * carl_baldwin is looking at the link
15:20:11 <carl_baldwin> jschwarz: I think the property is fine.  I can leave that in.
15:20:26 <jschwarz> very well then
15:20:51 <carl_baldwin> I also see the motivation for _get_router_info from the test you linked.  However, this doesn’t feel quite right.
15:21:06 <carl_baldwin> Could this work as a static factory method on the RouterInfo class?
15:21:43 <jschwarz> You mean, a RounterInfo.create() function which returns what we need?
15:22:02 <carl_baldwin> jschwarz: Yes, something like that.
15:22:18 <carl_baldwin> It doesn’t make sense where it is now to me.
15:22:26 <jschwarz> This will be problematic since in the functional tests we also change the RouterInfo we create (we override it with a TestRouterInfo, adding the cfg.CONF.host argument)
15:23:01 <jschwarz> So a factory function in the RouterInfo namespace will require also overriding functions that create the RouterInfo in the test agent
15:23:21 <jschwarz> #link https://review.openstack.org/#/c/117994/15/neutron/tests/agents/l3_agent.py
15:24:00 <jschwarz> :(
15:25:05 <carl_baldwin> That test does override it now.  so, it is not a new requirement.  The question is how it overrides it, right?
15:25:58 <jschwarz> Right. But I think it's better to override a _get_router_info over overriding (and refactoring) _router_added (iirc)
15:25:59 <carl_baldwin> I have not had the chance to look through the test yet.  I’ll do so today.
15:26:34 <jschwarz> I'm happy to schedule a sit-down with you on this subject on Monday once we both get a chance to think about this again, if you want :)
15:26:37 <carl_baldwin> I’ll abandon the reverts that I have up and try to propose something that will meet both our needs.
15:26:53 <jschwarz> carl_baldwin, sounds good.
15:27:22 <carl_baldwin> #action carl_baldwin will abondon reverts and find a better proposal.
15:27:29 <jschwarz> carl_baldwin, I'll be happy if you let me write that patch since the functional tests patch depends on the solution we'll implement
15:27:49 <carl_baldwin> jschwarz: I’ll be in touch.
15:27:53 <jschwarz> sounds great
15:27:55 <jschwarz> thanks
15:28:21 <carl_baldwin> jschwarz: we still have a fundamental problem now in that we have two efforts going on that will be very difficult to coordinate.
15:28:28 <Swami> hi
15:28:32 <carl_baldwin> Swami: hi
15:29:03 <jschwarz> carl_baldwin, I agree, so we better work on this together
15:29:53 <jschwarz> carl_baldwin, the functional tests patch is ready for core review since the smaller patches are all merged - maybe we can consider having the refactoring effort also include the functional tests
15:30:26 <carl_baldwin> I will post a spec for the refactoring I plan soon (hopefully today)
15:30:50 <carl_baldwin> jschwarz: I will review the tests patch.  Is it just the one patch?
15:31:02 <jschwarz> yep :) the rest are merged
15:31:10 <carl_baldwin> jschwarz: Thanks.
15:31:25 <yamahata> hi, I'm also interested in l3 agent refactoring.
15:31:26 <jschwarz> the integration tests are well in the work (will discuss this later) but that's a ways off IMO
15:31:30 <carl_baldwin> jschwarz: do you plan more work beyond this patch in the near future?
15:31:45 <carl_baldwin> yamahata: I will add you to the review of the spec.
15:31:46 <yamahata> carl_baldwin: can you explain the plan roughly?
15:32:09 <carl_baldwin> yamahata: It will be better to wait for the spec.  I will try to get it up today.
15:32:17 <yamahata> carl_baldwin: got it
15:32:17 <jschwarz> the integration tests' first test is planned to be about the HA (since amuller is working closely on this with me and Maru)
15:32:41 <matrohon> carl_baldwin : interested too :)
15:32:45 <jschwarz> but first the framework has to go through, and a spec, etc... and those aren't up yet
15:33:19 <jschwarz> carl_baldwin, you can see the current needs of the integration tests here: https://review.openstack.org/#/c/123000/5/neutron/tests/agents/l3_agent.py
15:33:36 <jschwarz> basically, more functions from the original L3 code needs overriding
15:33:53 <jschwarz> that said, it's a long way off
15:34:38 <carl_baldwin> jschwarz: I will get more familiar with this work.
15:34:39 <carl_baldwin> Thanks.
15:35:28 <carl_baldwin> #topic neutron-ovs-dvr
15:35:29 <jschwarz> Thank you. i'll make sure I add you as a reviewer on all relevant patches and will try to keep this forum involved in the future :)
15:35:40 <carl_baldwin> jschwarz: That will be great, thanks.
15:35:47 <carl_baldwin> Swami: hi
15:36:10 <Swami> hi
15:36:11 <carl_baldwin> I’m sorry that I missed most of the meeting yesterday.  I had a one-time conflict.
15:36:22 <Swami> no problems
15:36:46 <carl_baldwin> Anything to report or discuss?
15:36:59 <Swami> regarding DVR there are couple of items that we need to discuss
15:37:40 <Swami> There are two bugs right now, one with respect DB lockwait timeout and the other is triggered because of the DB lockwait timeout
15:37:49 <Swami> DB DuplicateError for Snat binding.
15:38:05 <Swami> I have posted patches for both these bugs.
15:38:17 <Swami> #link https://review.openstack.org/#/c/126793/
15:38:24 <Swami> patch for the DB Duplicate Error.
15:39:20 <carl_baldwin> Swami: Is it ready for review?  Do you need input on it?
15:39:28 <Swami> This patch again introduces the "hints" in the scheduler, since we have a timing issue with respect to Gateway clear and interface-delete, we need to prevent the snat_scheduler being called when there is router_interface-delete, so I am using the hints.
15:39:41 <Swami> Take a look at it and let me know.
15:40:01 <Swami> I have still address couple of  unit tests on this patch, but I want you to take a look at it.
15:40:22 <carl_baldwin> Swami: I will.
15:40:32 <Swami> s/have/have to
15:40:51 <carl_baldwin> I have been meaning to get to it.
15:40:53 <Swami> Also on the DB lockwait timeout issue, there is patch out there
15:41:04 <carl_baldwin> #action carl_baldwin will review https://review.openstack.org/#/c/126793/
15:41:11 <Swami> #lin https://review.openstack.org/#/c/127129/
15:41:16 <Swami> #link https://review.openstack.org/#/c/127129/
15:41:33 <Swami> This patch also needs your attention.
15:42:15 <carl_baldwin> #action carl_baldwin will review https://review.openstack.org/#/c/127129/
15:42:36 <carl_baldwin> Swami: I have had these on my list to look at.  I will bump them up to the top.
15:42:41 * carl_baldwin wonders where the time goes
15:42:43 <Swami> Also I have posted a WIP patch for the VPN with DVR.
15:42:52 <carl_baldwin> Swami: Thank you for the links.
15:42:57 <Swami> #link https://review.openstack.org/#/c/127133/
15:43:29 <Swami> Last week we had an action item to create a Wiki to start adding notes for the HA and DVR with Service node.
15:43:32 <Swami> #link https://wiki.openstack.org/wiki/Neutron/DVR/ServiceNode-HA
15:43:36 <carl_baldwin> Swami: A new one I have not seen yet.
15:44:30 <Swami> carl_baldwin: yes this is a new one, since armando abandoned the VPN patch that prevents someone from configuring the VPN for DVR, I started working on this patch.
15:44:48 <Swami> Now with DVR the IPsec reference implementation should work.
15:45:13 <carl_baldwin> Swami: that will be good.
15:45:37 <Swami> carl_baldwin: I will work on the "Migration comments" that you made and try to push a patch.
15:45:39 <carl_baldwin> Thanks for the HA/DVR wiki page link too.  That will be an important improvement.
15:45:47 <Swami> That's all I have from the DVR side.
15:45:58 <carl_baldwin> Swami: How many of you are there?  ;)
15:46:11 <Swami> Also rajeev is back from vacation and I will ask him to take a look at the IPv6.
15:46:14 <carl_baldwin> Swami: Thanks for the report.
15:46:36 <Swami> Right now it's only me and rajeev just joined me today.
15:47:02 * carl_baldwin was just kidding
15:47:08 <carl_baldwin> Swami: Great work.  Thanks.
15:47:14 <carl_baldwin> #topic Open Discussion
15:47:23 <carl_baldwin> I think that is all I wanted to cover today.
15:47:26 <carl_baldwin> Anything else?
15:47:41 <Swami> I am done, nothing else.
15:47:44 <jschwarz> Surprisingly, none from me :)
15:47:51 <pcm__> is there a link with an overview of the plans for refactorings?
15:48:02 * pcm__ trying to catch up
15:48:06 <carl_baldwin> pcm__: Not yet, I’m hoping to get a spec up today.  If not today then tomorrow.
15:48:24 <carl_baldwin> #action carl_baldwin will put up a spec detailing l3 agent refactoring goals.
15:48:25 <pcm__> carl_baldwin: cool. Interested in that effort as well
15:48:27 <jschwarz> will be happy if you could also add me as a reviewer for that
15:48:35 <carl_baldwin> jschwarz: I will.
15:48:39 <pcm__> me too
15:48:49 <matrohon> carl_baldwin : I wonder if you plan to resubmit pluggable-ext-net in kilo
15:48:51 <carl_baldwin> pcm__: Will add you too.
15:49:30 <matrohon> https://review.openstack.org/#/c/88619/5/specs/juno/pluggable-ext-net.rst
15:49:32 <carl_baldwin> matrohon: Yes, I do.  That is important work for me and I will resubmit it soon.  It will benefit greatly from some refactoring.
15:49:57 <matrohon> carl_baldwin : good to know thanks
15:50:46 <matrohon> is there anybody around still interested in BGPVPN?
15:50:48 <matrohon> https://review.openstack.org/#/c/93329/
15:51:27 <carl_baldwin> matrohon: devvesa mentioned a possible pod session or something at the conference.
15:51:41 <Swami> yes I will be interested in BGPVPN
15:51:53 <devvesa> matrohon: yes, I would like to reserve a pod during the summit to talk about BGP and BGPVPN
15:52:09 <carl_baldwin> devvesa: loop in Swami and matrohon for that discussion.
15:52:33 <matrohon> carl_baldwin, devvesa, Swami : great, there is a natural overlap devvesa work
15:53:00 <matrohon> pods are exclusively on friday?
15:53:47 <devvesa> no
15:54:14 <devvesa> I think there will be pods available all the design session days
15:54:49 <devvesa> however, even the design sessions are not defined yet (at least in the sched site)
15:54:49 <Swami> If we don't want to miss the design session then we can book the pod on friday to have our discussion
15:55:05 <devvesa> Ok. I'll reserve on friday
15:55:21 <matrohon> fine, one of the main contributor on BGP stuff in our team will attend the summit only untill thurday mornig
15:55:41 <matrohon> friday won't match with his planning :(
15:55:43 <devvesa> ouch
15:56:07 <carl_baldwin> Let’s wait a bit for the rest of the schedule to come out.  We’ll have a better idea of when we can fit it in.
15:56:19 <matrohon> there is no design session wednesday pm for neutron
15:56:28 <matrohon> for the moment
15:56:45 <matrohon> if i do remember well :)
15:57:06 <devvesa> Yes, let's wait. I'll ping all of you via IRC before reserve the pod and see your availability , ok?
15:57:18 <matrohon> http://kilodesignsummit.sched.org/overview/type/neutron#.VDawUps7vmE
15:57:25 <matrohon> devvesa : fine
15:57:44 <carl_baldwin> devvesa: Okay.
15:59:11 <carl_baldwin> Thanks everyone.  I’m looking forward to Kilo and the summit.
15:59:15 <carl_baldwin> #endmeeting