15:00:20 <carl_baldwin> #startmeeting neutron_l3
15:00:21 <openstack> Meeting started Thu Nov 20 15:00:20 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:25 <openstack> The meeting name has been set to 'neutron_l3'
15:00:41 <carl_baldwin> #topic Announcements
15:00:48 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam#Announcements
15:01:24 <carl_baldwin> Mid-cycle sprint and the Neutron spec proposal/approval deadlines are on the calendar.
15:01:40 <carl_baldwin> Any other announcements?
15:02:46 <carl_baldwin> #topic Bugs
15:03:40 <carl_baldwin> One new bug, bug 1388698, snuck in while we were at summit.
15:03:52 <carl_baldwin> #link https://bugs.launchpad.net/neutron/+bug/1388698
15:04:25 <carl_baldwin> Any other bugs that we need to discuss?
15:05:32 <amuller> I don't understand the bug description
15:05:43 <amuller> Can you explain it Carl?
15:06:18 <carl_baldwin> amuller: I have looked at it closely yet.  I may follow up with Eugene about it.
15:06:56 <amuller> there's a conflict in the bug description... anyway don't know if you want to spend any time on that bug right now
15:07:17 <carl_baldwin> #action carl_baldwin will follow up on bug 1388698 with Eugene
15:07:50 <carl_baldwin> #topic L3 Agent Restructuring
15:08:21 <carl_baldwin> #link https://review.openstack.org/#/c/131535/ I update the BP
15:08:43 <carl_baldwin> I haven’t seen much review action on it since the update.
15:09:15 <Swami> rejoining
15:09:18 <pc_m> carl_baldwin: Looks good
15:10:01 <carl_baldwin> pc_m: Thank you for your review!  The only one.
15:10:14 <SridharRamaswamy> carl_baldwin: looks good, switching to inheritance for router types is great
15:10:20 <hareeshp> carl_baldwin: yes, I think you have fairly clearly explained the main points.
15:10:47 <Swami> the spec is very detailed, but I have not reviewed it completely. Will do.
15:11:02 <carl_baldwin> SridharRamaswamy: hareeshp:  Thanks.  I look forward to any other feedback that you might have.
15:11:09 <carl_baldwin> Swami: Thanks.
15:11:22 <pc_m> carl_baldwin: I'd like to mention the WIP I have up for review for people to comment on: https://review.openstack.org/#/c/135392/2
15:11:49 <pc_m> carl_baldwin: It is a stab at taking a small step at teasing out the device driver loading.
15:12:08 <carl_baldwin> pc_m: Thanks.  I’m sorry I’ve not been over it yet.  I will prioritize that for today.
15:12:48 <carl_baldwin> I want to discuss functional testing today.
15:12:54 <pc_m> Looking forward to peoples' thoughts. Trying to take it one piece at a time and hopefully keeping within the goal of the spec.
15:13:30 <SridharRamaswamy> carl_baldwin: one related question - there are vendor codes in those device-drivers (for VPN, FW, LB) .. is it going to stay in tree and does it move to vendor repo (as proposed by Armando)
15:13:31 <carl_baldwin> pc_m: Sounds good.
15:13:50 <hareeshp> pc_m: Do you expect this loader to be used by the L3 agent?
15:13:57 <SridharRamaswamy> s/and/or
15:14:16 <pc_m> hareeshp: yes.
15:14:23 <carl_baldwin> SridharRamaswamy: I think the ultimate goal is to enable them to move out of tree.  However, moving out of tree is not a goal of this BP.
15:14:46 <pc_m> hareeshp: it will need to go through some iterations though.
15:15:12 <SridharRamaswamy> carl_baldwin: sounds good, perhaps will stay in tree for kilo ?
15:15:22 <pc_m> hareeshp: Wanted to get the logic out of the individual agents (which are in the L3 agent inheritance hierarchy right now)
15:15:23 <hareeshp> carl_baldwin: My understanding is that the vendor code will also be moved to the advanced services repo when that happens
15:15:53 <carl_baldwin> SridharRamaswamy: Not sure.  It could still move out for Kilo.
15:16:08 <hareeshp> pc_m: ok. thanks!
15:16:11 <SridharRamaswamy> carl_baldwin: okay
15:16:55 <carl_baldwin> hareeshp: That may be the case.  Moving it is out of scope for this BP.
15:17:20 <carl_baldwin> amuller: What should be our next action toward getting the functional testing that we need?
15:17:21 <hareeshp> carl_baldwin: understood and agreed. I think the loader will be useful exactly for that
15:17:28 <pc_m> hareeshp: My thoughts were that the L3 agent could call this advanced service loader, where ever it ends up living.
15:18:19 <carl_baldwin> hareeshp: But, I do see that this work will be key to enabling it to move.
15:18:30 <amuller> carl_baldwin: I haven't spoken to Adolfo yet. I understand he wrote d/s testing for DVR. We should setup a meeting where we match expectations of what kind of meeting we can push into Neutron right now, and what has to wait for John's full-stack white box testing, and what can go in Tempest
15:18:38 <amuller> what kind of tests*
15:18:48 <hareeshp> carl_baldwin: agree
15:18:57 <Swami> amuller: agreed, I will ask adolfo to keep in touch with you
15:19:05 <amuller> Swami: Thanks
15:19:16 <Swami> Yesterday we had a brief chat about this with Armando as well.
15:20:02 <Swami> amuller: What would be the best time to reach you out. Do you prefer IRC meeting or a phone call with adolfo.
15:20:30 <amuller> I think video chat would be best? Adolfo is based in the west coast? If so then his morning / my evening
15:20:45 <amuller> (I work Sunday to Thursday)
15:21:02 <Swami> Ok, I will send you an update email on the logistics on how we can sync up.
15:21:07 <amuller> alrighty
15:21:12 <carl_baldwin> amuller: That limits the time frame down quite a bit.  How late in the evening are you comfortable with?
15:22:24 <amuller> I guess 8pm Israel time
15:22:56 <amuller> should be 10 hours ahead of the west coast, if daylight savings is synced nowadays
15:23:30 <Swami> amuller: Ok that helps.
15:23:31 <carl_baldwin> Yes, I think DST is all gone now for the year.
15:23:33 <amuller> yeah it's 10 right now
15:24:19 <carl_baldwin> Swami: Are you going to handle scheduling?  Could you invite me?  I’d like to know how I can help out.
15:24:33 <mrsmith_> include me as well please
15:24:42 <Swami> carl_baldwin: sure
15:25:02 <amuller> Maru would ideally be there as well but we should schedule the meeting early next week at the latest
15:25:03 <carl_baldwin> Swami: Thanks.
15:25:18 <carl_baldwin> amuller: +1
15:25:42 <Swami> Next week is thanksgiving week. So probably we can have some thing scheduled for either Monday or Tuesday.
15:26:04 <carl_baldwin> Swami: +1 I’m out Wednesday - Friday
15:26:32 <carl_baldwin> Anything else on refactoring?
15:27:23 <carl_baldwin> #topic bgp-dynamic-routing
15:27:29 <carl_baldwin> devvesa: ping
15:27:35 <devvesa> hello
15:27:35 <amuller> Carl do you have actionable patches you had in mind that you can split out / paralelize to someone else?
15:27:54 <devvesa> btw. I just connected now. I can help in refactoring too
15:27:59 <carl_baldwin> #undo
15:28:00 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x1fb4150>
15:28:00 <amuller> That was a weird way of asking if I can help with some of the grunt work of the refactoring
15:28:07 <amuller> or anyone else
15:29:31 <carl_baldwin> amuller: Great question.  The first step is to break out the services from the L3 agent inheritence.  pc_m is working on VPNaaS.  FWaaS and metadata proxy are the other two.
15:30:18 <carl_baldwin> amuller: I wonder if you could have a look at the patch by pc_m, provide feedback and look to also break out the metadata proxy.
15:30:27 <pc_m> I'm trying to do some of the service stuff for all services.
15:30:48 <pc_m> Starting with device drivers.
15:31:57 <amuller> I can handle the metadata stuff, unless Paul you wanted to do that?
15:32:28 <amuller> Generally though I'm saying maybe Carl you could try to enumerate a list of patches you had in mind,  then we could try to figure out if there are patches that are not dependent
15:32:31 <pc_m> no go ahead (I don't know anything about it).
15:32:33 <amuller> then we hand some work out
15:32:52 <carl_baldwin> I think we need to move on.  We’re half way through the meeting time.  amuller and pc_m: we’ll sync up on this in the reviews and on IRC.
15:32:59 <amuller> ok
15:33:02 <pc_m> +1
15:33:15 <carl_baldwin> #topic bgp-dynamic-routing
15:33:20 <carl_baldwin> devvesa: ping (again)
15:33:29 <devvesa> hello (again)
15:33:59 <devvesa> not too much to say. I've been quite busy and I've just have had time to update the few nits from Mathieu
15:34:19 <devvesa> next monday I will (re)start with the code
15:34:41 <carl_baldwin> I sent a thread to the Neutron drivers team about the BP.  I got some questions back from them but no big unresolved concerns.
15:35:27 <devvesa> good. Can I do something about it?
15:35:40 <carl_baldwin> The biggest concern was that the L3 agent would be disruptive.  But, this BP doesn’t really touch the agent.
15:36:16 <devvesa> No, it doesn't.
15:36:29 <carl_baldwin> I dropped the ball and missed the drivers meeting yesterday.  (I’m not used to the new time yet, I guess)  But, I will be sure to make the next meeting to discuss it.
15:37:08 <devvesa> Are the non-drivers/non-core allowed to participate? I can be there too
15:37:48 <carl_baldwin> devvesa: It is a public meeting.  It just moved to 1530 on Wednesdays.  I would encourage you to be there too.
15:37:59 <devvesa> Ok. I'll be there
15:38:05 <carl_baldwin> It had been at 1500 UTC, same as this meeting.
15:39:04 <carl_baldwin> The IPv6 guys showed some interest in dynamic routing for IPv6.  I think that has helped to get some critical mass around it.  I’m hoping the drivers team sees it that way.
15:40:22 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam#Blueprint:_bgp-dynamic-routing_.28devvesa.2C_yamamoto.2C_.29
15:40:42 <devvesa> Uhm.. Maybe I'll ping Sean Collins to take a glance to it then. His feedback can be so useful
15:40:42 <carl_baldwin> This link has a lot of good information on the work that devvesa, yamamoto_ and others have already done.
15:41:02 <carl_baldwin> devvesa: Yes, that would be great.
15:41:39 <devvesa> (the link is quite out of date... I will update it)
15:42:17 <carl_baldwin> The interest with IPv6 comes from the fact that we have no floating IPs and NAT.  So, we need plain routing to neutron networks.
15:42:39 <carl_baldwin> devvesa: Updating would be great.  Try to check for out of date content there from time to time.
15:42:57 <carl_baldwin> devvesa: Anything else on this topic?
15:43:16 <carl_baldwin> #topic neutron-ipam
15:43:33 <carl_baldwin> johnbelamaric_: seizadi: ping
15:43:40 <johnbelamaric_> hello
15:43:58 <devvesa> carl_baldin: nothing else. thanks!
15:44:14 <johnbelamaric_> i saw your comments from yesterday, i will take a closer look today
15:44:16 <carl_baldwin> I think the discussion in the reviews has been going well.  Thanks for your timely feedback.
15:44:42 <johnbelamaric_> yes. as you mentioned in the comment i think we may be using different words for the same thing
15:45:11 <johnbelamaric_> we can discuss in detail on IRC later today or tomorrow after I review the new BP
15:45:15 <carl_baldwin> I have an update to push.  I made the updates yesterday but didn’t push.  Let me look over it this morning and then push it.
15:45:21 <johnbelamaric_> ok thansk
15:46:09 <johnbelamaric_> also - i think our subnet allocation use cases is not critical for kilo - our current Icehouse/Juno implementation doesn't do that. but i think it's a useful thing in the long run
15:46:50 <carl_baldwin> johnbelamaric_: I’d still like to understand it.  I don’t want to do something to make it more difficult to implement something like that later.
15:46:58 <johnbelamaric_> agreed
15:48:12 <carl_baldwin> johnbelamaric: I just posted a new version of the proposed interface.
15:48:23 <johnbelamaric_> i need to try another IRC client - just lost connection - but I am back
15:48:37 <johnbelamaric_> thanks, i will look today
15:48:41 <carl_baldwin> johnbelamaric: Find me on IRC later today.  Google Hangouts works well too.
15:48:46 <johnbelamaric_> ok
15:48:52 <carl_baldwin> johnbelamaric: Anything else?
15:49:00 <johnbelamaric_> nope
15:49:07 <carl_baldwin> johnbelamaric: Thanks!
15:49:19 <carl_baldwin> #topic neutron-ovs-dvr
15:49:32 <carl_baldwin> Looks like we lost Swami
15:49:50 <carl_baldwin> mrsmith_: Do you have anything?
15:50:16 <mrsmith_> yes
15:50:33 <mrsmith_> just wanted to ask about l3 ha and dvr
15:50:51 <mrsmith_> amuller - is there a patch currently or is this something you've started working on?
15:51:03 <mrsmith_> or is this something I can help with?
15:51:04 <amuller> I haven't started and I don't think I will in the next month or so
15:51:20 <mrsmith_> do you mind if I look into it a bit?
15:51:27 <amuller> I would kiss your feet
15:51:40 * pc_m :)
15:51:42 <amuller> So no I wouldn't mind :)
15:51:42 <mrsmith_> :)
15:51:49 <mrsmith_> cool
15:52:12 <carl_baldwin> mrsmith_: So, I guess it depends on whether you like having your feet kissed.  ;)
15:52:16 <mrsmith_> other than that, we are knocking off issues off the l3-dvr-backlog
15:52:51 <carl_baldwin> mrsmith_: Great.
15:53:12 <carl_baldwin> mrsmith_: We still need to discuss the manual move.  Will today be good?
15:53:30 <mrsmith_> ah.. yes... today should be good
15:53:39 <mrsmith_> I saw your comments on the re-schedule patch
15:53:46 <mrsmith_> all seem resonable
15:53:52 <mrsmith_> I am glad you like the new simple approach
15:53:53 <carl_baldwin> I’ll need to take off for a short time after this meeting to get in to the office.
15:54:10 <mrsmith_> (me too)
15:54:18 <carl_baldwin> mrsmith_: Funny, I can’t even remember making the comments.  I review too much.
15:54:25 <carl_baldwin> mrsmith_: Okay, ping me later.
15:54:48 <carl_baldwin> #topic Open Discussion
15:54:52 <mrsmith_> I will ping you later on the manual move
15:55:54 <yamahata> Hi, I updated spec of module l3 router plugin and uploaded some (WIP) patches.
15:56:14 <yamahata> I  also update the wiki page according to it.
15:56:52 <carl_baldwin> yamahata: I saw the update.  Thanks for keeping that up to date.
15:58:31 <carl_baldwin> I see that I was part way through reviewing the blueprint.  I will finish up that review.
15:59:46 <carl_baldwin> We’re out of time.  Thanks for all your work, everyone.
15:59:50 <carl_baldwin> #endmeeting