15:01:37 <carl_baldwin> #startmeeting neutron_l3
15:01:37 <openstack> Meeting started Thu Dec 4 15:01:37 2014 UTC and is due to finish in 60 minutes. The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:38 <amuller> hiya
15:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:42 <openstack> The meeting name has been set to 'neutron_l3'
15:01:43 <devvesa> hi
15:01:54 <carl_baldwin> #topic Announcements
15:01:57 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:02:17 <yamamoto> good to hear. but hi
15:02:26 <carl_baldwin> yamamoto: hi
15:02:27 <yamamoto> oops wrong window sorry
15:02:30 <yamamoto> but hi!
15:02:45 <carl_baldwin> Mid-cycle is next week.
15:03:22 <carl_baldwin> I’ll have to check my travel to see if I can attend this meeting next week.
15:03:46 <carl_baldwin> If I can’t, I’ll contact someone else to chair the meeting.
15:04:10 <carl_baldwin> Then, there are the SPD, SAD deadlines coming up fast.
15:04:16 <Swami> hi
15:04:20 <carl_baldwin> Are there any specs that are not up for review?
15:04:22 <carl_baldwin> Swami: i
15:04:24 <carl_baldwin> hi
15:04:42 <Swami> I might have to drop of at 7.40a.m
15:05:04 <carl_baldwin> Swami: No problem, do you have anything to discuss?
15:05:29 <johnbelamaric> seems like dhcp relay spec is getting some activity
15:05:37 <johnbelamaric> #link https://review.openstack.org/#/c/105660/
15:05:46 <johnbelamaric> i was thinking this was out-of-scope
15:05:56 <johnbelamaric> but looks like there is interest
15:06:48 <carl_baldwin> johnbelamaric: I guess if it can stand on its own and there is someone who can work on it...
15:07:24 <Swami> carl_baldwin: I do have one thing that I wanted to discuss with respect to DVR and FwaaS East-West
15:07:41 <johnbelamaric> ok, let's see where it goes
15:07:46 <carl_baldwin> #topic neutron-ovs-dvr
15:07:54 <carl_baldwin> Swami: Let’s go ahead and discuss that first.
15:08:11 <Swami> for the FWaaS East-West implementation for DVR.
15:08:21 <Swami> I have proposed two options with DVR.
15:08:50 <carl_baldwin> Swami: can you provide links?
15:08:52 <Swami> #link https://docs.google.com/document/d/11Gp62Yfyi1WH6yM6E_308OB4CC9A6xhxKZJ8B5jOwLc/edit
15:09:21 <Swami> i just wanted to validate the option 1 with the broader team before I drill deep into the implementaton specific.
15:09:46 <Swami> In the link you can see two pictures. The first one is the option 1.
15:10:10 <carl_baldwin> Swami: I think we’ll need to spend a little time looking through the diagram before we can have much of a discussion.
15:10:23 <Swami> Here FWaaS has an issue with the East-West because routing was only happening on one end of the node and the return traffic was not passing through the router on the same node.
15:10:41 <Swami> carl_baldwin: Ok, then we can have the discussion next week.
15:10:54 <SridarK> Swami: I am with u on leaning towards option 1
15:11:02 <Swami> But in the mean time can you take at option 1 and see if it is a viable solution.
15:11:14 <SridarK> Swami: With more discussion we can try to close before next week ?
15:11:25 <Swami> I just wanted to provide some high level description about both the options today.
15:11:32 <carl_baldwin> Swami: Maybe we could plan to meet less formally tomorrow so that we do not put it off another week.
15:11:33 <Swami> He can decide later.
15:12:06 <Swami> carl_baldwin: If you are available today at 11.00 to 12.00 pacific I can include you in the FwaaS meeting for East-West discussion.
15:12:33 <carl_baldwin> Yes, I am available and I’ll review before then.
15:12:35 <Swami> We do have a meeting today to discuss in detail about the proposals.
15:12:51 <Swami> Ok, then I will forward the meeting invite.
15:12:54 <carl_baldwin> Swami: Sounds good.
15:13:11 <Swami> Regarding the update on DVR.
15:13:24 <Swami> The VPNaaS support patch for DVR is up for review.
15:13:32 <carl_baldwin> Swami: How will this meeting be held? Will it be a conference, irc, hangout, or other?
15:13:51 <Swami> #link https://review.openstack.org/#/c/127133/
15:14:02 <Swami> This is a webconference I think.
15:14:31 <Swami> Yes it is a webex meeting.
15:14:38 <SridarK> Swami: carl_baldwin: y it is a webex
15:14:47 <Swami> SridarK: can you include carl in the webex meeting and invite him
15:14:59 <SridarK> Swami: sure will fwd
15:15:06 <carl_baldwin> Swami: Thank you for the link. Many have been focused on spec reviews. Soon, attention will shift more toward code review.
15:15:08 <Swami> ok
15:15:16 <Swami> carl_baldwin: thanks
15:15:27 <carl_baldwin> SridarK: Swami: Thanks. We’ll talk later today.
15:15:35 <SridarK> carl_baldwin: sounds good
15:15:37 <Swami> Also on the functional tests, adolfo has posted a patch for review.
15:15:52 <amuller> Swami: Yeah I didn't get the chance to review it yet
15:15:56 <amuller> just did a quick look
15:16:00 <carl_baldwin> Swami: Yes, I did see that.
15:16:00 <amuller> that's on me though
15:16:07 <Swami> #link https://review.openstack.org/138632
15:16:21 <Swami> amuller: thanks I knew that you are going to review it.
15:16:39 <mrsmith> for l3-ha and dvr, I have made some progress getting the dvr snat to work
15:16:44 <Swami> mrsmith: amuller and other are investigating the L3 DVR HA scenarios.
15:16:48 <mrsmith> I'll probably post a patch this week
15:16:57 <amuller> mrsmith: Sounds good
15:17:19 <carl_baldwin> mrsmith: sounds good.
15:17:24 <amuller> mrsmith: Mike and I did a lot of L3 HA + l2pop discussions... Hopefully he'll be able to post some code in 1 or 2 weeks
15:17:29 <amuller> not easy to fix that
15:17:44 <mrsmith> yes - too many "Mikes"
15:17:54 <amuller> in this case it's Kolesnik :)
15:17:58 <mrsmith> I was confused at first
15:18:02 <mrsmith> indeed!
15:18:28 <mrsmith> I'll be ready to test any ideas
15:18:48 <amuller> thanks
15:19:06 <carl_baldwin> Anything else for DVR today?
15:19:33 <Rajeev> carl_baldwin: I do have a review posted for devstack with ipv6 dvr
15:19:37 <Swami> nothing else.
15:19:54 <carl_baldwin> Rajeev: do you have a link?
15:20:11 <Rajeev> carl_baldwin: https://review.openstack.org/#/c/134676/5
15:21:00 <carl_baldwin> Rajeev: thanks
15:21:20 <mrsmith> I should point out for l3-ha rajeev is looking at the plugin side and I am working on the agent side
15:21:44 <carl_baldwin> mrsmith: thanks
15:21:46 <mrsmith> we will probably post 2 patches
15:22:13 <carl_baldwin> #topic L3 Agent Restructure
15:22:28 <Rajeev> mrsmith: Thanks, yes I will get a patch out too but may need a few more days
15:22:40 <carl_baldwin> I’m sorry to say that I haven’t had much time to focus on this this week.
15:23:02 <carl_baldwin> But, that will change today because the spec merged and it needs to be a top priority.
15:23:20 <carl_baldwin> amuller, pc_m, where are we with this?
15:23:39 <amuller> carl_baldwin: I haven't been able to get back to this since Tuesday
15:23:45 <pc_m> carl_baldwin: amuller will merge in his changes with mine.
15:23:52 <amuller> aye
15:24:00 <amuller> I should be able to get back to this early next week
15:24:11 <amuller> merge the two first commits and address the comments
15:24:18 <pc_m> amuller: Do you want me to merge them?
15:24:28 <amuller> If I'm blocking you go ahead
15:24:33 <amuller> If you can wait for me, that'd work for me
15:24:56 <pc_m> I can take a stab at it.
15:25:33 <amuller> pc_m: Did you get the chance to map out the required order of operations for the VPN observer?
15:25:40 <amuller> and if the current proposal could work?
15:26:18 <pc_m> amuller: I looked at it some early this week, but was going to do more today.
15:26:23 <amuller> ok
15:26:42 <amuller> I think that's the only reason concern at this point? Apart from changing the events from strings to an object or method(s)
15:26:54 <amuller> s/reason/real
15:27:02 <pc_m> amuller: yes
15:27:09 <amuller> the rest is naming and whatnot
15:27:13 <amuller> we can deal with that :)
15:27:50 <carl_baldwin> SridarK: Have you had a chance to look at FW in this context yet?
15:28:08 <pc_m> even the notification points are not a big deal (though clean to have small set of points)
15:28:11 <SridarK> carl_baldwin: not yet closing out on a FWaaS spec now
15:28:21 <SridarK> carl_baldwin: but will get this going next week
15:28:49 <carl_baldwin> SridarK: thanks.
15:30:18 <carl_baldwin> So, I’ll be working on this at least half the day today and much of tomorrow. Don’t hesitate to contact me if anything needs discussion.
15:30:34 <carl_baldwin> amuller, pc_m: Anything else we should discuss here?
15:30:42 <amuller> Nothing from me
15:31:15 <pc_m> carl_baldwin: don't think so. I can talk offline w/amuller on the merge
15:31:34 <carl_baldwin> amuller, pc_m, thanks
15:31:41 <carl_baldwin> #topic bgp-dynamic-routing
15:31:45 <carl_baldwin> devvesa: ping
15:31:53 <devvesa> hi
15:32:51 <carl_baldwin> devvesa: Anything new?
15:33:32 <devvesa> Well, I pushed a new patchset, which you already accepted... and I'm working on it
15:33:51 <devvesa> although I'm not full-time in it. So maybe it takes longer than (I) expected
15:34:09 <carl_baldwin> devvesa: Great. I’ll continue to try to get this topic in front of the Neutron drivers team.
15:34:25 <devvesa> Thanks.
15:34:29 <yamamoto> devvesa: anything i can help?
15:34:59 <carl_baldwin> yamamoto: Thanks for your review of the spec.
15:35:04 <devvesa> yamamoto: not now. I'm just re-doing the entities and endpoints exposed.
15:35:23 <devvesa> When I will have to work with the Ryu, I'm sure I'll ask you something :) Thanks
15:35:57 <yamamoto> devvesa: ok, thank you
15:36:14 <carl_baldwin> devvesa, yamamoto: thanks.
15:36:26 <carl_baldwin> #topic neutron-ipam
15:37:38 <carl_baldwin> johnbelamaric: How are we doing here?
15:37:58 <johnbelamaric> I believe that i have addressed all the comments on the core neutron-ipam spec
15:38:03 <carl_baldwin> I see there are two new patch sets since I reviewed it.
15:38:29 <carl_baldwin> #action carl_baldwin will review the spec again before the end of the week.
15:38:31 <carl_baldwin> #link https://blueprints.launchpad.net/neutron/+spec/neutron-ipam
15:38:32 <johnbelamaric> yes, though the second one is just filling in a TODO that I missed
15:38:44 <carl_baldwin> #link https://review.openstack.org/#/c/97967/
15:38:56 <johnbelamaric> minor point - it's on the wrong topic branch - any way to fix that?
15:39:16 <carl_baldwin> The owner of the patch can edit the topic right in gerrit.
15:39:29 <johnbelamaric> ok, I will ask Soheil to fix it. thanks
15:39:56 <carl_baldwin> It might be possible to push a new patch set to edit the topic using the git review command line option for a non-owner.
15:40:23 <johnbelamaric> i will take a look. thanks.
15:41:04 <carl_baldwin> I have uploaded a new patch set to my spec.
15:41:06 <carl_baldwin> #link https://review.openstack.org/#/c/135771/
15:41:38 <johnbelamaric> ok, i will review it this week, likely today
15:41:55 <carl_baldwin> I have also found an owner for the implementation that I’ve noted in the spec. I’ll be working closely with him.
15:42:22 <johnbelamaric> even better :)
15:42:25 <carl_baldwin> I forgot to ping him about attending this meeting. It is an early meeting for PST.
15:42:41 <johnbelamaric> Salvatore pushed a draft of the reference implementation spec
15:42:50 <carl_baldwin> I’m exciting to get these specs implemented for Kilo.
15:43:01 <carl_baldwin> johnbelamaric: I did not see that yet. Great!
15:43:24 <carl_baldwin> #link https://review.openstack.org/#/c/138803/
15:43:43 <johnbelamaric> yes, that's it
15:43:57 <carl_baldwin> #action carl_baldwin will review Salvatore’s spec today or tomorrow (likely tomorrow)
15:44:25 <johnbelamaric> we have a couple guys here at Infoblox to work on neutron-ipam and reference-ipam-driver
15:45:05 <carl_baldwin> johnbelamaric: There is one thing that I’m still not sure about. That is how to handle stateless ipv6 address generation.
15:45:05 <johnbelamaric> and i would like to also propose and infoblox-ipam-driver spec, which ideally we would get upstream in Kilo as well
15:46:01 <carl_baldwin> johnbelamaric: With recent focus on getting vendor stuff out of the tree, I wonder if it would be better to implement it out of tree. What do you think?
15:46:26 <johnbelamaric> carl_baldwin: I think for SLAAC a single helper to calculate the address that all the IPAMs use makes sense. i would see it more in this case as "inform the external IPAM" rather than "ask the external IPAM" - the address calc would be in the driver even for an external IPAM
15:47:22 <johnbelamaric> carl_baldwin: that is fine, though I am not clear on where that is landing. I thought there would be an upstream repo for it even if it's not in the same one. but it's not critical for us - what is critical is the core pluggability
15:47:24 <carl_baldwin> johnbelamaric: regarding slaac, I am starting to lean back toward having Neutron calculate the address and then just informing the driver about it by requesting a specific address.
15:47:40 <johnbelamaric> sure, that works too
15:47:52 <johnbelamaric> the driver should not be changing or rejecting it
15:48:23 <carl_baldwin> johnbelamaric: There could definitely be an open source repo and there could be third-party CI integration to test it against changes.
15:48:27 <salv-orlando> I would not focus too much on that for now. Both ways work. Unless distinct drivers might have their own way of doing SLAAC
15:48:57 <carl_baldwin> It is unclear to me whether the repo would live in gerrit or some other place like github.
15:49:31 <salv-orlando> johnbelamaric: I don't think we can make any chance of including drivers in tree if we don't validate the ipam with the reference impl first.
15:49:35 <carl_baldwin> salv-orlando: fair enough. I don’t think it should hold up the specs.
15:49:56 <johnbelamaric> carl_baldwin: ok, we'll just see where the split discussion lands.
15:50:02 <carl_baldwin> salv-orlando: I’m not sure how external IPAM could have its own way of doing slaac.
15:50:11 <salv-orlando> carl_baldwin: it's your choice (the repo). We do not have a policy for IPAM drivers yet - simply because they're just an artifcact of our minds so far
15:50:16 <johnbelamaric> salv-orlando: yes, definitely reference needs to be done prior to vendor
15:50:20 <salv-orlando> carl_baldwin: I am not sure either.
15:50:38 <salv-orlando> but I'm not the expert here. Just a random guy doing random things
15:50:51 <carl_baldwin> salv-orlando: less random than most.
15:51:04 <salv-orlando> carl_baldwin: it's just that I have a lucky seed ;)
15:51:09 <carl_baldwin> ;)
15:52:07 <carl_baldwin> I plan one more update to the interface. I’ll just take slaac the way I think it should go and you all can tell me if you think it is a really bad idea.
15:52:22 <carl_baldwin> Probably won’t be until next week though.
15:52:51 <carl_baldwin> Anything else to discuss on this topic?
15:53:01 <johnbelamaric> nope
15:53:09 <salv-orlando> carl_baldwin: if you're not coming to salt lake city meetup can you ping markmcclain about these specs. I think he has comments but he probably did not find them to put them on the gerrit review
15:53:39 <carl_baldwin> salv-orlando: I will both ping Mark and come to SLC. How’s that?
15:53:59 <carl_baldwin> #action carl_baldwin will ping Mark about the ipam specs.
15:54:16 <carl_baldwin> #topic pluggable-ext-net
15:54:36 <carl_baldwin> This topic hasn’t been on our agenda for a while.
15:55:03 <carl_baldwin> However, I have updated my spec for Kilo and I would like to work on this immediately after L3 agent restructuring.
15:55:19 <carl_baldwin> #link https://review.openstack.org/#/c/88619/
15:56:26 <carl_baldwin> I’m seeing this as important for IPv6 to support prefix delegation. Also, I’ve heard from a couple of operators who want this.
15:57:16 <salv-orlando> carl_baldwin: does this come before or after BGP routing? (you committed to that too...)
15:57:56 <carl_baldwin> salv-orlando: parallel. I’ll be working with BGP just as a reviewer and sound board.
15:58:34 <salv-orlando> carl_baldwin: cool. We'll see what we can do about the relevant specs. I have not reviewed both of them in a while. The spec approval deadline is close.
15:58:38 <carl_baldwin> This is the bridge that brings bgp and Neutron together to make it all work.
15:59:07 <carl_baldwin> salv-orlando: thank you. That is all I can ask.
15:59:19 <carl_baldwin> We’re about at time. Anything else?
15:59:23 <carl_baldwin> #topic Open Discussion
15:59:39 <jschwarz> not enough time so I'll just mention this
16:00:00 <jschwarz> I have the full-stack integration tests framework patches sitting at https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/integration-tests,n,z waiting for some attention
16:00:26 <carl_baldwin> jschwarz: Let’s take it to the openstack-neutron room.
16:00:31 <carl_baldwin> #endmeeting