15:00:07 <carl_baldwin> #startmeeting neutron_l3
15:00:08 <openstack> Meeting started Thu Dec 11 15:00:07 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:12 <openstack> The meeting name has been set to 'neutron_l3'
15:00:16 <carl_baldwin> pc_m: hi
15:00:21 <pc_m> carl_baldwin: hi!
15:00:40 <carl_baldwin> #topic Announcements
15:00:43 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:00:59 <carl_baldwin> We just wrapped up a very good mid-cycle.
15:01:13 <pc_m> +100
15:01:20 <carl_baldwin> The spec proposal deadline has passed.
15:01:35 <carl_baldwin> The spec approval deadline is this coming Monday.
15:01:50 <carl_baldwin> Any other announcements?
15:02:32 <carl_baldwin> #topic Bugs
15:03:19 <carl_baldwin> Any bugs to bring up?  I don’t see any new general L3 bugs since last week
15:03:48 <carl_baldwin> Though I think I’m do for another pass through the bug backlog.
15:04:16 <carl_baldwin> #action carl_baldwin will go through the existing bug list.
15:05:05 <carl_baldwin> #topic L3 Agent Restructuring
15:05:11 <Swami> I don't see any new bugs or critical on the dvr side.
15:05:22 <carl_baldwin> Swami: thanks
15:05:46 <carl_baldwin> We made a lot of progress on the L3 agent this week and gathered good momentum.
15:06:15 <carl_baldwin> Realistically, we’ve got a few more weeks to go on this.
15:06:54 <carl_baldwin> #link https://review.openstack.org/#/q/topic:bp/restructure-l3-agent+status:open,n,z
15:07:19 <carl_baldwin> The effort got a bit more complicated after the advanced services split.
15:08:00 <pc_m> Yes, need to get #link https://review.openstack.org/#/c/136549/ in, as FW and VPN services need the base class that's in that commit.
15:08:50 <carl_baldwin> pc_m: Yes, the dependency merged late yesterday.  I’ll review that next.
15:09:18 <Swami> carl_baldwin:with all these movemoments on L3 and services split, what will be the status of the current patches that are out for reveiw. Should it all wait for the transitions to happen first.
15:09:26 <pc_m> carl_baldwin: Great. That'll help getting that dependency out of the way.
15:09:41 <carl_baldwin> You should know that there are three new repositories (at least) neutron-vpnaas, neutron-fwaas, and neutron-lbass.
15:10:02 <carl_baldwin> Swami: If it isn’t critical then it should wait for the refactoring to go it.
15:10:24 <Swami> carl_baldwin: got it.
15:10:44 <carl_baldwin> The extra *aas repos means that our work is a ilttle more difficult until the refactoring is done which should decouple this quite a lot.
15:10:59 <pc_m> carl_baldwin: plus the tests in VPN/FW repos are still being skipped.
15:11:36 <carl_baldwin> pc_m: Good point.  What is your plan for the VPN tests?
15:12:19 <pc_m> carl_baldwin: Not sure :) Need to hook up with Doug, as he is going to work on getting the tests working.
15:12:36 <pc_m> plan to help on that as soon as I get back home.
15:12:40 <carl_baldwin> It is also worth noting that the core reviewer list for the new *aas repos is not the same as that of the neutron repo.
15:13:16 <carl_baldwin> pc_m: Keep me updated, I will follow up with fwaas about theirs.  Anyone from fwaas on today?
15:13:41 <carl_baldwin> #action carl_baldwin will follow up with fwaas about skipped tests.
15:13:45 <pc_m> carl_baldwin: sure. I'll probably help out on the FWaaS too.
15:14:01 * carl_baldwin reminds all to add action items for themselves when they come up.
15:14:08 <carl_baldwin> pc_m: That will help.
15:14:56 <pc_m> #action pc_m to work with Doug W on getting VPN and FW repo tests working.
15:15:57 <carl_baldwin> Let’s try to drive the current patches quickly.  We have a few more patches coming.  For example, creating the router class and moving router functionality out.  Creating that inheritence hierarchy to encapsulate DVR and HA, more *aas decoupling, etc.
15:16:34 <carl_baldwin> Try to give these patches priority in the review queue both on the reviewer and contributor side of things.
15:16:49 <carl_baldwin> Anything else we should bring up about the refactoring?
15:17:09 <pc_m> looks like you got it all.
15:17:26 <carl_baldwin> Here is another one that I think is ready:  https://review.openstack.org/#/c/140193/
15:19:46 <carl_baldwin> #topic bgp-dynamic-routing
15:19:48 <carl_baldwin> devvesa: ping
15:19:54 <carl_baldwin> Anything new this week?
15:20:15 <devvesa> well, it seems like the BGP proposal has been rejected
15:20:23 <carl_baldwin> Looks like the spec has been dropped from kilo.
15:20:27 <devvesa> yes
15:20:32 <carl_baldwin> I can’t say that I’m not really dissappointed.
15:20:56 <carl_baldwin> This just means that everything else will be pushed out further.
15:21:30 <carl_baldwin> I will propose it for reactivation later in Kilo.
15:21:41 <devvesa> what's 'everything else'?
15:22:35 <carl_baldwin> By “everything else” I meant anything that would leverage a bgp speaker in Neutron.
15:23:10 <devvesa> Oh. Sure. Anyway, I think the BGP-VPN guys are taking another path with the advanced services split
15:23:28 <carl_baldwin> There is the backing network work that I was going to do which requires bgp.
15:24:08 <carl_baldwin> ipv6 subnet routing requires bgp or something to complete routing.
15:24:22 <devvesa> Decision from Midokura will be to develop it as vendor extension, and then, keep trying to push it into neutron
15:24:42 <devvesa> You might consider to install midonet in HP datacenters :P
15:24:55 <carl_baldwin> :)
15:25:22 <devvesa> Well, meanwhile. If any of you need any kind of help, don't hesitate in let me know
15:25:24 <carl_baldwin> It may just mean that we’ll have to run some code outside of upstream.
15:26:00 <carl_baldwin> devvesa: Thanks.  I’d still like to collaborate on this.  If the implementation were still completed, it would be easier to argue to get it in if there is room in Kilo.
15:26:17 <carl_baldwin> I will certainly still continue to review the code and will start with what you have up now.
15:26:22 <carl_baldwin> devvesa: Anything else?
15:26:44 <devvesa> I'm afraid that's all
15:26:57 <carl_baldwin> devvesa: Thanks
15:27:02 <devvesa> thanks carl_baldwin
15:27:06 <carl_baldwin> Keep doing good work.
15:27:10 <carl_baldwin> #topic neutron-ipam
15:27:45 <carl_baldwin> johnbelamaric: I’ll make another pass on https://review.openstack.org/#/c/97967/ today.  I think it has to be close.
15:28:11 <johnbelamaric> carl_baldwin: ok, good. so far no comments on the last PS
15:28:26 <carl_baldwin> #action carl_baldwin will review https://review.openstack.org/#/c/97967/ today
15:28:47 <carl_baldwin> tidwellr1: I see you’ve been hard at work on https://review.openstack.org/#/c/135771/
15:29:12 <tidwellr1> carl_baldwin: yes
15:29:30 <carl_baldwin> Thank you for taking that on.  I will review that today too.
15:29:49 <carl_baldwin> #action carl_baldwin will review https://review.openstack.org/#/c/135771/
15:30:05 <tidwellr1> still some loose ends on that, I hope to tie them up today
15:30:19 <carl_baldwin> sc68cal: Would you mind taking another look at it?
15:31:16 <carl_baldwin> johnbelamaric: Anything more to bring up?
15:31:58 <johnbelamaric> one thing - on your comment on subnet-allocations, it sounded like you were thinking a global default prefix length - i think the default is per pool
15:31:58 <carl_baldwin> tidwellr1: How about you?
15:32:30 <johnbelamaric> just wanted to make sure we were all on the same page there
15:32:32 <carl_baldwin> johnbelamaric: per pool is what I was thinking.  Maybe it was unclear.
15:32:33 <tidwellr1> I was thinking a per-pool default
15:32:35 <johnbelamaric> ok
15:32:39 <johnbelamaric> good
15:32:47 <johnbelamaric> that's it for me
15:33:11 <tidwellr1> that's all for me
15:33:32 <carl_baldwin> johnbelamaric: tidwellr1:  Thanks.  This has come a long way.
15:33:53 <carl_baldwin> I think that both specs are manageable for Kilo.
15:34:12 <carl_baldwin> #topic neutron-ovs-dvr
15:34:12 <johnbelamaric> great, i think it will be a good addition
15:34:35 <mrsmith> Swami might have dropped off
15:34:39 <Swami> carl_baldwin: hi
15:34:47 <carl_baldwin> Swami: mrsmith: hi
15:34:47 <Swami> I am still here mike.
15:34:48 <mrsmith> guess not :)
15:35:09 <Swami> dvr team is still in the process of fixing bugs and filling in the technical debts.
15:35:19 <carl_baldwin> Rajeev: hi, you’re right on time.
15:35:31 <Rajeev> carl_baldwin: Hi.
15:35:33 <Swami> We have a bunch of patches in review and in progress.
15:35:58 <Swami> Right now we are also looking at the "instability" issues reported from the gate.
15:36:20 <Swami> Adolfo is looking into those tests to understand and what test is mainly causing the instability.
15:36:35 <carl_baldwin> Swami: I took a look through the backlog yesterday.  I plan to discuss with armax this week about diverting some core reviewer attention to it now that the specs review process is winding down.
15:36:47 <Swami> The issue that we might have now is with all the refactor happening, it would be a double fix and refactor for us.
15:37:05 <Swami> carl_baldwin: I would appreciate it.
15:37:22 <mrsmith> Rajeev and I have made good progress with l3-ha and DVR
15:37:31 <mrsmith> I pushed a patch for the agent last week
15:37:33 <carl_baldwin> Swami: That is great.  I linked the graph of the stability gap between non-dvr and dvr to the L3 subteam page.
15:37:34 <Swami> Regarding the dvr documentation we do have a good handle now and working with the documentation folks.
15:37:40 <carl_baldwin> … under the neutron-ovs-dvr section.
15:37:58 <Swami> carl_baldwin: thanks
15:38:27 <Swami> mrsmith: Rajeev : do you have anything else to discuss
15:39:06 <mrsmith> covered most of my points - backlog progress, l3-ha, gate
15:39:34 <mrsmith> I want to help out more with refactor patches - carl_baldwin: are there any for dvr I can take on?
15:39:40 <Swami> carl_baldwin: One other information is if our patches get delayed and more focus is given to the l3-refactoring work, may be we can help to speed up the process of l3-refactoring. mrsmith would be a valid candidate to fill in the l3-refactoring work.
15:40:04 <Swami> Also I can help on the services split vpnaas with pcm.
15:40:46 <Swami> dvr vlan patch is also progressing. I think vivek is posting patches upstream.
15:40:55 <Swami> That's all I have from the dvr side.
15:41:07 <pc_m> Swami: super. Can use help with reviews that are out right now.
15:41:14 <carl_baldwin> mrsmith: mlavalle and I will start moving router functionality out to router.py today.  We also need to create a dvr_router.py with a class that sub-classes the router class.
15:41:36 <Swami> pc_m: sure I will start reviewing the patches that are out there.
15:41:38 <carl_baldwin> Swami: I agree.
15:41:53 <carl_baldwin> mrsmith: Do you want to create the dvr_router.py?
15:41:56 <mrsmith> carl_baldwin: is there a patch for the router.py work?
15:42:04 <carl_baldwin> mrsmith: Coming very soon.
15:42:09 <mrsmith> sure - I can create dvr_router.py
15:42:10 <mrsmith> ok
15:42:47 <Swami> sorry folks I need to drop off. I will catch up with the logs.
15:42:48 <carl_baldwin> For now, we can start by creating a very small class that sub-classes the router
15:42:53 <carl_baldwin> Swami: Thanks.
15:43:27 <carl_baldwin> As the router class is fleshed out with more methods, there will be dvr only functionality which can be moved to the sub-class.
15:43:37 <mrsmith> sounds good
15:43:49 <carl_baldwin> mrsmith: I imagine the same could be done with HA.
15:43:58 <carl_baldwin> amuller may be able to work with you on that.
15:44:04 <Rajeev> great, I am focussing on plugin side HA for now, but help out where I can
15:44:38 <carl_baldwin> Rajeev: thanks.
15:45:44 <carl_baldwin> Anything else?
15:46:28 <carl_baldwin> Keep on eye on the dvr tempest job stability.  Looks like it may be starting to diverge further today.
15:46:50 <carl_baldwin> The link to the graph is too large for me to want to paste it here.  But, it is link from the L3 subteam page.
15:47:27 <mrsmith> we need more tests
15:48:51 <carl_baldwin> mrsmith: Yes, we do.  We also need to review the current tests proposed.
15:49:07 <carl_baldwin> #action carl_baldwin will review https://review.openstack.org/#/c/138632/
15:49:28 <carl_baldwin> #topic Open Discussion
15:49:41 <carl_baldwin> Anything I’ve missed?
15:51:24 <Rajeev> carl_baldwin: you may have touched this earlier, for the l3_agent refactor new non-refactor checkins are on hold for now
15:51:48 <carl_baldwin> Rajeev: Yes, I sent a message to the mailing. list.
15:52:10 <Rajeev> carl_baldwin: thanks, fair to expect a similar message when done ?
15:52:43 <carl_baldwin> Rajeev: I hope the heavy lifting can be done in a couple of weeks.  I will send a similar message when it is at a more stable point.
15:53:07 <Rajeev> Yes, that will be very helpful
15:53:55 <carl_baldwin> Thanks, everyone.  I’ve got a flight to go board.
15:54:11 <Rajeev> have a safe trip!
15:54:14 <carl_baldwin> #endmeeting