15:02:02 <carl_baldwin> #startmeeting neutron_l3
15:02:04 <openstack> Meeting started Thu Dec 18 15:02:02 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:07 <openstack> The meeting name has been set to 'neutron_l3'
15:02:14 <carl_baldwin> hi all
15:02:16 <yamamoto> hi
15:02:18 <mlavalle> hi
15:02:19 <johnbelamaric> hi
15:02:34 <carl_baldwin> #topic Announcements
15:02:40 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:02:54 <carl_baldwin> Looks like I need to update the agenda a bit.
15:03:16 <carl_baldwin> Looks like kilo-1 is today.
15:03:26 <carl_baldwin> https://wiki.openstack.org/wiki/Kilo_Release_Schedule
15:03:44 <mrsmith> howdy
15:04:34 <carl_baldwin> Specs are winding down for kilo.
15:04:48 <carl_baldwin> Are there any specs still lingering in the review queue that have not been finalized?
15:05:38 <carl_baldwin> #topic L3 Agent Restructuring
15:06:10 <carl_baldwin> pc_m: Are you around?
15:06:22 <carl_baldwin> amuller: ?
15:06:40 <haleyb> bueller? :)
15:07:52 <carl_baldwin> Well, Paul’s patch merged yesterday.  It had a few patches behind it that we should be able to merge soon.
15:08:00 <carl_baldwin> mlavalle: hi
15:08:11 <mlavalle> carl_baldwin: hi
15:08:31 <mlavalle> I added the next episode to the process_router last nigh: https://review.openstack.org/#/c/142644/
15:09:16 <carl_baldwin> mlavalle: I’ll have a look.  Could you edit the topic to “bp/restructure-l3-agent”?
15:09:18 <mlavalle> it follows up on the comments that carl_baldwin and haleyb made to my previous patch about about defer_off and defer_on
15:09:37 <mlavalle> carl_baldwin: yeah, I'll sure do that
15:09:42 <pc_m> sorry I'm late
15:09:55 <carl_baldwin> pc_m: hi
15:10:00 <mlavalle> after that patchset I'll start moving methods to the router calss
15:10:02 <carl_baldwin> pc_m: I see that your patch merged.
15:10:13 <pc_m> yes!
15:10:31 <carl_baldwin> mlavalle: I started taking a crack at that yesterday.  It may take more than one person to tag team on that.
15:10:52 <mlavalle> carl_baldwin: coll, let me know how can I help
15:10:54 <carl_baldwin> pc_m: Will you be driving the adv svcs portion of that now?
15:11:09 <mrsmith> I made good progress with dvr.py
15:11:24 <pc_m> carl_baldwin: sorry, late... portions of...?
15:11:26 <carl_baldwin> mlavalle: I will post a WIP today with a start.  I thought I’d start with the floating ip methods.  The choice was a bit arbitrary but seemed as good as any.
15:11:38 <mrsmith> moving dvr metods, etc there
15:11:42 <mlavalle> carl_baldwin: :-)
15:11:46 <haleyb> mlavalle: i will review your change today before i leave for holidays
15:11:56 <mlavalle> haleyb: thanks!
15:12:17 <mrsmith> carl_baldwin: I can adjust once I see what your patch looks like
15:12:39 <carl_baldwin> mrsmith: Great.
15:13:03 <carl_baldwin> mrsmith: I will post what I have soon.  It will not pass tests but I’ll be working on that.
15:13:07 <mrsmith> I also created a agents/common/constants.py file to hold our constants
15:13:27 <carl_baldwin> mrsmith: Is yours up as a WIP?
15:13:41 <mrsmith> not yet, probably today
15:14:10 <mrsmith> UTs are passing, etc - just doing some cleanup
15:14:31 <carl_baldwin> mrsmith: okay
15:15:48 <carl_baldwin> Sounds like we’ve got a lot of work going on.  Just be sure to use “bp/restructure-l3-agent” as the topic and I’ll track it and drive it as much as I can.
15:15:50 <mrsmith> I am using mixins like the ha.py does
15:16:46 <carl_baldwin> mrsmith: I was just thinking yesterday about how to change ha.py from using a mixing to being a sub-class.
15:16:53 <carl_baldwin> amuller: hi
15:17:03 <amuller> hiya
15:17:07 <amuller> Sorry meeting ran late
15:17:28 <carl_baldwin> amuller: thanks for making it.
15:17:39 <carl_baldwin> amuller: Do you have time to address https://review.openstack.org/#/c/137672/?
15:17:45 <mrsmith> carl_baldwin: sure... I was just going with small changes first
15:18:14 <amuller> carl_baldwin: Not today :( We had a lot of L3 HA blocker bugs pop up lately
15:18:30 <carl_baldwin> mrsmith: okay, sounds good.
15:18:48 <carl_baldwin> amuller: Okay, I’ll take a look at it today.
15:19:35 <amuller> carl_baldwin: Thank you
15:20:18 <carl_baldwin> amuller: You’re welcome.  I think we’ll be tag teaming much of this work to try to keep it going.
15:20:32 <carl_baldwin> Is there anything else on refactoring that we need to discuss?
15:21:25 <carl_baldwin> #topic bgp-dynamic-routing
15:21:31 <carl_baldwin> devvesa: Hi
15:21:38 <devvesa> hi
15:21:45 <carl_baldwin> I think I’ll probably move this topic later in the agenda but I do not want to drop it.
15:22:14 <devvesa> sure, no problem. I was about to ask you the same. Maybe even drop it for now if you want
15:22:31 <carl_baldwin> For now, I think our best bet is to continue the L3 agent refactoring so that it will be easier to eventually make the L3 changes needed to connect to L3 routed network.
15:23:08 <carl_baldwin> devvesa: That is fine.  I’ll plan to add it back to the agenda around kilo-2.
15:23:36 <devvesa> Ok. I'll be in the available in the meetings anyway
15:23:54 <devvesa> So add it again anytime
15:23:59 <carl_baldwin> devvesa: Thanks for all of your work.  It is good to have you here.
15:24:13 <devvesa> Thanks carl
15:24:16 <carl_baldwin> #topic neutron-ipam
15:24:36 <carl_baldwin> johnbelamaric: hi
15:24:49 <carl_baldwin> salv-orlando: around?
15:24:50 <johnbelamaric> hi
15:26:00 <carl_baldwin> Looks like there is one more spec to merge.
15:26:11 <carl_baldwin> #link https://review.openstack.org/#/c/138803/
15:26:32 <johnbelamaric> right
15:26:47 <carl_baldwin> We kind of need this to continue with the other specs.
15:27:33 <johnbelamaric> yes, have you heard anything from salv-orlando ?
15:28:30 <carl_baldwin> johnbelamaric: Looks like he’s been granted an extension until tomorrow to address the comments on the spec.  Probably because it is needed by our other specs that have been accepted.
15:28:42 <johnbelamaric> ok
15:29:38 <johnbelamaric> so - the plan now is to start work on refactor based on the WIP interface you have submitted?
15:30:33 <carl_baldwin> johnbelamaric: Yes, I think so.  It would be nice to tie up any loose ends on the interface.  Would you have any time to see what is still needed?
15:30:34 <johnbelamaric> once this spec has merged I think we can start on that - would be best to understand some of the plans here prior to refactoring
15:30:48 <johnbelamaric> i will take a look today
15:31:16 <carl_baldwin> johnbelamaric: Thanks.
15:31:25 <carl_baldwin> There is another related BP still in review.
15:31:27 <carl_baldwin> #link https://review.openstack.org/#/c/93054/
15:32:32 <carl_baldwin> I don’t think it will fit in to kilo with the rest of the IPAM work.  But, it will be a very nice enhancement to IPv6 capabilities.
15:32:58 <johnbelamaric> i have not looked at that one, I will take a peek
15:35:14 <carl_baldwin> johnbelamaric: Thanks.
15:35:28 <carl_baldwin> Anything else on IPAM?
15:36:04 <carl_baldwin> I think we need to get the work on the reference implementation started soon.  I’ll talk to salv-orlando about that.
15:36:23 <carl_baldwin> #action carl_baldwin will sync with salv-orlando on reference implementation.
15:36:25 <johnbelamaric> nothing more from me
15:36:51 <carl_baldwin> #topic neutron-ovs-dvr
15:37:12 <carl_baldwin> Had the dvr meeting yesterday.  Anything new since then?
15:37:52 <carl_baldwin> mrsmith: My impression yesterday is that there are a lot of reviews in play for dvr.
15:37:59 <mrsmith> I started the dvr.py refactoring effort as we discussed above
15:38:05 <carl_baldwin> More than I can wrap my head around.
15:38:13 <mrsmith> yes - there are a few patches in review
15:38:37 <mrsmith> manual snat move, agent restart, ipv6, l3-ha
15:38:44 <mrsmith> multiple ext nets
15:39:02 <mrsmith> we are actively working on them all :)
15:39:22 <mrsmith> functional tests also
15:39:45 <mrsmith> also trying to debug and isolate failures on the experimental tempest job
15:40:26 <carl_baldwin> mrsmith: Speaking of which, it looks like the failures are spiking again today.
15:40:46 <mrsmith> ahh... spikes are different... usually a clear breakage
15:41:10 <carl_baldwin> Yes, it looks like we have another breakage.  :(
15:41:48 <carl_baldwin> Yesterday the failure rate was tracking much closer to that of check-tempest-dsvm-neutron-full
15:42:13 <mrsmith> thats the goal
15:42:25 <carl_baldwin> What is it about Thursdays and this test job?
15:42:30 <mrsmith> I'll spend some cycles looking at this new breakage
15:42:53 <carl_baldwin> mrsmith: Thanks.
15:43:31 <carl_baldwin> Anything more on dvr?
15:44:00 <carl_baldwin> #topic l3-high-availability
15:44:24 <carl_baldwin> amuller: You mentioned L3 HA bugs?  Is there anything you want to discuss or mention here?
15:44:34 <amuller> We're doing some internal testing of L3 HA
15:44:48 <amuller> and found a few issues. There's also been some bugs reported by the community in the last couple of weeks
15:44:53 <amuller> I've been managing the l3-ha bugs list
15:45:20 <amuller> Carl I'll ping you when I feel a fix is ready for any of these bugs
15:45:41 <amuller> currently some fixes are missing, some are in review and not yet ready
15:46:21 <amuller> There's one which I would appreciate some thoughts on: Making L3 HA and l2pop work, is important both for L3 HA and to eventually integrate L3 HA and DVR. Mike Kolesnik has started a mailing list thread about this.
15:46:41 <carl_baldwin> amuller: Do you have a link for that one handy
15:46:42 <carl_baldwin> ?
15:47:04 <amuller> It's called [openstack-dev] [Neutron][L2Pop][HA Routers] Request for comments for a possible solution
15:47:28 <carl_baldwin> Ah, ML thread.  I’m with you now.
15:47:52 <amuller> That's it for me
15:48:23 <carl_baldwin> amuller: Thanks.
15:49:27 <carl_baldwin> #link http://lists.openstack.org/pipermail/openstack-dev/2014-December/053240.html
15:50:39 <carl_baldwin> #topic Open Discussion
15:52:15 <carl_baldwin> Thanks everyone!
15:52:22 <amuller> carl_baldwin: Thank you
15:52:24 <pc_m> bye!
15:52:30 <carl_baldwin> #endmeeting