15:00:57 <carl_baldwin> #startmeeting neutron_l3
15:00:57 <openstack> Meeting started Thu Jan  8 15:00:57 2015 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:00 <openstack> The meeting name has been set to 'neutron_l3'
15:01:21 <carl_baldwin> #topic Announcements
15:01:28 <Swami> hi
15:01:34 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:02:08 <carl_baldwin> #info Kilo-2 will be on February 5th
15:02:22 <carl_baldwin> Any other announcements?
15:03:20 <carl_baldwin> #topic Bugs
15:04:01 <carl_baldwin> Looks like I need to triage a little but I don’t see any new bugs to discuss
15:04:20 <carl_baldwin> #action carl_baldwin to triage new bugs
15:04:48 <carl_baldwin> #topic L3 Agent Restructuring
15:05:20 <carl_baldwin> I’ve been making a lot of progres on this this week.
15:06:14 <carl_baldwin> #link https://review.openstack.org/#/c/143733 is about ready to merge I think.
15:06:26 <carl_baldwin> amuller: ping
15:08:29 <carl_baldwin> Yesterday, I started teasing out fip namespace logic.  I would like eyes from Rajeev, mrsmith, and other dvr expertise here.
15:08:49 <carl_baldwin> #link https://review.openstack.org/#/c/145565/
15:08:51 <mrsmith> sure - no prob
15:09:22 <Swami> I will take a look at it
15:09:45 <carl_baldwin> mrsmith: Swami: thanks.
15:10:43 <pc_m> Can use review of FW refactoring: #link https://review.openstack.org/140884
15:11:05 <pc_m> Will then work on event handlers with SridarK
15:11:19 <carl_baldwin> I think my patch changes the logic a bit.  I think it better acknowledges multiple external networks.
15:11:56 <mrsmith> Swami and I are working thru issues already with multiple ext nets and dvr
15:12:12 <mrsmith> all these refactors make for busy reabses
15:12:16 <mrsmith> :)
15:13:20 <carl_baldwin> mrsmith: I know.  That’s why I want eyes on it right away.  It proved too difficult to do the floating ip refactoring without first working on the fip namespace.
15:13:37 <carl_baldwin> pc_m: I will look today.
15:13:44 <pc_m> carl_baldwin: Thanks!
15:14:08 <carl_baldwin> #action carl_baldwin will review https://review.openstack.org/#/c/140884/
15:18:01 <carl_baldwin> mrsmith: Swami: feel free to ping me with your concerns.  How has multiple ext-net progress been going?
15:18:19 <Swami_> carl_baldwin: we have a couple of patches that we are working on right now.
15:18:32 <mrsmith> good - definitely need some dvr agent changes
15:18:37 <Swami_> The final one is the "floatingip-namespace" correction. I am currently working on it.
15:19:34 <carl_baldwin> Do you have links to the patches handy?
15:20:11 <Swami_> #link https://review.openstack.org/#/c/142674/
15:20:24 <Swami_> #link https://review.openstack.org/#/c/143567/
15:20:43 <Swami_> These two above patches fixes the current exceptions that are raised.
15:21:10 <Swami_> As I mentioned we found an issue with the FIP namespace creation issues when there are more than one external network.
15:21:19 <mrsmith> the main issue is handling separate fip-namespaces for each ext net
15:21:24 <Swami_> We are working on it and when we have a wip I will push it in.
15:22:33 <carl_baldwin> mrsmith: You will definitely want to check out this patch in that context: https://review.openstack.org/#/c/145565/
15:23:00 <carl_baldwin> Hopefully we’re not going in incompatible directions.
15:23:03 <mrsmith> carl_baldwin: okay
15:23:50 <mrsmith> as you know, refactoring and bug fixing can be hard to do at the same time :)
15:24:31 <mrsmith> but we have to make progress on the refactoring
15:25:16 <carl_baldwin> mrsmith: I do know.  That is why I’m trying to call attention to what I’m doing very quickly rather than waiting to post the final result later.
15:25:30 <mrsmith> +1
15:25:46 <carl_baldwin> mrsmith: Swami_:  Yesterday afternoon, I added this:  https://review.openstack.org/#/c/145565/3/neutron/agent/l3/dvr.py L46
15:26:49 <Swami_> +1
15:27:13 <carl_baldwin> The new fip namespace class takes the external network id.  Multiple instances are created.  This was something that the old code wasn’t careful about.
15:27:38 <carl_baldwin> Anyway, we should move on.  Please ping me with your concerns.
15:27:48 <mrsmith> yes - or just plain ignorant... adding an array is something Swami and I were thinking of
15:28:08 <mrsmith> yup - thanks for working on this as always carl_baldwin
15:28:15 <carl_baldwin> pc_m: Anything else?
15:28:24 <Swami_> carl_baldwin: Just looking at your changes in the fip patch.
15:28:25 <pc_m> no, i'm all set.
15:28:36 <Swami_> That was exactly what we were thinking on
15:28:53 <Swami_> I will review your patch completely, test it and will provide my inputs.
15:29:22 <carl_baldwin> Swami_: At least we’re thinking along the same lines.  I will appreciate that.
15:29:41 <carl_baldwin> #topic neutron-ipam
15:30:04 <carl_baldwin> johnbelamaric: hi
15:30:14 <carl_baldwin> salv-orlando: ping
15:30:15 <johnbelamaric> carl_baldwin: hello
15:30:47 <carl_baldwin> All the relevant blueprints are in good shape, I think.
15:31:34 <johnbelamaric> yes. what do we need to get your interface merged?
15:31:58 <johnbelamaric> #link https://review.openstack.org/#/c/134339/
15:32:26 <johnbelamaric> most of our team was out for the holidays but we should be able to get going on refactor soon
15:32:45 <carl_baldwin> johnbelamaric: I was hoping to see salv-orlando’s work show up as a dependant patch sometime soon.
15:33:20 <carl_baldwin> johnbelamaric: Also, seeing a start on the refactoring of neutron as a dependent patch soon would be nice.
15:33:59 <johnbelamaric> carl_baldwin: ok
15:35:09 <carl_baldwin> I was thinking that starting both those efforts may show where the interface is deficient.
15:35:42 <carl_baldwin> johnbelamaric: What do you  think?
15:35:42 <johnbelamaric> carl_baldwin: yes, good point - we'll get started ASAP
15:36:46 <carl_baldwin> johnbelamaric: great!
15:36:52 <johnbelamaric> carl_baldwin: might be conflicts with salv-orlando's work, but we will resolve when we see that
15:37:58 <carl_baldwin> johnbelamaric: I’ll watch out for conflicts.  Initially, there shouldn’t be much conflict as salv-orlando will be working on mostly new code.
15:38:36 <carl_baldwin> johnbelamaric: anything else to discuss?
15:38:38 <johnbelamaric> carl_baldwin: right, but depending if he works on integrating it to the existing Db plugin. anyway, the bulk should be non-conflicting
15:38:45 <johnbelamaric> carl_baldwin: nope
15:38:51 <salv-orlando> I am not sure I am working on new code. I am moving existing code into new places
15:39:25 <salv-orlando> also - I am doing work dependent on patch #134339 and contextually removing existing IPAM logic in db_base_plugin_v2
15:39:54 <salv-orlando> nevertheless we should not stop each other fearing conflicts. Let's work independently and fix the conflicts when they arise
15:40:06 <johnbelamaric> salv-orlando: ok, will do
15:40:50 <carl_baldwin> salv-orlando: ok.  I misunderstood a bit.  I guess I thought that you would create new code without moving out the old implementation at first.  But, I’m okay with this too.
15:41:41 <carl_baldwin> salv-orlando: agree about conflicts.
15:41:50 <salv-orlando> carl_baldwin: If I did so then we would have the new and old implementation at the same time - with the new one untestable beyond unit test. Nobody would let us merge that.
15:42:13 <salv-orlando> But on the other hand we can still have a 3rd patch in the same patch series which does the cleanup in neutron and hooks the new logic
15:42:26 <salv-orlando> I mean does the "glueing"
15:42:50 <carl_baldwin> salv-orlando: I’ll let you go about your business.  Don’t want to tell you how to get it done.
15:43:14 <carl_baldwin> salv-orlando: Anything else to update?
15:43:15 <salv-orlando> carl_baldwin: you can I won't get offended
15:44:08 <salv-orlando> carl_baldwin: I have nothing else on IPAM or anything l3
15:44:34 <carl_baldwin> salv-orlando: thanks for the update.  I look forward to the ipam patch(es)
15:44:37 <salv-orlando> I am dealing with the aftermath of setting dnsmasq minimum requirement to 2.67, but that's not something that should concern you here ;)
15:45:30 <carl_baldwin> salv-orlando: I saw that going on.  Hope you get that straightened out without too much trouble.
15:45:39 <carl_baldwin> salv-orlando: johnbelamaric thanks.
15:45:53 <carl_baldwin> #topic neutron-ovs-dvr
15:45:57 <salv-orlando> carl_baldwin: there is no trouble unless you have consumers insisting on using ubuntu 12.04 ;)
15:46:19 <Swami_> carl_baldwin: I need to drop off, mike will provide the update on dvr
15:46:38 <carl_baldwin> Swami_: thanks
15:46:40 <mrsmith> we already talked about multi-ext-nets
15:46:58 <mrsmith> Rajeev and I are making progress on dvr-l3-ha
15:47:12 <mrsmith> keeping up with the refactoring
15:47:54 <Rajeev_> Links to patches : https://review.openstack.org/#/c/139686/
15:48:03 * carl_baldwin is just making life difficult everywhere for you, isn’t he?
15:48:05 <Rajeev_> https://review.openstack.org/#/c/143169/
15:48:23 <mrsmith> just keeping things interesting carl_baldwin ;)
15:48:40 <mrsmith> dvr-l3-ha is still wip
15:48:43 <Rajeev_> carl_baldwin: our turn will come too :)
15:48:45 <mrsmith> but we are close
15:49:07 <mrsmith> the l2pop patch seems stalled
15:49:20 <mrsmith> to fix l3-ha running with l2pop
15:49:33 <mrsmith> we will need that to get fixed for dvr-l3-ha to work
15:50:17 <carl_baldwin> mrsmith: link handy?
15:50:33 <mrsmith> no.... let me try to find it
15:51:03 <carl_baldwin> Rajeev_: Did you see the discussion earlier on https://review.openstack.org/#/c/145565 ?
15:51:50 <Rajeev_> carl_baldwin: no, but I will take a look at it and catch up from mrsmith
15:51:56 <carl_baldwin> Rajeev_: I would value your feedback on it.
15:52:24 <Rajeev_> carl_baldwin: will do
15:53:05 <mrsmith> here is the stalled l2pop patch:
15:53:23 <carl_baldwin> Rajeev_: regarding HA/DVR, have you seen https://review.openstack.org/#/c/143733 ?
15:53:45 <mrsmith> https://review.openstack.org/#/c/141114/
15:54:49 <Rajeev_> carl_baldwin: This is the refactoring into derived classes for dvr agent side.
15:55:05 <carl_baldwin> #action carl_baldwin will review https://review.openstack.org/#/c/141114/ today
15:55:30 <carl_baldwin> Rajeev_: Yes.  I’d value some feedback in the context of enabling dvr with ha.
15:56:33 <Rajeev_> carl_baldwin: will take a look with mrsmith as he is focusing on agent side ha dvr work.
15:56:34 <carl_baldwin> I’d also like amuller to take a look but I’ve just heard he’ll be out for a week.
15:57:12 <mrsmith> carl_baldwin: fyi I think I've already hit some oddities while using mixins and trying to implement ha and dvr
15:57:51 <mrsmith> so the derived classes may help
15:59:38 <carl_baldwin> We’re about out of time.  I’ve got to be offline to get in to the office but should be around the rest of the day.
16:00:11 <carl_baldwin> Thanks for all of your work.  Let’s communicate often during this refactoring.  We’ll get through it and I think we’ll be better off for it.
16:00:22 <carl_baldwin> #endmeeting