15:03:31 <carl_baldwin> #startmeeting neutron_l3
15:03:31 <openstack> Meeting started Thu Jan 15 15:03:31 2015 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:35 <openstack> The meeting name has been set to 'neutron_l3'
15:03:40 <carl_baldwin> #topic Announcements
15:03:50 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:04:07 <pavel_bondar> hi
15:04:11 <carl_baldwin> Kilo-2 is Feb 5.  Going to sneak up on us very quickly.
15:04:22 <carl_baldwin> Any other announcements?
15:04:54 <carl_baldwin> #topic Bugs
15:05:27 <carl_baldwin> I don’t see any new bugs since last week.  However, I only did half the triage that I was going to do.  So, I need to finish.  Just a couple more to triage.
15:05:43 <carl_baldwin> #action carl_baldwin to finish bug triage
15:05:52 <carl_baldwin> Any other bugs to bring up?
15:06:30 <carl_baldwin> #topic L3 Agent Restructuring
15:07:03 <carl_baldwin> I think we’ve made some great progress on this.  We’re starting to get some things untangled.
15:07:55 <carl_baldwin> This morning, I’m going to look at https://review.openstack.org/#/c/142644 and rebase it in to the chain to merge soon.
15:08:30 <mlavalle_> :-)
15:08:35 <carl_baldwin> mrsmith also reminded me about https://review.openstack.org/#/c/136042 which I think I can work in today.
15:09:02 <mrsmith> +1
15:09:06 <carl_baldwin> mlavalle_: Anything new on namespace refactoring?
15:09:36 <mlavalle_> mlavalle_: it's taking me a little bit longer than I expected, but making progress
15:09:58 <mlavalle_> carl_baldwin: I should push at the end of the day
15:10:27 <carl_baldwin> mlavalle_: ping me when it is ready.  Meanwhile, I’ll work on getting the above two worked in ^^.
15:10:28 <mlavalle_> so you can start looking at it. I am tracking closely your fip namesapaces patch, so we should align easily
15:10:53 <mlavalle_> will do
15:11:10 <carl_baldwin> mlavalle_: I think my fip namespace one has stabilized.
15:11:29 <carl_baldwin> #link https://review.openstack.org/#/c/145565/
15:11:52 <mlavalle_> yeah, it looks good. the only alignment I think will be needed is to move some methods to parent classes in my patchset
15:11:54 <carl_baldwin> mrsmith: Rajeev: thank you for your comments.  I will look at them today.
15:12:22 <carl_baldwin> mlavalle_: right.  I think that will be mostly mechanical.
15:12:29 <mlavalle_> yeap
15:12:39 <Rajeev> carl_baldwin: you are welcome, I reviewed patch #9, will try to look at the newer version
15:13:31 <carl_baldwin> Rajeev: The newer one is probably about the same.  Let me see.
15:14:23 <carl_baldwin> Ok.  The only thing I did in patch set 10 was to revert the inlining of _get_external_device_interface_name
15:14:35 <Rajeev> got it.
15:14:51 <mrsmith> I was going to comment on that in #9 :)
15:15:02 <carl_baldwin> mrsmith: :)
15:16:01 <carl_baldwin> I think the big step for this week will be to lift a lot of the code from the agent to the router classes.
15:16:17 <carl_baldwin> … and trying to keep a steady pace of merging the patches which are ready.
15:17:06 <mrsmith> carl_baldwin - lifting in the current patches or new patches?
15:17:27 <carl_baldwin> mrsmith: Starting with https://review.openstack.org/#/c/142863/
15:17:35 <carl_baldwin> I plan to resume this one today.
15:18:22 <mrsmith> gotcha
15:19:04 <mlavalle_> carl_baldwin: It seems to me we are in good shape for kilo-2
15:19:05 <carl_baldwin> mrsmith: Do you think that the snat namespace stuff could be encapsulated similarly to the fip namespace?
15:19:25 <mrsmith> yes, the thought crossed my mind while reviewing the fip ns patch
15:19:34 <mrsmith> didn't sort out the details - but yes
15:19:46 <mlavalle_> carl_baldwin: I am taking a stab at that in my patchset
15:19:46 <carl_baldwin> mrsmith: I think it would be significantly less complex than fip.
15:20:01 <mrsmith> the snat ns is really just a subset/version of the qrouter ns
15:20:03 <carl_baldwin> mlavalle_: Okay.  I didn’t know that.
15:20:24 <carl_baldwin> mlavalle_: Now I really want to see it.  :)
15:20:33 <mlavalle_> :-)
15:21:04 <mrsmith> subset with some special sauce :)
15:21:38 <carl_baldwin> I’ll be travelling next week.  My coding time will be limited.  I wonder if some of you code try to progress some of the patches.
15:22:15 <carl_baldwin> s/code/could/
15:22:31 <pc_m_> carl_baldwin: sure. Just let me know where I can help. I'm on travel this week, but avail next week.
15:22:32 <carl_baldwin> I’ll ping you guys to talk about it.
15:22:40 <carl_baldwin> pc_m_: Thanks
15:22:45 <mlavalle_> carl_baldwin: I am open to help where needed
15:22:47 <mrsmith> sounds good
15:23:01 <carl_baldwin> Anything else on l3 agent?
15:23:23 <pc_m_> Looks like we'll delay some FEW refactoring...
15:23:54 <pc_m_> for L3. Sridar wants to size the FW insertion work, which is critical and would change the L3 refactoring needed for FW.
15:24:05 <pc_m_> Will know more next week.
15:24:18 <carl_baldwin> pc_m_: okay.  Let me know.
15:24:22 <pc_m_> roger
15:25:07 <carl_baldwin> #topic neutron-ipam
15:25:31 <carl_baldwin> tidwellr: johnbelamaric: salv-orlando: hi
15:25:42 <johnbelamaric> carl_baldwin: hi
15:25:46 <tidwellr> hello
15:25:53 <johnbelamaric> carl_baldwin: also pavel_bondar is here he is working with me on this
15:25:55 <carl_baldwin> Anything to report?
15:26:08 <carl_baldwin> pavel_bondar: welcome
15:26:29 <johnbelamaric> carl_baldwin: we have a start, pavel submitted a patch that does the driver load
15:26:47 <carl_baldwin> johnbelamaric: Do you have a link handy?
15:27:13 <johnbelamaric> #link https://review.openstack.org/#/c/147479/
15:27:45 <pavel_bondar> carl_baldwin: hi
15:27:53 <johnbelamaric> carl_baldwin: question i have is on the extent of refactor we want to do on DB plugin
15:27:59 <carl_baldwin> pavel_bondar: Is this ready to review or WIP?
15:28:21 <pavel_bondar> I am addressing some comments right now, so WIP
15:28:39 <pavel_bondar> will upload new version for review today
15:29:00 <pavel_bondar> but IPAMDriver logic is complete in general
15:29:06 <johnbelamaric> carl_baldwin: I recall discussion on refactoring about not passing all these dicts around, is there any change in the plugin API itself?
15:29:26 <pavel_bondar> s/logic/loader/
15:29:49 <carl_baldwin> pavel_bondar: thanks, I’ve added myself as a reviewer.
15:29:51 <johnbelamaric> carl_baldwin: it would certainly be nice to separate the mgmt layer (db) from the real plugin layer. but I am thinking that is out-of-scope
15:30:00 <johnbelamaric> ?
15:30:32 <carl_baldwin> johnbelamaric: I think you’re probably right about the scope but I don’t know all of the details about the plugin API.  salv-orlando may be able to add something.
15:30:41 <pavel_bondar> <carl_baldwin> nice, thanks
15:31:49 <tidwellr> I'm aiming to get some WIP code for subnet allocation pushed before the end of the week, still catching up from my extended holiday. Not a whole lot to report
15:31:49 <carl_baldwin> tidwellr: Do you have anything to discuss?
15:32:35 <carl_baldwin> tidwellr: Thanks, ping me when you get something up.  Ping salv-orlando also.
15:33:33 <johnbelamaric> tidwellr: just to be clear, we should expect to see a subnet pool ID specified in the context in the subnet_create call to the plugin, correct? If it's not there, we would use the implicit pool for the tenant to decide the pool from which to allocate the subnet
15:34:39 <tidwellr> johnbelamaric: correct
15:35:15 <johnbelamaric> tidwellr: so the logic would be the ipam driver is called using the pool and inputs as described in the spec by DB plugin before handing off the actual subnet to the backend
15:35:40 <johnbelamaric> tidwellr: i.e., db plugin still has the logic to call out to IPAM to perform actual subnet determination
15:36:50 <tidwellr> johnbelamaric: that's my understanding
15:36:57 <johnbelamaric> tidwellr: thanks
15:37:05 <johnbelamaric> carl_baldwin: i don't have anything else - pavel_bondar or I will try to catch salv-orlando on IRC when we can
15:37:24 <carl_baldwin> johnbelamaric: Thanks.
15:37:46 <carl_baldwin> #topic neutron-ovs-dvr
15:37:57 <carl_baldwin> mrsmith: Rajeev: anything to discuss?
15:38:03 <Rajeev> carl_baldwin: on DVR HA, we have couple of patches out
15:38:25 <carl_baldwin> I’ve been eyeing https://review.openstack.org/#/c/141114
15:38:42 <carl_baldwin> I saw that it was updated this morning.
15:38:50 <carl_baldwin> I will review
15:38:57 <mrsmith> good progress - I tied my patch to your refactor patch so I am waiting for rebases :)
15:39:19 <mrsmith> I got the basic functionality working with rajeev's server side and your refactor patch
15:39:26 <carl_baldwin> I’ve also had an eye on https://review.openstack.org/#/c/138632
15:39:29 <Rajeev> https://review.openstack.org/#/c/143169/5
15:39:35 <mrsmith> still need the l2pop patch to progress... maybe I will check that later today
15:39:55 <carl_baldwin> mrsmith: ^^ about l2pop patch.
15:40:03 <carl_baldwin> Looks like it was updated.
15:40:28 <mrsmith> yes!
15:41:39 <Rajeev> for DVR HA, the l2pop + - https://review.openstack.org/#/c/143169/5 + - https://review.openstack.org/#/c/139686/ are the major patches so far
15:42:02 <Rajeev> mrsmith: did I miss anything ?
15:42:39 <carl_baldwin> Rajeev: Thanks.
15:42:55 <mrsmith> Rajeev:  looks good
15:44:04 <carl_baldwin> Anything else?
15:44:19 <Rajeev> all, especially the first 2 are getting ready for initial review, I believe
15:45:09 <Rajeev> mrsmith: adolfo: are also looking at possible test submissions
15:46:14 <mrsmith> carl_baldwin: listed aldolfo's test patch above I believe
15:46:38 <carl_baldwin> mrsmith: Yes, I have been looking at it.  Not finished yet.
15:46:46 <Rajeev> mrsmith: that covers HA -- right?
15:46:49 <carl_baldwin> I think it has made some progress.
15:47:20 <mrsmith> yup
15:49:02 <carl_baldwin> Anything else?
15:49:33 <mrsmith> not from me
15:49:35 <carl_baldwin> #topic Open Discussion
15:49:44 <mrsmith> just  working on open bugs as well
15:52:02 <carl_baldwin> Thanks all.  Keep up the good work.
15:53:36 <dolfo> Carl . I am waiting for the current test patch to be merge. Anything else will make it too big I think
15:53:59 <mrsmith> "a" dolfo? is that you?
15:54:07 <carl_baldwin> dolfo: What I said above was ambiguous.  I meant that I wasn’t finished with my review.  I agree.
15:54:21 <carl_baldwin> dolfo: Sorry for the confusion.
15:54:51 <dolfo> We will also need it for any functional test for dvr ha
15:55:18 <mrsmith> ya - getting the basic dvr functional test in is key
15:55:23 <dolfo> Cool tx
15:57:04 <carl_baldwin> #endmeeting