15:04:33 <mlavalle> #startmeeting neutron_l3
15:04:34 <openstack> Meeting started Thu Jun 11 15:04:33 2015 UTC and is due to finish in 60 minutes.  The chair is mlavalle. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:38 <openstack> The meeting name has been set to 'neutron_l3'
15:05:04 <mlavalle> carl_baldwin: I was just starting the meeting.... all yours
15:05:23 * carl_baldwin sorry to be late.
15:05:30 <carl_baldwin> mlavalle: Go ahead and continue.
15:05:45 <mlavalle> #topic Announcements
15:06:43 <mlavalle> First announcement is that the mid-cycle sprint will take place in Fort Collins in two weeks
15:07:30 <mlavalle> Second announcement is a reminder that Liberty-1 milestone is also in two weeks
15:07:37 <haleyb> https://etherpad.openstack.org/p/neutron-liberty-mid-cycle
15:07:53 <neiljerram> What does L-1 milestone mean for Neutron?
15:08:30 <mlavalle> This is what has been approved for Liberty-1; https://launchpad.net/neutron/+milestone/liberty-1
15:09:20 <mlavalle> Any oher announcements from the team?
15:09:23 <carl_baldwin> It is mostly a stake in the ground.  It doesn’t go through the release candidate testing that an end of cycle release will go through.
15:09:32 <carl_baldwin> No more announcements from me.
15:09:37 <neiljerram> My understanding is that it's not a deadline, more an interim release, right?
15:10:29 <neiljerram> I emailed a short while ago about my interest in doing the L3 routed networks work - is that an announcement, and am I stepping on anyone's toes there?
15:10:29 <carl_baldwin> neiljerram: Yes.
15:11:08 <mlavalle> ok moving on
15:11:11 <carl_baldwin> neiljerram: We can chat about that.  I will appreciate some help there.
15:11:23 <neiljerram> carl_baldwin: Thx, will do.
15:11:37 <mlavalle> #topic ML3 router plugin
15:11:56 <yamahata> hi
15:12:12 <carl_baldwin> Is pcarver around?
15:12:27 <pcarver> I'm here, although on a voice conference call at the same time
15:13:13 <neiljerram> BTW where is the agenda for this mtg; I think I must be looking at the wrong place (https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam)
15:13:32 <mlavalle> neiljerram: https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:14:05 <neiljerram> mlavalle: Ah, thanks, F5 to the rescue.
15:14:19 <carl_baldwin> yamahata: the floor is yours
15:14:44 <yamahata> According to the discussion and FRE, the first thing to do is to collect use cases and consider possible solutions.
15:15:02 <yamahata> the input from pcarver will  be important
15:15:14 <carl_baldwin> yamahata: Where will this be collected?
15:15:37 <yamahata> carl_baldwin: that's exactly what I'd like discuss.
15:15:41 <pcarver> I've been having a lot of discussions and thinking a lot about how multiple routers would work together.
15:16:00 <yamahata> etherpad or gerrit spec review
15:16:10 <yamahata> or google-doc?
15:16:15 <yamahata> any preference?
15:16:25 <yamamoto> i hate google doc
15:16:40 <yamahata> or wiki
15:16:40 <pcarver> In the hardware world we'd never accept an entire network that was single vendor, but it does seem pretty complicated to plug together a variety of vendors under Neutron
15:16:56 <carl_baldwin> I guess etherpad would be my choice.  Others?
15:17:07 <pcarver> etherpad is fine with me
15:17:10 <mlavalle> yeah, etherpad is great
15:17:28 <yamamoto> +1 etherpad
15:17:31 <yamahata> Okay, I created https://etherpad.openstack.org/p/neutron-modular-l3-router-plugin-use-cases
15:18:20 <carl_baldwin> yamahata: Great.  Now to diseminate.  We could send the link to the ML and include it in the spec review.
15:18:38 <pc_m> hopefully people can associate their nick with the color they use. That's my only nit on etherpad
15:18:42 <mlavalle> do we have already enough input from discussions FRE to populate the etherpad or we neeed a message to ML?
15:19:16 <john-davidge> couldn’t hurt to put the word out for more input
15:19:17 <pcarver> We've got to align our thoughts carefully on the relationship between ML3, ML2 and flavor framework
15:19:50 <pcarver> Some concepts from the hardware world do apply, but it's not an exact mapping
15:19:53 <yamahata> pcarver: +1 so far I got a question many time, why not ML2
15:20:13 <pcarver> every hardware router has an L2 component
15:20:24 <pcarver> but it isn't an L2 device
15:21:03 <pcarver> so there's got to be an expectation of what virtual GBIC/SFPs/line cards the virtual router supports
15:21:20 <pcarver> especially with the recent work on adding STT and Geneve types to ML2
15:22:08 <pcarver> In order for the tenant or admin to be able to select from multiple available routers, it's necessary that the routers support the relevant ML2 types that the tenant is using
15:23:02 <pcarver> but unless we change the name of ML2, people aren't going to be happy with extending ML2 to support the capabilities expected of routers
15:24:14 <pcarver> There's also a QoS consideration. Routers need to enforce QoS so plugging multiple routers into the same Neutron does impact QoS expectations
15:25:12 <carl_baldwin> This is all good information.  We could spend the whole meeting.  Should we set a goal for gathering more input on use cases and solutions?
15:25:13 * neiljerram has to slip away; bye all...
15:25:36 <pcarver> Yes, sorry to go on too long
15:25:48 <mlavalle> also, who will send message to ML with etherpad, yamahata?
15:25:53 <pcarver> Getting info into an Etherpad is a good start
15:25:55 <carl_baldwin> pcarver: No problem.  This is a good start.
15:26:24 <yamahata> mlavalle: I thought carl_baldwin would do per the gerrit discussion
15:26:41 <mlavalle> carl_baldwin: ok with you?
15:27:26 <carl_baldwin> #action carl_baldwin will send email to ML today.
15:28:01 <mlavalle> ok, moving on
15:28:11 <mlavalle> #topic Bugs
15:28:31 <HenryG> Does this include RFEs?
15:28:46 <mlavalle> carl_baldwin: I pull together yesterday all the bugs with High importance..... There were no critical
15:28:58 <carl_baldwin> HenryG: RFEs will be discussed in the drivers meeting.
15:29:09 <mlavalle> HenryG: No
15:29:36 <HenryG> carl_baldwin: I have an AI from the drivers meeting to discuss RFE bug 1460720 here.
15:29:37 <openstack> bug 1460720 in neutron "Add API to set ipv6 gateway" [Undecided,New] https://launchpad.net/bugs/1460720 - Assigned to Abishek Subramanian (absubram)
15:29:38 <carl_baldwin> I did some triage yesterday and trimmed down the list.
15:30:19 <carl_baldwin> HenryG: That should be in the agenda.  But, let’s discuss it right after the regular bugs agenda item.
15:30:48 <carl_baldwin> I don’t think there are any regular bugs I want to discuss.  Anyone else?
15:31:10 * HenryG shamefully goes to update the agenda after the fact :(
15:31:44 <mlavalle> ok, moving on
15:31:47 * carl_baldwin thinks he added it last week but it may be near the end.
15:31:56 <carl_baldwin> mlavalle: Let’s go to Henry’s agenda item next.
15:32:03 <mlavalle> ok
15:32:28 * HenryG sees it at the end
15:32:42 <mlavalle> #topic RFE bug 1460720
15:32:44 <openstack> bug 1460720 in neutron "Add API to set ipv6 gateway" [Undecided,New] https://launchpad.net/bugs/1460720 - Assigned to Abishek Subramanian (absubram)
15:33:13 <carl_baldwin> So, if I remember right, you can blame this one on me.
15:34:05 <carl_baldwin> Looks like I had suggested that maybe the ipv6_gateway could be a property of the network.  What do people think?
15:34:05 <HenryG> carl_baldwin: You mean that it was originally implemented as a config?
15:34:32 * carl_baldwin was just teasing
15:35:20 <haleyb> carl_baldwin: yes, of the external network
15:36:05 <carl_baldwin> My thinking is that, in this case, the gateway is not associated with any one subnet.  But, it could be different for each network.
15:37:06 <baoli> carl_baldwin: I kind of agree since all the subnets are on the same GW port for externall gateway.
15:37:24 <haleyb> HenryG: it is currently in neutron.conf right now
15:38:08 <HenryG> So the RFE just asks for a CRUD API for the property. Looks like we need to split it up into multiple work items.
15:38:50 <HenryG> First we need to re-locate it to an agreed place. Then add the API. ?
15:39:13 <carl_baldwin> Well, the rfe wants to put it on the gateway interface which is different than what I propose.
15:40:44 <HenryG> OK that's what I meant by re-locate, sorry.
15:41:25 <carl_baldwin> HenryG: Oh.  Okay.  I guess if we have agreement.  Does network sound better than router gw set in terms of the model?
15:41:48 <HenryG> Yes, to me it does
15:42:06 <carl_baldwin> Okay.  We should update the rfe description to reflect it.
15:42:44 <HenryG> baoli: absubram: ^^ can you do that?
15:43:11 <carl_baldwin> Then, yes.  The next work items would be to add the CRUD and DB.
15:43:51 <HenryG> What about policies? Can any tenant set the gw?
15:44:01 <carl_baldwin> I’m thinking that a setting on the network will override the current config option.  Then, we should consider a deprecation plan for the config.
15:44:15 <carl_baldwin> HenryG: Good question.  I would think admin or owner.
15:44:49 <HenryG> makes sense
15:45:20 <HenryG> As for the config: it could morph into the default when no gw is set?
15:45:50 <carl_baldwin> HenryG: Sounds good.
15:46:32 <HenryG> Great. I think that's it for this item. We have a plan.
15:46:39 <mlavalle> ok, moving on......
15:46:47 <carl_baldwin> Anything else.  I think we have a plan we can present to the drivers.  It is a small amount of straight-forward work I think.
15:47:09 <mlavalle> #topic bgp-dynamic-routing
15:47:31 <tidwellr> hi
15:47:44 <devvesa> hi
15:48:43 <carl_baldwin> hi.  How are things?  I think the spec is pretty close.  Do you think it is ready to merge?
15:48:57 <tidwellr> devvesa carl_baldwin: the updated spec looks good to me
15:49:06 <baoli> HenryG: will take a look at it again
15:49:11 <tidwellr> some more eyes on it would be good
15:49:18 <devvesa> I agree
15:49:40 <carl_baldwin> Okay, let’s get more eyes on it.
15:49:53 <carl_baldwin> #link https://review.openstack.org/#/c/125401/
15:50:11 <carl_baldwin> I think we resolved my concerns.
15:50:20 <mlavalle> carl_baldwin: I'll put it in the teams wiki
15:50:31 <devvesa> I like how it fits into the AddressScopes one. Thanks for your reviews!
15:50:33 <carl_baldwin> tidwellr: How is the old code.
15:50:35 <carl_baldwin> ?
15:50:36 <tidwellr> in the mean time, I'm still spinning another patch set for https://review.openstack.org/#/c/115554/, mostly adding some tests and renaming classes and such
15:51:13 <tidwellr> I got side-tracked yesterday so I wasn't able to make the progress I was hoping for
15:51:50 <carl_baldwin> tidwellr: What is your goal for L-1?
15:52:32 <tidwellr> my goal is to have the API/DB layer in place, with tests, no agent
15:53:03 <devvesa> I've removed all the references to the agent/implementation in the spec
15:53:14 <devvesa> Should I create a new one about it?
15:53:46 <tidwellr> the code is in pretty good shape, as I mentioned I'm just in the process of renaming things and filling out more tests
15:53:48 <carl_baldwin> I wonder if we should use devref for the details about the reference implementation.
15:54:07 <mlavalle> carl_baldwin: +1
15:54:10 <carl_baldwin> I would start light with devref giving an overview.
15:54:41 <devvesa> Ok
15:55:14 <carl_baldwin> devvesa: Thanks.
15:55:18 <carl_baldwin> Anything else?
15:55:34 <devvesa> I don't know if vikram is around here...
15:55:48 <carl_baldwin> Since we have just 4 minutes left.  Let’s go to Open Discussion.
15:55:58 <devvesa> I know he has been working on some CLI stuff... but I didn't took a look at it
15:56:03 <carl_baldwin> Vikram is on vacation for a bit.
15:56:08 <mlavalle> #topic Open Discussion
15:56:39 <johnbelamaric> On IPAM, I Pavel has broken it down into more patches. Jenkins is failing though I don't think it's due his changes
15:56:40 <carl_baldwin> The Address Scopes BP was approved.
15:56:44 <johnbelamaric> #link https://review.openstack.org/#/c/190162/
15:56:51 <johnbelamaric> carl_baldwin: nice!
15:57:17 <johnbelamaric> ^ link is the next in the review chain
15:57:17 <qwebirc689837> HI
15:57:21 <johnbelamaric> followed by
15:57:23 <johnbelamaric> #link https://review.openstack.org/#/c/190195/
15:57:30 <qwebirc689837> I am Ramanjaneya vikram team|
15:57:36 <john-davidge> prefix delegation is up-to-date with master and ready for review https://review.openstack.org/#/c/158697
15:57:42 <john-davidge> would be great to get some more eyes on it
15:57:51 <carl_baldwin> john-davidge: ack
15:58:29 <carl_baldwin> qwebirc689837: Hi, nice to see you.
15:58:31 <qwebirc689837> we are working on CLI part as vikram is on vacation
15:58:44 <HenryG> john-davidge: it's in my queue too
15:59:15 <carl_baldwin> Both IPAM and PD mentioned above should be reviewed.  Please review them.
15:59:45 <pavel_bondar> also fresh one for _rebuild_availability_ranges #link https://review.openstack.org/#/c/190668/
15:59:48 <john-davidge> carl_baldwin, HenryG: thanks
16:00:02 <mlavalle> any other topics? we are top of the hour now
16:00:03 <carl_baldwin> Well done.  We’re out of time.  We can take anything else to the neutron channel.
16:00:25 <mlavalle> #endmeeting