15:01:55 <carl_baldwin> #startmeeting neutron_l3
15:01:55 <openstack> Meeting started Thu Jul  2 15:01:55 2015 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:59 <openstack> The meeting name has been set to 'neutron_l3'
15:02:05 <carl_baldwin> #topic #topic Announcements
15:02:19 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:02:37 <Vikram_> hi
15:02:40 <carl_baldwin> I don’t have anything to announce.  Does anyone have anything?
15:02:49 <carl_baldwin> Vikram_: hi
15:03:19 <carl_baldwin> #topic Bugs
15:04:07 <carl_baldwin> First is bug 1404743, it has been around for a while.
15:04:07 <openstack> bug 1404743 in neutron "sporadic test failures due to VMs not getting a DHCP lease" [High,Confirmed] https://launchpad.net/bugs/1404743
15:05:13 <carl_baldwin> It sounds like one of those bugs where it could have any number of causes.
15:05:21 <neiljerram> Is any more detail known about it, e.g. is it to do with a previous dhcp_release failing?
15:05:50 <neiljerram> carl_baldwin: ah sorry, crossed lines :-)
15:06:02 <carl_baldwin> neiljerram: No problems.
15:06:40 <carl_baldwin> I think what we should do here is reassess the severity of the bug by looking through recent logstash.
15:07:09 <neiljerram> I guess there are lots of situations like this, so a meta-question would be what instrumentation could be added to the DHCP agent, to help distinguish between possible causes.
15:07:14 <carl_baldwin> #action carl_baldwin will reassess bug 1404743
15:07:14 <openstack> bug 1404743 in neutron "sporadic test failures due to VMs not getting a DHCP lease" [High,Confirmed] https://launchpad.net/bugs/1404743
15:08:04 <carl_baldwin> The other bug is bug 1469322
15:08:05 <openstack> bug 1469322 in neutron "Associating a floatingip with a dual stack port requires the fixed-address to be specified" [High,Confirmed] https://launchpad.net/bugs/1469322
15:08:38 <carl_baldwin> This one was filed as an rfe and discussed in the drivers meeting.  But, it looks like a regular bug to me.
15:09:19 <regXboi> carl_baldwin: I agree
15:09:22 <carl_baldwin> If anyone is interested in taking this on, let me know.
15:10:59 <carl_baldwin> #topic Routing Network Segments
15:11:13 <regXboi> carl_baldwin: can we go back a second - I have a question
15:11:42 <carl_baldwin> #undo
15:11:43 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x8e73a50>
15:11:52 <regXboi> do we want to talk about https://bugs.launchpad.net/neutron/+bug/1323766 and how it relates to 1469322? (i.e. do we want the same resource working on both)
15:11:52 <openstack> Launchpad bug 1323766 in neutron "Incorrect Floating IP behavior in dual stack or ipv6 only network" [Medium,In progress] - Assigned to Bradley Jones (bradjones)
15:13:23 <carl_baldwin> regXboi: It is worth considering.  I had forgotten about 1469322 to be honest.
15:13:41 <regXboi> I'm curious what progress is being made on 1323766 since they seem closely related
15:14:23 <regXboi> anyway - now that that is in the log, we can move on
15:14:43 <john-davidge> regXboi: pinging brad now to see if he’s available to comment
15:14:47 <carl_baldwin> regXboi: No progress has been made on 1323766 from what I can tell.
15:15:17 <regXboi> carl_baldwin: that's how I read the bug, but wanted to confirm
15:16:24 <carl_baldwin> Looks like the patch for 1469322 just stopped getting attention.
15:17:19 <carl_baldwin> #action carl_baldwin will follow up and reconcile 1469322 and 1323766
15:17:56 <carl_baldwin> #topic Routing Network Segments
15:18:34 <carl_baldwin> I think we made a lot of progress at the mid-cycle on this.  I have written it up as https://review.openstack.org/#/c/196812/
15:18:40 <regXboi> carl_baldwin: I've got one outstanding question about AS, but it's not enough to not +1 it
15:18:56 * regXboi shudders at the double negative
15:19:54 <carl_baldwin> regXboi: I see it.  I will address the comment.
15:20:41 <neiljerram> FWIW, I'm still interested in exploring my crazy pluggable IPAM idea, just in case it might fly...
15:21:05 <neiljerram> But that's no reason, I think, to hold up this spec as it is at the moment.
15:21:22 <regXboi> carl_baldwin: thx - and as I said, it's a nit, so I've had +1 on it for a couple of PS now
15:21:25 <carl_baldwin> neiljerram: johnbelamaric will be a very good person to help with that.
15:21:47 <neiljerram> carl_baldwin: Cool, I'll try to hook up with him
15:21:55 <carl_baldwin> regXboi: Yes, and thank you for that.  Also, thank you for clarifying.
15:22:02 <pcarver> I had one question that I added to the review but it may just be my misunderstanding of intent.
15:22:19 <pavel_bondar> neiljerram: john is on vac now, I guess he will be available next week
15:22:31 <carl_baldwin> pcarver: I did not see it until just now when I refreshed the page.
15:22:55 <neiljerram> pavel_bondar: Thanks.  Would you like to discuss my idea instead, then?  (After this meeting.)
15:23:02 <carl_baldwin> neiljerram: pavel_bondar could also be a good person to help.
15:23:25 <pavel_bondar> neiljerram: yes, let's try
15:24:01 <pcarver> There was some discussion at the summit regarding ODL and non-L2 networks. Is this spec on that same topic?
15:24:05 <carl_baldwin> pcarver: I will address your comment after the meeting when I can.
15:24:46 <neiljerram> pavel_bondar: Thanks, I'll ping you in about 1 hour from now, if that will be convenient for you.
15:24:51 <carl_baldwin> pcarver: I think this is a step in that direction.  I had a discussion with Ed about this one on one.  There will probably be more to it.
15:25:31 <pcarver> Ok. Just wanted to confirm. I talked with Ed one on one as well and learned a lot about what he was trying to say that I didn't get from the meeting.
15:26:16 <carl_baldwin> pcarver: Let’s talk about it later in the neutron room, I’m interested to know what you learned.
15:26:26 <pcarver> 10-4
15:26:39 <carl_baldwin> Let’s move on.  We’ve got a lot to cover.
15:26:42 <carl_baldwin> #topic bgp-dynamic-routing
15:27:08 <tidwellr> hi
15:27:09 <carl_baldwin> tidwellr: Vikram_: Anything to report here?  I know tidwellr has been working on the guts of this.
15:27:33 <regXboi> are there links to look at?
15:27:35 <pavel_bondar> neiljerram: let's better discuss it on monday in wide company(with john), since in an hour it will be 7:30 pm in my location, and long weekend starts today
15:27:43 <Vikram_> currently ryan is looking into it
15:27:53 <Vikram_> i will start from next week
15:27:59 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam#bgp-dynamic-routing
15:28:12 <regXboi> doh
15:28:31 <carl_baldwin> ^ This may need some cleanup.  tidwellr could you look over the links there quickly today?
15:28:44 <tidwellr> yes, I can do that
15:28:47 <tidwellr> I've got a devref review up https://review.openstack.org/#/c/196452
15:29:08 <tidwellr> it's WIP, but I intend to start fleshing it out
15:29:28 <carl_baldwin> tidwellr: ack
15:29:54 <tidwellr> it might be helpful for people to go to the devref first if they're interested
15:30:34 <tidwellr> I have a bunch of code queued in my sandbox that I haven't put out for review
15:30:38 <carl_baldwin> tidwellr: Thanks!  It looks like a reasonably condensed document.
15:30:47 <neiljerram> pavel_bondar: OK, thanks.
15:31:09 <tidwellr> hoping to push reviews early next week
15:31:52 <carl_baldwin> tidwellr: Great, sounds like good progress.  I also happen to know you’re well on your way to creating the server-side queries to drive the announcements.
15:32:06 <carl_baldwin> Anything else to discuss here?
15:32:40 <tidwellr> nope, we just need to get moving on the dr_agent and RPC interface next week
15:32:55 <Vikram_> will do that positively :)
15:33:19 <carl_baldwin> tidwellr: Vikram_: thanks
15:33:25 <carl_baldwin> #topic neutron-ipam
15:33:33 <carl_baldwin> pavel_bondar: I think we’re getting close.
15:33:44 <carl_baldwin> pavel_bondar: Thanks for your patience with us reviewers.
15:34:42 <pavel_bondar> carl_baldwin: we are moving forward, and that is good
15:35:16 <pavel_bondar> big refactoring is now decomposed
15:35:36 <pavel_bondar> into small review like #link https://review.openstack.org/#/c/197950/
15:35:42 <carl_baldwin> pavel_bondar: What is the next review in line?
15:36:11 <pavel_bondar> one I mentioned
15:36:26 <carl_baldwin> pavel_bondar: ack
15:36:40 <pavel_bondar> after it goes #link https://review.openstack.org/#/c/153236/
15:37:01 <pavel_bondar> I hope they are pretty small now and easy for review
15:37:13 <carl_baldwin> pavel_bondar: actually, https://review.openstack.org/#/c/197090
15:37:37 <carl_baldwin> …. has to merge.  I’ll take care of it.
15:37:47 <pavel_bondar> carl_baldwin: it is in gate now
15:38:18 <carl_baldwin> pavel_bondar: right, I thought it was hung up on something but just noticed it was approved this morning.
15:38:26 <carl_baldwin> pavel_bondar: Anything else?
15:38:38 <pavel_bondar> carl_baldwin: but I see some failure there, so may require recheck
15:38:53 <carl_baldwin> pavel_bondar: I’ll watch it.
15:38:54 <pavel_bondar> carl_baldwin: no, that is it
15:39:36 <pavel_bondar> carl_baldwin, thanks
15:39:39 <carl_baldwin> pavel_bondar: thanks
15:39:59 <carl_baldwin> I skipped an agenda item because I was reading the contents section of the L3 team page.
15:40:03 <carl_baldwin> #topic Proposing Neutron instrumentation
15:40:13 <carl_baldwin> regXboi: This is your item.  Sorry to have skipped it before.
15:40:15 <regXboi> carl_baldwin: no worries - I figured it would be at the end
15:40:40 <regXboi> the etherpad is live and I think the email explains it
15:40:53 <regXboi> #link https://etherpad.openstack.org/p/neutron-instrumentation etherpad
15:41:15 <regXboi> Sam-I-Am has already dropped a few notes in - I have to ping gsagie as wll
15:41:33 <regXboi> *well
15:42:10 <regXboi> others are welcome to chime in - I envision the output being an umbrella BP that won't totally land in liberty
15:42:20 <regXboi> but hopefully we can get some small pieces of it in
15:42:40 <regXboi> carl_baldwin: that's all unless folks have questions and those can go on the etherpad or ML
15:42:49 <carl_baldwin> regXboi: Good start.
15:43:01 <carl_baldwin> regXboi: This sounds bigger than L3 a bit.
15:43:19 <regXboi> carl_baldwin: it will likely grow beyond L3 as we go, but we'll start it here
15:43:43 <regXboi> carl_baldwin: I've already sorta pinged mestery on the side about the potential for that growth
15:44:00 <carl_baldwin> regXboi: ack, thanks
15:44:15 <carl_baldwin> #topic DNS
15:44:26 <carl_baldwin> mlavalle: hi
15:44:58 <mlavalle> carl_baldwin: I will be pushing next review to https://review.openstack.org/#/c/88624/ later today. I am almost done
15:45:23 <mlavalle> adding the third case: external ip on proverder network (no floating ip)
15:45:47 <mlavalle> I also want to ask yamamoto to review https://review.openstack.org/#/c/90150/ again
15:45:57 <mlavalle> that is the nova side
15:46:15 <yamamoto> sure
15:46:19 <mlavalle> it is compatible now with its neutron counterpart, that is already merged
15:46:28 <mlavalle> per your comment
15:46:59 <mlavalle> and I will be pushing code for 88623 over the next few days
15:47:11 <mlavalle> that's all so far
15:47:34 <carl_baldwin> mlavalle: Sounds like the spec side is coming together.
15:47:55 <carl_baldwin> mlavalle: How about the code side?
15:48:02 <mlavalle> yep, 88624 is ready for merge
15:48:25 <mlavalle> I will push code for 88623 over the next few days. Making progress
15:49:12 <mlavalle> and as soon as I am done with 88624, I will start coding that one as well
15:49:35 <carl_baldwin> mlavalle:  great!
15:50:00 <carl_baldwin> #topic Address Scopes
15:50:55 <carl_baldwin> Quick update on this.  I think I have most of the L3 agent side worked out.  But, much of it is WIP in my sandbox.  I will work over the next week to clean it up in to nice patch to submit.
15:51:13 <carl_baldwin> Vikram_ has also done some great work on the api and db side.
15:51:50 <Vikram_> Will complete by this week
15:51:56 <Vikram_> and submit for review
15:52:36 <carl_baldwin> Vikram_: thanks.
15:53:27 <carl_baldwin> #topic IPv6
15:53:58 <carl_baldwin> Anything here?
15:55:03 <carl_baldwin> haleyb: Are there any patches up for the issues that we’ve discovered recently?
15:56:22 <carl_baldwin> john-davidge: Also, what needs to happen with prefix delegation?
15:57:12 <carl_baldwin> john-davidge: Looks like a rebase is needed.  I’ll watch for that and then review.
15:58:28 <bradjones> carl_baldwin: sorry wasn't around for comment earlier I was working on 1323766 a while back but the patch got abandoned because of testing issues
15:58:52 <bradjones> carl_baldwin: shall I reactivate it, as I solved a lot of the issues around dual stack and can sort the tests out pretty quickly
15:58:54 <carl_baldwin> bradjones: hi.  Any plans to move forward with it?
15:59:33 <bradjones> carl_baldwin: yeah I can sort those tests out pretty quick so as long as I'm not treading on anyones toes i'll get that done
15:59:35 <carl_baldwin> bradjones: You are welcome to reactivate it for bug 1323766
15:59:35 <openstack> bug 1323766 in neutron "Incorrect Floating IP behavior in dual stack or ipv6 only network" [Medium,In progress] https://launchpad.net/bugs/1323766 - Assigned to Bradley Jones (bradjones)
15:59:48 <carl_baldwin> bradjones: Thanks.
15:59:58 <bradjones> carl_baldwin: no problem
16:00:15 <carl_baldwin> And, we’re out of time.  Thanks everyone.  There are lots of great things happening.
16:00:20 <carl_baldwin> #endmeeting