15:00:04 <carl_baldwin> #startmeeting neutron_l3
15:00:04 <openstack> Meeting started Thu Aug 13 15:00:04 2015 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:07 <pavel_bondar> hi
15:00:08 <openstack> The meeting name has been set to 'neutron_l3'
15:00:16 <regXboi> moo
15:00:17 <haleyb> hi
15:00:20 <carl_baldwin> #topic Announcements
15:00:36 <vikram_> hi
15:00:39 <mlavalle> hi
15:00:42 <tidwellr> hi
15:00:58 <carl_baldwin> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
15:01:22 <carl_baldwin> Liberty continues to march on.  Feature freeze will come at the end of the month.
15:01:26 <obondarev> hi
15:01:38 <carl_baldwin> Just three weeks away.
15:01:42 <carl_baldwin> Any other announcements?
15:01:47 <john-davidge> hi
15:02:35 <carl_baldwin> #topic Bugs
15:02:37 <carl_baldwin> mlavalle: ping
15:02:42 <mlavalle> pong
15:02:54 <mlavalle> today I want to highlight two bugs
15:03:10 <mlavalle> https://bugs.launchpad.net/neutron/+bug/1404743
15:03:10 <openstack> Launchpad bug 1404743 in neutron "sporadic test failures due to VMs not getting a DHCP lease" [Critical,Confirmed] - Assigned to Ryan Moats (rmoats)
15:03:31 <mlavalle> This one was discussed this week during the weekly Neutron IRC meeting
15:03:36 <mlavalle> it became critical
15:04:12 <mlavalle> any feedback on this regXboi, since it is assigned to you?
15:04:25 <regXboi> I have one more update for the first failure signature
15:04:45 <regXboi> the tempest case *IS* in fact using nova for the floating-ip setup
15:04:56 <regXboi> and not handling the 202 response back correctly
15:05:07 <regXboi> I still need to look at the second case some more
15:05:07 <carl_baldwin> Are the 1400 hits from 1400 difference failed runs?
15:05:25 <regXboi> carl_baldwin: no - when the failures happen, they happen in groups
15:05:35 <regXboi> so a single run may trigger 20+ hits
15:06:14 <regXboi> carl_baldwin: the problem is that the test code in one case is poorly written and creates a race condition
15:06:39 <mlavalle> regXboi: what's the name of the test scriupt?
15:06:42 <regXboi> I still am triaging the second case and then need to re-visit to see if there are more
15:07:05 <carl_baldwin> regXboi: Is there any way to write the logstash to isolate the various failure modes?
15:07:18 <regXboi> carl_baldwin: I haven't come up with a good query yet
15:07:28 <regXboi> mlavalle: I'll update the bug with that information
15:07:31 <carl_baldwin> regXboi: ok, thought I’d ask.
15:07:45 <mlavalle> regXboi: ok, i'll look for your update
15:07:51 <regXboi> carl_baldwin: I've been trying to come up with better queries - that's a bit of a blunderbuss
15:08:26 <regXboi> mlavalle: TestVolumeBootPattern:test_volume_boot_pattern
15:08:34 <regXboi> is the nova one
15:08:46 <carl_baldwin> regXboi: understood
15:09:01 <regXboi> the other signature looks to be either a stale or lost port id, which frankly, scares me
15:09:04 <mlavalle> regXboi: if i rememebr correctly, that one has been problematic for aloooooong time
15:09:24 <regXboi> mlavalle: I suspect so - it associates the FIP via nova client, which gives back a 202
15:09:32 <regXboi> and then never checks the FIP status to be sure it's active
15:09:37 <regXboi> that's a race condition waiting to happen
15:09:43 <mlavalle> of course
15:10:19 <regXboi> anyway, that's all I have on this for now
15:10:25 <carl_baldwin> regXboi: Thanks for the updates.
15:10:26 <regXboi> I'll keep the bug updated as I dig more out
15:10:43 <carl_baldwin> regXboi: Let us know if you need a hand.
15:10:51 <regXboi> carl_baldwin: ack
15:10:57 <mlavalle> the second bug is https://bugs.launchpad.net/neutron/+bug/1461172
15:10:57 <openstack> Launchpad bug 1461172 in neutron "neutron.tests.functional.agent.test_l3_agent.MetadataL3AgentTestCase.test_access_to_metadata_proxy times out intermittently" [High,Confirmed] - Assigned to Carl Baldwin (carl-baldwin)
15:11:23 <mlavalle> this one was assigned to us by mestery during the weekly neutronmeeting
15:11:58 <mlavalle> I see it assigned to carl_baldwin. I don't know if you've had time to take a look
15:12:00 <mlavalle> ?
15:12:18 <carl_baldwin> I have not looked at it.
15:12:28 <mlavalle> do you need help?
15:12:38 <mlavalle> triaging?
15:12:44 <carl_baldwin> Yes, I could use a hand.
15:12:51 <mlavalle> ok, i'll assign it to me
15:13:01 <mlavalle> i'll dig and report back soon
15:13:37 <mlavalle> regXboi: any other bug you want to highlight?
15:13:58 <regXboi> mlavalle: I have a few from the dvr backlog
15:14:21 <carl_baldwin> regXboi: you have the floor.
15:14:56 <regXboi> the first is http://bugs.launchpad.net/neutron/+bug/1405910
15:14:56 <openstack> Launchpad bug 1405910 in neutron "distributed router can not add routes" [High,In progress] - Assigned to Brian Haley (brian-haley)
15:15:09 <regXboi> this has a patch set that could use review so we can get it merged
15:15:33 <regXboi> the second is http://bugs.launchpad.net/neutron/+bug/1369721
15:15:34 <openstack> Launchpad bug 1369721 in neutron "manually moving dvr-snat router fails" [High,In progress] - Assigned to Oleg Bondarev (obondarev)
15:15:41 <regXboi> it also has a patch set that needs reviewing
15:15:54 <haleyb> i think that first one is ready to go
15:16:04 <regXboi> the third is http://bugs.launchpad.net/neutron/+bug/14365473
15:16:05 <openstack> regXboi: Error: malone bug 14365473 not found
15:16:16 <regXboi> let's try that again
15:16:27 <regXboi> the third is http://bugs.launchpad.net/neutron/+bug/1365473
15:16:28 <openstack> Launchpad bug 1365473 in neutron "Unable to create a router that's both HA and distributed" [High,In progress] - Assigned to Adolfo Duarte (adolfo-duarte)
15:16:43 <regXboi> I'm a little nervous on this one as I don't see any activity on the bug in the last week
15:17:02 <regXboi> lastly, there is http://bugs.launchpad.net/neutron/+bug/1407889
15:17:02 <openstack> Launchpad bug 1407889 in Percona Server 5.6 "Default config contains deprecated directives" [Medium,Triaged]
15:17:09 <carl_baldwin> regXboi: Can you clarify which patch set needs review for 1369721?  A quick glance through is confusing.
15:17:12 <regXboi> that's wrong
15:17:22 <regXboi> carl_badlwind
15:17:31 <regXboi> ack - my fingers aren't working
15:17:42 <mlavalle> regXboi: regarding 1365473, we could pin Adolfo. I can do it if you want
15:17:54 <regXboi> carl_baldwin: the patchset for 1369721 is the last one in the bug
15:18:03 <regXboi> mlavalle: please
15:18:09 <mlavalle> ok, will do
15:18:37 <regXboi> carl_baldwin: the patch set for 1369721 is https://review.openstack.org/#/c/122024/
15:18:53 <regXboi> the other patch set has been -2'd and can be abandoned as not being necessary
15:19:17 <carl_baldwin> regXboi: thanks.  Which is the one that has been -2d?
15:19:50 <regXboi> looking
15:20:14 <obondarev> https://review.openstack.org/#/c/123815/
15:20:17 <obondarev> carl_baldwin: ^^
15:20:30 <regXboi> thanks, obondarev
15:21:09 <carl_baldwin> obondarev: thanks.
15:21:10 <obondarev> as https://review.openstack.org/#/c/211939 should cover agent side changes needed to handle rescheduling
15:21:42 <regXboi> obondarev is correct - so we can abandon 123815 in favor of 122024 and 211939
15:21:53 <carl_baldwin> I can plan to begin reviewing these today.
15:21:59 <regXboi> carl_baldwin: thanks
15:22:00 <carl_baldwin> obondarev: Do you want to abandon that one?
15:22:02 <obondarev> carl_baldwin: thanks
15:22:15 <obondarev> carl_baldwin: I can
15:22:51 <mlavalle> #action mlavalle to ping assignee of bug 1365473
15:22:51 <openstack> bug 1365473 in neutron "Unable to create a router that's both HA and distributed" [High,In progress] https://launchpad.net/bugs/1365473 - Assigned to Adolfo Duarte (adolfo-duarte)
15:23:12 <regXboi> obondarev: can you provide an update on https://bugs.launchpad.net/neutron/+bug/1470889 ?
15:23:12 <openstack> Launchpad bug 1470889 in neutron "DVR: should not remove routers form down l3 agents on compute nodes" [High,In progress] - Assigned to Oleg Bondarev (obondarev)
15:23:25 <obondarev> regXboi: sure
15:23:30 <obondarev> there is a patch on it
15:23:41 <obondarev> let me find a link
15:23:42 <regXboi> obondarev: patch #? the bug doesn't show that
15:23:58 <obondarev> https://review.openstack.org/#/c/198009/
15:24:21 <obondarev> not sure why launchpad stopped showing patches in bugs lately
15:24:36 <regXboi> yeah, I don't know either - so I'm updating by hand as needed
15:24:50 <obondarev> regXboi: thanks
15:24:57 <regXboi> all: that patchset ^^^^ also needs review
15:25:02 <regXboi> and that's the high list from the backlog
15:25:28 <regXboi> carl_baldwin: I'm done - returning the floor
15:26:02 <carl_baldwin> regXboi: Thanks for your work here.  I feel the momentum building on this due to some new very capable hands.
15:26:11 <carl_baldwin> Any other bugs?
15:26:21 <mlavalle> carl_baldwin: that's it from me
15:26:26 <regXboi> carl_badlwin: thanks
15:27:15 <carl_baldwin> #topic Routed network segments
15:27:45 <carl_baldwin> Nothing new here.  I still have the action item to write a new proposal.
15:27:53 <carl_baldwin> I will devote tomorrow to that.
15:28:34 <regXboi> carl_baldwin: if you need help - ping me
15:28:48 <regXboi> I've got folks internally beating me up over this topic :)
15:29:36 <carl_baldwin> Also, looking forward to the discussion next week that we discussed last week.
15:29:44 <carl_baldwin> #topic BGP dynamic routing
15:29:50 <carl_baldwin> tidwellr: vikram_ : hi
15:29:57 <tidwellr> hi
15:29:58 <vikram_> hi
15:30:43 <tidwellr> https://review.openstack.org/#/c/201621
15:31:10 <tidwellr> start of the review chain
15:31:53 <tidwellr> not ready to throw in the towel yet, feature freeze is still a couple weeks away, but getting concerned
15:32:28 <carl_baldwin> tidwellr: understood.  I will review it today and encourage others to jump in.
15:32:32 <tidwellr> I'm getting bogged down in testing, every time I try testing a corner case I find something horribly wrong
15:32:53 <carl_baldwin> tidwellr: Well, that’s progress.
15:32:55 <carl_baldwin> :)
15:33:02 <vikram_> https://etherpad.openstack.org/p/bgp-dynamic-routing
15:33:16 <vikram_> Here we are maintaing our open items
15:33:41 <tidwellr> again, the struggle is in identifying what routes should be advertised, DVR  makes it a nightmare
15:34:16 <carl_baldwin> vikram_: That looks like overview.
15:34:49 <vikram_> request initial glance for "https://review.openstack.org/#/c/207607/", "https://review.openstack.org/#/c/207625/", and "https://review.openstack.org/#/c/207635/"
15:34:51 <carl_baldwin> tidwellr: Can we separate the dvr case from the simpler case?
15:35:06 <tidwellr> I have already punted on DVR host routes
15:35:22 <tidwellr> unfortunately, DVR is so intertwined that it's hard to ignore
15:36:34 <tidwellr> I've made some good progress, but it has delayed RPC's, automated tests, etc.
15:37:15 <tidwellr> the DB queries are over the hump, but we're now behind a little bit in terms of bringing the agent and server-sides together
15:38:40 <carl_baldwin> tidwellr: Can we do anything to help you out?
15:40:03 <tidwellr> it's a big ask, but reviews on what we have now would be helpful so we can address things before we start pushing final code
15:40:21 <vikram_> tidwellr:+1
15:40:23 <tidwellr> we're going down to the wire on this
15:40:37 <carl_baldwin> tidwellr: ack.  Let’s get reviewers on it.  I can start devoting more effort to reviews.
15:41:02 <tidwellr> it's a big ask I know, this stuff is all still WIP
15:41:04 <vikram_> tidwellr:+1-baldwin: thanks
15:41:14 <vikram_> carl_baldwin: thanks
15:41:43 <regXboi> tidwellr: do you expect needing help on getting voting jobs to pass?
15:42:55 <tidwellr> I have some tempest tests, unforatunately I've got a chicken and egg problem where we need to enable the svc plugin in the gate for them to be useful and even pass
15:43:26 <tidwellr> I pulled them API tests out into their own review, but abandoned that
15:43:42 <regXboi> tidwellr: that isn't quite what I was asking - I was more asking about keeping the pipeline flowing on the current WiP patches
15:45:00 <tidwellr> regXboi: I understand now, I haven't been blocked by it yet
15:45:31 <regXboi> tidwellr: I'm just noticing that the check pipeline isn't entirely happy with the patch set chain...
15:45:45 <regXboi> that's all
15:46:14 <tidwellr> ok, the dsvm-functional tests are failing because of that chicken-egg problem I mentioned
15:46:26 <regXboi> yep
15:46:28 <tidwellr> sorry, dsvm-api
15:46:35 <regXboi> we can take it off line
15:46:42 <tidwellr> dsvm-functional is failing and I don't know why
15:46:48 <tidwellr> offline
15:46:52 <carl_baldwin> I’m going to jump ahead a bit in the agenda.  I trust tidwellr, regXboi, vikram_, and others can connect out of band.
15:47:00 <tidwellr> carry on
15:47:15 <carl_baldwin> Thanks, guys.  Let’s get some attention on this since it is new functionality and must make Liberty-3 to be considered.
15:47:19 <carl_baldwin> #topic DNS
15:47:22 <carl_baldwin> mlavalle: hi
15:47:35 <mlavalle> carl_baldwin: https://review.openstack.org/#/c/200952 got a -1 from armax
15:47:53 <mlavalle> there is some debate as to why dns_name in ports was not implemented as an extension
15:48:10 <armax> mlavalle: well, calling me out is unfair, you got 4 -1!
15:48:12 <mlavalle> the help i need here is for you weigh in herehttps://review.openstack.org/#/c/200952/12/neutron/api/v2/attributes.py
15:48:13 <armax> :)
15:48:38 <mlavalle> armax: sorry for that, I am just trying to be quick
15:48:57 <armax> mlavalle: no worries…IMO this should be easy to fix
15:49:08 <armax> mlavalle: I gave you a pointer on how to do it
15:49:11 <mlavalle> carl_baldwin: and then I will continue the conversation with armax and the others
15:49:14 <carl_baldwin> armax: You just matter more than everyone else.  ;)
15:49:31 <mlavalle> carl_baldwin: that's right, armax is paramount
15:49:38 * armax blushes
15:50:32 <mlavalle> carl_baldwin: so if you can give us your opinion in gerrit, i'll take it from there
15:50:56 <mlavalle> carl_baldwin: I also pushed https://review.openstack.org/#/c/212213/ for the external dns
15:51:03 <carl_baldwin> mlavalle: Are you asking specifically about doing an extension?
15:51:13 <mlavalle> carl_baldwin: yes
15:51:41 <mlavalle> I'd like some guidance as to how to move forward. whichever way you think is best to move forward
15:52:01 <carl_baldwin> We should probably do some sort of an extension.  I should have thought of that before given I’ve run in to this before.
15:52:28 <mlavalle> carl_baldwin: ok, if you are time constrained, that's enough. i'll take it from here
15:52:34 <carl_baldwin> mlavalle: Thanks.
15:52:41 <mlavalle> as for https://review.openstack.org/#/c/212213/
15:53:04 <mlavalle> I mostly pushed it because I want early feedback from johnbelamaric on the driver interface
15:53:30 <johnbelamaric> mlavalle: ok, I will look at it today
15:53:34 <mlavalle> I will popuplate that interface today and then ask for his feedback, maybe tomorrow morning
15:53:43 <carl_baldwin> mlavalle: What do you think our realistic changes are for getting this part done in Liberty?
15:53:51 <johnbelamaric> mlavalle: I am on PTO next week so have to do it soon :)
15:53:51 <carl_baldwin> … the second part I mean.
15:54:10 <mlavalle> carl_baldwin: I think we have a shot. let's revisit this next week
15:54:28 <mlavalle> I am going to be working full throttle on this over the next few days
15:54:47 <mlavalle> I've asked my boss to remove any barriers between now and the end of the month
15:55:07 <carl_baldwin> mlavalle: Okay.  Let’s be sure to get the first part in.
15:55:15 <mlavalle> of course :-)
15:55:38 <mlavalle> so that's all I have
15:56:16 <carl_baldwin> mlavalle: Thanks.
15:56:19 <carl_baldwin> #topic Address Scopes
15:56:57 <carl_baldwin> I have finished the functionality in the L3 agent that I wanted to get to.  But, I have to admit, I’m in over my head to get this tested in the next three weeks with my travel schedule and other things.
15:57:21 <carl_baldwin> I can have my work posted by the end of this week.  Is anyone interested in lending a hand?
15:58:03 <carl_baldwin> vikram_ and numan are probably the most familiar with it at this point.
15:59:10 <carl_baldwin> Please let me know if you can lend a hand.
15:59:15 <numan> carl_baldwin, is there a review link ?
15:59:17 <carl_baldwin> #topic Open Discussion
15:59:22 <regXboi> I've got one thing
15:59:39 <regXboi> #link http://goo.gl/Y7LIYX graphite link for multinode full and DVR jobs
15:59:48 <carl_baldwin> numan: Look at the address-scopes gerrit topic.  I will have everything posted as WIP before the end of tomorrow.
16:00:17 <carl_baldwin> regXboi: nice.
16:00:18 <regXboi> there is a pending infra WiP patch for replacing -full with mutlinode-full already
16:00:21 <carl_baldwin> We’ve got to end the meeting.
16:00:29 <regXboi> I'll be pushing another one for DVR next week
16:00:30 <mlavalle> thanks
16:00:31 <regXboi> that's it
16:00:34 <carl_baldwin> regXboi: ack  Let’s move to the neutron room if needed.
16:00:36 <carl_baldwin> #endmeeting