15:00:46 <carl_baldwin> #startmeeting neutron_l3
15:00:47 <openstack> Meeting started Thu Aug 27 15:00:46 2015 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:51 <openstack> The meeting name has been set to 'neutron_l3'
15:01:01 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam Agenda
15:01:16 <vikram_> hi
15:01:25 <carl_baldwin> hi all, let’s get moving.
15:01:31 <carl_baldwin> #topic Announcements
15:02:10 <carl_baldwin> Liberty-3 will be around the 31st.  Time is running out.
15:02:23 <carl_baldwin> That will be feature freeze also.
15:02:49 <carl_baldwin> mestery has mentioned the possibility of an FFE for address scopes and BGP.
15:03:18 <carl_baldwin> I imagine that even with a FFE, we’ll need to have fully functional code in the next couple of days.
15:04:03 * carl_baldwin doesn’t enjoy the experience of rushing an incomplete feature in and then paying the very heavy price for it later.  :)
15:04:20 <vikram_> agreed :)
15:04:22 * regXboi cough *dvr?* cough
15:04:32 <Juno> currently, there is no blueprint about BGP MPLS VPN, right?
15:04:37 * neiljerram arrives a little late, sorry.
15:04:48 <Juno> is there any plan about BGP MPLS VPN or BGP MPLS EVPN?
15:04:54 <carl_baldwin> BTW, thanks all for running the meeting last week.  I meant to join, even while travelling but suffered from an embarrassing mental TZ miscalculation.
15:05:27 <regXboi> carl_bladwin: no worries - mlavalle was on top of things
15:05:28 <neiljerram> easily donw
15:05:33 <carl_baldwin> Juno: There is and it is being discussed extensively on the ML.  It is a separate project and is getting good attention.
15:05:45 * carl_baldwin is glad to have mlavalle around
15:05:51 <mlavalle> ;-)
15:06:30 <carl_baldwin> Any other announcements?
15:06:40 <Juno> Carl: great, will BGP MPLS VPN integrated with BGP dynamic routing?
15:07:05 <regXboi> carl_baldwin: if we have time I'd like to talk a little about DVR at the end
15:07:15 <regXboi> if not, it can wait until after L-3
15:07:24 <carl_baldwin> Juno: No plans now but it is a possible eventuality.
15:07:27 <vikram_> Juno: Not now..
15:07:30 <Juno> I find there are 2 blueprint about BGP, one is BGPVPN, the other is dynamic routing, will the both integrated together?
15:07:35 <carl_baldwin> regXboi: ack
15:07:41 <tidwellr> Juno: let's chat after this
15:07:58 <neiljerram> Everything in Neutron is integrated together, in some sense.  That's the point.
15:09:07 <carl_baldwin> Moving on...
15:09:13 <Juno> what is the release plan about BGPVPN and dynamic routing?
15:09:15 <carl_baldwin> #topic Bugs
15:09:29 <tidwellr> Juno: let's chat offline
15:09:39 <carl_baldwin> mlavalle: How are bugs looking?
15:09:53 <Juno> how to touch you offline?
15:09:59 <tidwellr> irc is fine
15:10:06 <mlavalle> our last critical bug was closed a few days ago thanks to regXboi
15:10:13 <mlavalle> thank you so much
15:10:13 <Juno> ok
15:10:22 * regXboi is still watching the gate in case it comes back
15:10:23 <neiljerram> Juno: in the #openstack-neutron channel
15:10:27 <mlavalle> we only hva high importance, most of them in progress
15:10:38 <carl_baldwin> mlavalle: regXboi: excellent
15:10:50 <mlavalle> I am following https://bugs.launchpad.net/neutron/+bug/1461172
15:10:52 <openstack> Launchpad bug 1461172 in neutron "neutron.tests.functional.agent.test_l3_agent.MetadataL3AgentTestCase.test_access_to_metadata_proxy times out intermittently" [High,Confirmed] - Assigned to Miguel Lavalle (minsel)
15:11:00 <amuller_mtg> mlavalle++
15:11:19 <mlavalle> I haven't benn able to reproduce locally, so I am digging in logstash
15:11:33 <regXboi> mlavalle: I found 4 cases in the last 48 hours
15:11:38 <regXboi> but that was all
15:11:45 <mlavalle> it has happened 10 times over the past 7 days
15:11:54 <regXboi> nevermind :)
15:12:02 <mlavalle> so i'll dig there and update accordingly
15:12:13 <neiljerram> Is there perhaps something structurally wrong with the gate or infra at the moment?  Delays seem really long.
15:12:38 <mlavalle> as far as https://bugs.launchpad.net/neutron/+bug/1365473
15:12:39 <openstack> Launchpad bug 1365473 in neutron "Unable to create a router that's both HA and distributed" [High,In progress] - Assigned to Adolfo Duarte (adolfo-duarte)
15:12:59 <regXboi> yes, on this - I'm no longer sure *which* patchsets apply to it anymore
15:13:05 <mlavalle> seems to be worked on, but i'll ping Adolfo to see really how it is going
15:13:07 <carl_baldwin> mlavalle: I’ve recently picked up reviewing this bug.
15:13:17 <amuller_mtg> mlavalle: carl_baldwin: I'm involved there as well
15:13:19 * carl_baldwin goes to find the two he’s reviewing.
15:13:26 <regXboi> can we get the bug updated with the *real* patch sets?
15:13:35 <amuller_mtg> jschwarz is helping there as well
15:13:49 * jschwarz is reading
15:13:51 <carl_baldwin> #link https://review.openstack.org/#/c/196893
15:14:07 <carl_baldwin> ^ This is where I started reviewing yesterday.
15:14:10 <mlavalle> carl_baldwin: I'll update the bug with the patchset so we can keep track
15:14:29 <jschwarz> yes sorry, i'm with you
15:14:50 <jschwarz> so I'm debugging a problem with HA+DVR routers where some of the flows get deleted somewhere in the binding stage
15:15:07 <carl_baldwin> Are there any patches other than this one and the one that depends on it?  (https://review.openstack.org/#/c/143169/)
15:15:11 <jschwarz> also l2pop seems to non-deterministicly delete the vxlan- devices from one or more of the hosts
15:15:28 <amuller_mtg> carl_baldwin: naw it's just the 2 patches
15:15:33 <carl_baldwin> amuller_mtg: ack
15:15:35 <amuller_mtg> one for server, one for agent
15:15:46 <regXboi> ok... then the launchpad is correct
15:15:57 <amuller_mtg> this will obviously slip L3, we'll need to decide if we want to ask for an extension or target it for M1
15:16:09 <amuller_mtg> I'm waiting on jschwarz's investigation
15:16:24 <amuller_mtg> he'll determine the status of it
15:16:39 <carl_baldwin> amuller_mtg: jschwarz:  Thanks
15:17:03 <regXboi> I've got one other to put on the list from the backlog as I'd like to see if it can make L-3
15:17:10 <mlavalle> regXboi: any other dvr bugs you want to highlight?
15:17:13 <regXboi> https://bugs.launchpad.net/neutron/+bug/1479130
15:17:16 <openstack> Launchpad bug 1479130 in neutron "DVR:Removing an interface from router with multiple interfaces and with ext gw set does not remove interface from SNAT namespace" [High,In progress] - Assigned to Swaminathan Vasudevan (swaminathan-vasudevan)
15:17:49 <regXboi> launchpad has three patch sets associated with that one (so far), so I'm not sure if it will make L-3
15:17:57 <regXboi> but I'd like to see if we can push it across the line
15:18:41 <carl_baldwin> regXboi: I’ll have a look at this to see where it stands.  I proposed an alternate way to resolve it based on pinpointing the commit that broke it.
15:18:50 <regXboi> carl_baldwin: ack
15:18:54 <carl_baldwin> regXboi: I need to touch base with Swami to confirm that it fixes it.
15:19:06 <regXboi> carl_baldwin: even better :)
15:19:12 <carl_baldwin> #action carl_baldwin will sync with Swamy on 1479130
15:19:23 <carl_baldwin> We’ll try to get it in this week.
15:19:39 <regXboi> After 8/1 I plan on sitting down an re-prio-ing the mass of "Medium" bugs
15:19:43 <regXboi> er 9/1
15:20:13 <regXboi> the good news is the backlog is coming down :)
15:20:15 <carl_baldwin> regXboi: great, thanks for that.
15:20:23 <carl_baldwin> Any other bugs?
15:20:23 <mlavalle> regXboi: ++
15:20:31 <mlavalle> not from me....
15:20:36 <regXboi> nope -
15:20:45 <john-davidge> https://review.openstack.org/#/c/212818/ could use another +workflow
15:20:58 <john-davidge> got caught by a merge conflict last night
15:21:08 <carl_baldwin> john-davidge: ack, will look soon
15:21:12 * regXboi has none to give :(
15:21:24 <john-davidge> thanks :)
15:21:41 <carl_baldwin> Okay, moving on.  Let’s skip routed networks until after Liberty-3.
15:21:59 <carl_baldwin> #topic  bgp-dynamic-routing
15:22:15 <carl_baldwin> tidwellr: vikram_ :  Over to you.
15:22:27 <Juno> I have a question about bgp-dynamic-routing,
15:22:34 <Juno> why it does not support vrf?
15:22:51 <tidwellr> Juno: keeping things simple at first
15:23:09 <tidwellr> we're having a hard enough time getting basic functionality in
15:23:23 <tidwellr> which is a great segway to status
15:23:45 <vikram_> Juno: Lot will come :)
15:24:18 <Juno> ok, i think if not support vrf, the bgp dynamic routing only used to advertise floating ip
15:24:49 <tidwellr> Juno: let's talk offline, I disagree with that assertion
15:24:49 <Juno> if user want to advertise tenant subnets, they can not use it
15:25:00 <Juno> ok
15:25:29 <tidwellr> I'm skeptical we'll get this in to Liberty
15:25:56 <tidwellr> as carl_baldwin mentioned, I don't want to rush this and end up with big headaches later
15:26:09 <vikram_> tidwellr:+1
15:26:32 <carl_baldwin> tidwellr: That may be the reality.  I know the feeling.  I’ve had a number of things slip to the next cycle.
15:26:37 <vikram_> We got the code almost ready but suspect test sufficiency
15:26:43 <tidwellr> we're still gluing together the server and agent RPC's, address scope awareness isn't there, and the automated tests don't account for DVR and non-DVR cases very thoroughly
15:26:55 <devvesa> hi
15:27:00 <neiljerram> Presumably it has some pieces merged already?  Are those OK for Liberty as they are?
15:27:15 <tidwellr> neiljerram: nope, nothing has merged
15:27:16 <devvesa> I'll start vacations next week, but I feel in debt with you vikram_ and tidwellr
15:27:26 <tidwellr> devvesa: no worries
15:27:27 <devvesa> because I've been out too much
15:27:35 <carl_baldwin> devvesa: hi!  Good to see you.
15:27:36 <tidwellr> you've given us a good head start
15:27:36 <devvesa> i'll try to help you during next week
15:27:48 <devvesa> carl_baldwin: hi! thanks :)
15:27:57 <tidwellr> I'm inclined to aim to merge in M-1
15:27:58 <devvesa> I'll not try, I'll do :)
15:28:01 <vikram_> devvesa: review wil be helpful
15:28:08 <devvesa> sure vikram_
15:28:55 <carl_baldwin> tidwellr: vikram_: devvesa:  Thanks for reporting in.  Keep up the good work and I’m sure we’ll have something merged when Mitaka opens up.
15:28:59 <vikram_> carl_baldwin: With FFE how much time we can buy?
15:30:05 <carl_baldwin> vikram_: It is hard to say.  Usually not more than a week or two.  Much later than that would likely been seen as risky for Liberty final.
15:30:29 <vikram_> carl_badwin: ok..
15:30:38 <carl_baldwin> Also, I view FFEs as more about giving a little extra time to review and test code that is complete.  But, others may have a different view.
15:31:16 <tidwellr> we're still iterating some basic things, so an FFE wouldn't be appropriate
15:31:18 <carl_baldwin> Keep pushing to complete functionality and we can look at it then.
15:31:37 <vikram_> ok
15:31:42 <mlavalle> carl_baldwin: that is a very useful definition
15:33:06 <carl_baldwin> Anything else on BGP?
15:34:08 <steve____> yes,
15:34:26 <carl_baldwin> steve____: ?
15:34:27 <steve____> how many use case bgp dynamic will support
15:34:37 <steve____> I found 2 in https://review.openstack.org/#/c/196452/7/doc/source/devref/bgp_speaker.rst
15:34:46 <steve____> except this, any more else
15:34:53 <tidwellr> steve___: the devref is incomplete
15:35:34 <tidwellr> we've been targeting FIP host routes, tenant networks (address scope aware), and DVR host routes
15:35:35 <steve____> yes, in devref, bgp can only advertise fip, it will limit the bgp value
15:36:11 <tidwellr> steve___: it can advertise more than FIP's
15:36:19 <steve____> ok
15:36:24 <carl_baldwin> It is well understood that the current proposal limits the value.  We are iterating and hope to get to something much fuller in the end.
15:36:30 <tidwellr> anyway, we can discuss in openstack-neutron after this
15:36:41 <tidwellr> input on future direction would be great
15:36:42 <steve____> sure
15:37:03 <vikram_> tidwellr: I have few :-)
15:37:33 <carl_baldwin> Let’s skip a few topics …
15:37:36 <carl_baldwin> #topic dns-resolution
15:37:42 <carl_baldwin> mlavalle: Over to you...
15:37:42 <mlavalle> hi
15:37:51 <mlavalle> yesterday we merged https://review.openstack.org/#/c/200952/
15:38:08 <mlavalle> thanks to all the reviewers who helped to get this thorugh
15:38:27 <mlavalle> very usful feedback all the time!
15:38:46 <carl_baldwin> mlavalle: ++  Nice job.
15:39:04 <mlavalle> right now working on the external side. This week I am getting the designate client loaded in Neutron
15:39:06 <johnbelamaric> +1 !
15:39:48 <mlavalle> once I do that, I think the rest of the work is very similar to what we have already merged, so I expect rapid progress
15:40:29 <mlavalle> so I expect to have functional code by the end of next week
15:41:08 <johnbelamaric> mlavalle: note my comment on there - I still don't see a need to query the zones
15:41:18 <carl_baldwin> mlavalle: Great, keep pinging reviewers (including me) to stay on top of it.
15:41:32 <mlavalle> johnbelamaric: I saw that =and I intend to follow your advice
15:41:42 <johnbelamaric> mlavalle: even better :)
15:42:02 <mlavalle> johnbelamaric: btw, thank for the feedback!
15:42:30 <mlavalle> I will also start bugging johnthetubaguy to get the nova side moving asap
15:42:36 <johnbelamaric> mlavalle: sure. it's selfish too. I'll add an Infoblox driver for this interface in networking-infoblox. Less work to do that is better :)
15:42:54 <mlavalle> johnbelamaric: I know :-)
15:43:38 <carl_baldwin> johnbelamaric: It is great to have your perspective in this.
15:43:50 <mlavalle> ++
15:44:25 <carl_baldwin> mlavalle: Thanks
15:44:32 <carl_baldwin> #topic Address Scopes
15:45:01 <carl_baldwin> I’m happy to say that I believe that my implementation is fully functional and you could try it out today from the gerrit chain.
15:45:42 <johnbelamaric> carl_baldwin: fantastic!
15:45:48 <john-davidge> Awesome!
15:45:55 <carl_baldwin> I’m sad to say that testing is still abismal and I’m embarrassed.  So, I’m going to continue to invest time on writing proper tests.
15:46:31 <carl_baldwin> So, I don’t believe that it is ready to merge yet and they’re marked WIP to reflect that.
15:47:04 <carl_baldwin> I’ll continue to push to the 31st to get this cleaned up.
15:47:16 <pavel_bondar> carl_baldwin: is the link handy?
15:47:22 <john-davidge> carl_baldwin: Do you see any parts of it changing significantly other than the tests?
15:47:58 <carl_baldwin> #link https://review.openstack.org/#/q/status:open+topic:bp/address-scopes,n,z
15:48:23 <carl_baldwin> john-davidge: I don’t think so but sometimes feedback has a way of changing that.
15:48:43 * carl_baldwin loves feedback but it can be difficult to swallow at first sometimes.  :)
15:48:54 <john-davidge> carl_baldwin: Haha, I have no idea what you’re talking about…
15:49:37 <carl_baldwin> john-davidge: :)  I dish it out so I ought to be able to take it, right?
15:50:11 <carl_baldwin> That’s all I have.
15:50:46 <carl_baldwin> #topic IPv6 Prefix Delegation
15:51:09 <carl_baldwin> john-davidge: great job here.
15:51:39 <carl_baldwin> Anything still pending?
15:51:55 <john-davidge> Thanks! The ongoing feedback from everyone over the months was invaluable, I’m really happy with the state when it merged
15:52:08 <john-davidge> Nothing still pending, I closed the blueprint this morning :)
15:52:28 <carl_baldwin> The one thing that fell out of this is the default subnet pool config option.  The more I think about it, the more I think we need to deprecate it and come up with something better.
15:52:32 <john-davidge> Looking forward to talking about future improvements
15:52:35 <amuller> it was merged? oh my that's good
15:53:02 <john-davidge> carl_baldwin: Yes I agree, hopefully we can hash something out to discuss at the summit
15:53:29 <carl_baldwin> john-davidge: ++
15:54:01 <carl_baldwin> I’ll post a review to deprecate it.  Maybe we can begin the discussion there.
15:54:25 <carl_baldwin> #action carl_baldwin will post a review to deprecate the default subnet pool option.
15:55:11 <john-davidge> carl_baldwin: Do you propose deprecating the option before we agree on an alternative?
15:55:53 <carl_baldwin> john-davidge: No, I just want a place-holder and somewhere to collect thoughts.
15:55:59 <john-davidge> carl_baldwin: For the record I would have no strong feelings against doing that, PD could easily be enabled with its own config option
15:56:03 <carl_baldwin> Maybe there is a better way but that should get us started.
15:56:05 <john-davidge> carl_baldwin: Ok great
15:56:45 <carl_baldwin> I won’t let it merge until Mitaka so that we can deprecate for Mitaka along with developing an alternative in Mitaka.
15:57:04 <carl_baldwin> #topic Open Discussion
15:57:34 <regXboi> carl_baldwin: I've got one vis-a-vis DVR
15:57:35 <john-davidge> carl_baldwin: Sounds good. Happy to volunteer my time to helping develop that alternative
15:57:41 <johnbelamaric> carl_baldwin: my confidence at being in Tokyo is up to 95% now :) so, we should but the DHCP relay piece on the agenda somewhere
15:58:10 <johnbelamaric> carl_baldwin: prob. only there Tues-Thu, maybe Fri AM (haven't booked flight yet)
15:58:42 <carl_baldwin> regXboi: go
15:58:43 <regXboi> at the operator mid-cycle meetup (https://etherpad.openstack.org/p/PAO-ops-meetup) on of the major asks was DVR for LB (well not an ask, more a "if you want us to take this seriously, make it work with LB" statement)
15:59:00 <regXboi> and I've been thinking that the OVS DVR design could use some ... improving
15:59:41 <regXboi> so I'm wondering if we should consider doing OVS for LB as a separate design to see if we can come up with something that isn't as complex as what we have now
15:59:42 <carl_baldwin> regXboi: We’ve looked at this a couple of ways.  We should probably take this to the neutron room…
15:59:50 <mickeys> FWaaS is limited to north/south only with DVR. There is an etherpad started going over the problem with east/west and potential solutions. Would really like some feedback on the etherpad. https://etherpad.openstack.org/p/FWaaS_with_DVR
15:59:59 <regXboi> carl_baldwin: ack
16:00:09 <carl_baldwin> mickeys: ack, thanks
16:00:13 <carl_baldwin> #endmeeting