14:59:59 <carl_baldwin> #startmeeting neutron_l3
14:59:59 <openstack> Meeting started Thu Sep  3 14:59:59 2015 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:03 <openstack> The meeting name has been set to 'neutron_l3'
15:00:09 <haleyb> hi
15:00:09 <vikram__> hi
15:00:10 <carl_baldwin> hi everyone!
15:00:29 <carl_baldwin> #topic Announcements
15:00:36 <john-davidge> hi
15:00:40 <regXboi> carl_baldwin: wondering if you were going to make it :)
15:00:40 <johnbelamaric> hi
15:00:40 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam#Agenda
15:00:41 <pc_m> hi
15:00:50 <regXboi> what's the status of L3?
15:01:02 <regXboi> given armax's liberal use of -2s ....
15:01:07 <pavel_bondar> hi
15:01:17 <carl_baldwin> I think Liberty-3 should be out soon.
15:01:44 <carl_baldwin> If you’re not in now and haven’t talked to armax then the ship has sailed.
15:02:10 <regXboi> carl_baldwin: I'm more worried about making sure the -2s get pulled from things that should be tagged RC1
15:02:24 <regXboi> er s/should be/either are or should be/
15:02:55 <carl_baldwin> regXboi: A valid concern.  I’ll follow up with armax after I’ve confirmed Liberty-3 is available.
15:03:09 <carl_baldwin> #action carl_baldwin will follow up on -2s after Liberty-3
15:03:11 <regXboi> carl_baldwin: ack and thanks and I may also :)
15:03:21 <regXboi> speak of the devil and he appears :)
15:04:00 <carl_baldwin> armax: hi, we’re just talking about Liberty-3 and -2s.  We can follow up with you later.
15:04:16 <carl_baldwin> Any other announcements?
15:04:40 <carl_baldwin> #topic Bugs
15:04:45 <carl_baldwin> mlavalle: hi
15:04:49 <mlavalle> hi
15:05:00 <armax> carl_baldwin: liberty-3 should be cut any minute now
15:05:09 <carl_baldwin> BTW, it has been great to see increased attention on bugs from an excellent team effort.
15:05:09 <mlavalle> so I've been researching https://bugs.launchpad.net/neutron/+bug/1461172, which became critical lately
15:05:10 <openstack> Launchpad bug 1461172 in neutron "neutron.tests.functional.agent.test_l3_agent.MetadataL3AgentTestCase.test_access_to_metadata_proxy times out intermittently" [Critical,Confirmed] - Assigned to Miguel Lavalle (minsel)
15:05:12 <regXboi> mlavalle: I added a bunch of items in the last 30 minutes :)
15:05:37 <carl_baldwin> armax: I thought it must be imminent.
15:05:56 <mlavalle> I updated the bug itself 30 mintes ago
15:06:57 <carl_baldwin> mlavalle: Thanks for the update.
15:07:07 <regXboi> mlavalle: I read the conversation in the bug and I'm still scratching my head over what to think of it
15:07:07 <mlavalle> It seems that a number of failures are caused by this change: https://review.openstack.org/#/c/196149
15:08:02 <carl_baldwin> mlavalle: That patch has not been in the gate queue, has it?
15:08:25 <mlavalle> so I had chat with pc_m. I probably need to do some research, but just before the meeting started, if I do the query asking to exclude that change, and the ocurences count drops to 2
15:08:26 <pc_m> mlavalle: That is a test change to exercise the experimental Neutron job that runs VPN fucntional tests to detect cross project breakage.
15:09:10 <pc_m> That commit has WIP set.
15:09:20 <mlavalle> carl_baldwin, pc_m: maybe I am querying logstash wrongly, so for the time being consider this findings tentative
15:09:53 <mlavalle> this is my query: message: "neutron.tests.functional.agent.test_l3_agent.MetadataL3AgentTestCase.test_access_to_metadata_proxy" AND message: FAILED
15:10:04 <pc_m> mlavalle: I think I actually got the failure to work as expected, so I probably won't need to run much more.
15:10:31 <carl_baldwin> mlavalle: Could you include the URL for your query in the bug report?
15:11:13 <mlavalle> carl_baldwin: I will.... and if it is not glaringly wrong, I'll track it daily, to see what else I can find
15:11:56 <carl_baldwin> mlavalle: Thanks.
15:12:49 <mlavalle> the other high importance bugs that I reviewed seem to have something in progress, so I'll let regXboi take the floor
15:13:02 <regXboi> thanks, mlavalle
15:13:17 <regXboi> so... first is  https://bugs.launchpad.net/neutron/+bug/1365473
15:13:19 <openstack> Launchpad bug 1365473 in neutron "Unable to create a router that's both HA and distributed" [High,In progress] - Assigned to Adolfo Duarte (adolfo-duarte)
15:13:52 <regXboi> there is an interesting conversation going there, but I don't see closure on it *yet*
15:14:25 <regXboi> https://bugs.launchpad.net/neutron/+bug/1479130 is also tagged RC-1 and has a couple of patchsets needing review
15:14:26 <openstack> Launchpad bug 1479130 in neutron "DVR:Removing an interface from router with multiple interfaces and with ext gw set does not remove interface from SNAT namespace" [High,In progress] - Assigned to Swaminathan Vasudevan (swaminathan-vasudevan)
15:15:01 <regXboi> the patch set links are in the agenda
15:15:18 <regXboi> last of the high priority items is https://bugs.launchpad.net/neutron/+bug/1489091
15:15:20 <openstack> Launchpad bug 1489091 in neutron "neutron l3-agent-router-remove is not unscheduling dvr routers from L3-agents" [High,In progress] - Assigned to Stephen Ma (stephen-ma)
15:15:37 <regXboi> again, this has a patch set in the agenda, and I'd like to have it tagged L-RC1 as well
15:16:11 <regXboi> any comments before I hit the last point?
15:16:13 <carl_baldwin> regXboi: Done
15:16:21 <regXboi> carl_baldwin: thx
15:16:22 <amuller> about L3 HA + DVR, jschawrz and adolfo are working on it, there's some issues there still. I'm assisting. Hopefully we'll be able to merge it for L, dunno.
15:16:34 <regXboi> amuller: thanks for that update
15:16:50 <carl_baldwin> amuller: Thanks.
15:17:10 <regXboi> Lastly, I put three Medium bugs in the hopper for being tagged with L-RC1 - They've all got patchsets that have been up for review for a while now
15:17:26 <regXboi> s/hopper/agenda/
15:17:53 <regXboi> I wasn't going to paste them into the logs unless specifically asked.
15:17:57 <regXboi> and that's all I have
15:18:45 <carl_baldwin> regXboi: thanks.  Where can we find those three bugs.
15:18:47 <carl_baldwin> ?
15:18:58 <regXboi> carl_baldwin: they are in the agenda for today
15:18:59 <mlavalle> carl_baldwin: they are in the agenda
15:19:08 <carl_baldwin> regXboi: Thanks.
15:19:22 <carl_baldwin> mlavalle: and thanks.
15:19:26 <carl_baldwin> Any other bugs to bring up?
15:19:37 * regXboi will have more next week - I'd like to try and cut the backlog down to 10-15 by RC-1
15:19:41 <mlavalle> carl_baldwin: I updated the cirtical bug with my query's url..... let me know if I am doing something stupid :-)
15:20:02 <regXboi> mlavalle: I'll look as well - my logstash fu isn't that strong, but it's getting better
15:20:24 <carl_baldwin> mlavalle: ack
15:20:41 <regXboi> carl_baldwin: yes there is one more bug to call out
15:20:46 <regXboi> https://bugs.launchpad.net/neutron/+bug/1456624
15:20:47 <openstack> Launchpad bug 1456624 in neutron "DVR Connection to external network lost when associating a floating IP" [Medium,In progress] - Assigned to venkata anil (anil-venkata)
15:20:50 <mlavalle> regXboi, carl_baldwin: thanks
15:21:11 <regXboi> I think this needs to be bumped from Medium up to High/Critical as it renders (imo) DVR useless for an operator
15:21:52 * regXboi admits that associated patch set could use simplification
15:22:02 <carl_baldwin> regXboi: Useless?  That was not my interpretation of the problem.
15:22:33 <regXboi> carl_baldwin: I think so - as I read the bug, existing connections out of the cloud stop working when a new FIP is associated
15:22:34 <carl_baldwin> But, I might have missed something.
15:22:57 <regXboi> I'll take the action item to confirm my understanding and update the bug
15:23:19 <regXboi> #action regXboi to triage https://bugs.launchpad.net/neutron/+bug/1456624 to see if his concerns are warranted
15:23:20 <openstack> Launchpad bug 1456624 in neutron "DVR Connection to external network lost when associating a floating IP" [Medium,In progress] - Assigned to venkata anil (anil-venkata)
15:23:38 <carl_baldwin> I may have to think about that a bit more.  My understanding was the same but it didn’t strike me as rendering DVR useluss.
15:23:41 <carl_baldwin> useless
15:24:34 <regXboi> carl_baldwin: like I said, let me try it out - I'm setting up a few DVR instances later today and so will have the oppt to more fully examine what happens
15:24:51 <regXboi> (legacy too for that matter)
15:24:59 <carl_baldwin> regXboi: Thanks.
15:25:18 <carl_baldwin> Maybe I’m underestimated the consequences.
15:25:52 <carl_baldwin> Any other bugs?
15:26:00 <mlavalle> not from me
15:26:10 <regXboi> not for this week
15:26:28 <carl_baldwin> Many thanks for your hard work mlavalle, regXboi, and others.
15:26:35 <carl_baldwin> #topic BGP dynamic routing
15:26:50 <carl_baldwin> tidwellr: vikram__ :
15:26:56 <tidwellr> hi
15:26:59 <vikram__> hi
15:27:51 <tidwellr> I'm starting to break down some patches into smaller patch sets, some of the reviews we have are huge
15:28:21 <vikram__> I am reworking for review findings for the scheduler and agent patches
15:28:41 <tidwellr> I chatted with armax yesterday, my understanding is that we don't need an RFE to carry this forward into Mitaka
15:28:42 <carl_baldwin> tidwellr: If there is a sensible way to do that, I find it can be a great advantage.
15:29:08 <carl_baldwin> tidwellr: I agree
15:29:29 <carl_baldwin> vikram__: ack
15:29:46 <carl_baldwin> tidwellr: vikram__: How is the overall functionality coming along?
15:30:07 <tidwellr> Agent side is looking really good
15:30:27 <vikram__> carl_baldwin: I was planned to test E2E but facing some issue to get the env up..
15:30:40 <vikram__> carl_baldwin: Will start soon
15:30:52 <tidwellr> I'm working and address scope aware route lookups
15:31:00 <tidwellr> *on
15:31:29 <tidwellr> refactoring of tests is the only thing slowing me down there
15:32:25 <vikram__> tidwellr: are you planning to move the agent code inside service_plugin folder
15:32:36 <vikram__> tidwellr: or you will take care of this?
15:32:47 <tidwellr> yes, I can do that
15:33:05 <vikram__> tidwellr: ok..
15:33:27 <tidwellr> emphasis right now is on an end-to-end demonstration, even if the routes published aren't quite right
15:33:58 <vikram__> tidwellr: I am working on the setup.. hope by this week will be able to test it
15:34:22 <carl_baldwin> tidwellr: That sounds like a good goal.
15:34:31 <tidwellr> yes, I'm gearing up to push some patches to enable that today
15:35:05 <carl_baldwin> Great, anything we can help out with?  Or, anything more to discuss?
15:35:44 <vikram__> carl_baldwin: By when we got to get this code in?
15:37:12 <carl_baldwin> vikram__: At this point, it is unlikely to make Liberty, to be honest.  If things come together soon, it could get an FFE but I don’t think it will be considered unless it comes together.
15:37:40 <vikram__> carl_baldwin: I agree.. We can plan for Mitaka-1
15:38:17 <carl_baldwin> vikram__: yes
15:38:21 <carl_baldwin> #topic DNS
15:38:23 <carl_baldwin> mlavalle: hi
15:38:29 <mlavalle> hi
15:38:43 <mlavalle> I've ben working on https://review.openstack.org/#/c/212213/
15:38:54 <mlavalle> at this point I got the designate client working
15:39:20 <mlavalle> I am able to create recordsets and delete them, which is what the interface we defined requires
15:39:53 <mlavalle> so since yesterday I am adding code to the floating ip side of neutron to start publishing addresses to designate
15:39:59 <carl_baldwin> mlavalle: Good progress.
15:40:21 <mlavalle> I should be pushing code again by the end of the week
15:40:35 <mlavalle> so I feel confident we will do a demo in Tokyo
15:40:51 <mlavalle> and since I feel frisky today, I say I live demo
15:41:09 * regXboi notes mlavalle has just written a check
15:41:22 <mlavalle> that's my report for this
15:41:42 * mlavalle also realizes that, oh well
15:42:37 <carl_baldwin> mlavalle: That would be cool.  I’d have some backup screenshots in case one of any number of possible problems arrises.  (like conference wifi issues)
15:42:53 <mlavalle> fully agree :-)
15:43:03 <carl_baldwin> mlavalle: When do you expect to have things functional?
15:43:20 <mlavalle> I think next week the fip's are going to be functional
15:43:46 <carl_baldwin> I guess we’ll do the same as with other features.  When it comes together fully, we’ll take a look at FFE.
15:43:57 <carl_baldwin> mlavalle: Good work.  Keep it up.
15:44:05 <mlavalle> yeah, I don't want to rush it
15:45:10 <carl_baldwin> #topic Address Scopes
15:45:57 <carl_baldwin> I got this broken down in to smaller patch sets and wrote tests for most of them.  It has come a long way.
15:46:26 <carl_baldwin> Sadly, though, it is in the same boat.  Missed Liberty-3 and has a couple of things preventing me from being totally confident in it.
15:47:17 <carl_baldwin> 1) Still needs some tests at a higher level (though UTs are pretty good now)
15:47:40 <carl_baldwin> 2) I need to make sure it gels with DVR
15:47:54 <carl_baldwin> I’ll keep working on it.
15:48:16 <carl_baldwin> #topic Open Discussion
15:48:23 <carl_baldwin> Anything else that needs discussion today?
15:48:43 <regXboi> carl_baldwin: it looks like multinode-dvr failure rates are tracking better to -dvr failure rates
15:48:54 <regXboi> not good enough to push for voting, *yet*
15:49:27 <carl_baldwin> regXboi: Thanks for watching.
15:52:04 <mlavalle> have a nice rest of the week !
15:52:36 <carl_baldwin> Thanks, all!
15:52:59 <carl_baldwin> #endmeeting