15:00:48 <tidwellr> #startmeeting neutron_l3
15:00:49 <openstack> Meeting started Thu Mar 10 15:00:48 2016 UTC and is due to finish in 60 minutes.  The chair is tidwellr. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:53 <openstack> The meeting name has been set to 'neutron_l3'
15:01:19 <tidwellr> #topic Announcements
15:02:05 <carl_baldwin> Hi
15:02:39 <johnbelamaric> hello
15:03:00 <tidwellr> any announcements from the team?
15:03:42 <mlavalle> Summit talk acceptances were sent out earlier this week
15:03:50 <carl_baldwin> Mitaka is closing fast
15:04:45 <carl_baldwin> I think we got a number of of talks from this team accepted.
15:05:22 <tidwellr> yes, there seemed to be a lot of L3-related talks accepted
15:05:29 <mlavalle> ++
15:06:02 <tidwellr> if nothing else, let's move on
15:06:26 <carl_baldwin> ok
15:06:29 <tidwellr> #topic Bugs
15:07:31 <tidwellr> seeing as Mitaka is closing fast, I wonder how many of these bugs will have fixes make it into Mitaka
15:07:50 <carl_baldwin> tidwellr: Are any targetted at RC1 right now?
15:07:59 <carl_baldwin> mlavalle: ?
15:08:18 <tidwellr> looking
15:08:47 <mlavalle> carl_baldwin: 'targeted to milestone' yes
15:09:01 <mlavalle> https://bugs.launchpad.net/neutron/+bug/1478100
15:09:01 <openstack> Launchpad bug 1478100 in neutron "DHCP agent scheduler can schedule dnsmasq to an agent without reachability to the network its supposed to serve" [High,In progress] - Assigned to Cedric Brandily (cbrandily)
15:09:43 <mlavalle> this one is specifically mitaka-1 RC1: https://bugs.launchpad.net/neutron/+bug/1543094
15:09:43 <openstack> Launchpad bug 1543094 in neutron "[Pluggable IPAM] DB exceeded retry limit (RetryRequest) on create_router call" [High,In progress] - Assigned to Pavel Bondar (pasha117)
15:09:58 <mlavalle> Pavel is assigned to it
15:10:06 <tidwellr> looks like it's just those 2
15:10:36 <carl_baldwin> johnbelamaric: I meant to follow up on this one this week but I've been in all day meetings.
15:11:17 <johnbelamaric> carl_baldwin: yes, pavel_bondar is out-of-office for another week. he spent quite a bit of time on it, but said he thinks we have to revert the change we made to go to "compare and swap" method.
15:11:42 <johnbelamaric> Basically, the compare-and-swap method fails more often than the original
15:11:49 <johnbelamaric> is my understanding
15:12:35 <mlavalle> The proposed fixed, https://review.openstack.org/#/c/287811/, is still marked with workflow -1
15:12:35 <carl_baldwin> johnbelamaric: We need think about that.  Compare and swap was the fix for another bug.  So, reverting would put us back to where we started.  Maybe I can get a second set of eyes on it.
15:13:11 <carl_baldwin> #action carl_baldwin to get a second set of eyes on https://bugs.launchpad.net/neutron/+bug/1543094
15:13:11 <openstack> Launchpad bug 1543094 in neutron "[Pluggable IPAM] DB exceeded retry limit (RetryRequest) on create_router call" [High,In progress] - Assigned to Pavel Bondar (pasha117)
15:13:18 <johnbelamaric> yeah, understood. the compare-and-swap was a fix for a bug when using Galera. Yes, if someone else can take a look that would be helpful - I don't have the time now
15:13:30 <carl_baldwin> johnbelamaric: Thanks.
15:14:19 <tidwellr> https://bugs.launchpad.net/neutron/+bug/1554825
15:14:19 <openstack> Launchpad bug 1554825 in neutron "get_isolated_subnets does not return latest results" [High,In progress] - Assigned to Shih-Hao Li (shihli)
15:14:28 <tidwellr> this one was tagged as rc1
15:14:47 * carl_baldwin looking...
15:14:54 <tidwellr> looks new
15:15:39 <mlavalle> yeah, hasn't seen it before
15:15:39 <carl_baldwin> Yep, I can review today.
15:16:05 <tidwellr> carl_baldwin: thanks
15:16:23 <tidwellr> alright, I think we can move on from bugs
15:17:31 <tidwellr> there are a number of RFE's, mostly BGP-related
15:17:48 <tidwellr> I need to look at those, no need to discuss right now
15:18:26 <tidwellr> #topic Routed Networks
15:18:32 <carl_baldwin> HI
15:18:49 <tidwellr> carl_baldwin: how is this going?
15:18:58 <carl_baldwin> We've got a good start but meetings this week have prevented me from working on it at all.  :(
15:19:15 <carl_baldwin> johnbelamaric: I had something for you.  Did I send you an email about segments (cuz I meant to.)
15:20:23 <johnbelamaric> carl_baldwin: I don't thinks so - unless you mean #link https://bugs.launchpad.net/neutron/+bug/1544768
15:20:23 <openstack> Launchpad bug 1544768 in neutron "[RFE] Differentiate between service and floating subnets" [Wishlist,Triaged] - Assigned to Brian Haley (brian-haley)
15:20:51 <carl_baldwin> johnbelamaric: Thats part of it.
15:20:58 <johnbelamaric> carl_baldwin: but i haven't had a chance to look at that closely yet
15:21:05 * carl_baldwin guesses he didn't actually send the email yet.
15:21:36 <carl_baldwin> johnbelamaric: I'll send it.  I'd like to get your perspective.
15:21:41 <johnbelamaric> carl_baldwin: ok, no problem
15:22:21 <carl_baldwin> johnbelamaric: Not only may subnets have different types for different purposes with bug 1544768, they will also associate with segments with the routed networks work.
15:22:21 <openstack> bug 1544768 in neutron "[RFE] Differentiate between service and floating subnets" [Wishlist,Triaged] https://launchpad.net/bugs/1544768 - Assigned to Brian Haley (brian-haley)
15:22:47 <carl_baldwin> #action carl_baldwin will start discussion with johnbelamaric .  Probably on the ML.
15:22:59 <johnbelamaric> carl_baldwin: interesting, thanks
15:23:14 <carl_baldwin> mlavalle: Do you have anything?
15:23:19 <mlavalle> yes
15:23:45 <mlavalle> Yesterday I got a nice conversation with edleafe about resource pools in nova
15:24:00 <mlavalle> and how they will relate to routed networks
15:24:17 <mlavalle> I will go today thoroughly thorugh that spec
15:24:27 <mlavalle> and give my feedback
15:24:39 <carl_baldwin> mlavalle: excellent!
15:24:48 <carl_baldwin> I welcome the feedback from a new perspective.
15:24:53 <mlavalle> also today I will rebase my segments host mapping patchset and continue work there
15:25:18 <mlavalle> that's all I have for now
15:25:38 <carl_baldwin> mlavalle: Thanks.
15:25:44 <carl_baldwin> tidwellr: I think that's all for today.
15:26:22 <tidwellr> it's great to see lots of activity on this
15:26:39 <tidwellr> #topic BGP Dynamic Routing
15:26:56 <tidwellr> BGP has finally merged'
15:27:02 <mlavalle> yaay!
15:27:17 <tidwellr> mlavalle: tell me about it :)
15:27:40 <tidwellr> there's still some work to do in cleaning up API tests
15:28:12 * carl_baldwin thinks documentation too. ;)
15:28:21 <johnbelamaric> tidwellr: congratulations!
15:28:24 <tidwellr> yes, that too
15:28:42 <tidwellr> had some discussions with armax this week, there's a broader problem of API tests not being very well isolated
15:29:43 <tidwellr> basically we think that getting to the point where the devstack is configured to support multiple external networks would go a long way toward isolating the BGP tests
15:30:32 <carl_baldwin> tidwellr: ++
15:31:20 <tidwellr> I'm focused on docs at the moment, but the API tests will need to be revisited soon-ish
15:32:09 <tidwellr> that's all I had on this topic
15:32:24 <tidwellr> #topic DNS
15:32:29 <mlavalle> hi
15:32:36 <tidwellr> mlavalle: the floor is yours
15:32:54 <mlavalle> This week we added/merged unit tests
15:33:23 <mlavalle> We discovered 3 bugs and submitted fixed for those too. Also merged yesterday
15:33:38 <carl_baldwin> \o/
15:34:08 <mlavalle> and the doc, in the form of a chapter for the Networking Guide, also merged over the past 12 hours
15:34:18 <johnbelamaric> nice
15:34:31 <carl_baldwin> mlavalle: You're a great example to us all!
15:34:41 <tidwellr> ++
15:34:58 <mlavalle> carl_baldwin: no, I am just getting a lot of help from you all :-)
15:35:26 <mlavalle> Thanks also to janzian for his great work with those 3 bugs
15:35:48 <mlavalle> and the great reviews from carl_baldwin (as always)
15:36:06 <janzian> Yes, thanks carl_baldwin and mlavalle :)
15:36:47 <carl_baldwin> janzian: good work
15:36:53 <mlavalle> we discovered also a bug that is not dns per se, but would be a good quick win. THis is the fix: https://review.openstack.org/#/c/277597/
15:37:39 <yamamoto> mlavalle: can you provide url of the doc?
15:38:06 <carl_baldwin> mlavalle: janzian: I took a quick look at it and marked the bug for RC1.
15:38:14 <mlavalle> yamamoto: https://review.openstack.org/#/c/280957/
15:38:23 <mlavalle> carl_baldwin: thanks :-)
15:38:29 <yamamoto> thank you
15:38:35 <mlavalle> that's all for DNS today
15:38:39 * carl_baldwin goes mobile. Will keep an eye on the meeting as he can.
15:38:51 <tidwellr> mlavalle: thanks
15:39:09 <tidwellr> #topic Open Discussion
15:39:36 <tidwellr> any topics not discussed that someone would like to bring up?
15:40:33 <tidwellr> going once....
15:41:07 <tidwellr> going twice.....
15:41:37 <tidwellr> alright, thanks everyone!
15:41:53 <mlavalle> thanks, have a nice day
15:42:03 <tidwellr> #endmeeting