14:59:57 <mlavalle> #startmeeting neutron_l3
14:59:57 <openstack> Meeting started Thu Mar 17 14:59:57 2016 UTC and is due to finish in 60 minutes.  The chair is mlavalle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:00 <openstack> The meeting name has been set to 'neutron_l3'
15:00:03 <mlavalle> hi
15:00:04 <haleyb> hi
15:00:06 <tidwellr> hi
15:00:38 <vikram_> hi
15:00:50 <mlavalle> haleyb, tidwellr, janzian, vikram_ : welcome!
15:01:06 <janzian> Hello
15:01:10 <mlavalle> #topic Announcements
15:01:32 <mlavalle> Agenda for today is here: https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam#Agenda
15:01:55 <mlavalle> And we made it through Mitaka... Welcome to Newton!
15:02:33 <mlavalle> Any other announcements from the team?
15:03:48 <mlavalle> oh yeah, carl_baldwin broke the DC subway: http://www.cbsnews.com/news/washington-dc-metro-shutdown-commute-maryland-virginia/
15:03:55 <mlavalle> LOL
15:04:13 <mlavalle> he is spending his spring break there :-)
15:04:34 <tidwellr> lol
15:04:34 <mlavalle> moving on...
15:04:47 <mlavalle> #topic Bugs
15:05:27 <mlavalle> We have two friends from previous meetings:
15:05:31 <mlavalle> https://bugs.launchpad.net/neutron/+bug/1478100
15:05:33 <openstack> Launchpad bug 1478100 in neutron "DHCP agent scheduler can schedule dnsmasq to an agent without reachability to the network its supposed to serve" [High,In progress] - Assigned to Cedric Brandily (cbrandily)
15:06:01 <mlavalle> For this one Cedric upload a new revision to the fix and is waiting reviews
15:06:50 <mlavalle> The next up is https://bugs.launchpad.net/neutron/+bug/1543094
15:06:52 <openstack> Launchpad bug 1543094 in neutron "[Pluggable IPAM] DB exceeded retry limit (RetryRequest) on create_router call" [High,In progress]
15:07:28 <tidwellr> I tried my hand at implementing an approach suggested by carl_baldwin to fix this one
15:07:30 <mlavalle> carl_baldwin suggested a change of algorithm that computes availability on the fly
15:07:50 <mlavalle> tidwellr: yeah, I was about to ask you. Anything you want to share here
15:07:57 <mlavalle> ?
15:08:03 <tidwellr> sure, the idea sounds straight-forward in theory
15:08:32 <tidwellr> there are a lot of tests and test helpers that rely on a more deterministic approach to allocating IP addresses
15:09:18 <mlavalle> is your concern purely a matter of available bodies to change all that needs to be changed?
15:09:31 <tidwellr> computing availability on the fly is only part of the solution, to avoid contention we have been looking at randomly selecting an IP address from a small window of IP addresses
15:10:06 <tidwellr> it's not a matter of man(or woman)-power
15:10:32 <mlavalle> human-power :-)
15:11:04 * carl_baldwin broke the metro, it's true. Reverted that patch though, so it is fixed.
15:11:33 <mlavalle> carl_baldwin: ++
15:11:39 <tidwellr> I've found that this approach introduces some non-determinism that makes it hard to pin down all the tests that need to change, you get a different set of failures from run-to-run
15:12:05 <mlavalle> tidwellr: any suggestions on how to move forward?
15:12:36 <tidwellr> I don't know if pbondar is still looking into this
15:12:55 <mlavalle> he doesn't seem to be on-line
15:13:04 <mlavalle> not in this channel anyway
15:13:20 <tidwellr> I think continuing with 2 different approaches if we can would be good, then we can see which one gets more traction
15:13:53 <mlavalle> tidwellr: thanks for looking at this. Trying out alternatives is progress in my book
15:14:23 <tidwellr> I'm continuing with the approach suggested by carl_baldwin, I haven't made much progress as of yet this week but I intend to pick this up again today
15:14:41 <carl_baldwin> tidwellr: thanks for the report
15:14:45 <mlavalle> tidwellr: great! let's re-visit next week
15:15:24 <mlavalle> moving on
15:15:46 <mlavalle> The new bug this week is https://bugs.launchpad.net/neutron/+bug/1533034
15:15:47 <openstack> Launchpad bug 1533034 in neutron "an unclear error info returned when create an ipv6 subnetpool associate to ipv4 address scope" [High,In progress] - Assigned to Cedric Brandily (cbrandily)
15:16:14 <mlavalle> it is not that new. It's priority was raised by armax recently, though
15:16:26 <mlavalle> and there is a fix proposed for it
15:17:07 <mlavalle> any comments on this one?
15:17:33 <tidwellr> interesting, I'll take  a look today
15:18:04 <mlavalle> any other bugs I may have missed?
15:18:15 <carl_baldwin> I'm not sure why the importance was raised
15:19:13 <mlavalle> ok, moving on
15:19:24 <mlavalle> #topic Routed Networks
15:19:49 <mlavalle> since carl_baldwin is on vacation, I can give a quick update
15:20:52 <carl_baldwin> Thanks, mlavalle.  Nothing new from me.
15:21:05 <mlavalle> We have a first proposal on how to start implementing in OVN
15:21:47 <mlavalle> There is a message in the ML from xiaohhui on this topic
15:22:35 <mlavalle> http://osdir.com/ml/openstack-dev/2016-03/msg01755.html
15:22:46 <mlavalle> Take a look if you have some time
15:23:18 <mlavalle> Progress is also being made with the OpenStack client to incorporate CRUD for segments
15:23:48 <mlavalle> rtheis_ is taking care of this
15:24:13 <mlavalle> I am working on the segments - host mapping
15:24:24 <vikram_> cli: https://review.openstack.org/#/c/290267/
15:24:53 <mlavalle> and the ip deferral in Nova. I had a good conversation with edleafe in the Nova team
15:25:28 <rtheis_> osc patches: https://review.openstack.org/#/c/290138/ and https://review.openstack.org/#/c/290054/
15:25:41 <mlavalle> rtheis_: thanks!
15:25:45 <rtheis_> yw
15:25:56 <mlavalle> moving on
15:26:13 <mlavalle> #topic BGP dynamic routing
15:26:26 <tidwellr> docs, docs, and more docs :)
15:26:32 <mlavalle> LOL
15:26:43 <mlavalle> is that the only remaining bit?
15:26:46 <tidwellr> yes
15:26:59 <mlavalle> fantastic!
15:27:12 <tidwellr> I've been eyeing some things for Newton, but that's future enhancement
15:27:43 <vikram_> +1000
15:27:57 <vikram_> how about the separate repo?
15:28:06 <vikram_> i think we got to do it early
15:28:19 <tidwellr> ugh, haven't thought about it yet
15:28:26 <vikram_> https://review.openstack.org/#/c/268726/
15:28:45 * tidwellr needs to catch up
15:29:28 <vikram_> IMO, we got to figure out what all we will be eyeing for Newton now
15:29:37 <vikram_> there are couple of rfe's lined up
15:29:40 <tidwellr> yes, I did file https://bugs.launchpad.net/neutron/+bug/1557290
15:29:41 <openstack> Launchpad bug 1557290 in neutron "DVR FIP agent gateway does not pass traffic directed at fixed IP" [Wishlist,Confirmed]
15:29:59 <tidwellr> this is the bug that kept us from adding full DVR support in Mitaka
15:30:30 <vikram_> i can do the repo part for now
15:30:41 <vikram_> if PTL agrees
15:30:51 <vikram_> + all of us as well ;-)
15:30:55 <steve_ruan> @Tidqwellr
15:31:08 <steve_ruan> how about the bgp listener and bgp vpn
15:31:13 <tidwellr> thanks for driving this vikram_
15:31:21 <steve_ruan> will be add to newton?
15:31:34 <tidwellr> steve_ruan: I would like to
15:31:50 <vikram_> steve_raun: +1
15:31:55 <tidwellr> steve_ruan: getting full DVR support is a priority of mine though
15:32:07 <steve_ruan> ok,
15:32:08 <tidwellr> steve_ruan: that still feels like a hole
15:32:27 <vikram_> I feel let's decide where we got to develope.. in tree or separate repo fast
15:32:37 <steve_ruan> but if there is no listen, half of bgp functionality is missing
15:32:41 <vikram_> need help in getting this resolved faster
15:32:50 <vikram_> steve_raun: agreed
15:33:17 <mlavalle> steve_ruan: ^^^
15:33:18 <steve_ruan> vikram_: I agree to develop in a separate repo
15:33:34 <vikram_> should we send a mail to the community and poll opinions?
15:33:41 <tidwellr> I think we will be pushed in that direction'
15:33:48 <mlavalle> vikram_: yeah, let's do that
15:33:56 <tidwellr> vikram_: socializing your plans on the ML is a good idea
15:34:04 <vikram_> ok .. will send then
15:34:27 <vikram_> #action item for me ;-)
15:35:07 <mlavalle> #action vikram_ to send message to the ML about moving BGP dynamic routing code to a separate repo
15:35:38 <mlavalle> any thing else on this topic?
15:35:48 <vikram_> i am really confused with big tent now
15:36:10 <vikram_> can someone help me with pointers
15:36:42 <vikram_> I remember seeing a mail from armax saying the rules for big-tent will be finalized soon
15:37:15 <mlavalle> I suggest pinging armax directly
15:37:28 <vikram_> Nice idea.. Will do that
15:37:42 <mlavalle> ok, moving on
15:37:58 <mlavalle> #topic DNS
15:38:11 <mlavalle> This topic is mostly finished
15:38:39 <mlavalle> janzian has agreed to increase the coverage of the unit tests, focusing specifically floating ips
15:38:56 <mlavalle> he will be working on this over the next couple of weeks
15:39:12 <mlavalle> thanks for doing this janzian
15:39:44 <mlavalle> so, moving on
15:39:44 <janzian> Thanks mlavalle
15:39:59 <mlavalle> #topic Open discussion
15:40:18 <mlavalle> any other topics that need to be discussed here today?
15:41:00 <mlavalle> going once
15:41:28 <mlavalle> going twice
15:41:50 <mlavalle> ok...
15:41:55 <mlavalle> #endmeeting